Failure in Backing Up eSight Because the Non-default Port of the SQL Server Database Is Used
Symptom
In Windows operating system, eSight uses the non-default port of the SQL Server database listener. When users attempt to back up data, a failure occurs and the illegal user or keyvalue message is displayed.
Possible Causes
When the maintenance tool attempts to connect to the database using IP address (for example, osql -S127.0.0.1 -Usa -PChangeme@@123), the default port of the SQL Server database (1433) is used. Currently, the port listened by sqlserver is not 1433. You need to manually configure sqlserver to listening on the port 1433.
Procedure
- Log in to the server as an administrator.
- Among all programs, choose Microsoft SQL Server 2012 > SQL Server Configuration Manager.
- In the SQL Server Configuration Manager window, choose SQL Server Network Configuration > Protocols for xxx, right-click TCP/IP, and choose Properties.
Here, xxx indicates the name of the database instance.
- Find the listening address of the sqlserver process in the TCP/IP Properties window. (The listening address in the actual environment is used.) Add 1433 in the corresponding value of TCP Port and separate the port with other ports using a comma (,). Ensure that Active is set to Yes and Enabled is set to Yes. Click OK.
- In the SQL Server Configuration Manager window, choose SQL Server Service, right-click SQL Server Agent (xxx), and choose Restart.
Here, xxx indicates the name of the database instance.
- Perform a backup again.