No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM FRR

Example for Configuring PIM FRR

This section provides an example for configuring PIM FRR. PIM FRR helps minimize multicast traffic loss caused by link or node failures on networks that have high real-time transmission requirements.

Networking Requirements

On the network shown in Figure 4-17, configure PIM FRR to enable multicast traffic to be switched to a backup link when the primary link or node fails.

Figure 4-17 Configuring PIM FRR
NOTE:

Interface 1, Interface 2, and Interface 3 stand for GE 1/0/1, GE 1/0/2, and GE 1/0/3, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign IP addresses to router interfaces and configure a unicast routing protocol.

  2. Configure IS-IS FRR on router B.

    NOTE:

    Unicast route FRR can be configured for either static or dynamic routes, or for both of them. This example uses IS-IS FRR.

  3. Enable multicast routing and PIM-SM on all routers that provide the multicast service.

  4. Configure a static IGMP group on the router interface connected to hosts.

  5. Configure a rendezvous point (RP).

  6. Enable PIM FRR on router B.

Data Preparation

To complete the configuration, you need the following data:

  • Multicast group address: 225.1.0.0

  • Multicast source address: 20.0.5.100

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Configure IS-IS FRR on router B.

    [~Device B] isis 1
    [*Device B-isis-1] network-entity 10.0000.0000.0002.00
    [*Device B-isis-1] frr
    [*Device B-isis-1-frr] loop-free-alternate level-1
    [*Device B-isis-1-frr] commit

  3. Enable multicast routing on each router and PIM-SM on each interface.

    # Enable multicast routing on each router and PIM-SSM on each interface of the routers.

    [~Device B] multicast routing-enable
    [*Device B] interface gigabitethernet 1/0/1
    [*Device B-GigabitEthernet1/0/1] pim sm
    [*Device B-GigabitEthernet1/0/1] quit
    [*Device B] interface gigabitethernet 1/0/2
    [*Device B-Gigabitethernet1/0/2] pim sm
    [*Device B-Gigabitethernet1/0/2] quit
    [*Device B] interface gigabitethernet 1/0/3
    [*Device B-GigabitEthernet1/0/3] pim sm
    [*Device B-GigabitEthernet1/0/3] quit
    [*Device B] commit

    The configurations of Device A and Device C are similar to the configuration of Device B. For configuration details, see Configuration Files in this section.

  4. Configure a static IGMP group on the router interface connected to hosts to simulate a user join.

    # Configure a static IGMP group on the Device interface connected to hosts.

    [~Device B] interface gigabitethernet 1/0/3
    [~Device B-GigabitEthernet1/0/3] igmp static-group 225.1.0.0 source 20.0.5.100
    [*Device B-GigabitEthernet1/0/3] quit
    [*Device B] commit

  5. Configure an RP.

    # Configure a candidate-BSR (C-BSR) and candidate-RP (C-RP) on Device B.

    [~Device B] pim
    [~Device B-pim] c-bsr gigabitethernet 1/0/1
    [*Device B-pim] c-rp gigabitethernet 1/0/1
    [*Device B-pim] quit
    [*Device B] commit

    # Check the PIM routing table of Device B. The command output does not show backup inbound or outbound interface information.

    [~Device B] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (20.0.5.100, 225.1.0.0)
         RP: 192.168.8.2 (local)
         Protocol: pim-sm, Flag: SPT SG_RCVR
         UpTime: 01:21:36
         Upstream interface: GigabitEthernet1/0/1
             Upstream neighbor: 192.168.8.1
             RPF prime neighbor: 192.168.8.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/3
                 Protocol: static, UpTime: 01:05:00, Expires: -

  6. Enable PIM FRR on Device B.

    [~Device B] acl name frracl
    [*Device B-acl4-advance-frracl] rule permit ip source 20.0.5.100 0 destination 225.1.0.0 0
    [*Device B-acl4-advance-frracl] commit
    [~Device B-acl4-advance-frracl] quit
    [~Device B] pim
    [~Device B-pim] rpf-frr policy acl-name frracl
    [*Device B-pim] quit
    [*Device B] commit

    The configurations on Device A and Device C are similar to the configuration of Device B. For configuration details, see Configuration Files in this section.

    # Check the PIM routing table of Device B. The command output shows backup inbound interface information.

    [~Device B] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (20.0.5.100, 225.1.0.0)
         RP: 192.168.8.2 (local)
         Protocol: pim-sm, Flag: SPT SG_RCVR
         UpTime: 01:22:40
         Upstream interface: GigabitEthernet1/0/1
             Upstream neighbor: 192.168.8.1
             RPF prime neighbor: 192.168.8.1
         Backup upstream interface: GigabitEthernet1/0/2
             Backup upstream neighbor: 192.168.10.1
             Backup RPF prime neighbor: 192.168.10.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/3
                 Protocol: static, UpTime: 01:06:04, Expires: -

  7. Verify the configuration.

    # Run the shutdown command on GE 1/0/1 of Device A to simulate a link failure.

    [~Device A] interface gigabitethernet 1/0/1
    [*Device A-GigabitEthernet1/0/1] shutdown
    [*Device A-GigabitEthernet1/0/1] commit

    # Run the display pim routing-table command on Device B immediately after the shutdown command is run.

    [~Device B] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (20.0.5.100, 225.1.0.0)
         RP: NULL
         Protocol: pim-sm, Flag: SPT SG_RCVR
         UpTime: 01:24:22
         Upstream interface: GigabitEthernet1/0/2
             Upstream neighbor: 192.168.10.1
             RPF prime neighbor: 192.168.10.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/3
                 Protocol: static, UpTime: 01:07:46, Expires: -

    The command output shows that the inbound interface of the forwarding route on Device B has been switched to GE 1/0/2 on the backup link.

Configuration Files

  • Device A configuration file

    #
    sysname Device A
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 20.0.5.100 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Gigabitethernet1/0/1
     undo shutdown
     ip address 192.168.8.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 192.168.9.1 255.255.255.0
     pim sm
     isis enable 1
    #
    return
  • Device B configuration file

    #
    sysname Device B
    #
    acl name frracl
     rule permit ip source 20.0.5.100 0 destination 225.1.0.0 0
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     frr
      loop-free-alternate level-1
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 192.168.8.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Gigabitethernet1/0/2
     undo shutdown
     ip address 192.168.10.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 192.168.11.1 255.255.255.0
     pim sm
     isis enable 1
     igmp static-group 225.1.0.0 source 20.0.5.100
    #
    pim
     rpf-frr policy acl-name frracl
    #
    return
  • Device C configuration file

    #
    sysname Device C
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 192.168.9.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface Gigabitethernet1/0/2
     undo shutdown
     ip address 192.168.10.1 255.255.255.0
     pim sm
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 40685

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next