No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast Static Routes to Connect RPF Routes

Example for Configuring Multicast Static Routes to Connect RPF Routes

After multicast static routes are configured, a receiver can receive multicast data from a multicast source in another area that is unreachable with unicast routes.

Networking Requirements

As shown in Figure 7-2, the network runs PIM-SM, all routers support multicast, and the receiver can receive information from Source1. Device B and Device C run OSPF. There is no unicast route between Device A and Device B. To enable the receiver to receive information sent from Source 2, configure a multicast static route.

Figure 7-2 Configuring multicast static routes to connect RPF routes

Device Name

Interface

IP Address

DeviceA

GE1/0/0

10.1.5.1/24

GE3/0/0

10.1.4.2/24

DeviceB

GE1/0/0

10.1.2.2/24

GE2/0/0

10.1.3.1/24

GE3/0/0

10.1.4.1/24

DeviceC

GE1/0/0

10.1.2.1/24

GE2/0/0

10.1.1.1/24

Precautions

When configuring multicast static routes to connect RPF routes, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • When configuring a multicast static route, if the next hop is a Point-to-point (P2P) interface, you must specify the outbound interface number; if the next hop is not a P2P interface, you must specify the next-hop address.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure OSPF on routers.

  2. Enable multicast routing on each routers, enable PIM-SM on each interface, and enable IGMP on interfaces connecting routers to hosts.

  3. Configure Candidate-BootStrap Routers (C-BSRs) and Candidate-Rendezvous Points (C-RPs).

  4. Configure multicast static routes on Device B and Device C.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of Source 2

  • RPF interface connecting Device B to Source 2 and the RPF neighbor of Device B

  • RPF interface connecting Device C to Source 2 and the RPF neighbor of Device C

Procedure

  1. Configure an IP address for each router interface and a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device B.

    [~DeviceB] multicast routing-enable
    [*DeviceB] interface GigabitEthernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] pim sm
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] interface gigabitethernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] pim sm
    [*DeviceB-GigabitEthernet2/0/0] quit
    [*DeviceB] interface GigabitEthernet 3/0/0
    [*DeviceB-GigabitEthernet3/0/0] pim sm
    [*DeviceB-GigabitEthernet3/0/0] commit
    [~DeviceB-GigabitEthernet3/0/0] quit

    The configurations of Device A and Device C are similar to the configuration of Device B. For configuration details, see Configuration Files in this section.

  3. Enable IGMP on interfaces that connect to hosts.

    # Enable IGMP on the interface connecting Device C to hosts.

    [~DeviceC] interface gigabitethernet 2/0/0
    [~DeviceC-GigabitEthernet2/0/0] igmp enable
    [*DeviceC-GigabitEthernet2/0/0] commit
    [~DeviceC-GigabitEthernet2/0/0] quit

  4. Configure C-BSRs and C-RPs.

    # Configure GE 1/0/0 on Device B as both a C-BSR and a C-RP.

    [~DeviceB] pim
    [*DeviceB] c-bsr GigabitEthernet 1/0/0
    [*DeviceB] c-rp GigabitEthernet 1/0/0
    [*DeviceB] commit
    [~DeviceB] quit

    Source 1 (10.1.3.2/24) and Source2 (10.1.5.2/24) both send multicast data to G (225.1.1.1). The receiver joins G and can receive multicast data sent from Source1 and Source2.

    # Run the display multicast rpf-info 10.1.5.2 command on Device B and Device C. There is no command output. This indicates that Devices have no RPF routes to Source 2.

  5. Configure multicast static routes.

    # Configure a multicast static route on Device B and specify Device A as an RPF neighbor to Source 2.

    <DeviceB> system-view
    [~DeviceB] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.4.2
    [*DeviceB] commit
    [~DeviceB] quit

    # Configure a multicast static route on Device C and specify Device B as an RPF neighbor to Source2.

    <DeviceC> system-view
    [~DeviceC] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.2.2
    [*DeviceC] commit
    [~DeviceC] quit

  6. Verify the configuration.

    # Run the display multicast rpf-info 10.1.5.2 command again on Device B and Device C. The command output shows RPF information of Source 2.

    <DeviceB> display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about: 10.1.5.2
         RPF interface: GigabitEthernet3/0/0, RPF neighbor: 10.1.4.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selecting rule: preference-preferred
         Load splitting rule: disable 
    <DeviceC> display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source 10.1.5.2:
         RPF interface: GigabitEthernet1/0/0, RPF neighbor: 10.1.2.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

    # Run the display pim routing-table command on Device C to view information about PIM routing tables. Device C has multicast entries related to Source 2 and the receiver can receive multicast data from Source 2.

    <DeviceC> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
     (*, 225.1.1.1)
         RP: 10.1.2.2
         Protocol: PIM-SM, Flag: WC
         UpTime: 03:54:19
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: PIM-SM, UpTime: 01:38:19, Expires: never
    (10.1.3.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: PIM-SM, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: GigabitEthernet2/0/0
                  Protocol: PIM-SM, UpTime: 00:00:44, Expires: never
    (10.1.5.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: PIM-SM, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: GigabitEthernet2/0/0
                  Protocol: PIM-SM, UpTime: 00:00:44, Expires: never

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0 undo shutdown
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.5.0 0.0.0.255
       network 10.1.4.0 0.0.0.255
    #
    return
    
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    pim
     c-bsr GigabitEthernet3/0/0
     c-rp GigabitEthernet3/0/0
    #
    ip rpf-route-static 10.1.5.0 24 10.1.4.2
    #
    return
    
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.2.2
    #
    return
    
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43703

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next