No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Inter-AS Seamless MPLS NG MVPN Option C

Example for Configuring an Inter-AS Seamless MPLS NG MVPN Option C

This example describes how to configure inter-AS seamless MPLS NG MVPN in Option C mode to implement E2E service connectivity, when the devices are in different ASs.

Networking Requirements

As shown in the Figure 9-28, the PEs, ABR and ASBRs are in different ASs. To implement the connectivity between PEs and provides multicast service with MVPN, you can implement the inter-AS seamless MPLS NG MVPN.

Figure 9-28 Inter-AS Seamless MPLS NG MVPN Option C

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IGP protocols at each network to implement network connectivity at each network.

  2. Set up an MPLS LDP LSP in each network.

  3. Establish IBGP peer relationships at each AS and enable devices to exchange labeled routes.

  4. Configure an EBGP peer relationship between ASBRs and enable these devices to exchange labeled routes across ASs.

  5. Configure ABR as an RR.

  6. Configure a routing policy to control label distribution for a BGP LSP to be established on each device. The egress of the BGP LSP to be established needs to assign an MPLS label to the route advertised to an upstream node. If a transit node receives a labeled IPv4 route from downstream, the downstream node must re-assign an MPLS label to the transit node.

  7. Configure BGP peers.

  8. Configure a P2MP LSP to carry multicast traffic.

Data Preparation

To complete the configuration, you need the following data:

  • MPLS LSR IDs of each device (99.0.0.1, 99.0.0.2, 99.0.0.3, 99.0.0.4, 99.0.0.5)

  • Route policy configured on each device (policy1)

Procedure

  1. Configure IP address for each interface.

    Assign an IP address and its mask to every physical interface; configure a loopback interface address as an LSR ID on every device shown in Figure 9-28; configure OSPF and IS-IS to advertise the route to the network segment of each interface and a host route to each loopback interface address (LSR ID). For configuration details, see Configuration Files in this section.

  2. Enable MPLS and LDP globally on each device.

    # Configure PE1.

    [~PE1] mpls lsr-id 99.0.0.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface Ethernet 1/0/2
    [*PE1-Ethernet1/0/2] mpls
    [*PE1-Ethernet1/0/2] mpls ldp
    [*PE1-Ethernet1/0/2] quit
    [*PE1] commit

    # Configure ABR.

    <ABR> system-view 
    [~ABR] mpls lsr-id 99.0.0.2
    [*ABR] mpls
    [*ABR-mpls] quit
    [*ABR] mpls ldp
    [*ABR-mpls-ldp] quit
    [*ABR] interface Ethernet 1/0/2
    [*ABR-Ethernet1/0/2] mpls
    [*ABR-Ethernet1/0/2] mpls ldp
    [*ABR-Ethernet1/0/2] quit
    [*ABR] interface Ethernet 1/0/3
    [*ABR-Ethernet1/0/3] mpls
    [*ABR-Ethernet1/0/3] mpls ldp
    [*ABR-Ethernet1/0/3] quit
    [*ABR] commit

    # Configure ASBR1.

    [~ASBR1] mpls lsr-id 99.0.0.3
    [*ASBR1] mpls
    [*ASBR1-mpls] quit
    [*ASBR1] mpls ldp
    [*ASBR1-mpls-ldp] quit
    [*ASBR1] interface Ethernet 1/0/3
    [*ASBR1-GigabitEthernet1/0/3] mpls
    [*ASBR1-GigabitEthernet1/0/3] mpls ldp
    [*ASBR1-GigabitEthernet1/0/3] quit
    [*ASBR1] interface Ethernet 1/0/4
    [*ASBR1-GigabitEthernet1/0/4] mpls
    [*ASBR1-GigabitEthernet1/0/4] mpls ldp
    [*ASBR1-GigabitEthernet1/0/4] quit
    [*ASBR1] commit

    # Configure ASBR2.

    [~ASBR2] mpls lsr-id 99.0.0.4
    [*ASBR2] mpls
    [*ASBR2-mpls] quit
    [*ASBR2] mpls ldp
    [*ASBR2-mpls-ldp] quit
    [*ASBR2] interface Ethernet 1/0/1
    [*ASBR2-Ethernet1/0/1] mpls
    [*ASBR2-Ethernet1/0/1] mpls ldp
    [*ASBR2-Ethernet1/0/1] quit
    [*ABR] interface Ethernet 1/0/3
    [*ABR-Ethernet1/0/3] mpls
    [*ABR-Ethernet1/0/3] mpls ldp
    [*ABR-Ethernet1/0/3] quit
    [*ASBR2] commit

    # Configure PE2.

    [~PE2] mpls lsr-id 99.0.0.5
    [*PE2] mpls
    [*PE2-mpls] quit
    [*PE2] mpls ldp
    [*PE2-mpls-ldp] quit
    [*PE2] interface Ethernet 1/0/1
    [*PE2-Ethernet1/0/1] mpls
    [*PE2-Ethernet1/0/1] mpls ldp
    [*PE2-Ethernet1/0/1] quit
    [*PE2] commit

  3. Configure automatic mLDP P2MP tunnel.

    # Configure PE1.

    [~PE1] mpls ldp
    [~PE1-mpls-ldp] mldp p2mp
    [*PE1-mpls-ldp] mldp recursive-fec
    [*PE1-mpls-ldp] commit
    [~PE1-mpls-ldp] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure ABR.

    [~ABR] mpls ldp
    [~ABR-mpls-ldp] mldp p2mp
    [*ABR-mpls-ldp] mldp recursive-fec
    [*ABR-mpls-ldp] commit
    [~ABR-mpls-ldp] quit

    # Configure ASBR1.

    [~ASBR1] mpls ldp
    [~ASBR1-mpls-ldp] mldp p2mp
    [*ASBR1-mpls-ldp] mldp recursive-fec
    [*ASBR1-mpls-ldp] commit
    [~ASBR1-mpls-ldp] quit

    The configuration of ASBR2 is similar to the configuration of ASBR1. For configuration details, see Configuration Files in this section.

  4. Establish IBGP peer relationships at each AS, establish EBGP peer relationships between PEs and between ASBRs in different ASs, and enable these devices to exchange labeled routes.

    # Configure PE1.

    [~PE1] bgp 1.0
    [*PE1-bgp] peer 99.0.0.2 as-number 1.0
    [*PE1-bgp] peer 99.0.0.2 connect-interface LoopBack 0
    [*PE1-bgp] peer 99.0.0.5 as-number 65535.65535
    [*PE1-bgp] peer 99.0.0.5 ebgp-max-hop 10
    [*PE1-bgp] peer 99.0.0.5 connect-interface LoopBack0
    [*PE1-bgp] ipv4-family unicast
    [*PE1-bgp-af-ipv4] undo synchronization
    [*PE1-bgp-af-ipv4] peer 99.0.0.2 label-route-capability
    [*PE1-bgp-af-ipv4] peer 99.0.0.2 enable
    [*PE1-bgp-af-ipv4] peer 99.0.0.5 enable
    [*PE1-bgp-af-ipv4] network 99.0.0.1 32
    [*PE1-bgp-af-ipv4] quit
    [*PE1-bgp] ipv4-family mvpn
    [*PE1-bgp-af-mvpn] policy vpn-target
    [*PE1-bgp-af-mvpn] peer 99.0.0.2 enable
    [*PE1-bgp-af-mvpn] peer 99.0.0.5 enable
    [*PE1-bgp-af-mvpn] quit
    [*PE1-bgp] ipv4-family vpnv4
    [*PE1-bgp-af-vpnv4] policy vpn-target
    [*PE1-bgp-af-vpnv4] peer 99.0.0.2 enable
    [*PE1-bgp-af-vpnv4] peer 99.0.0.5 enable
    [*PE1-bgp-af-vpnv4] quit
    [*PE1-bgp] quit
    [*PE1] commit

    # Configure ABR.

    [~ABR] bgp 1.0
    [*ABR-bgp] peer 99.0.0.1 as-number 1.0
    [*ABR-bgp] peer 99.0.0.1 connect-interface LoopBack 1
    [*ABR-bgp] peer 99.0.0.3 as-number 1.0
    [*ABR-bgp] peer 99.0.0.3 connect-interface LoopBack 1
    [*ABR-bgp] ipv4-family unicast
    [*ABR-bgp-af-ipv4] undo synchronization
    [*ABR-bgp-af-ipv4] peer 99.0.0.1 enable
    [*ABR-bgp-af-ipv4] peer 99.0.0.1 label-route-capability
    [*ABR-bgp-af-ipv4] peer 99.0.0.3 enable
    [*ABR-bgp-af-ipv4] peer 99.0.0.3 label-route-capability
    [*ABR-bgp-af-ipv4] quit
    [*ABR-bgp] ipv4-family mvpn
    [*ABR-bgp-af-mvpn] undo policy vpn-target
    [*ABR-bgp-af-mvpn] peer 99.0.0.1 enable
    [*ABR-bgp-af-mvpn] peer 99.0.0.3 enable
    [*ABR-bgp-af-mvpn] quit
    [*ABR-bgp] ipv4-family vpnv4
    [*ABR-bgp-af-vpnv4] undo policy vpn-target
    [*ABR-bgp-af-vpnv4] peer 99.0.0.1 enable
    [*ABR-bgp-af-vpnv4] peer 99.0.0.3 enable
    [*ABR-bgp-af-vpnv4] quit
    [*ABR-bgp] quit
    [*ABR] commit

    # Configure ASBR1.

    <ASBR1> system-view 
    [~ASBR1] bgp 1.0
    [*ASBR1-bgp] peer 99.0.0.2 as-number 1.0
    [~ASBR1-bgp] peer 20.0.16.2 as-number 65535.65535
    [*ASBR1-bgp] peer 99.0.0.2 connect-interface LoopBack 0
    [*ASBR1-bgp] ipv4-family unicast
    [*ASBR1-bgp-af-ipv4] undo synchronization
    [*ASBR1-bgp-af-ipv4] peer 20.0.16.2 enable
    [*ASBR1-bgp-af-ipv4] peer 99.0.0.2 enable
    [*ASBR1-bgp-af-ipv4] peer 20.0.16.2 label-route-capability
    [*ASBR1-bgp-af-ipv4] peer 99.0.0.2 label-route-capability
    [*ASBR1-bgp-af-ipv4] quit
    [*ASBR1-bgp] quit
    [*ASBR1] commit

    # Configure ASBR2.

    <ASBR2> system-view 
    [~ASBR2] bgp 65535.65535
    [*ASBR2-bgp] peer 99.0.0.5 as-number 65535.65535
    [*ASBR2-bgp] peer 20.0.16.1 as-number 1.0
    [*ASBR2-bgp] peer 99.0.0.5 connect-interface LoopBack 0
    [*ASBR2-bgp] ipv4-family unicast
    [*ASBR2-bgp-af-ipv4] undo synchronization
    [*ASBR2-bgp-af-ipv4] peer 20.0.16.1 enable
    [*ASBR2-bgp-af-ipv4] peer 99.0.0.5 enable
    [*ASBR2-bgp-af-ipv4] peer 20.0.16.1 label-route-capability
    [*ASBR2-bgp-af-ipv4] peer 99.0.0.5 label-route-capability
    [*ASBR2-bgp-af-ipv4] network 99.0.0.5 32
    [*ASBR2-bgp-af-ipv4] quit
    [*ASBR2-bgp] quit
    [*ASBR2] commit

    # Configure PE2.

    [~PE2] bgp 65535.65535
    [*PE2-bgp] peer 99.0.0.4 as-number 65535.65535
    [*PE2-bgp] peer 99.0.0.4 connect-interface LoopBack 0
    [*PE2-bgp] peer 99.0.0.1 as-number 1.0
    [*PE2-bgp] peer 99.0.0.1 ebgp-max-hop 10
    [*PE2-bgp] peer 99.0.0.1 connect-interface LoopBack 0
    [*PE2-bgp] ipv4-family unicast
    [*PE2-bgp-af-ipv4] undo synchronization
    [*PE2-bgp-af-ipv4] peer 99.0.0.1 enable
    [*PE2-bgp-af-ipv4] peer 99.0.0.4 enable
    [*PE2-bgp-af-ipv4] peer 99.0.0.4 label-route-capability
    [*PE2-bgp-af-ipv4] quit
    [*PE2-bgp] ipv4-family mvpn
    [*PE2-bgp-af-mvpn] policy vpn-target
    [*PE2-bgp-af-mvpn] peer 99.0.0.1 enable
    [*PE2-bgp-af-mvpn] quit
    [*PE2-bgp] ipv4-family vpnv4
    [*PE2-bgp-af-vpnv4] policy vpn-target
    [*PE2-bgp-af-vpnv4] peer 99.0.0.1 enable
    [*PE2-bgp-af-vpnv4] quit
    [*PE2-bgp] quit
    [*PE2] commit

  5. Configure ABR as an RR to reflect the VPNv4 routes of PE1 and PE2 to each other.

    # Configure ABR.

    [~ABR] bgp 1.0
    [*ABR-bgp] ipv4-family unicast
    [*ABR-bgp-af-ipv4] peer 99.0.0.1 reflect-client
    [*ABR-bgp-af-ipv4] peer 99.0.0.1 next-hop-local
    [*ABR-bgp-af-ipv4] peer 99.0.0.3 reflect-client
    [*ABR-bgp-af-ipv4] peer 99.0.0.3 next-hop-local
    [*ABR-bgp-af-ipv4] quit
    [*ABR-bgp] ipv4-family mvpn
    [*ABR-bgp-af-mvpn] peer 99.0.0.1 reflect-client
    [*ABR-bgp-af-mvpn] peer 99.0.0.3 reflect-client
    [*ABR-bgp-af-mvpn] quit
    [*ABR-bgp] ipv4-family vpnv4
    [*ABR-bgp-af-vpnv4] peer 99.0.0.1 reflect-client
    [*ABR-bgp-af-vpnv4] peer 99.0.0.3 reflect-client
    [*ABR-bgp-af-vpnv4] quit
    [*ABR-bgp] quit
    [*ABR] commit

  6. Configure a routing policy on each device to establish a BGP LSP.

    # Configure route policy on PE1, and apply to the routes advertised to peers.

    [~PE1] route-policy policy1 permit node 1
    [*PE1-route-policy] apply mpls-label
    [*PE1-route-policy] quit
    [*PE1] bgp 1.0
    [*PE1-bgp] ipv4-family unicast
    [*PE1-bgp-af-ipv4] peer 99.0.0.2 route-policy policy1 export
    [*PE1-bgp-af-ipv4] quit
    [*PE1-bgp] quit
    [*PE1] commit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure route policy on ABR, and apply to the routes advertised to peers.

    [~ABR] route-policy policy1 permit node 1
    [*ABR-route-policy] apply mpls-label
    [*ABR-route-policy] quit
    [*ABR] bgp 1.0
    [*ABR-bgp] ipv4-family unicast
    [*ABR-bgp-af-ipv4] peer 99.0.0.1 route-policy policy1 export
    [*ABR-bgp-af-ipv4] peer 99.0.0.3 route-policy policy1 export
    [*ABR-bgp-af-ipv4] quit
    [*ABR-bgp] quit
    [*ABR] commit

    # Configure route policy on ASBR1, and apply to the routes advertised to peers.

    [~ASBR1] route-policy policy1 permit node 1
    [*ASBR1-route-policy] apply mpls-label
    [*ASBR1-route-policy] quit
    [~ASBR1] route-policy policy2 permit node 1
    [*ASBR1-route-policy] if-match mpls-label
    [*ASBR1-route-policy] apply mpls-label
    [*ASBR1-route-policy] quit
    [*ASBR1] bgp 1.0
    [*ASBR1-bgp] ipv4-family unicast
    [*ASBR1-bgp-af-ipv4] peer 20.0.16.2 route-policy policy1 export
    [*ASBR1-bgp-af-ipv4] peer 99.0.0.2 route-policy policy2 export
    [*ASBR1-bgp-af-ipv4] quit
    [*ASBR1-bgp] quit
    [*ASBR1] commit
    The configuration of ASBR2 is similar to the configuration of ASBR1. For configuration details, see Configuration Files in this section.

  7. Configure unicast peers and BGP MVPN neighbors.

    # Configure PE1.

    [~PE1] ip vpn-instance ng
    [*PE1-vpn-instance-ng] ipv4-family
    [*PE1-vpn-instance-ng-af-ipv4] route-distinguisher 1.2.3.4:1
    [*PE1-vpn-instance-ng-af-ipv4] vpn-target 1:1 both
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] quit
    [*PE1] interface ethernet 1/0/0
    [*PE1-Ethernet1/0/0] ip binding vpn-instance ng
    [*PE1-Ethernet1/0/0] ip address 20.0.5.6 255.255.255.0
    [*PE1-Ethernet1/0/0] quit
    [*PE1] bgp 1.0
    [*PE1-bgp] ipv4-family vpn-instance ng
    [*PE1-bgp-af-vpn-ng] import-route direct
    [*PE1-bgp-af-vpn-ng] quit
    [*PE1-bgp] quit
    [*PE1] commit
    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

  8. Configure P2MP LSPs to carry multicast traffic on PEs.

    # On PE1, configure the PE1 as a sender PE.

    [~PE1] multicast mvpn 99.0.0.1
    [~PE1] ip vpn-instance ng
    [~PE1-vpn-instance-ng] ipv4-family
    [~PE1-vpn-instance-ng-af-ipv4] multicast routing-enable
    [*PE1-vpn-instance-ng-af-ipv4] mvpn
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] rpt-spt mode
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] auto-discovery inter-as
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] ipmsi-tunnel
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] mldp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] quit
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] commit
    [~PE1-vpn-instance-ng] quit

    # On PE2, configure the PE2 as a Recevier PE.

    [~PE2] multicast mvpn 99.0.0.5
    [~PE2] ip vpn-instance ng
    [~PE2-vpn-instance-ng] ipv4-family
    [~PE2-vpn-instance-ng-af-ipv4] multicast routing-enable
    [~PE2-vpn-instance-ng-af-ipv4] mvpn
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] sender-enable
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] rpt-spt mode
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] auto-discovery inter-as
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE2-vpn-instance-ng-af-ipv4] quit
    [*PE2-vpn-instance-ng] commit
    [~PE2-vpn-instance-ng] quit

  9. Configure PIM

    # Configure PE1.

    [~PE1] pim vpn-instance ng
    [~PE1-pim-vpn-instance-ng] static-rp 99.0.0.1
    [*PE1-pim-vpn-instance-ng] commit
    [~PE1-pim-vpn-instance-ng] quit
    [*PE1] interface Ethernet 1/0/0
    [*PE1-Ethernet1/0/0] pim sm
    [*PE1-Ethernet1/0/0] commit
    [~PE1-Ethernet1/0/0] quit

    # Configure PE2.

    [~PE2] pim vpn-instance ng
    [~PE2-pim-vpn-instance-ng] static-rp 99.0.0.1
    [*PE2-pim-vpn-instance-ng] commit
    [~PE2-pim-vpn-instance-ng] quit
    [*PE2] interface Ethernet 1/0/0
    [*PE2-Ethernet1/0/0] pim sm
    [*PE2-Ethernet1/0/0] igmp enable
    [*PE2-Ethernet1/0/0] commit
    [~PE2-Ethernet1/0/0] quit

  10. Verify the configuration.

    After completing the configurations, run the display ip routing-table command on PE1 or PE2 to display the routes to each other's loopback address.

    The following example uses the command output on PE1.

    <PE1> display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 10       Routes : 10
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
           99.0.0.1/32  Direct  0    0             D  127.0.0.1       LoopBack1
           99.0.0.2/32  OSPF    10   1             D  10.1.1.2        GigabitEthernet1/0/0
           99.0.0.5/32  IBGP    255  0             RD 99.0.0.2        GigabitEthernet1/0/0
           10.1.1.0/24  Direct  0    0             D  10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0             D  127.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct  0    0             D  127.0.0.1       GigabitEthernet1/0/0
          127.0.0.0/8   Direct  0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0

    Run the display mpls lsp command on PE1 or PE2 to display the LSP information.

    The following example uses the command output on PE1.

    <PE1> display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label    In/Out IF                      Vrf Name
    99.0.0.1/32        3/NULL          -/-
    99.0.0.2/32        NULL/3          -/GE1/0/0
    99.0.0.2/32        32828/3         -/GE1/0/0
    -------------------------------------------------------------------------------
                     LSP Information: BGP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label    In/Out IF                      Vrf Name
    99.0.0.1/32        32830/NULL      -/-
    99.0.0.5/32        NULL/32835      -/-

    Run th3 ping lsp command on PE1 or PE2 to check the connectivity of BGP LSP.

    The following example uses the command output on PE1.

    <PE1> ping lsp bgp 99.0.0.5 32
      LSP PING FEC: IPV4 PREFIX 5.5.5.5/32/ : 100  data bytes, press CTRL_C to break
        Reply from 99.0.0.5: bytes=100 Sequence=1 time=94 ms
        Reply from 99.0.0.5: bytes=100 Sequence=2 time=4 ms
        Reply from 99.0.0.5: bytes=100 Sequence=3 time=4 ms
        Reply from 99.0.0.5: bytes=100 Sequence=4 time=4 ms
        Reply from 99.0.0.5: bytes=100 Sequence=5 time=4 ms
    
      --- FEC: BGP LABLED IPV4 PREFIX 99.0.0.5/32 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 4/22/94 ms

Configuration Files

  • PE1 configuration file

    #
    sysname PE1 
    #
    multicast mvpn 99.0.0.1 
    #
    ip vpn-instance ng 
     ipv4-family 
      route-distinguisher 1.2.3.4:1 
      vpn-target 1:1 export-extcommunity 
      vpn-target 1:1 import-extcommunity 
      multicast routing-enable 
      mvpn 
       sender-enable 
       c-multicast signaling bgp 
       rpt-spt mode 
       auto-discovery inter-as 
       ipmsi-tunnel 
        mldp 
    #
    mpls lsr-id 99.0.0.1 
    #
    mpls 
    #
    mpls ldp 
     mldp p2mp
     mldp recursive-fec 
     
     ipv4-family 
     
    #
    route-policy policy1 permit node 1 
     apply mpls-label 
    #
    interface Ethernet0/1/0 
     undo shutdown 
     ip binding vpn-instance ng 
     ip address 20.0.5.6 255.255.255.0 
     pim sm
    #
    interface Ethernet0/1/2 
     undo shutdown 
     ip address 20.0.11.6 255.255.255.0 
     mpls 
     mpls ldp 
    #
    interface Virtual-Template0 
     ppp authentication-mode auto 
    #
    interface LoopBack0 
     ip address 99.0.0.1 255.255.255.255 
    # 
    interface NULL0 
    #
    bgp 1.0 
     peer 99.0.0.2 as-number 1.0  
     peer 99.0.0.2 connect-interface LoopBack0  
     peer 99.0.0.5 as-number 65535.65535  
     peer 99.0.0.5 ebgp-max-hop 10  
     peer 99.0.0.5 connect-interface LoopBack0
     #
     ipv4-family unicast  
      undo synchronization  
      network 99.0.0.1 255.255.255.255  
      peer 99.0.0.2 enable  
      peer 99.0.0.2 route-policy policy1 export 
      peer 99.0.0.2 label-route-capability  
      peer 99.0.0.5 enable
     #
     ipv4-family mvpn 
      policy vpn-target 
      peer 99.0.0.2 enable  
      peer 99.0.0.5 enable
     #
     ipv4-family vpnv4  
      policy vpn-target 
      peer 99.0.0.2 enable  
      peer 99.0.0.5 enable
     #
     ipv4-family vpn-instance ng  
      import-route direct
    #
    ospf 1 
     area 0.0.0.0 
     network 20.0.11.0 0.0.0.255 
     network 99.0.0.1 0.0.0.0 
     
    #
    undo dcn
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    pim vpn-instance ng
     static-rp 99.0.0.1
    #
    return
  • ABR configuration file

    # 
    sysname ABR 
    # 
    mpls lsr-id 99.0.0.2 
    # 
    mpls 
    # 
    mpls ldp 
     mldp p2mp 
     mldp recursive-fec 
     
     ipv4-family 
    # 
    isis 1 
     is-level level-2 
     cost-style wide 
     network-entity 10.0000.0000.000c.00 
    # 
    interface Ethernet0/1/2 
     undo shutdown 
     ip address 20.0.7.5 255.255.255.0 
     isis enable 1 
     mpls 
     mpls ldp 
    # 
    interface Ethernet0/1/3 
     undo shutdown 
     ip address 20.0.11.5 255.255.255.0 
     mpls 
     mpls ldp 
    # 
    interface Virtual-Template0 
     ppp authentication-mode auto 
    # 
    interface LoopBack0 
     ip address 99.0.0.2 255.255.255.255 
     isis enable 1 
    # 
    interface NULL0 
    # 
    bgp 1.0 
     peer 99.0.0.1 as-number 1.0 
     peer 99.0.0.1 connect-interface LoopBack0 
     peer 99.0.0.3 as-number 1.0 
     peer 99.0.0.3 connect-interface LoopBack0 
     # 
     ipv4-family unicast 
      undo synchronization 
      peer 99.0.0.1 enable 
      peer 99.0.0.1 route-policy policy1 export 
      peer 99.0.0.1 reflect-client 
      peer 99.0.0.1 next-hop-local 
      peer 99.0.0.1 label-route-capability 
      peer 99.0.0.3 enable 
      peer 99.0.0.3 route-policy policy1 export 
      peer 99.0.0.3 reflect-client 
      peer 99.0.0.3 next-hop-local 
      peer 99.0.0.3 label-route-capability 
     # 
     ipv4-family mvpn 
      undo policy vpn-target 
      peer 99.0.0.1 enable 
      peer 99.0.0.1 reflect-client
      peer 99.0.0.3 enable 
      peer 99.0.0.1 reflect-client
     # 
     ipv4-family vpnv4 
      undo policy vpn-target 
      peer 99.0.0.1 enable 
      peer 99.0.0.1 reflect-client 
      peer 99.0.0.3 enable 
      peer 99.0.0.3 reflect-client 
    # 
    ospf 1 
     area 0.0.0.0 
     network 20.0.11.0 0.0.0.255 
     network 99.0.0.2 0.0.0.0 
    # 
    undo dcn
    #
    route-policy policy1 permit node 1 
     apply mpls-label 
    # 
    return 
  • ASBR1 configuration file

    # 
    sysname ABR1 
    # 
    mpls lsr-id 99.0.0.3 
    # 
    mpls 
    # 
    mpls ldp 
     mldp p2mp 
     mldp recursive-fec 
     
     ipv4-family 
    # 
    isis 1 
     is-level level-2 
     cost-style wide 
     network-entity 10.0000.0000.000a.00 
    # 
    interface Ethernet0/1/3 
     undo shutdown 
     ip address 20.0.7.7 255.255.255.0 
     isis enable 1 
     mpls 
     mpls ldp 
    # 
    interface Ethernet0/1/4 
     undo shutdown 
     ip address 20.0.16.1 255.255.255.0 
     mpls 
     mpls ldp 
    # 
    interface Virtual-Template0 
     ppp authentication-mode auto 
    # 
    interface LoopBack0 
     ip address 99.0.0.3 255.255.255.255 
     isis enable 1 
    # 
    interface NULL0 
    # 
    bgp 1.0 
     peer 20.0.16.2 as-number 65535.65535 
     peer 99.0.0.2 as-number 1.0 
     peer 99.0.0.2 connect-interface LoopBack0 
     #
     ipv4-family unicast
      undo synchronization
      peer 20.0.16.2 enable
      peer 20.0.16.2 route-policy policy1 export
      peer 20.0.16.2 label-route-capability
      peer 99.0.0.2 enable
      peer 99.0.0.2 route-policy policy2 export
      peer 99.0.0.2 label-route-capability 
    # 
    undo dcn
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    route-policy policy2 permit node 1
     if-match mpls-label
     apply mpls-label
    # 
    ip route-static 99.0.0.4 255.255.255.255 20.0.16.2 
    # 
    return 
  • ASBR2 configuration file

    # 
    sysname ASBR2 
    # 
    mpls lsr-id 99.0.0.4 
    # 
    mpls 
    # 
    mpls ldp 
     mldp p2mp 
     mldp recursive-fec 
    # 
     ipv4-family 
    # 
    isis 1 
     is-level level-2 
     cost-style wide 
     network-entity 10.0000.0000.000b.00 
    # 
    interface Ethernet0/1/1 
     undo shutdown 
     ip address 20.0.10.4 255.255.255.0 
     isis enable 1 
     mpls 
     mpls ldp 
    # 
    interface Ethernet0/1/3 
     undo shutdown 
     ip address 20.0.16.2 255.255.255.0 
     mpls 
     mpls ldp 
    # 
    interface Virtual-Template0 
     ppp authentication-mode auto 
    # 
    interface LoopBack0 
     ip address 99.0.0.4 255.255.255.255 
     isis enable 1 
    # 
    interface NULL0 
    # 
    bgp 65535.65535 
     peer 20.0.16.1 as-number 1.0 
     peer 99.0.0.5 as-number 65535.65535 
     peer 99.0.0.5 connect-interface LoopBack0 
     #
     ipv4-family unicast
      undo synchronization
      network 99.0.0.5 255.255.255.255
      peer 20.0.16.1 enable
      peer 20.0.16.1 route-policy policy1 export
      peer 20.0.16.1 label-route-capability
      peer 99.0.0.5 enable
      peer 99.0.0.5 route-policy policy2 export
      peer 99.0.0.5 label-route-capability
    # 
    undo dcn
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    route-policy policy2 permit node 1
     if-match mpls-label
     apply mpls-label
    # 
    ip route-static 99.0.0.3 255.255.255.255 20.0.16.1 
    # 
    return 
  • PE2 configuration file

    #
    sysname PE2 
    #  
    multicast mvpn 99.0.0.5  
    #  
    ip vpn-instance ng  
     ipv4-family  
     route-distinguisher 2.3:1  
     vpn-target 1:1 export-extcommunity 
     vpn-target 1:1 import-extcommunity 
     multicast routing-enable  
     mvpn  
      c-multicast signaling bgp  
      rpt-spt mode
      auto-discovery inter-as  
      ipmsi-tunnel  
       mldp  
    # 
    mpls lsr-id 99.0.0.5  
    # 
    mpls  
    # 
    mpls ldp  
     mldp p2mp
     mldp recursive-fec  
     # 
     ipv4-family  
    # 
    isis 1  
     is-level level-2  
     cost-style wide  
     network-entity 10.0000.0000.000d.00 
    #  
    interface Ethernet0/1/0  
     undo shutdown  
     ip binding vpn-instance ng  
     ip address 20.0.3.3 255.255.255.0  
     pim sm
     igmp enable
    #  
    interface Ethernet0/1/1  
     undo shutdown  
     ip address 20.0.10.3 255.255.255.0  
     isis enable 1  
     mpls  
     mpls ldp  
    #  
    interface Virtual-Template0  
     ppp authentication-mode auto  
    #  
    interface LoopBack0  
     ip address 99.0.0.5 255.255.255.255 
     isis enable 1  
    #  
    interface NULL0  
    #  
    bgp 65535.65535
     peer 99.0.0.1 as-number 1.0
     peer 99.0.0.1 ebgp-max-hop 10
     peer 99.0.0.1 connect-interface LoopBack0
     peer 99.0.0.4 as-number 65535.65535
     peer 99.0.0.4 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 99.0.0.1 enable
      peer 99.0.0.4 enable
      peer 99.0.0.4 label-route-capability
     #
     ipv4-family mvpn
      policy vpn-target
      peer 99.0.0.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 99.0.0.1 enable
     #
     ipv4-family vpn-instance ng
      import-route direct
    #  
    undo dcn
    #
    pim vpn-instance ng
     static-rp 99.0.0.1
    #  
    return 
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 44395

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next