No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM-SM Intra-domain Multicast

Example for Configuring PIM-SM Intra-domain Multicast

This section provides an example for configuring basic PIM-SM functions for a PIM-SM domain.

Networking Requirements

The network shown in Figure 4-9 is connected to the Internet and has only one PIM-SM domain. To enable hosts on this network to use the VoD service in multicast mode, configure basic PIM-SM functions.

Figure 4-9 Configuring PIM-SM intra-domain multicast

Device Interface IP Address Device Interface IP Address
Device A GE 1/0/0 192.168.9.1/24 Device D GE 1/0/0 192.168.4.2/24
GE 3/0/0 192.168.1.1/24 GE 2/0/0 192.168.1.2/24
GE 2/0/0 10.110.1.1/24 GE 1/0/1 10.110.4.1/24
Device B GE 1/0/0 192.168.2.1/24 GE 3/0/0 10.110.5.1/24
GE 2/0/0 10.110.2.1/24 Device E GE 1/0/0 192.168.3.2/24
Device C GE 2/0/0 192.168.3.1/24 GE 2/0/0 192.168.2.2/24
GE 1/0/0 10.110.2.2/24 GE 3/0/0 192.168.9.2/24
GE 1/0/1 192.168.4.1/24

Precautions

When configuring PIM-SM intra-domain multicast, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • To use a static Rendezvous Point (RP), configure the same RP address on all routers.

  • If users require multicast data from specific sources, enable Protocol Independent Multicast-Source-Specific Multicast (PIM-SSM) and set the same SSM group address range on all routers.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure a unicast routing protocol.

  2. Enable multicast routing on all multicast routers.

  3. Enable PIM-SM on all router interfaces.

  4. Enable IGMP on router interfaces that directly connect to hosts.

  5. Configure RPs. An RP is a rendezvous point tree (RPT)'s root node on a PIM-SM network. Configuring a router that has more multicast branches as an RP is recommended. For example, configure Device E as an RP on the network shown in Figure 4-9.

  6. (Optional) Configure BootStrap router (BSR) boundaries on interfaces connected to the Internet. Bootstrap messages cannot pass through the BSR boundaries, and each BSR serves only the local PIM-SM domain.

  7. (Optional) Set the same SSM group address range on all routers, so a multicast router provides services only for the multicast groups in the SSM group address range.

Data Preparation

To complete the configuration, you need the following data:

  • Multicast group address

  • Multicast source address

  • SSM group address range

Procedure

  1. Configure an IP address for each router interface and a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device E.

    [~DeviceE] multicast routing-enable
    [*DeviceE] interface GigabitEthernet 1/0/0
    [*DeviceE-GigabitEthernet1/0/0] pim sm
    [*DeviceE-GigabitEthernet1/0/0] quit
    [*DeviceE] interface GigabitEthernet 2/0/0
    [*DeviceE-GigabitEthernet2/0/0] pim sm
    [*DeviceE-GigabitEthernet2/0/0] quit
    [*DeviceE] interface GigabitEthernet 3/0/0
    [*DeviceE-GigabitEthernet3/0/0] pim sm
    [*DeviceE-GigabitEthernet3/0/0] quit
    [*DeviceE] interface GigabitEthernet 1/0/1
    [*DeviceE-GigabitEthernet1/0/1] pim sm
    [*DeviceE-GigabitEthernet1/0/1] commit
    [~DeviceE-GigabitEthernet1/0/1] quit

    Repeat this step for Device A, Device B, Device C, and Device D. For configuration details, see Configuration Files in this section.

  3. Enable IGMP on router interfaces that directly connect to hosts.

    # Configure Device A.

    [~DeviceA] interface gigabitethernet 2/0/0
    [~DeviceA-GigabitEthernet2/0/0] igmp enable
    [*DeviceA-GigabitEthernet2/0/0] igmp version 3
    [*DeviceA-GigabitEthernet2/0/0] commit
    [~DeviceA-GigabitEthernet2/0/0] quit

    Repeat this step for Device B, Device C, Device D, and Device E. For configuration details, see Configuration Files in this section.

  4. Configure RPs.

    NOTE:

    You can configure both a static RP and a BSR RP, or only one of them. When both a static RP and a BSR RP are configured, the BSR RP is used by default. To use the static RP, specify preferred in the static-rp rp-address command.

    The following shows how to configure both a static RP and a BSR RP, with the BSR RP being preferred and the static RP being the backup.

    # Configure a BSR RP. Perform the following configurations on one or several routers in the PIM-SM domain. For example, on Device E, set the range of groups severed by the RP and addresses of Candidate-BootStrap Routers (C-BSRs) and Candidate-Rendezvous Points (C-RPs).

    [~DeviceE] acl number 2000
    [*DeviceE-acl4-basic-2000] rule permit source 225.1.1.0 0.0.0.255
    [*DeviceE-acl4-basic-2000] quit
    [*DeviceE] pim
    [*DeviceE-pim] c-bsr GigabitEthernet 2/0/0
    [*DeviceE-pim] c-rp GigabitEthernet 2/0/0 group-policy 2000 priority 0
    [*DeviceE-pim] commit
    [~DeviceE-pim] quit

    # Configure a static RP on Device E.

    [~DeviceE] pim
    [*DeviceE-pim] static-rp 192.168.4.1
    [*DeviceE-pim] commit
    [~DeviceE-pim] quit

    Repeat this step for Device A, Device B, Device C, and Device D. For configuration details, see Configuration Files in this section.

  5. (Optional) Configure a BSR boundary on the interface that connects Device D to the Internet.

    [~DeviceD] interface GigabitEthernet 1/0/1
    [~DeviceD-GigabitEthernet1/0/1] pim bsr-boundary
    [*DeviceD-GigabitEthernet1/0/1] commit
    [~DeviceD-GigabitEthernet1/0/1] quit

  6. (Optional) Set the SSM group address range to 232.1.1.0/24 on all routers.

    # Configure Device E

    [~DeviceE] acl number 2001
    [*DeviceE-acl4-basic-2001] rule permit source 232.1.1.0 0.0.0.255
    [*DeviceE-acl4-basic-2001] quit
    [*DeviceE] pim
    [*DeviceE-pim] ssm-policy 2001
    [*DeviceE-pim] commit
    [~DeviceE-pim] quit

    Repeat this step for Device A, Device B, Device C, and Device D. For configuration details, see Configuration Files in this section.

  7. Verify the configuration.

    # Run the display pim interface command to view information about PIM interfaces on each router. The following example uses the command output on Device E.

    <DeviceE> display pim interface
    VPN-Instance: public net
    Interface              State NbrCnt HelloInt   DR-Pri     DR-Address
    GigabitEthernet1/0/0   up     1       30         1        192.168.3.2
    GigabitEthernet2/0/0   up     1       30         1        192.168.2.2
    GigabitEthernet3/0/0   up     1       30         1        192.168.9.2
    GigabitEthernet1/0/1   up     1       30         1        192.168.4.2

    # Run the display pim bsr-info command to check information about the BSRs on each router. The following examples use the command outputs on Device D and Device E (C-BSR information is also displayed on Device E).

    <DeviceD> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScope BSR Count: 0
     Elected BSR Address: 192.168.2.2
         Priority: 0
         Hash mask length: 30
         State: Accept Preferred
         Scope: Not scoped
         Uptime: 02:08:57
         Expires: 00:01:15
         C-RP Count: 1
    <DeviceE> display pim bsr-info
     VPN-Instance: public net
     Elected AdminScope BSR Count: 0
     Elected BSR Address: 192.168.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped
         Uptime: 02:25:03
         Next BSR message scheduled at: 00:00:57
         C-RP Count: 1
     Candidate AdminScope BSR Count: 0
     Candidate BSR Address: 192.168.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped
         Wait to be BSR: 0

    # Run the display pim rp-info command to check information about the RPs on the routers. The following examples use the command outputs on Device D andDevice E.

    <DeviceD> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP information:
     Group/MaskLen: 225.1.1.0/24
         RP: 192.168.2.2
         Priority: 0
         Uptime: 02:27:17
         Expires: 00:02:15
     PIM SM static RP information:
         Static RP: 192.168.4.1
    <DeviceE> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP information:
     Group/MaskLen: 225.1.1.0/24
         RP: 192.168.2.2 (local)
         Priority: 0
         Uptime: 02:27:27
         Expires: 00:02:03
     PIM SM static RP information:
         Static RP: 192.168.4.1 (local)

    # Have Host A receive data for multicast group 225.1.1.1/24 and have Host B receive data sent from source 10.110.5.100/24 to group 232.1.1.1/24. Then, run the display pim routing-table command to check the PIM routing table on each router. The following examples use the command outputs on Device D and Device E.

    <DeviceD> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entries
    
     (10.110.5.100, 225.1.1.1)
         RP: 192.168.2.2
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:57:20
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: NULL
             RPF prime neighbor: 10.110.5.100
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet2/0/0
                 Protocol:  pim-sm, UpTime: 00:57:20, Expires: 00:03:02
    
     (10.110.5.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: LOC
         UpTime: 00:31:21
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: NULL
             RPF prime neighbor: 10.110.5.100
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol:  pim-ssm, UpTime: 00:31:21, Expires: 00:03:09
    <DeviceE> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.2.2 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:40
         Upstream interface: register
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet3/0/0
                 Protocol:  pim-sm, UpTime: 00:21:40, Expires: 00:02:43
    
     (10.110.5.100, 232.1.1.1)
         Protocol: pim-ssm, Flag:
         UpTime: 00:18:44
         Upstream interface: GigabitEthernet1/0/1
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol:  pim-ssm, UpTime: 00:18:44, Expires: 00:02:43
    

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.9.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2001
     static-rp 192.168.4.1
    #
    return
    
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     isis enable 1
    #
    pim
     ssm-policy 2001
     static-rp 192.168.4.1
    #
    return
    
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2001
     static-rp 192.168.4.1
     #
    return
    
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.4.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.110.5.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.110.4.1 255.255.255.0
     pim bsr-boundary
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2001
     static-rp 192.168.4.1
    #
    return
  • Device E configuration file

    #
    sysname DeviceE
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 225.1.1.0 0.0.0.255
    #
    acl number 2001
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.9.2 255.255.255.0
     pim sm
     isis enable 1
    #
     interface GigabitEthernet1/0/1
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2001
     static-rp 192.168.4.1
     c-bsr GigabitEthernet2/0/0
     c-rp GigabitEthernet2/0/0 group-policy 2000
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 39727

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next