No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Dual-Device IGMP Hot Backup

Example for Configuring Dual-Device IGMP Hot Backup

This section provides an example for configuring dual-device IGMP hot backup in a master/backup E-Trunk scenario. After dual-device IGMP hot backup is configured, multicast services are not interrupted during a master/backup E-Trunk switchover.

Networking Requirements

On the network shown in Figure 3-10, configure an E-Trunk on DeviceA and DeviceB. DeviceA is the master device, and DeviceB is the backup device. In normal situations, the link between DeviceA and DeviceC is Up, and the link between DeviceB and DeviceCis Down. DeviceC sends packets to DeviceA, DeviceA through the Up link to establish IGMP entries. After receiving the packets, DeviceA backs up the packets to DeviceB through the RBS channel.

If DeviceA or the link between DeviceA and DeviceC fails, a master/backup E-Trunk switchover is performed and the link between DeviceB and DeviceC goes Up. DeviceC sends packets to DeviceB through the Up link, ensuring IGMP service continuity.

Figure 3-10 Example for configuring dual-device IGMP hot backup in a master/backup E-Trunk scenario

Interface 1, Interface 2, and Interface 3 stand for GE 1/0/1, GE 1/0/2, and GE 1/0/3, respectively.

To ensure that IGMP services are not interrupted during a master/backup E-Trunk switchover, configure dual-device IGMP hot backup on DeviceA and DeviceB. After the configuration is complete, DeviceB synchronizes IGMP entries from DeviceA in real time.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign IP addresses to loopback interfaces on the master and backup devices, and configure a routing protocol.

  2. Configure an E-Trunk on DeviceA and DeviceB.

  3. Establish a dual-device backup platform on DeviceA and DeviceB.

  4. Create BFD sessions and bind them to E-Trunk on DeviceA and DeviceB.

  5. Enable remote backup for IGMP services on DeviceA and DeviceB.

Data Preparation

To complete the configuration, you need the following data:

  • Eth-Trunk ID on DeviceA, DeviceB, and DeviceC: 1. LACP system priority of DeviceA: 100.

  • E-Trunk ID on DeviceA and DeviceB: 1.

  • DeviceA's Loopback0 interface IP address is: 1.1.1.1/32; DeviceB's Loopback0 interface IP address: 2.2.2.2/32; TCP port number: 1025.

  • DeviceA's IP address: 10.0.13.1/24; DeviceB's IP address: 10.0.13.3/24.

  • RBS name: service1; RBP name: profile1; backup ID: 10.

Procedure

  1. Assign an IP address to each interface and configure OSPF on DeviceA and DeviceB. For configuration details, see Configuration Files in this section.
  2. Add an Ethernet interface to Eth-Trunk 1, and add Eth-Trunk 1 to E-Trunk 1 on DeviceA and DeviceB. For configuration details, see Configuration Files in this section.
  3. Add the interfaces for connecting DeviceC to DeviceA and DeviceB to Eth-Trunk 1. For configuration details, see Configuration Files in this section.
  4. Configure an RBS.

    # Configure an RBS on DeviceA.
    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*DeviceA] remote-backup-service service1
    [*DeviceA-rm-backup-srv-service1] peer 3.3.3.3 source 1.1.1.1 port 1025
    [*DeviceA-rm-backup-srv-service1] commit
    [~DeviceA-rm-backup-srv-service1] quit
    # Configure an RBS on DeviceB.
    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*DeviceB] remote-backup-service service1
    [*DeviceB-rm-backup-srv-service1] peer 1.1.1.1 source 3.3.3.3 port 1025
    [*DeviceB-rm-backup-srv-service1] commit
    [~DeviceB-rm-backup-srv-service1] quit

  5. # Configure an RBP.

    # Configure an RBP on DeviceA.
    [~DeviceA] remote-backup-profile profile1
    [*DeviceA-rm-backup-prf-profile1] backup-id 10 remote-backup-service service1
    [*DeviceA-rm-backup-prf-profile1] commit
    [~DeviceA-rm-backup-prf-profile1] quit
    [~DeviceA] interface Eth-Trunk 1
    [*DeviceA-Eth-Trunk1] remote-backup-profile profile1
    [*DeviceA-Eth-Trunk1] commit
    [~DeviceA-Eth-Trunk1] quit
    # Configure an RBP on DeviceB.
    [~DeviceB] remote-backup-profile profile1
    [*DeviceB-rm-backup-prf-profile1] backup-id 10 remote-backup-service service1
    [*DeviceB-rm-backup-prf-profile1] commit
    [~DeviceB-rm-backup-prf-profile1] quit
    [~DeviceB] interface Eth-Trunk 1
    [*DeviceB-Eth-Trunk1] remote-backup-profile profile1
    [*DeviceB-Eth-Trunk1] commit
    [~DeviceB-Eth-Trunk1] quit

  6. Configure a dual-device E-Trunk backup platform.

    # Configure a dual-device E-Trunk 1 backup platform on DeviceA.

    1. Configure E-Trunk 1 on DeviceA.
      [~DeviceA] e-trunk 1
      [*DeviceA-e-trunk-1] peer-address 3.3.3.3 source-address 1.1.1.1
      [*DeviceA-e-trunk-1] commit
      [~DeviceA-e-trunk-1] quit
    2. Bind E-Trunk 1's member interface Eth-Trunk 1 to the RBP named profile1 on DeviceA.
      [~DeviceA] remote-backup-profile profile1
      [*DeviceA-rm-backup-prf-profile1] e-trunk 1 eth-trunk 1
      [*DeviceA-rm-backup-prf-profile1] commit
      [~DeviceA-rm-backup-prf-profile1] quit
    3. Enable IGMP Report/Leave packet forwarding function on DeviceA.
      [~DeviceA] multicast routing-enable
      [*DeviceA] interface Eth-Trunk 1
      [*DeviceA-Eth-Trunk1] pim sm
      [*DeviceA-Eth-Trunk1] igmp enable
      [*DeviceA-Eth-Trunk1] commit
      [~DeviceA-Eth-Trunk1] quit

    # Configure a dual-device E-Trunk 1 backup platform on DeviceB.

    1. Configure E-Trunk 1 on DeviceB.
      [~DeviceB] e-trunk 1
      [*DeviceB-e-trunk-1] peer-address 1.1.1.1 source-address 3.3.3.3
      [*DeviceB-e-trunk-1] commit
      [~DeviceB-e-trunk-1] quit
    2. Bind E-Trunk 1's member interface Eth-Trunk 1 to the RBP named profile1 on DeviceB.
      [~DeviceB] remote-backup-profile profile1
      [*DeviceB-rm-backup-prf-profile1] e-trunk 1 eth-trunk 1
      [*DeviceB-rm-backup-prf-profile1] commit
      [~DeviceB-rm-backup-prf-profile1] quit
    3. Enable IGMP Report/Leave packet forwarding function on DeviceB.
      [~DeviceB] multicast routing-enable
      [*DeviceB] interface Eth-Trunk 1
      [*DeviceB-Eth-Trunk1] pim sm
      [*DeviceB-Eth-Trunk1] igmp enable
      [*DeviceB-Eth-Trunk1] commit
      [~DeviceB-Eth-Trunk1] quit

  7. Enable remote backup for IGMP services.

    # Enable remote backup for IGMP services in the view of the RBP named profile1 on DeviceA.
    [~DeviceA] remote-backup-profile profile1
    [*DeviceA-rm-backup-prf-profile1] service-type igmp
    [*DeviceA-rm-backup-prf-profile1] commit
    [~DeviceA-rm-backup-prf-profile1] quit
    # Enable remote backup for IGMP services in the view of the RBP named profile1 on DeviceB.
    [~DeviceB] remote-backup-profile profile1
    [*DeviceB-rm-backup-prf-profile1] service-type igmp
    [*DeviceB-rm-backup-prf-profile1] commit
    [~DeviceB-rm-backup-prf-profile1] quit

  8. Verify the configuration.

    After completing the configuration, run the display remote-backup-profile command on DeviceA. The command output shows that the RBP named profile1 has been created and the master/backup protocol is E-Trunk.
    <DeviceA> display remote-backup-profile profile1
     -----------------------------------------------
     Profile-Index        : 0x1000
     Profile-Name         : profile1
     Service              : igmp
     Remote-backup-service: service1
     Backup-ID            : 10
     track protocol       : E-TRUNK
         E-Trunk  ID      : 1
         Eth-trunk ID     : 1
     Interface            :
                            Eth-Trunk1
     Backup mode          : hot
     Slot-Number          : --
     Card-Number          : --
     Port-Number          : --
    Run the display remote-backup-profile command on DeviceB. The command output shows that the RBP named profile1 has been created and the master/backup protocol is E-Trunk.
    <DeviceB> display remote-backup-profile profile1
     -----------------------------------------------
     Profile-Index        : 0x1000
     Profile-Name         : profile1
     Service              : igmp
     Remote-backup-service: service1
     Backup-ID            : 10
     track protocol       : E-TRUNK
         E-Trunk  ID      : 1
         Eth-trunk ID     : 1
     Interface            :
                            Eth-Trunk1
     Backup mode          : hot
     Slot-Number          : --
     Card-Number          : --
     Port-Number          : --
    Run the display remote-backup-service command on DeviceA. The command output shows that the RBS named service1 has been created.
    <DeviceA> display remote-backup-service service1
    ----------------------------------------------------------
     Service-Index    : 1
     Service-Name     : service1
     TCP-State        : Connecting
     Peer-ip          : 3.3.3.3
     Source-ip        : 1.1.1.1
     TCP-Port         : 1025
     Track-BFD        : --
     SSL-Policy-Name  : --
     SSL-State        : --
     Last up time     : 2018-05-29 03:21:36
    ----------------------------------------------------------
    Run the display remote-backup-service command on DeviceB. The command output shows that the RBS named service1 has been created.
    <DeviceB> display remote-backup-service service1
    ----------------------------------------------------------
     Service-Index    : 1
     Service-Name     : service1
     TCP-State        : Listening
     Peer-ip          : 1.1.1.1
     Source-ip        : 3.3.3.3
     TCP-Port         : 1025
     Track-BFD        : --
     SSL-Policy-Name  : --
     SSL-State        : --
     Last up time     : 2018-05-29 03:21:36
    ----------------------------------------------------------
    Run the display eth-trunk command on DeviceA. The command output shows the status of Eth-Trunk interface.
    <DeviceA> display eth-trunk
    Eth-Trunk1's state information is:
    WorkingMode: NORMAL         Hash arithmetic: According to flow
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 32
    Operate status: up          Number Of Up Ports In Trunk: 1
    --------------------------------------------------------------------------------
    PortName                      Status      Weight
    GigabitEthernet1/0/2          Up          1
    Run the display eth-trunk command on DeviceB. The command output shows the status of Eth-Trunk interface.
    <DeviceB> display eth-trunk
    Eth-Trunk1's state information is:
    WorkingMode: NORMAL         Hash arithmetic: According to flow
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 32
    Operate status: down        Number Of Up Ports In Trunk: 0
    --------------------------------------------------------------------------------
    PortName                      Status      Weight
    GigabitEthernet1/0/3          Down        1

Configuration Files

  • DeviceA configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    e-trunk 1
     peer-address 3.3.3.3 source-address 1.1.1.1
    #
    lacp priority 100
    #
    remote-backup-service service1
     peer 3.3.3.3 source 1.1.1.1 port 1025
    #
    remote-backup-profile profile1
     service-type igmp
     backup-id 10 remote-backup-service service1
     peer-backup hot
     e-trunk 1 eth-trunk 1
    #
    interface Eth-Trunk1
     ip address 10.0.15.1 255.255.255.0
     pim sm
     igmp enable
     e-trunk 1
     remote-backup-profile profile1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.0.13.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     eth-trunk 1
     dcn
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 10.0.12.1 255.255.255.0
     pim sm
    #
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
    #
    interface NULL0
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.0.12.0 0.0.0.255
      network 10.0.13.0 0.0.0.255
      network 10.0.15.0 0.0.0.255
    #
    pim
     static-rp 2.2.2.2
    #
    return
  • DeviceB configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    e-trunk 1
     peer-address 1.1.1.1 source-address 3.3.3.3
    #
    remote-backup-service service1
     peer 1.1.1.1 source 3.3.3.3 port 1025
    #
    remote-backup-profile profile1
     service-type igmp
     backup-id 10 remote-backup-service service1
     peer-backup hot
     e-trunk 1 eth-trunk 1
    #
    interface Eth-Trunk1
     ip address 10.0.35.3 255.255.255.0
     pim sm
     igmp enable
     e-trunk 1
     remote-backup-profile profile1
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.0.13.3 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.0.23.3 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     eth-trunk 1
    #
    interface Loopback0
     ip address 3.3.3.3 255.255.255.255
    #
    interface NULL0
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.0.13.0 0.0.0.255
      network 10.0.23.0 0.0.0.255
      network 10.0.35.0 0.0.0.255
    #
    pim
     static-rp 2.2.2.2
    #
    return

    DeviceC configuration file

    #
    sysname DeviceC
    #
    vlan batch 100
    #
    multicast routing-enable
    #
    interface Eth-Trunk1
     portswitch
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet1/0/1
     portswitch
     undo shutdown
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     eth-trunk 1
    #
    interface Loopback0
     ip address 5.5.5.5 255.255.255.255
    #
    interface NULL0 
    #
    ospf 1
     area 0.0.0.0
      network 5.5.5.5 0.0.0.0
    #
    return

    DeviceD configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #               
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.0.5.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.0.23.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/3
     undo shutdown
     ip address 10.0.12.2 255.255.255.0
     pim sm
    #
    interface Loopback0
     ip address 2.2.2.2 255.255.255.255
    #
    interface NULL0
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.0.5.0 0.0.0.255
      network 10.0.12.0 0.0.0.255
      network 10.0.23.0 0.0.0.255
    #
    pim
     static-rp 2.2.2.2
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43705

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next