No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Inter-Area Seamless MPLS NG MVPN

Example for Configuring an Inter-Area Seamless MPLS NG MVPN

The backbone network is in an AS. PE and ABR advertise routes through MP-IBGP.

Networking Requirements

As shown in the Figure 9-29, CE1 is in AS 65003 and CE2 is in AS 65004. CEs communicate with each other spanning AS 65535.65535. An MP-IBGP peer relationship is established between PE and ABR. ABR is configured as an RR.

Figure 9-29 Inter-Area Seamless NG MVPN

Device Name

Interface

IP Address

CE1 Ethernet0/1/0 20.0.5.6/24
Ethernet0/1/3 20.0.6.6/24
PE1 LoopBack0 99.0.0.2/32
Ethernet0/1/3 20.0.6.3/24
Ethernet0/1/4 20.0.2.3/24
ABR1 LoopBack0 99.0.0.3/32
Ethernet0/1/2 20.0.7.5/24
Ethernet0/1/4 20.0.2.5/24
ABR2 LoopBack0 99.0.0.4/32
Ethernet0/1/3 20.0.7.7/24
Ethernet0/1/4 20.0.16.1/24
PE2 Loopback0 99.0.0.5/32
Ethernet0/1/3 20.0.16.2/24
Ethernet0/1/4 20.0.14.4/24
CE2 Ethernet0/1/0 20.0.3.1/24
Ethernet0/1/4 20.0.14.1/24

Configuration Notes

When configuring inter-Area seamless MPLS NG MVPN, note the following:

  • Set up MP-IBGP peer relationship between PE and ABR and between ABRs.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IGP protocols at the AS to implement network connectivity, and set up an MPLS LDP LSP in the AS.

  2. Configure automatic mLDP P2MP tunnel.

  3. Establish IBGP peer relationships between PE and ABR in the same AS.

  4. Configure VPN instances on PEs.

  5. Configure a routing policy to control label distribution for a BGP LSP to be established on PEs and ABRs.

  6. Configure ABR as an RR.

  7. Configure BGP peers.

  8. Configure a P2MP LSP to carry multicast traffic.

  9. Configure PIM.

Data Preparation

To complete the configuration, you need the following data:

  • MPLS LSR IDs of each device (99.0.0.2, 99.0.0.3, 99.0.0.4, 99.0.0.5)

Procedure

  1. Configure an IGP on the MPLS backbone network, so that the PEs and ABRs can communicate.

    This example uses OSPF as the IGP. For configuration details, see Configuration Files in this section.

    After the configurations are complete, OSPF neighbor relationship is established for each node in the AS.

  2. Configure basic MPLS functions and MPLS LDP, and set up LDP LSPs on the MPLS backbone network of the AS.

    # Configure PE1.

    [~PE1] mpls lsr-id 99.0.0.2
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface Ethernet 1/0/4
    [*PE1-Ethernet1/0/4] mpls
    [*PE1-Ethernet1/0/4] mpls ldp
    [*PE1-Ethernet1/0/4] commit
    [~PE1-Ethernet1/0/4] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure ABR1.

    [~ABR1] mpls lsr-id 99.0.0.3
    [*ABR1] mpls
    [*ABR1-mpls] quit
    [*ABR1] mpls ldp
    [*ABR1-mpls-ldp] quit
    [*ABR1] interface Ethernet 1/0/2
    [*ABR1-Ethernet1/0/2] mpls
    [*ABR1-Ethernet1/0/2] mpls ldp
    [*ABR1-Ethernet1/0/2] commit
    [~ABR1-Ethernet1/0/2] quit
    [*ABR1] interface Ethernet 1/0/4
    [*ABR1-Ethernet1/0/4] mpls
    [*ABR1-Ethernet1/0/4] mpls ldp
    [*ABR1-Ethernet1/0/4] commit
    [~ABR1-Ethernet1/0/4] quit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

    After the configurations are complete, the LDP sessions can be established between the PE and ABR and between the ABRs. Run the display mpls ldp session command on each device. The command output shows that the Status field is Operational. The following example uses the command output on PE1.

    <PE1> display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDD:HH:MM)
     -------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     -------------------------------------------------------------------------
     99.0.0.3          Operational DU   Passive  0000:00:01  5/5
     -------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.

  3. Configure automatic mLDP P2MP tunnel.

    # Configure PE1.

    [~PE1] mpls ldp
    [~PE1-mpls-ldp] mldp p2mp
    [*PE1-mpls-ldp] commit
    [~PE1-mpls-ldp] quit

    # Configure PE2.

    [~PE2] mpls ldp
    [~PE2-mpls-ldp] mldp p2mp
    [*PE2-mpls-ldp] mldp recursive-fec
    [*PE2-mpls-ldp] commit
    [~PE2-mpls-ldp] quit

    # Configure ABR1.

    [~ABR1] mpls ldp
    [~ABR1-mpls-ldp] mldp p2mp
    [*ABR1-mpls-ldp] mldp recursive-fec
    [*ABR1-mpls-ldp] commit
    [~ABR1-mpls-ldp] quit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

  4. Establish IBGP peer relationships between PEs and ABRs.

    # On CE1, configure BGP.

    [~CE1] bgp 65003
    [*CE1-bgp] peer 20.0.6.3 as-number 65535.65535

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # On PE1, establish IBGP peer relationship with ABR1.

    [~PE1] bgp 65535.65535
    [*PE1-bgp] peer 99.0.0.3 as-number 65535.65535
    [*PE1-bgp] peer 99.0.0.3 connect-interface loopback 0
    [*PE1-bgp] ipv4-family unicast
    [*PE1-bgp-af-ipv4] undo synchronization
    [*PE1-bgp-af-ipv4] network 99.0.0.2 32
    [*PE1-bgp-af-ipv4] peer 99.0.0.3 enable
    [*PE1-bgp-af-ipv4] peer 99.0.0.3 label-route-capability
    [*PE1-bgp-af-ipv4] commit
    [~PE1-bgp-af-ipv4] quit
    [~PE1-bgp] ipv4-family vpnv4
    [*PE1-bgp-af-vpnv4] policy vpn-target
    [*PE1-bgp-af-vpnv4] peer 99.0.0.3 enable
    [*PE1-bgp-af-vpnv4] commit
    [~PE1-bgp-af-vpnv4] quit
    [~PE1-bgp] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # On ABR1, establish IBGP peer relationship with PE1.

    [~ABR1] bgp 65535.65535
    [*ABR1-bgp] peer 99.0.0.2 as-number 65535.65535
    [*ABR1-bgp] peer 99.0.0.2 connect-interface loopback 0
    [*ABR1-bgp] peer 99.0.0.4 as-number 65535.65535
    [*ABR1-bgp] peer 99.0.0.4 connect-interface loopback 0
    [*ABR1-bgp] ipv4-family unicast
    [*ABR1-bgp-af-mvpn] undo synchronization
    [*ABR1-bgp-af-mvpn] peer 99.0.0.2 enable
    [*ABR1-bgp-af-mvpn] peer 99.0.0.2 label-route-capability
    [*ABR1-bgp-af-mvpn] peer 99.0.0.4 enable
    [*ABR1-bgp-af-mvpn] peer 99.0.0.4 label-route-capability
    [*ABR1-bgp-af-mvpn] quit
    [*ABR1-bgp] ipv4-family vpnv4
    [*ABR1-bgp-af-vpnv4] undo policy vpn-target
    [*ABR1-bgp-af-vpnv4] peer 99.0.0.2 enable
    [*ABR1-bgp-af-vpnv4] peer 99.0.0.4 enable
    [*ABR1-bgp-af-vpnv4] quit
    [*ABR1-bgp] commit
    [~ABR1-bgp] quit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

    After completing the configurations, run the display bgp vpnv4 all peer command on the PE or ABR. The command output shows that an MP-IBGP peer relationship has been established between the PE and ABR and between the ABRs. The following example uses the command output on PE1.

    <PE1> display bgp vpnv4 all peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 1         Peers in established state : 1
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
    
      99.0.0.3        4         100    18970    19008     0 91:51:24   Established    0
    

  5. Configure VPN instances.

    # Configure PE1.

    [~PE1] ip vpn-instance ng
    [*PE1-vpn-instance-ng] ipv4-family
    [*PE1-vpn-instance-ng-af-ipv4] route-distinguisher 1.2.3.4:1
    [*PE1-vpn-instance-ng-af-ipv4] vpn-target 1:1 both
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] quit
    [*PE1] interface ethernet 1/0/3
    [*PE1-Ethernet1/0/3] ip binding vpn-instance ng
    [*PE1-Ethernet1/0/3] ip address 20.0.6.3 24
    [*PE1-Ethernet1/0/3] quit
    [*PE1] bgp 65535.65535
    [*PE1-bgp] ipv4-family vpn-instance ng
    [*PE1-bgp-af-vpn-ng] import-route direct
    [*PE1-bgp-af-vpn-ng] peer 20.0.6.6 as-number 65003
    [*PE1-bgp-af-vpn-ng] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] ip vpn-instance ng
    [*PE2-vpn-instance-ng] ipv4-family
    [*PE2-vpn-instance-ng-af-ipv4] route-distinguisher 2:3
    [*PE2-vpn-instance-ng-af-ipv4] vpn-target 1:1 both
    [*PE2-vpn-instance-ng-af-ipv4] quit
    [*PE2-vpn-instance-ng] quit
    [*PE2] interface ethernet 1/0/4
    [*PE2-Ethernet1/0/4] ip binding vpn-instance ng
    [*PE2-Ethernet1/0/4] ip address 20.0.14.4 24
    [*PE2-Ethernet1/0/4] quit
    [*PE1] bgp 65535.65535
    [*PE1-bgp] ipv4-family vpn-instance ng
    [*PE1-bgp-af-vpn-ng] import-route direct
    [*PE1-bgp-af-vpn-ng] peer 20.0.14.1 as-number 65004
    [*PE1-bgp-af-vpn-ng] quit
    [*PE2] commit

    After completing the configurations, run the display ip vpn-instance verbose command on PEs. The command output shows VPN instance configurations. The following example uses the command output on PE1.

    <PE1> display ip vpn-instance verbose
     Total VPN-Instances configured : 1
     Total IPv4 VPN-Instances configured : 1 
     Total IPv6 VPN-Instances configured : 0
     
     VPN-Instance Name and ID : ng, 1
      Interfaces : Ethernet1/0/3
     Address family ipv4 
      Create date : 2017/03/18 11:30:35
      Up time : 0 days, 00 hours, 05 minutes and 19 seconds
      Route Distinguisher : 1.2.3.4:1
      Export VPN Targets :  1:1
      Import VPN Targets :  1:1
      Label policy: label per route
      The diffserv-mode Information is : uniform
      The ttl-mode Information is : pipe

  6. Configure unicast peers and BGP MVPN neighbors.

    # Configure CE1.

    [~CE1] bgp 65003
    [~CE1-bgp] ipv4-family unicast
    [~CE1-bgp-af-ipv4] undo synchronization
    [*CE1-bgp-af-ipv4] import-route direct
    [*CE1-bgp-af-ipv4] peer 20.0.6.3 enable
    [*CE1-bgp-af-ipv4] commit
    [~CE1-bgp-af-ipv4] quit
    [~CE1-bgp] quit

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # Configure PE1.

    [~PE1] bgp 100
    [~PE1-bgp] ipv4-family vpn-instance ng
    [~PE1-bgp-af-vpn-ng] import-route direct
    [*PE1-bgp-af-vpn-ng] peer 20.0.6.6 as-number 65003
    [*PE1-bgp-af-vpn-ng] commit
    [~PE1-bgp-af-vpn-ng] quit
    [~PE1-bgp] ipv4-family mvpn
    [~PE1-bgp-af-mvpn] policy vpn-target
    [*PE1-bgp-af-mvpn] peer 99.0.0.3 enable
    [*PE1-bgp-af-mvpn] commit
    [~PE1-bgp-af-mvpn] quit
    [~PE1-bgp] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure ABR1.

    [~ABR1] bgp 100
    [~ABR1-bgp] ipv4-family mvpn
    [~ABR1-bgp-af-mvpn] undo policy vpn-target
    [*ABR1-bgp-af-mvpn] peer 99.0.0.2 enable
    [*ABR1-bgp-af-mvpn] peer 99.0.0.4 enable
    [*ABR1-bgp-af-mvpn] commit
    [~ABR1-bgp-af-mvpn] quit
    [~ABR1-bgp] quit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

  7. Configure ABR as an RR to reflect the VPNv4 routes of PE1 and PE2 to each other.

    # Configure ABR1.

    [~ABR1] bgp 1.0
    [*ABR1-bgp] ipv4-family unicast
    [*ABR1-bgp-af-ipv4] peer 99.0.0.2 reflect-client
    [*ABR1-bgp-af-ipv4] peer 99.0.0.2 next-hop-local
    [*ABR1-bgp-af-ipv4] peer 99.0.0.4 reflect-client
    [*ABR1-bgp-af-ipv4] peer 99.0.0.4 next-hop-local
    [*ABR1-bgp-af-ipv4] quit
    [*ABR1-bgp] ipv4-family mvpn
    [*ABR1-bgp-af-mvpn] peer 99.0.0.2 reflect-client
    [*ABR1-bgp-af-mvpn] peer 99.0.0.4 reflect-client
    [*ABR1-bgp-af-mvpn] quit
    [*ABR1-bgp] ipv4-family vpnv4
    [*ABR1-bgp-af-vpnv4] peer 99.0.0.2 reflect-client
    [*ABR1-bgp-af-vpnv4] peer 99.0.0.4 reflect-client
    [*ABR1-bgp-af-vpnv4] quit
    [*ABR1-bgp] quit
    [*ABR1] commit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

  8. Configure a routing policy on PEs and ABRs to establish a BGP LSP.

    # Configure route policy on PE1, and apply to the routes advertised to peers.

    [~PE1] route-policy policy1 permit node 1
    [*PE1-route-policy] apply mpls-label
    [*PE1-route-policy] quit
    [*PE1] bgp 65535.65535
    [*PE1-bgp] ipv4-family unicast
    [*PE1-bgp-af-ipv4] peer 99.0.0.3 route-policy policy1 export
    [*PE1-bgp-af-ipv4] quit
    [*PE1-bgp] quit
    [*PE1] commit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure route policy on ABR, and apply to the routes advertised to peers.

    [~ABR1] route-policy policy1 permit node 1
    [*ABR1-route-policy] apply mpls-label
    [*ABR1-route-policy] quit
    [*ABR1] bgp 1.0
    [*ABR1-bgp] ipv4-family unicast
    [*ABR1-bgp-af-ipv4] peer 99.0.0.2 route-policy policy1 export
    [*ABR1-bgp-af-ipv4] peer 99.0.0.4 route-policy policy1 export
    [*ABR1-bgp-af-ipv4] quit
    [*ABR1-bgp] quit
    [*ABR1] commit

    The configuration of ABR2 is similar to the configuration of ABR1. For configuration details, see Configuration Files in this section.

  9. Configure MSDP peer relationship between CEs and PEs.

    # Configure CE1.

    [~CE1] msdp
    [~CE1-msdp] peer 20.0.6.3 connect-interface Ethernet1/0/3
    [*CE1-msdp] commit
    [~CE1-msdp] quit

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # Configure PE1.

    [~PE1] msdp vpn-instance ng
    [~PE1-msdp-ng] peer 20.0.6.6 connect-interface Ethernet1/0/3
    [*PE1-msdp-ng] commit
    [~PE1-msdp-ng] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

  10. Configure P2MP LSPs to carry multicast traffic on PEs.

    # On PE1, configure the PE1 as a sender PE.

    [~PE1] multicast mvpn 99.0.0.2
    [~PE1] ip vpn-instance ng
    [~PE1-vpn-instance-ng] ipv4-family
    [~PE1-vpn-instance-ng-af-ipv4] multicast routing-enable
    [*PE1-vpn-instance-ng-af-ipv4] mvpn
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] sender-enable
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] import msdp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] spt-only mode
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] ipmsi-tunnel
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] mldp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] quit
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] commit
    [~PE1-vpn-instance-ng] quit

    # On PE2, configure the PE2 as a Recevier PE.

    [~PE2] multicast mvpn 99.0.0.5
    [~PE2] ip vpn-instance ng
    [~PE2-vpn-instance-ng] ipv4-family
    [~PE2-vpn-instance-ng-af-ipv4] multicast routing-enable
    [~PE2-vpn-instance-ng-af-ipv4] mvpn
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] export msdp
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] spt-only mode
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE2-vpn-instance-ng-af-ipv4] quit
    [*PE2-vpn-instance-ng] commit
    [~PE2-vpn-instance-ng] quit

  11. Configure PIM

    # Configure CE1.

    [~CE1] pim
    [~CE1-pim] static-rp 20.0.6.6
    [*CE1-pim] commit
    [~CE1-pim] quit
    [~CE1] multicast routing-enable
    [*CE1] interface Ethernet 1/0/0
    [*CE1-Ethernet1/0/0] pim sm
    [*CE1-Ethernet1/0/0] commit
    [~CE1-Ethernet1/0/0] quit
    [~CE1] interface Ethernet 1/0/3
    [~CE1-Ethernet1/0/3] pim sm
    [*CE1-Ethernet1/0/3] commit
    [~CE1-Ethernet1/0/3] quit

    # Configure CE2.

    [~CE2] pim
    [~CE2-pim] static-rp 20.0.14.1
    [*CE2-pim] commit
    [~CE2-pim] quit
    [~CE2] multicast routing-enable
    [*CE2] interface Ethernet 1/0/0
    [*CE2-Ethernet1/0/0] pim sm
    [*CE2-Ethernet1/0/0] igmp enable
    [*CE2-Ethernet1/0/0] commit
    [~CE2-Ethernet1/0/0] quit
    [~CE2] interface Ethernet 1/0/4
    [~CE1-Ethernet1/0/4] pim sm
    [*CE1-Ethernet1/0/4] commit
    [~CE1-Ethernet1/0/4] quit

    Configure PE1.

    [~PE1] pim vpn-instance ng
    [~PE1-pim-vpn-instance-ng] static-rp 20.0.6.3
    [*PE1-pim-vpn-instance-ng] source-lifetime 60
    [*PE1-msdp-ng] commit
    [~PE1-msdp-ng] quit
    [*PE1] interface Ethernet 1/0/3
    [*PE1-Ethernet1/0/3] pim sm
    [*PE1-Ethernet1/0/3] commit
    [~PE1-Ethernet1/0/3] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

  12. Verify the configuration.

    After completing the configurations, CE1 and CE2 can ping each other.

    The following example uses the command output on CE1.

    <CE1> display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 9        Routes : 9
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
           20.0.6.0/24  Direct 0    0             D  20.0.6.6        GigabitEthernet1/0/0
           20.0.6.6/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
         20.0.6.255/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
           20.0.6.6/24  Direct 0    0             D  127.0.0.1       LoopBack1
         20.0.14.0/24  IBGP   255  0             D  20.0.6.3        GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    <CE1> ping -a 20.0.6.6 20.0.14.1
      PING 20.0.14.1: 56  data bytes, press CTRL_C to break
        Reply from 20.0.14.1: bytes=56 Sequence=1 ttl=252 time=109 ms
        Reply from 20.0.14.1: bytes=56 Sequence=2 ttl=252 time=89 ms
        Reply from 20.0.14.1: bytes=56 Sequence=3 ttl=252 time=71 ms
        Reply from 20.0.14.1: bytes=56 Sequence=4 ttl=252 time=116 ms
        Reply from 20.0.14.1: bytes=56 Sequence=5 ttl=252 time=70 ms
      --- 20.0.14.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 70/91/116 ms 

    Run the display bgp vpnv4 all routing-table command on ABR to display the VPNv4 routes information.

    The following example uses the command output on ABR1.

    <ABR1> display bgp vpnv4 all routing-table
    
     BGP Local router ID is 99.0.0.3
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
    
    
     Total number of routes from all PE: 2
     Route Distinguisher: 1.2.3.4:1
    
    
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>i  20.0.6.6/32       99.0.0.2         0          100        0      ?
     Route Distinguisher: 2:3
    
    
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   20.0.14.1/32      99.0.0.5                               0      200?

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    multicast routing-enable
    #
    interface Ethernet0/1/0
     undo shutdown
     ip address 20.0.5.6 255.255.255.0
     pim sm
    #
    interface Ethernet0/1/3
     undo shutdown
     ip address 20.0.6.6 255.255.255.0
     pim sm
    #
    interface Virtual-Template0
     ppp authentication-mode auto
    #
    bgp 65003
     peer 20.0.6.3 as-number 65535.65535
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 20.0.6.3 enable
    #
    pim
     static-rp 20.0.6.6
    #
    msdp
     peer 20.0.6.3 connect-interface Ethernet0/1/3
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #
    multicast mvpn 99.0.0.2
    #
    ip vpn-instance ng                                                                                                                  
     ipv4-family                                                                                                                        
      route-distinguisher 1.2.3.4:1                                                                                                         
      vpn-target 1:1 export-extcommunity                                                                                                
      vpn-target 1:1 import-extcommunity                                                                                                
      multicast routing-enable                                                                                                          
      mvpn                                                                                                                              
       sender-enable                                                                                                                    
       c-multicast signaling bgp                                                                                                        
       import msdp                                                                                                                      
       spt-only mode                                                                                                                     
       ipmsi-tunnel                                                                                                                     
        mldp                                                                                                                            
    #                                                                                                                                   
    mpls lsr-id 99.0.0.2                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp
    #                                                                                                                                   
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip binding vpn-instance ng                                                                                                         
     ip address 20.0.6.3 255.255.255.0                                                                                                  
     pim sm                                                                                                                             
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.2.3 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp
    #
    interface LoopBack0
     ip address 99.0.0.2 255.255.255.255
    #
    bgp 65535.65535
     peer 99.0.0.3 as-number 65535.65535
     peer 99.0.0.3 connect-interface LoopBack0                                                                                          
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      network 99.0.0.2 255.255.255.255
      peer 99.0.0.3 enable                                                                                                              
      peer 99.0.0.3 route-policy policy1 export
      peer 99.0.0.3 label-route-capability
     #                                                                                                                                  
     ipv4-family mvpn                                                                                                                   
      policy vpn-target                                                                                                                 
      peer 99.0.0.3 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpnv4                                                                                                                  
      policy vpn-target                                                                                                                 
      peer 99.0.0.3 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpn-instance ng                                                                                                        
      import-route direct                                                                                                               
      peer 20.0.6.6 as-number 65003                                                                                                     
    #                                                                                                                                   
    ospf 1                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.2.0 0.0.0.255                                                                                                        
      network 99.0.0.2 0.0.0.0
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #                                                                                                                                   
    pim vpn-instance ng                                                                                                                 
     static-rp 20.0.6.3                                                                                                                 
     source-lifetime 60                                                                                                                 
    #                                                                                                                                   
    msdp vpn-instance ng                                                                                                                
     peer 20.0.6.6 connect-interface Ethernet0/1/3
    #
    return
  • ABR1 configuration file

    #
    sysname ABR1
    #                                                                                                                                   
    mpls lsr-id 99.0.0.3                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp                                                                                                                          
     mldp recursive-fec
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.000c.00
    #                                                                                                                                   
    interface Ethernet0/1/2                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.7.5 255.255.255.0                                                                                                  
     isis enable 1
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.2.5 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp
    #                                                                                                                                   
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.3 255.255.255.255
    #
    bgp 65535.65535                                                                                                                             
     peer 99.0.0.2 as-number 65535.65535
     peer 99.0.0.2 connect-interface LoopBack0
     peer 99.0.0.4 as-number 65535.65535                                                                                                        
     peer 99.0.0.4 connect-interface LoopBack0                                                                                          
     #  
     ipv4-family unicast
      undo synchronization
      peer 99.0.0.2 enable
      peer 99.0.0.2 route-policy policy1 export
      peer 99.0.0.2 reflect-client
      peer 99.0.0.2 next-hop-local
      peer 99.0.0.2 label-route-capability
      peer 99.0.0.4 enable
      peer 99.0.0.4 route-policy policy1 export
      peer 99.0.0.4 reflect-client
      peer 99.0.0.4 next-hop-local
      peer 99.0.0.4 label-route-capability
     #
     ipv4-family mvpn
      undo policy vpn-target
      peer 99.0.0.2 enable
      peer 99.0.0.2 reflect-client
      peer 99.0.0.4 enable
      peer 99.0.0.4 reflect-client
     #
     ipv4-family vpnv4
      undo policy vpn-target
      peer 99.0.0.2 enable
      peer 99.0.0.2 reflect-client
      peer 99.0.0.4 enable
      peer 99.0.0.4 reflect-client
    #
    ospf 1
     area 0.0.0.0
      network 20.0.2.0 0.0.0.255
      network 99.0.0.3 0.0.0.0
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    return
  • ABR2 configuration file

    #
    sysname ABR2
    #                                                                                                                                   
    mpls lsr-id 99.0.0.4                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp                                                                                                                          
     mldp recursive-fec
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.000d.00
    #                                                                                                                                   
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.7.7 255.255.255.0                                                                                                  
     isis enable 1
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.16.1 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp
    #                                                                                                                                   
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.4 255.255.255.255
    #
    bgp 65535.65535                                                                                                                             
     peer 99.0.0.3 as-number 65535.65535
     peer 99.0.0.3 connect-interface LoopBack0
     peer 99.0.0.5 as-number 65535.65535                                                                                                        
     peer 99.0.0.5 connect-interface LoopBack0                                                                                          
     #  
     ipv4-family unicast
      undo synchronization
      peer 99.0.0.3 enable
      peer 99.0.0.3 route-policy policy1 export
      peer 99.0.0.3 reflect-client
      peer 99.0.0.3 next-hop-local
      peer 99.0.0.3 label-route-capability
      peer 99.0.0.5 enable
      peer 99.0.0.5 route-policy policy1 export
      peer 99.0.0.5 reflect-client
      peer 99.0.0.5 next-hop-local
      peer 99.0.0.5 label-route-capability
     #
     ipv4-family mvpn
      undo policy vpn-target
      peer 99.0.0.3 enable
      peer 99.0.0.3 reflect-client
      peer 99.0.0.5 enable
      peer 99.0.0.5 reflect-client
     #
     ipv4-family vpnv4
      undo policy vpn-target
      peer 99.0.0.2 enable
      peer 99.0.0.2 reflect-client
      peer 99.0.0.4 enable
      peer 99.0.0.4 reflect-client
    #
    ospf 2
     area 0.0.0.0
      network 20.0.16.0 0.0.0.255
      network 99.0.0.4 0.0.0.0
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    multicast mvpn 99.0.0.5                                                                                                             
    #
    ip vpn-instance ng                                                                                                                  
     #
     ipv4-family                                                                                                                        
      route-distinguisher 2:3                                                                                                         
      vpn-target 1:1 export-extcommunity                                                                                                
      vpn-target 1:1 import-extcommunity                                                                                                
      multicast routing-enable                                                                                                          
      mvpn                                                                                                                              
       c-multicast signaling bgp                                                                                                        
       export msdp                                                                                                                      
       spt-only mode                                                                                                                     
    #
    mpls lsr-id 99.0.0.5                                                                                                                
    #
    mpls                                                                                                                                
    #
    mpls ldp                                                                                                                            
     mldp p2mp
     mldp recursive-fec
    #
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.16.2 255.255.255.0                                                                                                 
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip binding vpn-instance ng                                                                                                         
     ip address 20.0.14.4 255.255.255.0                                                                                                 
     pim sm
    #
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.5 255.255.255.255
    #
    bgp 65535.65535
     peer 99.0.0.4 as-number 65535.65535
     peer 99.0.0.4 connect-interface LoopBack0                                                                                          
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      network 99.0.0.5 255.255.255.255
      peer 99.0.0.4 enable                                                                                                              
      peer 99.0.0.4 route-policy policy1 export
      peer 99.0.0.4 label-route-capability
     #                                                                                                                                  
     ipv4-family mvpn                                                                                                                   
      policy vpn-target                                                                                                                 
      peer 99.0.0.4 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpnv4                                                                                                                  
      policy vpn-target                                                                                                                 
      peer 99.0.0.4 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpn-instance ng                                                                                                        
      import-route direct                                                                                                               
      peer 20.0.14.1 as-number 65004
    #
    ospf 2                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.16.0 0.0.0.255                                                                                                       
      network 99.0.0.5 0.0.0.0
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    pim vpn-instance ng
     static-rp 20.0.14.4
     source-lifetime 60
    #
    msdp vpn-instance ng
     peer 20.0.14.1 connect-interface Ethernet0/1/4
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    multicast routing-enable
    #                                                                                                                                   
    interface Ethernet0/1/0                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.3.1 255.255.255.0                                                                                                  
     pim sm                                                                                                                             
     igmp enable
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.14.1 255.255.255.0                                                                                                 
     pim sm
    #                                                                                                                                   
    bgp 65004                                                                                                                           
     peer 20.0.14.4 as-number 65535.65535                                                                                                       
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      import-route direct                                                                                                               
      peer 20.0.14.4 enable
    #                                                                                                                                   
    pim                                                                                                                                 
     static-rp 20.0.14.1                                                                                                                
    #                                                                                                                                   
    msdp                                                                                                                                
     peer 20.0.14.4 connect-interface Ethernet0/1/4
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43054

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next