No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM-SM Inter-domain Multicast

Example for Configuring PIM-SM Inter-domain Multicast

You can set up MSDP peer relationships between Rendezvous Points (RPs) in different PIM-SM domains in the same autonomous system (AS) or between the RPs in different ASs that have set up BGP peer relationships so that hosts can receive multicast data from the source in another PIM-SM domain in the AS or from the source in another AS.

Networking Requirements

On the network shown in Figure 5-3, there are two ASs. Each AS contains at least one PIM-SM domain and each PIM-SM domain may contain no or one multicast source and receiver. To enable the receiver in PIM-SM2 domain to receive both multicast data sent by S3 in PIM-SM3 domain and multicast data sent by S1 in PIM-SM1 domain, configure PIM-SM inter-domain multicast.

Figure 5-3 Configuring PIM-SM inter-domain multicast

Device Interface IP Address Device Interface IP Address
DeviceA GigabitEthernet1/0/0 10.110.1.1/24 DeviceD GigabitEthernet1/0/0 10.110.2.1/24
GigabitEthernet2/0/0 192.168.1.1/24 GigabitEthernet2/0/0 192.168.3.2/24
DeviceB Loopback0 1.1.1.1/32 DeviceE Loopback0 3.3.3.3/32
GigabitEthernet1/0/0 192.168.2.1/24 GigabitEthernet2/0/0 192.168.5.1/24
GigabitEthernet2/0/0 192.168.1.2/24 GigabitEthernet3/0/0 192.168.4.2/24
GigabitEthernet1/0/1 192.168.6.1/24 GigabitEthernet1/0/1 192.168.6.2/24
DeviceC Loopback0 2.2.2.2/32 DeviceF GigabitEthernet1/0/0 10.110.3.1/24
GigabitEthernet1/0/0 192.168.2.2/24 GigabitEthernet2/0/0 192.168.5.2/24
GigabitEthernet2/0/0 192.168.3.1/24
GigabitEthernet3/0/0 192.168.4.1/24

Precautions

When configuring PIM-SM inter-domain multicast, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • Establish an MSDP peer relationship between BGP peers only when the RP and the unicast autonomous system boundary router (ASBR) are configured on the same router.

  • The address of the interface on which the MSDP peer is configured must be the same as that of the interface on which the External Border Gateway Protocol (EBGP) peer is configured.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure OSPF in the ASs to ensure that unicast routes are reachable between the ASs.

  2. Establish an EBGP peer relationship between ASs and configure BGP and OSPF to import routes from each other to ensure that unicast routes are reachable between the ASs.

  3. Enable multicast routing, enable PIM-SM on each interface, configure BSR boundaries to divide PIM-SM domains, and enable IGMP on interfaces connected to hosts.

  4. Configure the Candidate-BootStrap Router (C-BSR) and the Candidate-Rendezvous Point (C-RP). Configure the RPs of PIM-SM1 and PIM-SM2 on the ASBRs in the two domains.

  5. Establish MSDP peer relationships between RPs of PIM-SM domains.

  6. Add all MSDP peers in the same and different ASs to the same mesh group.

Data Preparation

To complete the configuration, you need the following data:

  • Multicast group address

  • AS numbers of Device A, Device B, Device C, Device D, Device E, and Device F

  • Router IDs of Device B and Device C
  • Name of the mesh group that MSDP peers join

Procedure

  1. Configure an IP address for each router interface and configure OSPF in the ASs. For configuration details, see Configuration Files in this section.
  2. Establish an EBGP peer relationship between ASs and configure BGP and OSPF to import routes from each other.

    # Configure EBGP on Device B and import OSPF routes.

    [~DeviceB] bgp 100
    [*DeviceB-bgp] router-id 1.1.1.1
    [*DeviceB-bgp] peer 192.168.2.2 as-number 200
    [*DeviceB-bgp] peer 192.168.2.2 ebgp-max-hop 255
    [*DeviceB-bgp] peer 192.168.6.2 as-number 200
    [*DeviceB-bgp] peer 192.168.6.2 ebgp-max-hop 255
    [*DeviceB-bgp] import-route ospf 1
    [*DeviceB-bgp] commit
    [~DeviceB-bgp] quit

    # Configure EBGP on Device C and import OSPF routes.

    [~DeviceC] bgp 200
    [*DeviceC-bgp] router-id 2.2.2.2
    [*DeviceC-bgp] peer 192.168.2.1 as-number 100
    [*DeviceC-bgp] peer 192.168.2.1 ebgp-max-hop 255
    [*DeviceC-bgp] import-route ospf 1
    [*DeviceC-bgp] commit
    [~DeviceC-bgp] quit

    # Configure EBGP on Device E and import OSPF routes.

    [~DeviceE] bgp 200
    [*DeviceE-bgp] router-id 3.3.3.3
    [*DeviceE-bgp] peer 192.168.6.1 as-number 100
    [*DeviceE-bgp] peer 192.168.6.1 ebgp-max-hop 255
    [*DeviceE-bgp] import-route ospf 1
    [*DeviceE-bgp] commit
    [~DeviceE-bgp] quit

    # Import BGP routes to OSPF on Device B.

    [~DeviceB] ospf 1
    [*DeviceB-ospf-1] import-route bgp
    [*DeviceB-ospf-1] commit
    [~DeviceB-ospf-1] quit

    Repeat this step for Device C and DeviceE. For configuration details, see Configuration Files in this section.

  3. Enable multicast routing, enable PIM-SM on interfaces, and configure BSR boundaries.

    # Enable multicast routing on Device B and enable PIM-SM on each interface.

    [~DeviceB] multicast routing-enable
    [*DeviceB] interface GigabitEthernet 2/0/0
    [*DeviceB-GigabitEthernet2/0/0] pim sm
    [*DeviceB-GigabitEthernet2/0/0] quit
    [*DeviceB] interface GigabitEthernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] pim sm
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] interface GigabitEthernet 1/0/1
    [*DeviceB-GigabitEthernet1/0/1] pim sm
    [*DeviceB-GigabitEthernet1/0/1] commit

    Repeat this step for other routers. For configuration details, see Configuration Files in this section.

    # Configure a BSR boundary on GE 1/0/0 and GE 1/0/1 on Device B, GE 3/0/0 and GE 1/0/1 on Device E, and GE 1/0/0 and GE 3/0/0 on Device C respectively.

    [*DeviceB] interface GigabitEthernet 1/0/0
    [~DeviceB-GigabitEthernet1/0/0] pim bsr-boundary
    [*DeviceB-GigabitEthernet1/0/0] commit
    [~DeviceB-GigabitEthernet1/0/0] quit
    [~DeviceB] interface GigabitEthernet 1/0/1
    [~DeviceB-GigabitEthernet1/0/1] pim bsr-boundary
    [*DeviceB-GigabitEthernet1/0/1] commit
    [~DeviceB-GigabitEthernet1/0/1] quit

    Repeat this step for Device E and Device C. For configuration details, see Configuration Files in this section.

  4. Enable IGMP on interfaces connected to hosts.

    # Enable IGMP on the interface connecting Device D to hosts.

    [~DeviceD] interface gigabitethernet 1/0/0
    [~DeviceD-GigabitEthernet1/0/0] igmp enable
    [*DeviceD-GigabitEthernet1/0/0] commit
    [~DeviceD-GigabitEthernet1/0/0] quit

  5. Configure a C-BSR and a C-RP.

    # Create Loopback 0 on Device B and configure Loopback 0 as both a C-BSR and a C-RP.

    [~DeviceB] interface loopback 0
    [*DeviceB-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*DeviceB-LoopBack0] pim sm
    [*DeviceB-LoopBack0] quit
    [*DeviceB] pim
    [*DeviceB-pim] c-bsr loopback 0
    [*DeviceB-pim] c-rp loopback 0
    [*DeviceB-pim] commit
    [~DeviceB-pim] quit

    The configurations of Device C and Device E are similar to the configuration of Device B. For configuration details, see Configuration Files in this section.

  6. Establish MSDP peer relationships.

    # Configure an MSDP peer on Device B.

    [~DeviceB] msdp
    [*DeviceB-msdp] peer 192.168.2.2 connect-interface GigabitEthernet1/0/0
    [*DeviceB-msdp] peer 192.168.6.2 connect-interface GigabitEthernet1/0/1
    [*DeviceB-msdp] commit
    [~DeviceB-msdp] quit

    # Configure an MSDP peer on Device C.

    [~DeviceC] msdp
    [*DeviceC-msdp] peer 192.168.2.1 connect-interface GigabitEthernet1/0/0
    [*DeviceC-msdp] peer 192.168.4.2 connect-interface GigabitEthernet3/0/0
    [*DeviceC-msdp] commit
    [~DeviceC-msdp] quit

    # Configure an MSDP peer on Device E.

    [~DeviceE] msdp
    [*DeviceE-msdp] peer 192.168.4.1 connect-interface GigabitEthernet3/0/0
    [*DeviceE-msdp] peer 192.168.6.1 connect-interface GigabitEthernet1/0/1
    [*DeviceE-msdp] commit
    [~DeviceE-msdp] quit

  7. Add all MSDP peers in the same and different ASs to the same mesh group.

    # Add Device B to the mesh group group1.

    [~DeviceB] msdp
    [*DeviceB-msdp] peer 192.168.2.2 mesh-group group1
    [*DeviceB-msdp] peer 192.168.6.2 mesh-group group1
    [*DeviceB-msdp] commit
    [~DeviceB-msdp] quit

    # Add Device C to the mesh group group1.

    [~DeviceC] msdp
    [*DeviceC-msdp] peer 192.168.2.1 mesh-group group1
    [*DeviceC-msdp] peer 192.168.4.2 mesh-group group1
    [*DeviceC-msdp] commit
    [~DeviceC-msdp] quit

    # Add Device E to the mesh group group1.

    [~DeviceE] msdp
    [*DeviceE-msdp] peer 192.168.4.1 mesh-group group1
    [*DeviceE-msdp] peer 192.168.6.1 mesh-group group1
    [*DeviceE-msdp] commit
    [~DeviceE-msdp] quit

  8. Verify the configuration.

    # Run the display bgp peer command. The command output shows BGP peer relationships established between routers. For example, the BGP peer relationship between Device B and Device C is displayed as follows:

    <DeviceB> display bgp peer
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 1         Peers in established state : 1
    
      Peer              V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      192.168.2.2       4   200       52       49     0 00:42:37 Established        7
    

    # Run the display bgp routing-table command. The command output shows BGP routing tables on routers. For example, the BGP routing table on Device C is displayed as follows:

    <DeviceC> display bgp routing-table
     
     BGP Local router ID is 2.2.2.2
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 10
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   1.1.1.1/32         192.168.2.1     0                     0      100?
     *>   2.2.2.2/32         0.0.0.0         0                     0      ?
     *>   3.3.3.3/32         0.0.0.0         1                     0      ?
     *>   10.110.1.0/24      192.168.2.1     2                     0      100?
     *>   10.110.2.0/24      0.0.0.0         2                     0      ?
     *>   10.110.3.0/24      0.0.0.0         3                     0      ?
     *>   192.168.1.0        192.168.2.1     1                     0      100?
     *>   192.168.3.0        0.0.0.0         1                     0      ?
     *>   192.168.4.0        0.0.0.0         1                     0      ?
     *>   192.168.5.0        0.0.0.0         2                     0      ?

    # Run the display msdp brief command. The command output shows MSDP peer relationships established between routers. The brief information about MSDP peer relationships established between Device B and Device C and Device E is displayed as follows:

    <DeviceB> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      2            2            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.2.2        Up        00:12:27        200    13         0
      192.168.6.2        Up        01:13:08        200    13         0
    <DeviceC> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      2            2            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.2.1        Up        01:07:08        100    8          0
      192.168.4.2        Up        00:06:39        200    13         0
    <DeviceE> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      2            2            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.4.1        Up        00:15:32        200    8          0
      192.168.6.1        Up        01:18:40        100    8          0

    # Run the display msdp peer-status command. The command output shows detailed information about MSDP peer relationships established between routers. The detailed information about MSDP peer relationships on Device B is displayed as follows:

    <DeviceB> display msdp peer-status
    MSDP Peer Information of VPN-Instance: public net
      MSDP Peer 192.168.2.2, AS 200
      Description:
      Information about connection status:
        State: Up
        Up/down time: 00:15:47
        Resets: 0
        Connection interface: GigabitEthernet1/0/0 (192.168.2.1)
        Number of sent/received messages: 16/16
        Number of discarded output messages: 0
        Elapsed time since last connection or counters clear: 00:17:51
        Mesh group peer joined: group1
      Information about (Source, Group)-based SA filtering policy:
        Import policy: none
        Export policy: none
      Information about SA-Requests:
        Policy to accept SA-Request messages: none
        Sending SA-Requests status: disable
      Minimum TTL to forward SA with encapsulated data: 0
      SAs learned from this peer: 0, SA-cache maximum for the peer: none
      Input queue size: 0, Output queue size: 0
      Counters for MSDP message:
        Count of RPF check failure: 0
        Incoming/outgoing SA messages: 0/0
        Incoming/outgoing SA requests: 0/0
        Incoming/outgoing SA responses: 0/0
        Incoming/outgoing data packets: 0/0
        Peer authentication: unconfigured
        Peer authentication: none
      MSDP Peer 192.168.6.2, AS 200
      Description:
      Information about connection status:
        State: Up
        Up/down time: 01:10:49
        Resets: 0
        Connection interface: GigabitEthernet1/0/1 (192.168.6.1)
        Number of sent/received messages: 71/71
        Number of discarded output messages: 0
        Elapsed time since last connection or counters clear: 01:11:50
        Mesh group peer joined: group1
      Information about (Source, Group)-based SA filtering policy:
        Import policy: none
        Export policy: none
      Information about SA-Requests:
        Policy to accept SA-Request messages: none
        Sending SA-Requests status: disable
      Minimum TTL to forward SA with encapsulated data: 0
      SAs learned from this peer: 0, SA-cache maximum for the peer: none
      Input queue size: 0, Output queue size: 0
      Counters for MSDP message:
        Count of RPF check failure: 0
        Incoming/outgoing SA messages: 0/0
        Incoming/outgoing SA requests: 0/0
        Incoming/outgoing SA responses: 0/0
        Incoming/outgoing data packets: 0/0
      Peer authentication: unconfigured
      Peer authentication type: none

    # Run the display pim routing-table command. The command output shows PIM routing tables on routers. When S1 (10.110.1.2/24) in PIM-SM1 domain and S3 (10.110.3.2/24) in PIM-SM3 domain send multicast data to G (225.1.1.1/24), Receiver (10.110.2.2/24) in PIM-SM2 domain can receive the multicast data. Information about the PIM routing tables on Device B and Device C is as follows:

    <DeviceB> display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
     (10.110.1.2, 225.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:00:42
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.1.1
             RPF neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    <DeviceC> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
    (*, 225.1.1.1)
         RP: 2.2.2.2 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:13:46
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0,
                 Protocol: pim-sm, UpTime: 00:13:46, Expires:-
    (10.110.1.2, 225.1.1.1)
         RP: 2.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    (10.110.3.2, 225.1.1.1)
         RP: 2.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: 192.168.4.2
             RPF neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-

Configuration Files

  • Device B configuration file

    #
    sysname DeviceB
    #
     multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 192.168.6.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ospf 1
     import-route BGP
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
    #
    bgp 100
     router-id 1.1.1.1
     peer 192.168.2.2 as-number 200
     peer 192.168.6.2 as-number 200
     peer 192.168.2.2 ebgp-max-hop 255
     peer 192.168.6.2 ebgp-max-hop 255
     #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.2 enable
      peer 192.168.6.2 enable
      peer 192.168.2.2 route-update-interval 0
    #
    msdp
     peer 192.168.2.2 connect-interface GigabitEthernet1/0/0
     peer 192.168.2.2 mesh-group group1
     peer 192.168.6.2 connect-interface GigabitEthernet1/0/1
     peer 192.168.6.2 mesh-group group1
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
     multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.4.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ospf 1
     import-route BGP
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 2.2.2.2 0.0.0.0
    #
    bgp 200
     router-id 2.2.2.2
     peer 192.168.2.1 as-number 100
     peer 192.168.2.1 ebgp-max-hop 255
     #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.1 enable
      peer 192.168.2.1 route-update-interval 0
    #
    msdp
     peer 192.168.2.1 connect-interface GigabitEthernet1/0/0
     peer 192.168.2.1 mesh-group group1
     peer 192.168.4.2 connect-interface GigabitEthernet3/0/0
     peer 192.168.4.2 mesh-group group1
    #
    return
  • Device E configuration file

    #
    sysname DeviceE
    #
     multicast routing-enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.4.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 192.168.6.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    # 
    ospf 1
     import-route BGP
     area 0.0.0.0
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
    #
    bgp 200
     router-id 3.3.3.3
     peer 192.168.6.1 as-number 100
     peer 192.168.6.1 ebgp-max-hop 255
     #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.6.1 enable
    #
    msdp
     peer 192.168.4.1 connect-interface GigabitEthernet3/0/0
     peer 192.168.4.1 mesh-group group1
     peer 192.168.6.1 connect-interface GigabitEthernet1/0/1
     peer 192.168.6.1 mesh-group group1
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 38983

Downloads: 96

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next