No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Inter-AS NG MVPN Option B

Example for Configuring an Inter-AS NG MVPN Option B

This example describes how to configure inter-AS NG MVPN in Option B mode, in which ASBRs use MP-EBGP to advertise labeled VPNv4 routes.

Networking Requirements

As shown in the Figure 9-25, CE1 and CE2 are in different VPNs which communicate with each other accross AS100 and AS200. The VPN configuration does not need to be deployed on the ASBRs. The ASBRs only need to forwarding VPNv4 routes to peer ASBRs. The MP-IBGP relationship is built between PE and ASBR. The MP-EBGP relationship is built between ASBRs.

Figure 9-25 Networking for configuring inter-AS NG MVPN in option B mode

Device Name

Interface Name

IP Address

CE1 Ethernet0/1/0 20.0.5.6/24
Ethernet0/1/3 20.0.6.6/24
PE1 LoopBack0 99.0.0.1/32
Ethernet0/1/3 20.0.6.3/24
Ethernet0/1/4 20.0.2.3/24
ASBR1 LoopBack0 99.0.0.2/32
Ethernet0/1/2 20.0.7.5/24
Ethernet0/1/4 20.0.2.5/24
ASBR2 LoopBack0 99.0.0.3/32
Ethernet0/1/3 20.0.7.7/24
Ethernet0/1/4 20.0.16.1/24
PE2 Loopback1 99.0.0.4/32
Ethernet0/1/3 20.0.16.2/24
Ethernet0/1/4 20.0.14.4/24
CE2 Ethernet0/1/0 20.0.3.1/24
Ethernet0/1/4 20.0.14.1/24

Configuration Notes

During the configuration, pay attention to the following:

  • Configure EBGP between ASBRs in different ASs. Configure IBGP between PE and ASBR in the same AS.

  • The ASBRs do not filter received VPNv4 routes based on VPN-target.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP in each AS to interconnect devices in the same AS; set up an MPLS LDP LSP between the ASBR and PE in the same AS.

  2. Set up an MP-EBGP peer relationship between the ASBRs in different ASs; set up an MP-IBGP peer relationship between the PE and ASBR in the same AS.

  3. Configure a VPN instance on each PE and bind the interface that connects a PE to a CE to the VPN instance on that PE.

  4. Enable MPLS on the interface connected to ASBRs. Configure no VPN-target filtration on the received VPNv4 routes.

  5. Configure BGP peers.

  6. Configure a P2MP LSP to carry multicast traffic.

  7. Configure PIM.

Data Preparation

To complete the configuration, you need the following data:

  • MPLS LSR IDs of PEs and ASBRs (99.0.0.1, 99.0.0.2, 99.0.0.3, 99.0.0.4)

  • VPN instance names (ng), RDs (100:1 and 200:1), and VPN targets of VPN instances (1:1)

Procedure

  1. On the MPLS backbone network in each AS, configure an IGP to interconnect the devices in the same AS.

    This example uses OSPF as the IGP. For configuration details, see Configuration Files in this section.

    After the configurations are complete, the OSPF neighbor relationship can be established between the devices in the same AS. Run the display ospf peer command. The command output shows that the neighbor relationship is in the Full state. The devices in the same AS can learn and ping the IP address of each other's loopback interface.

  2. Configure basic MPLS functions and MPLS LDP, and set up LDP LSPs on the MPLS backbone network of each AS.

    # Configure PE1.

    [~PE1] mpls lsr-id 99.0.0.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface Ethernet 1/0/4
    [*PE1-Ethernet1/0/4] mpls
    [*PE1-Ethernet1/0/4] mpls ldp
    [*PE1-Ethernet1/0/4] commit
    [~PE1-Ethernet1/0/4] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure ASBR1.

    [~ASBR1] mpls lsr-id 99.0.0.2
    [*ASBR1] mpls
    [*ASBR1-mpls] quit
    [*ASBR1] mpls ldp
    [*ASBR1-mpls-ldp] quit
    [*ASBR1] interface Ethernet 1/0/4
    [*ASBR1-Ethernet1/0/4] mpls
    [*ASBR1-Ethernet1/0/4] mpls ldp
    [*ASBR1-Ethernet1/0/4] commit
    [~ASBR1-Ethernet1/0/4] quit

    The configuration of ASBR2 is similar to the configuration of ASBR1. For configuration details, see Configuration Files in this section.

    After the configurations are complete, the LDP sessions can be established between the PE and ASBR and between the ASBRs. Run the display mpls ldp session command on each device. The command output shows that the Status field is Operational. The following example uses the command output on PE1

    <PE1> display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
     -------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     -------------------------------------------------------------------------
     99.0.0.2          Operational DU   Passive  0000:00:01  5/5
     -------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.

  3. Configure automatic mLDP P2MP tunnel on PEs and ASBRs.

    # Configure PE1.

    [~PE1] mpls ldp
    [~PE1-mpls-ldp] mldp p2mp
    [*PE1-mpls-ldp] commit
    [~PE1-mpls-ldp] quit

    # Configure PE2.

    [~PE2] mpls ldp
    [~PE2-mpls-ldp] mldp p2mp
    [*PE2-mpls-ldp] mldp recursive-fec
    [*PE2-mpls-ldp] commit
    [~PE2-mpls-ldp] quit

    # Configure ASBR1.

    [~ASBR1] mpls ldp
    [~ASBR1-mpls-ldp] mldp p2mp
    [*ASBR1-mpls-ldp] mldp recursive-fec
    [*ASBR1-mpls-ldp] commit
    [~ASBR1-mpls-ldp] quit

    The configuration of ASBR2 is similar to the configuration of ASBR1. For configuration details, see Configuration Files in this section.

  4. Configure BGP areas, and set up an MP-IBGP peer relationship between the PE and ASBR in the same AS.

    # On CE1, configure a BGP area.

    [~CE1] bgp 65003
    [*CE1-bgp] peer 20.0.6.3 as-number 100

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # On PE1, set up an MP-IBGP peer relationship between the PE and ASBRin the same AS.

    [~PE1] bgp 100
    [*PE1-bgp] peer 99.0.0.2 as-number 100
    [*PE1-bgp] peer 99.0.0.2 connect-interface loopback 0
    [*PE1-bgp] ipv4-family vpnv4
    [*PE1-bgp-af-vpnv4] peer 99.0.0.2 enable
    [*PE1-bgp-af-vpnv4] commit
    [~PE1-bgp-af-vpnv4] quit
    [~PE1-bgp] quit

    # On ASBR1, set up an MP-IBGP peer relationship between the PE and ASBRin the same AS.

    [~ASBR1] bgp 100
    [*ASBR1-bgp] peer 99.0.0.1 as-number 100
    [*ASBR1-bgp] peer 99.0.0.1 connect-interface loopback 0
    [*ASBR1-bgp] ipv4-family vpnv4
    [*ASBR1-bgp-af-vpnv4] peer 99.0.0.1 enable
    [*ASBR1-bgp-af-vpnv4] commit
    [~ASBR1-bgp-af-vpnv4] quit
    [~ASBR1-bgp] quit

    The configurations of devices in AS200 are similar to the configurations of devices in AS100. For configuration details, see Configuration Files in this section.

    After completing the configurations, run the display bgp vpnv4 all peer command on the PE or ASBR. The command output shows that an MP-IBGP peer relationship has been established between the PE and ASBR in the same AS. The following example uses the command output on PE1.

    <PE1> display bgp vpnv4 all peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 1         Peers in established state : 1
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
    
      99.0.0.2        4         100    18970    19008     0 91:51:24   Established    0
    

  5. Configure VPN instance on PEs.

    # Configure PE1.

    [~PE1] ip vpn-instance ng
    [*PE1-vpn-instance-ng] ipv4-family
    [*PE1-vpn-instance-ng-af-ipv4] route-distinguisher 100:1
    [*PE1-vpn-instance-ng-af-ipv4] vpn-target 1:1 both
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] quit
    [*PE1] interface ethernet 1/0/3
    [*PE1-Ethernet1/0/3] ip binding vpn-instance ng
    [*PE1-Ethernet1/0/3] ip address 20.0.6.3 24
    [*PE1-Ethernet1/0/3] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] ip vpn-instance ng
    [*PE2-vpn-instance-ng] ipv4-family
    [*PE2-vpn-instance-ng-af-ipv4] route-distinguisher 200:1
    [*PE2-vpn-instance-ng-af-ipv4] vpn-target 1:1 both
    [*PE2-vpn-instance-ng-af-ipv4] quit
    [*PE2-vpn-instance-ng] quit
    [*PE2] interface ethernet 1/0/4
    [*PE2-Ethernet1/0/4] ip binding vpn-instance ng
    [*PE2-Ethernet1/0/4] ip address 20.0.14.4 24
    [*PE2-Ethernet1/0/4] commit
    [~PE2-Ethernet1/0/4] quit

    After completing the configurations, run the display ip vpn-instance verbose command on PEs. The command output shows VPN instance configurations. The following example uses the command output on PE1.

    <PE1> display ip vpn-instance verbose
     Total VPN-Instances configured : 1
     Total IPv4 VPN-Instances configured : 1 
     Total IPv6 VPN-Instances configured : 0
     
     VPN-Instance Name and ID : ng, 1
      Interfaces : Ethernet1/0/3
     Address family ipv4 
      Create date : 2017/03/18 11:30:35
      Up time : 0 days, 00 hours, 05 minutes and 19 seconds
      Route Distinguisher : 100:1
      Export VPN Targets :  1:1
      Import VPN Targets :  1:1
      Label policy: label per route
      The diffserv-mode Information is : uniform
      The ttl-mode Information is : pipe

  6. Set up EBGP peer relationships between ASBRs in different ASs, and disable the VPN-target filter for received VPNv4 routes.

    # On ASBR1, enable MPLS on Ethernet 1/0/2 that connects ASBR1 to ASBR2.

    [~ASBR1] interface ethernet 1/0/2
    [~ASBR1-Ethernet1/0/2] ip address 20.0.7.5 24
    [*ASBR1-Ethernet1/0/2] mpls
    [*ASBR1-Ethernet1/0/2] mpls ldp
    [*ASBR1-Ethernet1/0/2] commit
    [~ASBR1-Ethernet1/0/2] quit

    # On ASBR2, enable MPLS on Ethernet 2/0/0 that connects ASBR2 to ASBR1.

    [~ASBR2] interface ethernet 1/0/3
    [~ASBR2-Ethernet1/0/3] ip address 20.0.7.7 24
    [*ASBR2-Ethernet1/0/3] mpls
    [*ASBR2-Ethernet1/0/3] mpls ldp
    [*ASBR2-Ethernet1/0/3] commit
    [~ASBR2-Ethernet1/0/3] quit

    On ASBR1, specify ASBR2 as the MP-EBGP peer, and configure ASBR1 not to filter received VPNv4 routes based on VPN targets.

    [~ASBR1] bgp 100
    [~ASBR1-bgp] peer 20.0.7.7 as-number 200
    [*ASBR1-bgp] ipv4-family vpnv4
    [*ASBR1-bgp-af-vpnv4] peer 20.0.7.7 enable
    [*ASBR1-bgp-af-vpnv4] undo policy vpn-target
    [*ASBR1-bgp-af-vpnv4] commit
    [~ASBR1-bgp-af-vpnv4] quit
    [~ASBR1-bgp] quit

    On ASBR2, set up an MP-EBGP peer relationship between ASBR2 and ASBR1, and configure ASBR2 not to filter received VPNv4 routes based on VPN targets.

    [~ASBR2] bgp 200
    [~ASBR2-bgp] peer 20.0.7.5 as-number 100
    [*ASBR2-bgp] ipv4-family vpnv4
    [*ASBR2-bgp-af-vpnv4] peer 20.0.7.5 enable
    [*ASBR2-bgp-af-vpnv4] undo policy vpn-target
    [*ASBR2-bgp-af-vpnv4] commit
    [~ASBR2-bgp-af-vpnv4] quit
    [~ASBR2-bgp] quit

    After completing the configurations, run the display bgp vpnv4 all peer command. The command output shows that the MP-EBGP peer relationships between the ASBRs have been established. The following example uses the command output on ASBR1.

    <PE1> display bgp vpnv4 all peer
    
     BGP local router ID : 99.0.0.2
     Local AS number : 100
     Total number of peers : 2         Peers in established state : 2
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
    
      99.0.0.1        4         100    17533    17554     0 127:24:5 Established    1
      99.0.0.3        4         200    12343    34554     0 127:24:5 Established    1

  7. Configure unicast peers and BGP MVPN neighbors.

    # Configure CE1.

    [~CE1] bgp 65003
    [~CE1-bgp] ipv4-family unicast
    [~CE1-bgp-af-ipv4] undo synchronization
    [*CE1-bgp-af-ipv4] import-route direct
    [*CE1-bgp-af-ipv4] peer 20.0.6.3 enable
    [*CE1-bgp-af-ipv4] commit
    [~CE1-bgp-af-ipv4] quit
    [~CE1-bgp] quit

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # Configure PE1.

    [~PE1] bgp 100
    [~PE1-bgp] ipv4-family unicast
    [~PE1-bgp-af-ipv4] undo synchronization
    [*PE1-bgp-af-ipv4] peer 99.0.0.2 enable
    [*PE1-bgp-af-ipv4] commit
    [~PE1-bgp-af-ipv4] quit
    [~PE1-bgp] ipv4-family vpn-instance ng
    [~PE1-bgp-af-vpn-ng] import-route direct
    [*PE1-bgp-af-vpn-ng] peer 20.0.6.6 as-number 65003
    [*PE1-bgp-af-vpn-ng] commit
    [~PE1-bgp-af-vpn-ng] quit
    [~PE1-bgp] ipv4-family mvpn
    [~PE1-bgp-af-mvpn] policy vpn-target
    [*PE1-bgp-af-mvpn] peer 99.0.0.2 enable
    [*PE1-bgp-af-mvpn] commit
    [~PE1-bgp-af-mvpn] quit
    [~PE1-bgp] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

    # Configure ASBR1.

    [~ASBR1] bgp 100
    [~ASBR1-bgp] ipv4-family unicast
    [~ASBR1-bgp-af-ipv4] undo synchronization
    [*ASBR1-bgp-af-ipv4] peer 20.0.7.7 enable
    [*ASBR1-bgp-af-ipv4] peer 99.0.0.1 enable
    [*ASBR1-bgp-af-ipv4] commit
    [~ASBR1-bgp-af-ipv4] quit
    [~ASBR1-bgp] ipv4-family mvpn
    [~ASBR1-bgp-af-mvpn] undo policy vpn-target
    [*ASBR1-bgp-af-mvpn] peer 20.0.7.7 enable
    [*ASBR1-bgp-af-mvpn] peer 99.0.0.1 enable
    [*ASBR1-bgp-af-mvpn] commit
    [~ASBR1-bgp-af-mvpn] quit
    [~ASBR1-bgp] quit

    The configuration of ASBR2 is similar to the configuration of ASBR1. For configuration details, see Configuration Files in this section.

  8. Configure MSDP peers on CEs and PEs.

    # Configure CE1.

    [~CE1] msdp
    [~CE1-msdp] peer 20.0.6.3 connect-interface Ethernet0/1/3
    [*CE1-msdp] commit
    [~CE1-msdp] quit

    The configuration of CE2 is similar to the configuration of CE1. For configuration details, see Configuration Files in this section.

    # Configure PE1.

    [~PE1] msdp vpn-instance ng
    [~PE1-msdp-ng] peer 20.0.6.6 connect-interface Ethernet0/1/3
    [*PE1-msdp-ng] commit
    [~PE1-msdp-ng] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

  9. Configure P2MP LSPs to carry multicast traffic on PEs.

    # On PE1, configure the PE1 as a sender PE.

    [~PE1] multicast mvpn 99.0.0.1
    [~PE1] ip vpn-instance ng
    [~PE1-vpn-instance-ng] ipv4-family
    [~PE1-vpn-instance-ng-af-ipv4] multicast routing-enable
    [*PE1-vpn-instance-ng-af-ipv4] mvpn
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] sender-enable
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] rpt-spt mode
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] auto-discovery inter-as
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] ipmsi-tunnel
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] mldp
    [*PE1-vpn-instance-ng-af-ipv4-mvpn-ipmsi] quit
    [*PE1-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE1-vpn-instance-ng-af-ipv4] quit
    [*PE1-vpn-instance-ng] commit
    [~PE1-vpn-instance-ng] quit

    # On PE2, configure the PE2 as a Recevier PE.

    [~PE2] multicast mvpn 99.0.0.4
    [~PE2] ip vpn-instance ng
    [~PE2-vpn-instance-ng] ipv4-family
    [~PE2-vpn-instance-ng-af-ipv4] multicast routing-enable
    [~PE2-vpn-instance-ng-af-ipv4] mvpn
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] c-multicast signaling bgp
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] rpt-spt mode
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] auto-discovery inter-as
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] ipmsi-tunnel
    [*PE2-vpn-instance-ng-af-ipv4-mvpn-ipmsi] quit
    [*PE2-vpn-instance-ng-af-ipv4-mvpn] quit
    [*PE2-vpn-instance-ng-af-ipv4] quit
    [*PE2-vpn-instance-ng] commit
    [~PE2-vpn-instance-ng] quit

  10. Configure PIM.

    # Configure CE1.

    [~CE1] pim
    [~CE1-pim] static-rp 20.0.6.6
    [*CE1-pim] commit
    [~CE1-pim] quit
    [~CE1] multicast routing-enable
    [*CE1] interface Ethernet 1/0/0
    [*CE1-Ethernet1/0/0] pim sm
    [*CE1-Ethernet1/0/0] commit
    [~CE1-Ethernet1/0/0] quit
    [~CE1] interface Ethernet 1/0/3
    [~CE1-Ethernet1/0/3] pim sm
    [*CE1-Ethernet1/0/3] commit
    [~CE1-Ethernet1/0/3] quit

    # Configure CE1.

    [~CE2] pim
    [~CE2-pim] static-rp 20.0.6.6
    [*CE2-pim] commit
    [~CE2-pim] quit
    [~CE2] multicast routing-enable
    [*CE2] interface Ethernet 1/0/0
    [*CE2-Ethernet1/0/0] pim sm
    [*CE2-Ethernet1/0/0] igmp enable
    [*CE2-Ethernet1/0/0] commit
    [~CE2-Ethernet1/0/0] quit
    [~CE2] interface Ethernet 1/0/4
    [~CE1-Ethernet1/0/4] pim sm
    [*CE1-Ethernet1/0/4] commit
    [~CE1-Ethernet1/0/4] quit

    # Configure PE1.

    [~PE1] pim vpn-instance ng
    [~PE1-pim-vpn-instance-ng] static-rp 20.0.6.3
    [*PE1-pim-vpn-instance-ng] source-lifetime 60
    [*PE1-msdp-ng] commit
    [~PE1-msdp-ng] quit
    [*PE1] interface Ethernet 1/0/3
    [*PE1-Ethernet1/0/3] pim sm
    [*PE1-Ethernet1/0/3] commit
    [~PE1-Ethernet1/0/3] quit

    The configuration of PE2 is similar to the configuration of PE1. For configuration details, see Configuration Files in this section.

  11. Verify the configuration.

    After completing the configurations, CE1 and CE2 can ping each other.

    The following example uses the command output on CE1.

    <CE1> display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 9        Routes : 9
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
           20.0.6.0/24  Direct 0    0           D   20.0.6.6       GigabitEthernet1/0/3
           20.0.6.6/32  Direct 0    0           D  127.0.0.1       GigabitEthernet1/0/3
         20.0.6.255/32  Direct 0    0           D  127.0.0.1       GigabitEthernet1/0/0
          20.0.14.0/24  EBGP   255  0           D  20.0.6.3        GigabitEthernet1/0/3
          127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0           D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0           D  127.0.0.1       InLoopBack0
    <CE1> ping -a 20.0.6.6 20.0.14.1
      PING 20.0.14.1: 56  data bytes, press CTRL_C to break
        Reply from 20.0.14.1: bytes=56 Sequence=1 ttl=252 time=120 ms
        Reply from 20.0.14.1: bytes=56 Sequence=2 ttl=252 time=73 ms
        Reply from 20.0.14.1: bytes=56 Sequence=3 ttl=252 time=111 ms
        Reply from 20.0.14.1: bytes=56 Sequence=4 ttl=252 time=86 ms
        Reply from 20.0.14.1: bytes=56 Sequence=5 ttl=252 time=110 ms
      --- 20.0.14.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 73/100/120 ms 

    Run the display bgp vpnv4 all routing-table command on ASBRs to see the VPNv4 routes.

    The following example uses the command output on ASBR1.

    <ASBR1> display bgp vpnv4 all routing-table
    
     BGP Local router ID is 99.0.0.2
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     RPKI validation codes: V - valid, I - invalid, N - not-found
    
    
     Total number of routes from all PE: 2
     Route Distinguisher: 100:1
    
    
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>i  20.0.6.6/32        99.0.0.1       0          100        0      ?
     Route Distinguisher: 200:1
    
    
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   20.0.14.1/32       20.0.7.7                             0      200?

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    multicast routing-enable
    #
    interface Ethernet0/1/0
     undo shutdown
     ip address 20.0.5.6 255.255.255.0
     pim sm
    #
    interface Ethernet0/1/3
     undo shutdown
     ip address 20.0.6.6 255.255.255.0
     pim sm
    #
    bgp 65003
     peer 20.0.6.3 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 20.0.6.3 enable
    #
    pim
     static-rp 20.0.6.6
    #
    msdp
     peer 20.0.6.3 connect-interface Ethernet0/1/3
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #                                                                                                                                   
    multicast mvpn 99.0.0.1                                                                                                             
    #                                                                                                                                   
    ip vpn-instance ng                                                                                                                  
     ipv4-family                                                                                                                        
      route-distinguisher 100:1                                                                                                         
      vpn-target 1:1 export-extcommunity                                                                                                
      vpn-target 1:1 import-extcommunity                                                                                                
      multicast routing-enable                                                                                                          
      mvpn                                                                                                                              
       sender-enable                                                                                                                    
       c-multicast signaling bgp                                                                                                        
       rpt-spt mode                                                                                                                     
       auto-discovery inter-as                                                                                                          
       ipmsi-tunnel                                                                                                                     
        mldp                                                                                                                            
    #                                                                                                                                   
    mpls lsr-id 99.0.0.1                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp
    #                                                                                                                                   
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip binding vpn-instance ng                                                                                                         
     ip address 20.0.6.3 255.255.255.0                                                                                                  
     pim sm                                                                                                                             
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.2.3 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp
    #                                                                                                                                   
    interface GigabitEthernet0/0/0                                                                                                      
     undo shutdown                                                                                                                      
     ip address 189.98.244.189 255.255.0.0                                                                                              
    #                                                                                                                                   
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.1 255.255.255.255
    #                                                                                                                                   
    bgp 100                                                                                                                             
     peer 99.0.0.2 as-number 100                                                                                                        
     peer 99.0.0.2 connect-interface LoopBack0                                                                                          
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      peer 99.0.0.2 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family mvpn                                                                                                                   
      policy vpn-target                                                                                                                 
      peer 99.0.0.2 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpnv4                                                                                                                  
      policy vpn-target                                                                                                                 
      peer 99.0.0.2 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpn-instance ng                                                                                                        
      import-route direct                                                                                                               
      peer 20.0.6.6 as-number 65003                                                                                                     
    #                                                                                                                                   
    ospf 1                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.2.0 0.0.0.255                                                                                                        
      network 99.0.0.1 0.0.0.0
    #                                                                                                                                   
    pim vpn-instance ng                                                                                                                 
     static-rp 20.0.6.3                                                                                                                 
     source-lifetime 60                                                                                                                 
    #                                                                                                                                   
    msdp vpn-instance ng                                                                                                                
     peer 20.0.6.6 connect-interface Ethernet0/1/3
    #
    return
  • ASBR1 configuration file

    #
     sysname ASBR1
    #                                                                                                                                   
    mpls lsr-id 99.0.0.2                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp                                                                                                                          
     mldp recursive-fec
    #                                                                                                                                   
    interface Ethernet0/1/2                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.7.5 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.2.5 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp
    #                                                                                                                                   
    interface GigabitEthernet0/0/0                                                                                                      
     undo shutdown                                                                                                                      
     ip address 189.98.244.191 255.255.0.0                                                                                              
    #                                                                                                                                   
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.2 255.255.255.255
    bgp 100                                                                                                                             
     peer 20.0.7.7 as-number 200                                                                                                        
     peer 99.0.0.1 as-number 100                                                                                                        
     peer 99.0.0.1 connect-interface LoopBack0                                                                                          
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      peer 20.0.7.7 enable                                                                                                              
      peer 99.0.0.1 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family mvpn                                                                                                                   
      undo policy vpn-target                                                                                                            
      peer 20.0.7.7 enable                                                                                                              
      peer 99.0.0.1 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpnv4                                                                                                                  
      undo policy vpn-target                                                                                                            
      peer 20.0.7.7 enable                                                                                                              
      peer 99.0.0.1 enable                                                                                                              
    #                                                                                                                                   
    ospf 1                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.2.0 0.0.0.255                                                                                                        
      network 99.0.0.2 0.0.0.0
    #
    ip route-static 99.0.0.3 255.255.255.255 20.0.7.7
    #
    return
  • ASBR2 configuration file

    #
     sysname ASBR2
    #                                                                                                                                   
    mpls lsr-id 99.0.0.3                                                                                                                
    #                                                                                                                                   
    mpls                                                                                                                                
    #                                                                                                                                   
    mpls ldp                                                                                                                            
     mldp p2mp                                                                                                                          
     mldp recursive-fec
    #                                                                                                                                   
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.7.7 255.255.255.0                                                                                                  
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.16.1 255.255.255.0                                                                                                 
     mpls                                                                                                                               
     mpls ldp
    #                                                                                                                                   
    interface GigabitEthernet0/0/0                                                                                                      
     undo shutdown                                                                                                                      
     ip address 189.98.244.188 255.255.0.0                                                                                              
    #                                                                                                                                   
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.3 255.255.255.255
    bgp 200                                                                                                                             
     peer 20.0.7.5 as-number 100                                                                                                        
     peer 99.0.0.4 as-number 200                                                                                                        
     peer 99.0.0.4 connect-interface LoopBack0                                                                                          
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      peer 20.0.7.5 enable                                                                                                              
      peer 99.0.0.4 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family mvpn                                                                                                                   
      undo policy vpn-target                                                                                                            
      peer 20.0.7.5 enable                                                                                                              
      peer 99.0.0.4 enable                                                                                                              
     #                                                                                                                                  
     ipv4-family vpnv4                                                                                                                  
      undo policy vpn-target                                                                                                            
      peer 20.0.7.5 enable                                                                                                              
      peer 99.0.0.4 enable                                                                                                              
    #                                                                                                                                   
    ospf 1                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.16.0 0.0.0.255                                                                                                       
      network 99.0.0.3 0.0.0.0
    #
    ip route-static 99.0.0.2 255.255.255.255 20.0.7.5
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    multicast mvpn 99.0.0.4                                                                                                             
    #
    ip vpn-instance ng                                                                                                                  
     #
     ipv4-family                                                                                                                        
      route-distinguisher 200:1                                                                                                         
      vpn-target 1:1 export-extcommunity                                                                                                
      vpn-target 1:1 import-extcommunity                                                                                                
      multicast routing-enable                                                                                                          
      mvpn                                                                                                                              
       c-multicast signaling bgp                                                                                                        
       rpt-spt mode                                                                                                                     
       auto-discovery inter-as                                                                                                          
    #
    mpls lsr-id 99.0.0.4                                                                                                                
    #
    mpls                                                                                                                                
    #
    mpls ldp                                                                                                                            
     mldp p2mp
     mldp recursive-fec
    #
    interface Ethernet0/1/3                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.16.2 255.255.255.0                                                                                                 
     mpls                                                                                                                               
     mpls ldp                                                                                                                           
    #
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip binding vpn-instance ng                                                                                                         
     ip address 20.0.14.4 255.255.255.0                                                                                                 
     pim sm
    #
    interface GigabitEthernet0/0/0                                                                                                      
     undo shutdown                                                                                                                      
     ip address 189.98.244.190 255.255.0.0                                                                                              
    #
    interface LoopBack0                                                                                                                 
     ip address 99.0.0.4 255.255.255.255
    #
    bgp 200                                                                                                                             
     peer 99.0.0.3 as-number 200                                                                                                        
     peer 99.0.0.3 connect-interface LoopBack0                                                                                          
                                                                                                                                     
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      peer 99.0.0.3 enable                                                                                                              
                                                                                                                                     
     ipv4-family mvpn                                                                                                                   
      policy vpn-target                                                                                                                 
      peer 99.0.0.3 enable                                                                                                              
                                                                                                                                     
     ipv4-family vpnv4                                                                                                                  
      policy vpn-target                                                                                                                 
      peer 99.0.0.3 enable                                                                                                              
                                                                                                                                     
     ipv4-family vpn-instance ng                                                                                                        
      import-route direct                                                                                                               
      peer 20.0.14.1 as-number 65004                                                                                                    
    #
    ospf 1                                                                                                                              
     area 0.0.0.0                                                                                                                       
      network 20.0.16.0 0.0.0.255                                                                                                       
      network 99.0.0.4 0.0.0.0
    #
    pim vpn-instance ng                                                                                                                 
     static-rp 20.0.14.4                                                                                                                
     source-lifetime 60                                                                                                                 
    #
    msdp vpn-instance ng                                                                                                                
     peer 20.0.14.1 connect-interface Ethernet0/1/4
    #
    return
  • CE2 configuration file

     
    #
    sysname CE2
    #
    multicast routing-enable
    #                                                                                                                                   
    interface Ethernet0/1/0                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.3.1 255.255.255.0                                                                                                  
     pim sm                                                                                                                             
     igmp enable
    #                                                                                                                                   
    interface Ethernet0/1/4                                                                                                             
     undo shutdown                                                                                                                      
     ip address 20.0.14.1 255.255.255.0                                                                                                 
     pim sm
    #                                                                                                                                   
    interface GigabitEthernet0/0/0                                                                                                      
     undo shutdown                                                                                                                      
     ip address 189.98.244.187 255.255.0.0
    #                                                                                                                                   
    bgp 65004                                                                                                                           
     peer 20.0.14.4 as-number 200                                                                                                       
     #                                                                                                                                  
     ipv4-family unicast                                                                                                                
      undo synchronization                                                                                                              
      import-route direct                                                                                                               
      peer 20.0.14.4 enable
    #                                                                                                                                   
    pim                                                                                                                                 
     static-rp 20.0.14.1                                                                                                                
    #                                                                                                                                   
    msdp                                                                                                                                
     peer 20.0.14.4 connect-interface Ethernet0/1/4
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43369

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next