No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IGMP Functions

Example for Configuring Basic IGMP Functions

This section provides an example for configuring basic IGMP functions.

Networking Requirements

On the network shown in Figure 3-7, hosts request to receive VoD information in multicast mode, and Host A and Host B want to statically join multicast group 225.1.1.1 to receive programs. To meet these requirements, configure basic IGMP functions.

Figure 3-7 Configuring basic IGMP functions

Device Interface IP Address Device Interface IP Address
Device A GE 2/0/0 192.168.1.1/24 Device D GE 1/0/0 192.168.4.1/24
GE 1/0/0 10.110.1.1/24 GE 2/0/1 192.168.1.2/24
Device B GE 2/0/0 192.168.2.1/24 GE 2/0/2 192.168.2.2/24
GE 1/0/0 10.110.2.1/24 GE 2/0/3 192.168.3.2/24
Device C GE 2/0/0 192.168.3.1/24
GE 1/0/0 10.110.2.2/24

Precautions

When configuring basic IGMP functions, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • Interfaces connected to the same user network segment must run the same IGMP version.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure a unicast routing protocol.

  2. Enable multicast routing on all multicast routers.

  3. Enable PIM-SM on router interfaces.

  4. Enable IGMP on interfaces that connect to hosts.

  5. Configure GE 1/0/0 on Device A to statically join IGMP group 225.1.1.1.

Data Preparation

To complete the configuration, you need the following data:

  • IGMPv2 runs on routers and hosts

  • Address of the IGMP group that the interface statically joins

Procedure

  1. Configure an IP address for each router interface and a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device D.

    [~DeviceD] multicast routing-enable
    [*DeviceD] interface GigabitEthernet 1/0/0
    [*DeviceD-GigabitEthernet1/0/0] pim sm
    [*DeviceD-GigabitEthernet1/0/0] quit
    [*DeviceD] interface GigabitEthernet 2/0/1
    [*DeviceD-GigabitEthernet2/0/1] pim sm
    [*DeviceD-GigabitEthernet2/0/1] quit
    [*DeviceD] interface GigabitEthernet 2/0/2
    [*DeviceD-GigabitEthernet2/0/2] pim sm
    [*DeviceD-GigabitEthernet2/0/2] quit
    [*DeviceD] interface GigabitEthernet 2/0/3
    [*DeviceD-GigabitEthernet2/0/3] pim sm
    [*DeviceD-GigabitEthernet2/0/3] commit
    [~DeviceD-GigabitEthernet2/0/3] quit

    Repeat this step for Device A, Device B, and Device C. For configuration details, see Configuration Files in this section.

  3. Configure a Rendezvous Point (RP).

    # Configure a dynamic RP on Device D.

    [~DeviceD] pim
    [*DeviceD-pim] c-bsr GigabitEthernet 1/0/0
    [*DeviceD-pim] c-rp GigabitEthernet 1/0/0
    [*DeviceD-pim] commit
    [~DeviceD-pim] quit

  4. Enable IGMP on interfaces that connect to hosts.

    # Configure Device A.

    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] igmp enable
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    Repeat this step for Device B and Device C. For configuration details, see Configuration Files in this section.

  5. Configure GE 1/0/0 on Device A to statically join IGMP group 225.1.1.1.

    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] igmp static-group 225.1.1.1
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

  6. Verify the configuration.

    # Run the display igmp interface command to view brief IGMP information on the router interfaces. The following example uses IGMP information on GE 1/0/0 of Device B.

    <DeviceB> display igmp interface
    Interface information of VPN-Instance: public net
     GigabitEthernet1/0/0(10.110.2.1):
       IGMP is enabled   
       Current IGMP version is 2   
       IGMP state: up
       IGMP group policy: none
       IGMP limit: -
       Value of query interval for IGMP (negotiated): -
       Value of query interval for IGMP (in seconds): 60 s
       Value of other querier timeout for IGMP(in seconds): 0 s
       Value of maximum query response time for IGMP(in seconds): 10 s
       Querier for IGMP: 10.110.2.1 (this router)
       Total 1 IGMP Group reported

    The command output shows that Device B is a querier. This is because GE 1/0/0 of Device B has the lowest IP address among the interfaces connected to the user network segment.

    # Run the display pim routing-table command on Device A to check whether GE 1/0/0 has joined IGMP group 225.1.1.1. The command output shows that the (*, 225.1.1.1) entry is generated, the downstream interface is GE 1/0/0, and the protocol type is static. These information indicates that GE 1/0/0 has joined IGMP group 225.1.1.1.

    <DeviceA> display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
     (*, 225.1.1.1)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:12:17
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: static, UpTime: 00:12:17, Expires: -

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 225.1.1.1
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     isis enable 1
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
     isis enable 1
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/1
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/2
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/3
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     c-bsr GigabitEthernet1/0/0
     c-rp GigabitEthernet1/0/0
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 39915

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next