No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic PIM-DM Functions

Example for Configuring Basic PIM-DM Functions

This section provides an example for configuring basic PIM-DM functions, so that a user can receive data from any multicast source in a normal unicast routing AS.

Networking Requirements

On the network shown in Figure 4-8, multicast is required on the router, so that client hosts on the network can receive VoD traffic in multicast mode. PIM-DM applies to small-scale networks with densely distributed multicast group members.

Figure 4-8 Configuring basic PIM-DM functions
NOTE:

Interface 1 stands for GE 1/0/0, Interface 2 for GE 1/0/1, and Interface 3 for GE 1/0/2.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable multicast on all routers.

  2. Enable PIM-DM on all router interfaces.

  3. Configure IGMP on all router interfaces connected to hosts.

Data Preparation

To complete the configuration, you need the following data:

  • Group address: 225.1.1.1/24

  • Source address: 10.1.4.100/24

  • Version number of IGMP running between the router and client hosts: 2

Procedure

  1. Assign an IP address to each router interface and configure a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast and PIM-DM on all interfaces.

    # Configure Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] multicast routing-enable
    [*DeviceA] interface gigabitethernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] pim dm
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] interface gigabitethernet 1/0/1
    [*DeviceA-GigabitEthernet1/0/1] pim dm
    [*DeviceA-GigabitEthernet1/0/1] quit
    [*DeviceA] commit

    Repeat this step for Device B, Device C, and Device D. For configuration details, see Configuration Files in this section.

  3. Configure IGMP on all router interfaces connected to hosts.

    # Configure Device C.

    [~DeviceC] interface gigabitethernet 1/0/0
    [~DeviceC-GigabitEthernet1/0/0] igmp enable
    [*DeviceC-GigabitEthernet1/0/0] igmp static-group 225.1.1.1
    [*DeviceC-GigabitEthernet1/0/0] quit
    [*DeviceC] commit

    # Configure Device D.

    [~DeviceD] interface gigabitethernet 1/0/1
    [~DeviceD-GigabitEthernet1/0/1] igmp enable
    [*DeviceD-GigabitEthernet1/0/1] igmp static-group 225.1.1.1
    [*DeviceD-GigabitEthernet1/0/1] quit
    [*DeviceD] commit

  4. Verify the configuration.

    # After completing the configurations, run the display pim interface command. The command output shows the PIM-DM operating status on a router interface. The following example uses the command output on Device B.

    <DeviceB> display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address      
     GE1/0/0             up         1       30          1     10.1.1.2 (local) 
     GE1/0/1             up         1       30          1     10.1.2.2         
     GE1/0/2             up         1       30          1     10.1.3.2 

    # Run the display pim neighbor command. The command output shows the PIM-DM neighbor relationship between routers. The following example uses the command output on Device B.

    <DeviceB> display pim neighbor
     VPN-Instance: public net
     Total: 3 
    
            Neighbor           Interface   Uptime  Expires  Dr-Priority BFD-Session 
            10.1.1.1            GE1/0/0  04:34:59 00:01:18            1           N
            10.1.2.2            GE1/0/1  04:29:56 00:01:23            1           N
            10.1.3.2            GE1/0/2  04:24:22 00:01:28            1           N

    # Run the display pim routing-table command. The command output shows the router PIM routing table. In a scenario where both User A and User B need to receive messages from multicast group G (225.1.1.1/24), when the multicast source S (10.1.4.100/24) sends data to G, a multicast forwarding tree is formed through flooding. (S, G) entries are created for every router path. When User A and User B join G, a (*, G) entry is created on Device C and Device D. The following example uses the command output on these devices.

    <DeviceA> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.1.4.100, 225.1.1.1)
         Protocol: pim-dm, Flag: LOC ACT 
         UpTime: 00:08:18     
         Upstream interface: GigabitEthernet1/0/1
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol: pim-dm, UpTime: 00:08:18, Expires: never
    <DeviceB> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.1.4.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT 
         UpTime: 00:10:25     
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.1.1
             RPF prime neighbor: 10.1.1.1
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: GigabitEthernet1/0/1
                 Protocol: pim-dm, UpTime: 00:06:48, Expires: never 
            2: GigabitEthernet1/0/2
                 Protocol: pim-dm, UpTime: 00:05:53, Expires: never 
    <DeviceC> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC 
         UpTime: 00:11:47     
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol: static, UpTime: 00:11:47, Expires: never 
    
     (10.1.4.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT 
         UpTime: 00:17:13     
         Upstream interface: GigabitEthernet1/0/1
             Upstream neighbor: 10.1.2.1
             RPF prime neighbor: 10.1.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol: pim-dm, UpTime: 00:11:47, Expires: -
    <DeviceD> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC 
         UpTime: 00:05:26     
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/1
                 Protocol: static, UpTime: 00:05:26, Expires: never 
    
     (10.1.4.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT 
         UpTime: 00:09:58     
         Upstream interface: GigabitEthernet1/0/2
             Upstream neighbor: 10.1.3.1
             RPF prime neighbor: 10.1.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/1
                 Protocol: pim-dm, UpTime: 00:05:26, Expires: - 

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     pim dm
    #
    interface GigabitEthernet1/0/1
     undo portswitch
     undo shutdown
     ip address 10.1.4.1 255.255.255.0
     pim dm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     pim dm
    #
    interface GigabitEthernet1/0/1
     undo portswitch
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     pim dm
    #
    interface GigabitEthernet1/0/2
     undo portswitch
     undo shutdown
     ip address 10.1.3.1 255.255.255.0
     pim dm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.5.1 255.255.255.0
     pim dm
     igmp enable
     igmp static-group 225.1.1.1
    #
    interface GigabitEthernet1/0/1
     undo portswitch
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
     pim dm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/1
     undo portswitch
     undo shutdown
     ip address 10.1.6.1 255.255.255.0
     pim dm
     igmp enable
     igmp static-group 225.1.1.1
    #
    interface GigabitEthernet1/0/2
     undo portswitch
     undo shutdown
     ip address 10.1.3.2 255.255.255.0
     pim dm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43100

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next