No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM-SSM Multicast

Example for Configuring PIM-SSM Multicast

This section provides an example for configuring basic Protocol Independent Multicast-Source-Specific Multicast (PIM-SSM) functions so that hosts can receive multicast data from specific multicast source.

Networking Requirements

To enable hosts on the network shown in Figure 4-13 to join source-specific multicast groups, configure PIM-SSM multicast.

Figure 4-13 Configuring PIM-SSM multicast

Device Interface IP Address Device Interface IP Address
Device A GE 1/0/0 192.168.2.1/24 Device C GE 1/0/0 192.168.4.2/24
GE 2/0/0 10.110.1.2/24 GE 2/0/0 10.110.2.1/24
Device B GE 1/0/0 192.168.2.2/24
GE 2/0/0 192.168.4.1/24

Precautions

When configuring PIM-SSM multicast, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • You must set the same SSM group address range on all routers.

  • A Rendezvous Point (RP) must be configured on the PIM-SSM network.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure a unicast routing protocol.

  2. Enable multicast routing on all multicast routers.

  3. Enable PIM-SM on all router interfaces.

  4. Enable IGMP on routers connected to hosts.

  5. Set the same SSM group address range on all routers.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of the multicast source

  • SSM group address range

Procedure

  1. Configure an IP address for each router interface and a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device A.

    [~DeviceA] multicast routing-enable
    [*DeviceA] interface gigabitethernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] pim sm
    [*DeviceA-GigabitEthernet2/0/0] quit
    [*DeviceA] interface gigabitEthernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] pim sm
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    Repeat this step for Device B and Device C. For configuration details, see Configuration Files in this section.

  3. Enable IGMP on router interfaces that directly connect to hosts.

    # Enable IGMP on the interface connecting Device C to the host and set the IGMP version to 3.

    [~DeviceC] interface gigabitethernet 2/0/0
    [~DeviceC-GigabitEthernet2/0/0] igmp enable
    [*DeviceC-GigabitEthernet2/0/0] igmp version 3
    [*DeviceC-GigabitEthernet2/0/0] commit
    [~DeviceC-GigabitEthernet2/0/0] quit

  4. Set the SSM group address range to 232.1.1.0/24 on all routers.

    # Configure Device A.

    [~DeviceA] acl number 2000
    [*DeviceA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*DeviceA-acl4-basic-2000] quit
    [*DeviceA] pim
    [*DeviceA-pim] ssm-policy 2000
    [*DeviceA-pim] commit
    [~DeviceA-pim] quit

    Repeat this step for Device B and Device C. For configuration details, see Configuration Files in this section.

  5. Verify the configuration.

    # Have Host A receive the data sent from source 10.110.1.1/24 to group 232.1.1.1/24. Then, run the display pim routing-table command to view information about the PIM routing table on each router. The following examples use the command outputs on Device A and Device B.

    <DeviceA> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: LOC
         UpTime: 00:02:13
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 10.110.1.1
             RPF prime neighbor: 10.110.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/0
                 Protocol:  pim-ssm, UpTime: 00:02:13, Expires: 00:03:17
    <DeviceB> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag:
         UpTime: 00:09:15
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet2/0/0
                 Protocol:  pim-ssm, UpTime: 00:09:15, Expires: 00:03:13
    

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.4.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
    
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 39402

Downloads: 97

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next