No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM Anycast-RP

Example for Configuring PIM Anycast-RP

In the scenario where multiple multicast sources and receivers are located in a PIM-SM domain, you can configure Anycast-Rendezvous Point (RP) peer relationships so that IP routing will automatically select the topologically closest RP for each source and receiver. This alleviates burdens on RPs, implements RP backup, and optimizes multicast forwarding paths.

Networking Requirements

On a traditional PIM-SM domain, all multicast groups map to one RP. When the network is overloaded or traffic congests on an RP, the RP may be overburdened. If the RP fails, routes are converged slowly or multicast packets are forwarded over non-optimal paths. Configuring the Anycast-RP in the PIM-SM domain can address these problems. IP routing will automatically select the topologically closest RP for each source and receiver. This feature can accelerate data transmission to receivers.

On the network shown in Figure 4-14, there are multiple multicast sources and receivers in the PIM-SM domain. Receiver 2 requests multicast data from the source. Configure Anycast-RP peer relationships between Device C and Device D so that Receiver 2 can send a Join message to the closest RP, that is, Device D. After receiving multicast data from the source, Device A encapsulates the multicast data into a Register message and sends it to Device C. Upon receipt, Device C forwards it to Device D and Receiver 2 can receive the multicast data from the source.

Figure 4-14 Configuring PIM Anycast-RP

Device Interface IP Address
Device A GE 1/0/0 10.110.1.1/24
GE 2/0/0 192.168.1.1/24
Device B GE 1/0/0 192.168.2.1/24
Device C GE 1/0/0 192.168.3.1/24
GE 2/0/0 192.168.1.2/24
GE 3/0/0 10.110.2.1/24
Loopback 0 1.1.1.1/32
Loopback 1 2.2.2.2/32
Device D GE 1/0/0 192.168.2.2/24
GE 2/0/0 10.110.3.1/24
GE 3/0/0 192.168.3.2/24
Loopback 0 1.1.1.1/32
Loopback 1 3.3.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each router interface and configure OSPF to implement IP interworking.

  2. Enable multicast routing on each router and PIM-SM on each router interface.

  3. Enable IGMP on interfaces connecting routers to hosts.

  4. On Device C and Device D, configure the Loopback 0 interfaces as both Candidate-Rendezvous Points (C-RPs) and Candidate-BootStrap Routers (C-BSRs).

  5. Configure the address of the Loopback 0 interfaces on Device C and Device D as the Anycast-RP address.

  6. On Device C and Device D, configure the addresses of the loopback 1 interfaces as the local addresses of Anycast-RPs.

  7. Configure Anycast-RP peer relationships between Device C and Device D.

Data Preparation

To complete the configuration, you need the following data:

  • Multicast group address: 226.1.1.1/24

  • RP address

  • Local RP address of the Anycast-RP

Procedure

  1. Assign an IP address to each router interface and configure OSPF to implement IP interworking. Enable multicast routing on each router and PIM-SM on each router interface. For configuration details, see Configuration Files in this section.

    # Assign an IP address and mask for each router interface in the PIM-SM domain based on Figure 4-14, and configure OSPF between routers to implement IP interworking. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] multicast routing-enable
    [*DeviceA] interface gigabitethernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] ip address 10.110.1.1 24
    [*DeviceA-GigabitEthernet1/0/0] pim sm
    [*DeviceA-GigabitEthernet1/0/0] quit
    [*DeviceA] interface gigabitEthernet 2/0/0
    [*DeviceA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [*DeviceA-GigabitEthernet2/0/0] pim sm
    [*DeviceA-GigabitEthernet2/0/0] quit
    [*DeviceA] ospf
    [*DeviceA-ospf-1] area 0
    [*DeviceA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*DeviceA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*DeviceA-ospf-1-area-0.0.0.0] quit
    [*DeviceA-ospf-1] quit
    [*DeviceA] commit

    # Configure Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] multicast routing-enable
    [*DeviceB] interface gigabitEthernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] ip address 192.168.2.1 24
    [*DeviceB-GigabitEthernet1/0/0] pim sm
    [*DeviceB-GigabitEthernet1/0/0] quit
    [*DeviceB] ospf
    [*DeviceB-ospf-1] area 0
    [*DeviceB-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*DeviceB-ospf-1-area-0.0.0.0] quit
    [*DeviceB-ospf-1] quit
    [*DeviceB] commit

    # Configure Device C.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceC
    [*HUAWEI] commit
    [~DeviceC] multicast routing-enable
    [*DeviceC] interface gigabitEthernet 1/0/0
    [*DeviceC-GigabitEthernet1/0/0] ip address 192.168.3.1 24
    [*DeviceC-GigabitEthernet1/0/0] pim sm
    [*DeviceC-GigabitEthernet1/0/0] quit
    [*DeviceC] interface gigabitEthernet 2/0/0
    [*DeviceC-GigabitEthernet2/0/0] ip address 192.168.1.2 24
    [*DeviceC-GigabitEthernet2/0/0] pim sm
    [*DeviceC-GigabitEthernet2/0/0] quit
    [*DeviceC] interface gigabitethernet 3/0/0
    [*DeviceC-GigabitEthernet3/0/0] ip address 10.110.2.1 24
    [*DeviceC-GigabitEthernet3/0/0] pim sm
    [*DeviceC-GigabitEthernet3/0/0] quit
    [*DeviceC] interface loopback0
    [*DeviceC-LoopBack0] ip address 1.1.1.1 32
    [*DeviceC-LoopBack0] pim sm
    [*DeviceC-LoopBack0] quit
    [*DeviceC] interface loopback1
    [*DeviceC-LoopBack1] ip address 2.2.2.2 32
    [*DeviceC-LoopBack1] pim sm
    [*DeviceC-LoopBack1] quit
    [*DeviceC] ospf
    [*DeviceC-ospf-1] area 0
    [*DeviceC-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] network 10.110.2.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*DeviceC-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [*DeviceC-ospf-1-area-0.0.0.0] quit
    [*DeviceC-ospf-1] quit
    [*DeviceC] commit

    # Configure Device D.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceD
    [*HUAWEI] commit
    [~DeviceD] multicast routing-enable
    [*DeviceD] interface gigabitEthernet 1/0/0
    [*DeviceD-GigabitEthernet1/0/0] ip address 192.168.2.2 24
    [*DeviceD-GigabitEthernet1/0/0] pim sm
    [*DeviceD-GigabitEthernet1/0/0] quit
    [*DeviceD] interface gigabitethernet 2/0/0
    [*DeviceD-GigabitEthernet2/0/0] ip address 10.110.3.1 24
    [*DeviceD-GigabitEthernet2/0/0] pim sm
    [*DeviceD-GigabitEthernet2/0/0] quit
    [*DeviceD] interface gigabitEthernet 3/0/0
    [*DeviceD-GigabitEthernet3/0/0] ip address 192.168.3.2 24
    [*DeviceD-GigabitEthernet3/0/0] pim sm
    [*DeviceD-GigabitEthernet3/0/0] quit
    [*DeviceD] interface loopback0
    [*DeviceD-LoopBack0] ip address 1.1.1.1 32
    [*DeviceD-LoopBack0] pim sm
    [*DeviceD-LoopBack0] quit
    [*DeviceD] interface loopback1
    [*DeviceD-LoopBack1] ip address 3.3.3.3 32
    [*DeviceD-LoopBack1] pim sm
    [*DeviceD-LoopBack1] quit
    [*DeviceD] ospf
    [*DeviceD-ospf-1] area 0
    [*DeviceD-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*DeviceD-ospf-1-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [*DeviceD-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [*DeviceD-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*DeviceD-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [*DeviceD-ospf-1-area-0.0.0.0] quit
    [*DeviceD-ospf-1] quit
    [*DeviceD] commit

  2. Enable IGMP on interfaces connecting routers to hosts.

    # Enable IGMP on the interfaces connecting Device C and Device D to hosts.

    # Configure Device C.

    [~DeviceC] interface gigabitethernet 3/0/0
    [~DeviceC-GigabitEthernet3/0/0] igmp enable
    [*DeviceC-GigabitEthernet3/0/0] quit

    # Configure Device D.

    [~DeviceD] interface gigabitethernet 2/0/0
    [~DeviceD-GigabitEthernet2/0/0] igmp enable
    [*DeviceD-GigabitEthernet2/0/0] quit

  3. On Device C and Device D, configure the Loopback 0 interfaces as both C-RPs and C-BSRs.

    # Configure Device C.

    [~DeviceC] pim
    [*DeviceC-pim] c-bsr loopback0
    [*DeviceC-pim] c-rp loopback0

    # Configure Device D.

    [~DeviceD] pim
    [*DeviceD-pim] c-bsr loopback0
    [*DeviceD-pim] c-rp loopback0

  4. Configure the address of the Loopback 0 interfaces on Device C and Device D as the Anycast-RP address.

    # Configure Device C.

    [*DeviceC-pim] anycast-rp 1.1.1.1
    [*DeviceC-pim-anycast-rp-1.1.1.1] quit

    # Configure Device D.

    [*DeviceD-pim] anycast-rp 1.1.1.1
    [*DeviceD-pim-anycast-rp-1.1.1.1] quit

  5. On Device C and Device D, configure the addresses of the Loopback 1 interfaces as the local addresses of Anycast-RPs.

    # Configure Device C.

    [*DeviceC-pim] anycast-rp 1.1.1.1
    [*DeviceC-pim-anycast-rp-1.1.1.1] local-address 2.2.2.2
    [*DeviceC-pim-anycast-rp-1.1.1.1] quit

    # Configure Device D.

    [*DeviceD-pim] anycast-rp 1.1.1.1
    [*DeviceD-pim-anycast-rp-1.1.1.1] local-address 3.3.3.3
    [*DeviceD-pim-anycast-rp-1.1.1.1] quit

  6. Configure Anycast-RP peer relationships between Device C and Device D.

    # Configure Device C.

    [*DeviceC-pim] anycast-rp 1.1.1.1
    [*DeviceC-pim-anycast-rp-1.1.1.1] peer 3.3.3.3
    [*DeviceC-pim-anycast-rp-1.1.1.1] quit
    [*DeviceC-pim] quit
    [*DeviceC] commit

    # Configure Device D.

    [*DeviceD-pim] anycast-rp 1.1.1.1
    [*DeviceD-pim-anycast-rp-1.1.1.1] peer 2.2.2.2
    [*DeviceD-pim-anycast-rp-1.1.1.1] quit
    [*DeviceD-pim] quit
    [*DeviceD] commit

  7. Verify the configuration.

    # Run the display pim rp-info command on Device C and Device D to check RP information.

    <DeviceC> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 1.1.1.1 (local)
         Priority: 0
         Uptime: 00:45:19
         Expires: 00:02:11
    <DeviceD> display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 1.1.1.1 (local)
         Priority: 0
         Uptime: 02:27:56
         Expires: 00:01:39
    

    The preceding command output shows that Device C and Device D both serve as an RP and can forward Register messages from the multicast source to each other.

    # Have Source (10.110.1.2/24) send multicast data to group G (226.1.1.1) and have Receiver 2 join G and receive the multicast data sent to G. Have Source send a Register message to Device C and have Receiver 2 send a Join message to Device D. Then, run the display pim routing-table command to check PIM entries on each router.

    <DeviceC> display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entries
    
     (10.110.1.2, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: 2MSDP ACT
         UpTime: 00:00:38
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information: None
    <DeviceD> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entries
    
     (*, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:25
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: igmp, UpTime: 00:01:25, Expires: -
    
     (10.110.1.2, 226.1.1.1)
         RP: 1.1.1.1 (local)
         Protocol: pim-sm, Flag: 2MSDP SWT ACT
         UpTime: 00:00:02
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:02, Expires: -

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
       network 192.168.2.0 0.0.0.255
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
      network 2.2.2.2 0.0.0.0
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
     anycast-rp 1.1.1.1
      local-address 2.2.2.2
      peer 3.3.3.3
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.0
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
      network 1.1.1.1 0.0.0.0
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
     anycast-rp 1.1.1.1
      local-address 3.3.3.3
      peer 2.2.2.2
    #
    return
    
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 44228

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next