No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 User-Side Multicast for a VPN

Example for Configuring IPv4 User-Side Multicast for a VPN

This section describes how to configure IPv4 user-side multicast for a VPN.

Networking Requirements

On the network shown in Figure 14-8, users access the network in IPoE mode through sub-interface interface 2 on a broadband remote access server (BRAS). The users and multicast source belong to the same VPN instance named red. Configure user-side multicast, allowing the users to order programs from the multicast source and allowing for refined user management.

Figure 14-8 Configuring IPv4 user-side multicast for a VPN
NOTE:

Interface 1, interface 2, and interface 3 stand for GE 1/0/0, GE 1/0/1 (with the sub-interface 1/0/1.1), and GE 1/0/2, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure multicast VPN functions. An NG MVPN over an mLDP P2MP tunnel is used as an example.

    1. Configure a BGP MPLS/IP VPN and ensure that the unicast VPN is working properly.

    2. Enable mLDP globally on PE1 and PE2.

    3. Establish a BGP MVPN peer relationship between PE1 and PE2.

    4. Configure an mLDP I-PMSI tunnel on PE1.

    5. Bind an interface on PE2 to the VPN instance.

    6. Configure IGMP on the interface that connects the multicast-capable device to the user network segment.

  2. Configure an IPv4 address pool.

  3. Configure AAA schemes.

  4. Configure a domain.

  5. Configure the IPoE access mode.

    1. Configure an authentication mode.

    2. Bind a sub-interface to a VLAN.

    3. Configure a BAS interface and specify a user access type for the interface.

  6. Configure a multicast replication mode. Multicast replication by multicast VLAN is used as an example.

  7. Configure basic multicast functions.

  8. Bind an interface to the VPN instance.

Data Preparation

  • IP addresses of loopback 0 on the BRAS and PE2: 1.1.1.1 and 2.2.2.2, respectively

  • Public network OSPF process ID: 1; area ID: 0

  • MPLS LSR IDs of the BRAS and PE2: 1.1.1.1 and 2.2.2.2, respectively

  • MVPN IDs of the BRAS and PE2: 1.1.1.1 and 2.2.2.2, respectively

  • Names, RDs, and VPN targets of the VPN instances on the BRAS and PE2: red, 1:1, and 1:1, respectively

  • IPv4 address pool parameters

  • Authentication and accounting scheme parameters

  • User domain parameters

  • BAS interface parameters

Procedure

  1. Configure an NG MVPN over an mLDP P2MP tunnel. For details, see Example for Configuring an Intra-AS NG MVPN with an mLDP P2MP LSP.
  2. Configure an IPv4 address pool.

    <HUAWEI> system-view
    [HUAWEI] sysname BRAS
    [*HUAWEI] commit
    [~BRAS] ip pool vpn bas local
    [*BRAS-ip-pool-vpn] vpn-instance red
    [*BRAS-ip-pool-vpn] gateway 40.0.0.1 255.255.0.0
    [*BRAS-ip-pool-vpn] section 255 40.0.0.1 40.0.0.255
    [*BRAS-ip-pool-vpn] quit
    [*BRAS] commit

  3. Configure AAA schemes.

    # Configure an authentication scheme.

    [~BRAS] aaa
    [*BRAS-aaa] authentication-scheme none
    [*BRAS-aaa-authen-none] authentication-mode none
    [*BRAS-aaa-authen-none] quit
    [*BRAS-aaa] commit

    # Configure an accounting scheme.

    [~BRAS-aaa] accounting-scheme none
    [*BRAS-aaa-accounting-none] accounting-mode none
    [*BRAS-aaa-accounting-none] quit
    [*BRAS-aaa] quit
    [*BRAS] commit

  4. Configure a domain.

    [~BRAS] aaa
    [*BRAS-aaa] domain vpn
    [*BRAS-aaa-domain-vpn] authentication-scheme none
    [*BRAS-aaa-domain-vpn] accounting-scheme none
    [*BRAS-aaa-domain-vpn] ip-pool vpn
    [*BRAS-aaa-domain-vpn] vpn-instance red
    [*BRAS-aaa-domain-vpn] quit
    [*BRAS-aaa] quit
    [*BRAS] commit

  5. Bind a sub-interface to a VLAN.

    [~BRAS] interface gigabitethernet 1/0/1.1
    [*BRAS-GigabitEthernet1/0/1.1] user-vlan 1
    [*BRAS-GigabitEthernet1/0/1.1-vlan-1-1] quit
    [*BRAS-GigabitEthernet1/0/1.1] commit

  6. Configure a BAS interface and specify a user access type for the interface.

    [~BRAS-GigabitEthernet1/0/1.1] bas
    [*BRAS-GigabitEthernet1/0/1.1-bas] access-type layer2-subscriber default-domain authentication vpn
    [*BRAS-GigabitEthernet1/0/1.1-bas] authentication-method bind
    [*BRAS-GigabitEthernet1/0/1.1-bas] quit
    [*BRAS-GigabitEthernet1/0/1.1] quit
    [*BRAS] commit

  7. Configure multicast replication by multicast VLAN.

    [~BRAS] interface gigabitethernet 1/0/1.1
    [~BRAS-GigabitEthernet1/0/1.1] multicast user-aggregation qinq pe-vid 2 ce-vid 9
    [*BRAS-GigabitEthernet1/0/1.1] quit
    [*BRAS] commit

  8. Configure basic multicast functions.

    [~BRAS] multicast routing-enable
    [*BRAS] interface gigabitethernet 1/0/1
    [*BRAS-GigabitEthernet1/0/1] pim sm
    [*BRAS-GigabitEthernet1/0/1] igmp enable
    [*BRAS-GigabitEthernet1/0/1] quit
    [*BRAS] commit
    [~PE2] interface gigabitethernet 1/0/2
    [~PE2-GigabitEthernet1/0/2] undo shutdown
    [*PE2-GigabitEthernet1/0/2] ip address 10.1.2.1 255.255.255.0
    [*PE2-GigabitEthernet1/0/2] pim sm
    [*PE2-GigabitEthernet1/0/2] quit
    [*PE2] commit

  9. Bind the interface to a VPN instance.

    [~BRAS] interface gigabitethernet 1/0/1
    [~BRAS-GigabitEthernet1/0/1] multicast binding vpn-instance red
    [*BRAS-GigabitEthernet1/0/1] quit
    [*BRAS] commit

  10. Verify the configuration.

    # Run the display multicast group-ip command to view information about users that join a specified multicast group, with the group address being set to 225.0.0.1, outbound interface to GigabitEthernet 1/0/1.1, and VPN instance name to red. The command output shows that the users with IDs 96 and 97 in the VPN instance named red join the multicast program of which the group address is 225.0.0.1.
    [~BRAS] display multicast group-ip 225.0.0.1 out-interface GigabitEthernet 1/0/1.1 vpn-instance red
      User ID    User IP                     User type    Interface
    
      96         40.0.0.250                  Local        GigabitEthernet1/0/1.1
      97         40.0.0.249                  Local        GigabitEthernet1/0/1.1
    
      Local user number :2
      Remote user number:0
      Total user number :2
    # Run the display multicast user-ip command to view information about multicast programs that a user joins on a BAS interface, with the user IP address being set to 40.0.0.250 and VPN instance name to red.
    [~BRAS] display multicast user-ip 40.0.0.250 vpn-instance red
      User information:
      User ID             :96
      User IPv4 address   :40.0.0.250
      Gateway IPv4 address:40.0.0.1
      BRAS interface      :GigabitEthernet1/0/1.1
      User MAC-address    :0005-0101-0101
      MAX program list    :4
    
      User order program:
      Group IP           Source IP
      225.0.0.1          0.0.0.0
    
      Total:1
    # Run the display pim vpn-instance vpn-instance-name routing-table command to view PIM entries of a VPN instance named red.
    [~BRAS] display pim vpn-instance red routing-table
     VPN-Instance: red
     Total 1 (S, G) entry
    
     (10.1.2.100, 225.0.0.1)
         Protocol: pim-ssm, Flag: SG_RCVR
         UpTime: 00:00:38
         Upstream interface: through-BGP
             Upstream neighbor: 2.2.2.2
             RPF prime neighbor: 2.2.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet1/0/1(bas)
                 Protocol: igmp, UpTime: 00:00:38, Expires: -
    [~PE2] display pim vpn-instance red routing-table
     VPN-Instance: red
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.1.2.100, 225.0.0.1)
         RP: NULL
         Protocol: pim-sm, Flag: SPT LOC ACT SG_RCVR
         UpTime: 16:29:06
         Upstream interface: GigabitEthernet1/0/2
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: pseudo
                 Protocol: BGP, UpTime: 00:13:57, Expires: -
    # Run the display multicast vpn-instance vpn-instance-name routing-table command to view multicast routing entries of a VPN instance named red.
    [~BRAS] display multicast vpn-instance red routing-table
    Multicast routing table of VPN-Instance: red
     Total 1 entry
    
     00001. (10.1.2.100, 225.0.0.1)
           Uptime: 00:12:28
           Upstream Interface: pseudo
           List of 1 downstream interface
               1: GigabitEthernet1/0/1(bas)
    [~PE2] display multicast vpn-instance red routing-table
    Multicast routing table of VPN-Instance: red
     Total 1 entry
    
     00001. (10.1.2.100, 225.0.0.1)
           Uptime: 16:29:28
           Upstream Interface: GigabitEthernet1/0/2
           List of 1 downstream interface
               1: pseudo

Configuration Files

  • BRAS configuration file

    #
    sysname BRAS
    #
    multicast routing-enable
    #
    multicast mvpn 1.1.1.1
    #
    ip vpn-instance red
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      mvpn
       sender-enable
       c-multicast signaling bgp
       ipmsi-tunnel
        mldp
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     mldp p2mp
    #
    ip pool vpn bas local
     vpn-instance red
     gateway 40.0.0.1 255.255.0.0
     section 255 40.0.0.1 40.0.0.255
    #
    aaa
     #
     authentication-scheme none
      authentication-mode none
     #
     accounting-scheme none
      accounting-mode none
     #
     domain vpn
      authentication-scheme none
      accounting-scheme none
      ip-pool vpn
      vpn-instance red
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     undo shutdown
      multicast binding vpn-instance red
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/1.1
     user-vlan 1
     multicast user-aggregation qinq pe-vid 2 ce-vid 9
     bas
     #
      access-type layer2-subscriber default-domain authentication vpn
      authentication-method bind
     #
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.2 enable
     #
     ipv4-family mvpn
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance red
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    multicast mvpn 2.2.2.2
    #
    ip vpn-instance red
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      mvpn
       sender-enable
       c-multicast signaling bgp
       ipmsi-tunnel
        mldp
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     mldp p2mp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip binding vpn-instance red
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
     #
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance red
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 2.2.2.2 0.0.0.0
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 39336

Downloads: 96

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next