No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AS Multicast by Using Static RPF Peers

Example for Configuring Inter-AS Multicast by Using Static RPF Peers

You can set up MSDP peer relationships between Rendezvous Points (RPs) in different PIM-SM domains in the same autonomous system (AS) or static Reverse Path Forwarding (RPF) relationships between the RPs in different ASs so that hosts can receive multicast data from the source in another PIM-SM domain in the AS or from the source in another AS.

Networking Requirements

On the network shown in Figure 5-4, there are two ASs. Each AS contains at least one PIM-SM domain and each PIM-SM domain may contain no or one multicast source and receiver. To enable the receiver in PIM-SM2 domain to receive both multicast data sent by S2 in PIM-SM3 domain and multicast data sent by S1 in PIM-SM1 domain, configure inter-AS multicast, without changing the unicast topology.

Figure 5-4 Configuring inter-AS multicast by using static RPF peers

Device Interface IP Address Device Interface IP Address
Device A GE 1/0/0 192.168.5.2/24 Device D GE 1/0/0 192.168.3.2/24
Device B GE 2/0/0 192.168.2.2/24 Loopback 0 2.2.2.2/32
Device C GE 1/0/0 192.168.1.1/24 Device E GE 2/0/0 192.168.2.1/24
GE 2/0/0 192.168.4.1/24 Device F GE 1/0/0 192.168.5.1/24
Loopback 0 1.1.1.1/32 Loopback 0 3.3.3.3/32

Precautions

When configuring inter-AS multicast by using static RPF peers, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • Incorrect configuration of static RPF peers may cause a routing loop of source active (SA) messages. So, configure static RPF peers with caution.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface; configure OSPF in each AS and configure External Border Gateway Protocol (EBGP) between ASs; configure BGP and OSPF to import routes from each other.

  2. Enable multicast routing and PIM-SM on each interface. Configure Loopback 0 as both a Candidate-BootStrap Router (C-BSR) and a Candidate-Rendezvous Point (C-RP): Loopback 0 interfaces on Device C, Device D, and Device F function as the C-BSRs and the C-RPs for the PIM-SM domains where they reside.

  3. Establish an MSDP peer relationship between RPs in PIM-SM domains: Establish MSDP peer relationships between Device C and Device D, and between Device C and Device F.

  4. Specify static RPF peers for MSDP peers: Specify Device D and Device F as static RPF peers of Device C. Specify Device C as the only static RPF peer for Device D and Device F.

Data Preparation

To complete the configuration, you need the following data:

  • AS numbers of Device A, Device B, Device C, Device D, Device E, Device F, and Device G

  • Router IDs of Device A, Device B, Device C, Device D, Device E, and Device F

  • Policy used by Device C to filter the SA messages received from Device D and Device F

  • Policy used by Device D and Device F to filter the SA messages received from Device C

Procedure

  1. Configure an IP address for each router interface and configure OSPF in the ASs. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and PIM-SM on each router interface.

    # Configure Device C.

    [~DeviceC] multicast routing-enable
    [*DeviceC] interface GigabitEthernet 1/0/0
    [*DeviceC-GigabitEthernet1/0/0] pim sm
    [*DeviceC-GigabitEthernet1/0/0] quit
    [*DeviceC] interface GigabitEthernet 2/0/0
    [*DeviceC-GigabitEthernet2/0/0] pim sm
    [*DeviceC-GigabitEthernet2/0/0] commit
    [~DeviceC-GigabitEthernet2/0/0] quit

    The configurations of other routers are similar to the configuration of router C. For configuration details, see Configuration Files in this section.

    # Configure a BSR boundary on GE 1/0/0 on Device A and Device F, and GE 2/0/0 on Device B and Device E.

    [~DeviceA] interface GigabitEthernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] pim bsr-boundary
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    The configurations of Device B, Device E, and Device F are similar to the configuration of Device A. For configuration details, see Configuration Files in this section.

  3. Enable IGMP on interfaces connected to hosts. For configuration details, see Configuration Files in this section.
  4. Configure Loopback 0 as both a C-BSR and a C-RP.

    # Create Loopback 0 on Device C, Device D, and Device F. Configure Loopback 0 as both a C-BSR and a C-RP on each router.

    [~DeviceC] interface loopback 0
    [*DeviceC-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [*DeviceC-LoopBack0] pim sm
    [*DeviceC-LoopBack0] quit
    [*DeviceC] pim
    [*DeviceC-pim] c-bsr loopback 0
    [*DeviceC-pim] c-rp loopback 0
    [*DeviceC-pim] commit
    [~DeviceC-pim] quit

    The configurations of Device D and Device F are similar to the configuration of Device C. For configuration details, see Configuration Files in this section.

  5. Configure static RPF peers.

    # Configure Device D and Device F as static RPF peers of Device C.

    [~DeviceC] ip ip-prefix list-df permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*DeviceC] msdp
    [*DeviceC-msdp] peer 192.168.3.2 connect-interface GigabitEthernet 1/0/0
    [*DeviceC-msdp] peer 192.168.5.1 connect-interface GigabitEthernet 2/0/0
    [*DeviceC-msdp] static-rpf-peer 192.168.3.2 rp-policy list-df
    [*DeviceC-msdp] static-rpf-peer 192.168.5.1 rp-policy list-df 
    [*DeviceC-msdp] commit
    [~DeviceC-msdp] quit

    # Configure Device C as static RPF peers of Device D and Device F.

    [~DeviceD] ip ip-prefix list-c permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*DeviceD] msdp
    [*DeviceD-msdp] peer 192.168.1.1 connect-interface GigabitEthernet 1/0/0
    [*DeviceD-msdp] static-rpf-peer 192.168.1.1 rp-policy list-c
    [*DeviceD-msdp] commit
    [~DeviceD-msdp] quit

    The configuration of Device F is similar to the configuration of Device D. For configuration details, see Configuration Files in this section.

  6. Verify the configuration.

    # Run the display bgp peer command. The command output shows BGP peer relationships established between routers. Device C has no output, which indicates that the BGP peer relationships are not set up between Device C and Device D, or between Device C and Device F.

    # Run the display msdp brief command. The command output shows MSDP peer relationships established between routers. When S1 in PIM-SM1 domain sends multicast data, the receivers in PIM-SM2 and PIM-SM3 domains can receive the data. For example, the command output of MSDP peers on Device C, Device D, and Device F is as follows:

    <DeviceC> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      2            2            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.3.2        Up        01:07:08        ?      8          0
      192.168.5.1        Up        00:16:39        ?      13         0
    <DeviceD> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      1            1            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.1.1        Up        01:07:09        ?      8          0
    <DeviceF> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      1            1            0            0            0            0
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.4.1        Up        00:16:40        ?      13         0

Configuration Files

  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    ip ip-prefix list-df index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
    #
    msdp
     peer 192.168.3.2 connect-interface GigabitEthernet 1/0/0
     peer 192.168.5.1 connect-interface GigabitEthernet 2/0/0
     static-rpf-peer 192.168.3.2 rp-policy list-df
     static-rpf-peer 192.168.5.1 rp-policy list-df
    #
    return 
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 2.2.2.2 0.0.0.0
    #
    msdp
     peer 192.168.1.1 connect-interface GigabitEthernet 1/0/0
     static-rpf-peer 192.168.1.1 rp-policy list-c
    #
    return
  • Device F configuration file

    #
    sysname DeviceF
    #
    multicast routing-enable
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.5.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
    #
    msdp
     peer 192.168.4.1 connect-interface GigabitEthernet 1/0/0
     static-rpf-peer 192.168.4.1 rp-policy list-c
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43930

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next