No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IGMP SSM Mapping

Example for Configuring IGMP SSM Mapping

If hosts' IGMP version cannot be upgraded to IGMPv3, configure Source-Specific Multicast (SSM) mapping to implement version compatibility between a multicast device (running a higher IGMP version) and user hosts (running lower IGMP versions) and enable the multicast device to provide SSM services for the user hosts. The user hosts can then receive multicast data from a specified source.

Networking Requirements

On the multicast network shown in Figure 3-8, PIM-SM is run and the SSM mode is configured. IGMPv3 is run on the interface connecting the router to the receiver and IGMPv2 is run on the receiver. The IGMP version on the receiver is unable to be upgraded to IGMPv3.

The SSM group address range is set to 232.1.1.0/24, and Sources 1, 2, and 3 all send multicast data to multicast groups in this range. The receiver requires multicast data only from Sources 1 and 3. To meet this requirement, configure IGMP SSM mapping.

Figure 3-8 Configuring IGMP SSM mapping
NOTE:


Device Interface IP Address Device Interface IP Address
Device A GE 1/0/0 10.10.1.2/24 Device C GE 1/0/0 10.10.3.2/24
GE 2/0/0 192.168.1.1/24 GE 2/0/0 192.168.3.1/24
GE 3/0/0 192.168.4.2/24 GE 3/0/0 192.168.2.2/24
Device B GE 1/0/0 10.10.2.2/24 Device D GE 1/0/0 10.10.4.2/24
GE 2/0/0 192.168.1.2/24 GE 2/0/0 192.168.3.2/24
GE 3/0/0 192.168.2.1/24 GE 3/0/0 192.168.4.1/24

Precautions

When configuring IGMP SSM mapping, note the following precautions:

  • PIM-SM must be enabled before IGMP is enabled.

  • Set the same SSM group address range on all routers in the PIM-SM domain.

  • The basic IGMP function must be configured before IGMP SSM mapping is configured. For detailed configuration information, see the Example for Configuring Basic IGMP Functions.

  • To make SSM source-group address mapping entries take effect, you must enable SSM mapping first.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each router interface and configure a unicast routing protocol.

  2. Enable multicast routing on all multicast routers.

  3. Enable PIM-SM on all router interfaces.

  4. Enable IGMP and SSM mapping on interfaces connect routers to receivers.

  5. Set the same SSM group address range on all routers in the PIM-SM domain.

  6. Configure SSM mapping rules on routers connected to receivers.

Data Preparation

To complete the configuration, you need the following data:

  • SSM group address range

  • IP addresses of Sources 1 and 3

Procedure

  1. Configure an IP address for each router interface and a unicast routing protocol. For configuration details, see Configuration Files in this section.
  2. Enable multicast routing on each router and enable PIM-SSM on each router interface.

    # Configure Device D.

    [~DeviceD] multicast routing-enable
    [*DeviceD] interface gigabitethernet 1/0/0
    [*DeviceD-GigabitEthernet1/0/0] pim sm
    [*DeviceD-GigabitEthernet1/0/0] quit
    [*DeviceD] interface gigabitethernet 2/0/0
    [*DeviceD-GigabitEthernet2/0/0] pim sm
    [*DeviceD-GigabitEthernet2/0/0] quit
    [*DeviceD] interface gigabitethernet 3/0/0
    [*DeviceD-GigabitEthernet3/0/0] pim sm
    [*DeviceD-GigabitEthernet3/0/0] commit
    [~DeviceD-GigabitEthernet3/0/0] quit

    Repeat this step for Device A, Device B, and Device C. For configuration details, see Configuration Files in this section.

  3. Enable IGMP and SSM mapping on the interface connecting the router to the receiver.

    # Enable IGMP and SSM mapping on GE 1/0/0 of Device D.

    [~DeviceD] interface gigabitethernet 1/0/0
    [~DeviceD-GigabitEthernet1/0/0] igmp enable
    [*DeviceD-GigabitEthernet1/0/0] igmp version 3
    [*DeviceD-GigabitEthernet1/0/0] igmp ssm-mapping enable
    [*DeviceD-GigabitEthernet1/0/0] commit
    [~DeviceD-GigabitEthernet1/0/0] quit

  4. Set the SSM group address range to 232.1.1.0/24 on all routers in the PIM-SM domain.

    # Configure Device A.

    [~DeviceA] acl number 2000
    [*DeviceA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*DeviceA-acl4-basic-2000] quit
    [*DeviceA] pim
    [*DeviceA-pim] ssm-policy 2000
    [*DeviceA-pim] commit
    [~DeviceA-pim] quit

    Repeat this step for router B, router C, and router D. For configuration details, see Configuration Files in this section.

  5. Configure SSM mapping rules on the router connected to the receiver.

    # On Device D, map the multicast groups in the range of 232.1.1.0/24 to Sources 1 and 3.

    [~DeviceD] igmp
    [*DeviceD-igmp] ssm-mapping 232.1.1.0 24 10.10.1.1
    [*DeviceD-igmp] ssm-mapping 232.1.1.0 24 10.10.3.1
    [*DeviceD-igmp] commit
    [~DeviceD-igmp] quit

  6. Verify the configuration.

    # View information about SSM mapping rules on Device D.

    <DeviceD> display igmp ssm-mapping group
    IGMP SSM-Mapping conversion table of VPN-Instance: public net
     Total 2 entries    2 entries matched
     00001. (10.10.1.1, 232.1.1.0)
     00002. (10.10.3.1, 232.1.1.0)
     Total 2 entries matched

    # Run the display igmp group ssm-mapping command to view source-group information on Device D. The command output is as follows:

    <DeviceD> display igmp group ssm-mapping
    IGMP SSM mapping Interface group report information of VPN-Instance: public net
     GigabitEthernet1/0/0 (10.10.4.2):
      Total 1 IGMP SSM-Mapping Group reported
       Group Address   Last Reporter   Uptime      Expires
       232.1.1.1       10.10.4.1     00:01:44    00:00:26
    <DeviceD> display igmp group ssm-mapping verbose
    Interface group report information of VPN-Instance: public net 
     Limited entry of this VPN-Instance: - 
     GigabitEthernet1/0/0 (10.10.4.2):
      Total entry on this interface: 1
      Limited entry on this interface: - 
      Total 1 IGMP SSM-Mapping Group reported
       Group: 232.1.1.1
         Uptime: 00:01:52
         Expires: 00:00:18
         Last reporter: 10.10.4.1
         Last-member-query-counter: 0
         Last-member-query-timer-expiry: off
         Group mode: exclude
         Version1-host-present-timer-expiry: off
         Version2-host-present-timer-expiry: 00:00:17

    # Run the display pim routing-table command to view information about the PIM-SM routing table on Device D. The command output is as follows:

    <DeviceD> display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entries
     (10.10.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
     (10.10.3.1, 232.1.1.1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.3.1
             RPF prime neighbor: 192.168.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    multicast routing-enable
    #
    acl number 2000
     rule permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.4.2 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    multicast routing-enable
    #
    acl number 2000
     rule permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    multicast routing-enable
    #
    acl number 2000
     rule permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.1 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     isis enable 1
    #
    pim
     ssm-policy 2000
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    multicast routing-enable
    #
    acl number 2000
     rule permit source 232.1.1.0 0.0.0.255
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.4.2 255.255.255.0
     isis enable 1
     pim sm
     igmp enable
     igmp version 3
     igmp ssm-mapping enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.3.2 255.255.255.0
     pim sm
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.4.1 255.255.255.0
     pim sm
     isis enable 1
    #
    igmp
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.1.1
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.3.1
    #
    pim
     ssm-policy 2000
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 42695

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next