No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Multicast 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Multicast
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MVPN Extranet in the Local Cross Scenario Where the Source and Receiver VPN Instances Reside on the Same PE

Example for Configuring MVPN Extranet in the Local Cross Scenario Where the Source and Receiver VPN Instances Reside on the Same PE

This section provides an example for configuring MVPN Extranet in the local cross scenario where the source and receiver VPN instances reside on the same PE.

Networking Requirements

MD MVPN supports only intra-VPN multicast service distribution. However, in a real-world situation, a service provider on a VPN may need to provide multicast services for users on other VPNs.

In the local cross scenario of intra-AS MD MVPN shown in Figure 8-7, the receiver in VPN RED requires multicast data from the source in VPN BLUE. To meet this requirement, deploy MVPN extranet.

Figure 8-7 Configuring MVPN extranet in the local cross scenario where the source and receiver VPN instances reside on the same PE
NOTE:

Interfaces 1 through 3 in this example are GE 1/0/0, GE 2/0/0, GE 3/0/0, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic intra-AS MD MVPN functions.

  2. Configure Rendezvous Points (RPs) to serve the public network and the multicast groups running the multicast VPN extranet service.

Data Preparation

To complete the configuration, you need the following data:

  • RD and RT of VPN BLUE: 100:1

  • RD and RT of VPN RED: 200:1

  • Share-group address of VPN BLUE: 239.0.0.0

  • Share-group address of VPN RED: 238.0.0.0

  • Multicast group address used by the VPN extranet: 228.0.0.1

Procedure

  1. Configure basic intra-AS MD MVPN functions.
    1. Configure basic MPLS functions and MPLS LDP and set up LDP LSPs on the public network.

      # Configure PE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] mpls lsr-id 1.1.1.1
      [*PE1] mpls
      [*PE1-mpls] quit
      [*PE1] mpls ldp
      [*PE1-mpls-ldp] quit
      [*PE1] interface gigabitethernet 1/0/0
      [*PE1-GigabitEthernet1/0/0] mpls
      [*PE1-GigabitEthernet1/0/0] mpls ldp
      [*PE1-GigabitEthernet1/0/0] quit
      [*PE1] commit

      # Configure P.

      <HUAWEI> system-view
      [~HUAWEI] sysname P
      [*HUAWEI] commit
      [~P] mpls lsr-id 2.2.2.2
      [*P] mpls
      [*P-mpls] quit
      [*P] mpls ldp
      [*P-mpls-ldp] quit
      [*P] interface gigabitethernet 1/0/0
      [*P-GigabitEthernet1/0/0] mpls
      [*P-GigabitEthernet1/0/0] mpls ldp
      [*P-GigabitEthernet1/0/0] quit
      [*P] interface gigabitethernet 2/0/0
      [*P-GigabitEthernet2/0/0] mpls
      [*P-GigabitEthernet2/0/0] mpls ldp
      [*P-GigabitEthernet2/0/0] quit
      [*P] commit

      # Configure PE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] mpls lsr-id 3.3.3.3
      [*PE2] mpls
      [*PE2-mpls] quit
      [*PE2] mpls ldp
      [*PE2-mpls-ldp] quit
      [*PE2] interface gigabitethernet 2/0/0
      [*PE2-GigabitEthernet2/0/0] mpls
      [*PE2-GigabitEthernet2/0/0] mpls ldp
      [*PE2-GigabitEthernet2/0/0] quit
      [*PE2] commit

    2. Configure unicast OSPF and multicast on the public network to ensure that the multicast routes on the network are reachable.

      # Configure PE1.

      [~PE1] multicast routing-enable
      [*PE1] interface loopback 1
      [*PE1-LoopBack1] ip address 1.1.1.1 32
      [*PE1-LoopBack1] pim sm
      [*PE1-LoopBack1] quit
      [*PE1] interface gigabitethernet 1/0/0
      [*PE1-Gigabitethernet1/0/0] ip address 192.168.1.1 24
      [*PE1-Gigabitethernet1/0/0] pim sm
      [*PE1-Gigabitethernet1/0/0] quit
      [*PE1] ospf
      [*PE1-ospf-1] area 0
      [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
      [*PE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
      [*PE1-ospf-1-area-0.0.0.0] quit
      [*PE1-ospf-1] quit
      [*PE1] commit

      # Configure P.

      [~P] multicast routing-enable
      [*P] interface loopback 1
      [*P-LoopBack1] ip address 2.2.2.2 32
      [*P-LoopBack1] pim sm
      [*P-LoopBack1] quit
      [*P] interface gigabitethernet 1/0/0
      [*P-Gigabitethernet1/0/0] ip address 192.168.1.2 24
      [*P-Gigabitethernet1/0/0] pim sm
      [*P-Gigabitethernet1/0/0] quit
      [*P] interface gigabitethernet 2/0/0
      [*P-Gigabitethernet2/0/0] ip address 192.168.2.1 24
      [*P-Gigabitethernet2/0/0] pim sm
      [*P-Gigabitethernet2/0/0] quit
      [*P] ospf
      [*P-ospf-1] area 0
      [*P-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
      [*P-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
      [*P-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
      [*P-ospf-1-area-0.0.0.0] quit
      [*P-ospf-1] quit
      [*P] commit

      # Configure PE2.

      [~PE2] multicast routing-enable
      [*PE2] interface loopback 1
      [*PE2-LoopBack1] ip address 3.3.3.3 32
      [*PE2-LoopBack1] pim sm
      [*PE2-LoopBack1] quit
      [*PE2] interface gigabitethernet 2/0/0
      [*PE2-Gigabitethernet2/0/0] ip address 192.168.2.2 24
      [*PE2-Gigabitethernet2/0/0] pim sm
      [*PE2-Gigabitethernet2/0/0] quit
      [*PE2] ospf 1
      [*PE2-ospf-1] area 0
      [*PE2-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
      [*PE2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
      [*PE2-ospf-1-area-0.0.0.0] quit
      [*PE2-ospf-1] quit
      [*PE2] commit

    3. Create VPN instances enabled with the IPv4 address family on PE2; set the share-group address for each VPN instance; create MTunnel interfaces; bind the interface connecting a PE to a CE to a VPN instance.

      # Create VPN BLUE enabled with the IPv4 address family on PE2. Enable the global multicast function in VPN BLUE and set the share-group address for VPN BLUE. Bind the share-group address to MTunnel 0 and bind GE 1/0/0 connecting PE2 to CE1 to VPN BLUE.

      [~PE2] ip vpn-instance BLUE
      [*PE2-vpn-instance-BLUE] ipv4-family
      [*PE2-vpn-instance-BLUE-af-ipv4] route-distinguisher 100:1
      [*PE2-vpn-instance-BLUE-af-ipv4] vpn-target 100:1 both
      [*PE2-vpn-instance-BLUE-af-ipv4] multicast routing-enable
      [*PE2-vpn-instance-BLUE-af-ipv4] multicast-domain share-group 239.0.0.0 binding mtunnel 0
      [*PE2-vpn-instance-BLUE-af-ipv4] quit
      [*PE2-vpn-instance-BLUE] quit
      [*PE2] interface gigabitethernet 1/0/0
      [*PE2-GigabitEthernet1/0/0] ip binding vpn-instance BLUE
      [*PE2-GigabitEthernet1/0/0] ip address 10.1.2.2 24
      [*PE2-GigabitEthernet1/0/0] pim sm
      [*PE2-GigabitEthernet1/0/0] quit
      [*PE2] commit

      # Create VPN RED enabled with the IPv4 address family on PE2. Enable the global multicast function in VPN RED and set the share-group address for VPN RED. Bind the share-group address to MTunnel 1 and bind GE 3/0/0 connecting PE2 to CE2 to VPN RED. Import the routes from VPN BLUE into VPN RED.

      [~PE2] ip vpn-instance RED
      [*PE2-vpn-instance-RED] ipv4-family
      [*PE2-vpn-instance-RED-af-ipv4] route-distinguisher 200:1
      [*PE2-vpn-instance-RED-af-ipv4] vpn-target 200:1 both
      [*PE2-vpn-instance-RED-af-ipv4] vpn-target 100:1 import-extcommunity
      [*PE2-vpn-instance-RED-af-ipv4] multicast routing-enable
      [*PE2-vpn-instance-RED-af-ipv4] multicast-domain share-group 238.0.0.0 binding mtunnel 1
      [*PE2-vpn-instance-RED-af-ipv4] quit
      [*PE2-vpn-instance-RED] quit
      [*PE2] interface gigabitethernet 3/0/0
      [*PE2-GigabitEthernet3/0/0] ip binding vpn-instance RED
      [*PE2-GigabitEthernet3/0/0] ip address 10.1.3.1 24
      [*PE2-GigabitEthernet3/0/0] pim sm
      [*PE2-GigabitEthernet3/0/0] quit
      [*PE2] commit

    4. Configure a unicast routing protocol on the public network and enable the multicast function in VPN BLUE and VPN RED separately, ensuring normal multicast routing in the VPN instances.

      # Configure CE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE1
      [*HUAWEI] commit
      [~CE1] interface gigabitethernet 1/0/0
      [*CE1-GigabitEthernet1/0/0] ip address 10.1.2.1 24
      [*CE1-GigabitEthernet1/0/0] pim sm
      [*CE1-GigabitEthernet1/0/0] quit
      [*CE1] interface gigabitethernet 2/0/0
      [*CE1-GigabitEthernet2/0/0] ip address 10.1.1.1 24
      [*CE1-GigabitEthernet2/0/0] pim sm
      [*CE1-GigabitEthernet2/0/0] quit
      [*CE1] interface loopback 1
      [*CE1-LoppBack1] ip address 4.4.4.4 32
      [*CE1-LoppBack1] pim sm
      [*CE1-LoppBack1] quit
      [*CE1] ospf 3
      [*CE1-ospf-3] area 0
      [*CE1-ospf-3-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [*CE1-ospf-3-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*CE1-ospf-3-area-0.0.0.0] network 4.4.4.4 0.0.0.0
      [*CE1-ospf-3-area-0.0.0.0] quit
      [*CE1-ospf-3] quit
      [*CE1] commit

      # Configure CE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE2
      [*HUAWEI] commit
      [~CE2] interface gigabitethernet 3/0/0
      [*CE2-GigabitEthernet3/0/0] ip address 10.1.3.2 24
      [*CE2-GigabitEthernet3/0/0] pim sm
      [*CE2-GigabitEthernet3/0/0] quit
      [*CE2] interface gigabitethernet 2/0/0
      [*CE2-GigabitEthernet2/0/0] ip address 10.1.4.1 24
      [*CE2-GigabitEthernet2/0/0] pim sm
      [*CE2-GigabitEthernet2/0/0] quit
      [*CE2] ospf 2
      [*CE2-ospf-2] area 0
      [*CE2-ospf-2-area-0.0.0.0] network 10.1.3.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] network 10.1.4.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] quit
      [*CE2-ospf-2] quit
      [*CE2] commit

    5. Establish an MP-IBGP peer relationship between PEs; configure a unicast routing protocol between a PE and a CE to ensure that the PE and the CE are routable.

      # Configure PE1.

      [~PE1] bgp 100
      [*PE1-bgp] peer 3.3.3.3 as-number 100
      [*PE1-bgp] peer 3.3.3.3 connect-interface LoopBack 1
      [*PE1-bgp] ipv4-family vpnv4
      [*PE1-bgp-af-vpnv4] peer 3.3.3.3 enable
      [*PE1-bgp-af-vpnv4] quit
      [*PE1-bgp] quit
      [*PE1] commit

      # Configure PE2.

      [~PE2] bgp 100
      [*PE2-bgp] peer 1.1.1.1 as-number 100
      [*PE2-bgp] peer 1.1.1.1 connect-interface LoopBack 1
      [*PE2-bgp] ipv4-family vpn-instance BLUE
      [*PE2-bgp-BLUE] import-route ospf 3
      [*PE2-bgp-BLUE] import-route direct
      [*PE2-bgp-BLUE] quit
      [*PE2-bgp] ipv4-family vpn-instance RED
      [*PE2-bgp-RED] import-route ospf 2
      [*PE2-bgp-RED] import-route direct
      [*PE2-bgp-RED] quit
      [*PE2-bgp] ipv4-family vpnv4
      [*PE2-bgp-af-vpnv4] peer 1.1.1.1 enable
      [*PE2-bgp-af-vpnv4] quit
      [*PE2-bgp] quit
      [*PE2] ospf 2 vpn-instance RED
      [*PE2-ospf-2] import-route bgp
      [*PE2-ospf-2] area 0.0.0.0
      [*PE2-ospf-2-area-0.0.0.0] network 10.1.3.0 0.0.0.255
      [*PE2-ospf-2-area-0.0.0.0] quit
      [*PE2-ospf-2] quit
      [*PE2] ospf 3 vpn-instance BLUE
      [*PE2-ospf-3] import-route bgp
      [*PE2-ospf-3] area 0.0.0.0
      [*PE2-ospf-3-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*PE2-ospf-3-area-0.0.0.0] quit
      [*PE2-ospf-3] quit
      [*PE2] commit

    6. Configure IP addresses for MTunnel interfaces.

      # Configure PE2.

      [~PE2] interface MTunnel 0
      [*PE2-MTunnel0] ip address 3.3.3.3 32
      [*PE2-MTunnel0] quit
      [*PE2] interface MTunnel 1
      [*PE2-MTunnel1] ip address 3.3.3.3 32
      [*PE2-MTunnel1] quit
      [*PE2] commit

  2. Configure an RP to serve the public network and the multicast groups running the multicast VPN extranet service.

    • # Configure loopback 1 on P as a Candidate-BSR (C-BSR) and a Candidate-RP (C-RP) on the public network.

      [~P] pim
      [*P-pim] c-bsr Loopback 1 
      [*P-pim] c-rp Loopback 1
      [*P-pim] quit
      [*P] commit
    • # In the PIM view of CE1 and CE2 and views of VPN BLUE and VPN RED on PE2, configure loopback 1 of CE1 as a static RP to serve the multicast groups running the multicast VPN extranet service.

      NOTE:

      Source VPN instances and receiver VPN instances support only static RPs. In addition, the routes to static RPs and the routes to the sources need to be in the same VPN instance.

      # Configure CE1.

      [~CE1] pim
      [*CE1-pim] static-rp 4.4.4.4
      [*CE1-pim] quit
      [*CE1] commit

      # Configure PE2.

      [~PE2] pim vpn-instance BLUE
      [*PE2-pim-BLUE] static-rp 4.4.4.4
      [*PE2-pim-BLUE] quit
      [*PE2] pim vpn-instance RED
      [*PE2-pim-RED] static-rp 4.4.4.4
      [*PE2-pim-RED] quit
      [*PE2] commit

      # Configure CE2.

      [~CE2] pim
      [*CE2-pim] static-rp 4.4.4.4
      [*CE2-pim] quit
      [*CE2] commit

  3. Verify the configuration.

    By checking the configuration result, you can view that the receiver in VPN RED can receive multicast data from the source in VPN BLUE.

    Run the display pim routing-table command on PE2 to check information about the PIM routing table. The following command output shows that the upstream of the Reverse Path Forwarding (RPF) route selected by the PIM entry corresponding to group 228.0.0.1 is VPN BLUE.

    [~PE2] display pim vpn-instance RED routing-table extranet source-vpn-instance BLUE
     VPN-Instance: RED
     Total 1 (*, G) entry; 1 (S, G) entry
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:03:05
         Upstream interface: MCAST_Extranet(BLUE)
             Upstream neighbor: 10.1.2.1
             RPF prime neighbor: 10.1.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet3/0/0
                 Protocol: pim-sm, UpTime: 00:03:05, Expires: 00:03:26
     
     (10.1.1.2, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:00:02
         Upstream interface: MCAST_Extranet(BLUE)
             Upstream neighbor: 10.1.2.1
             RPF prime neighbor: 10.1.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet3/0/0
                 Protocol: pim-sm, UpTime: 00:00:06, Expires: -

    The following command output shows that the MVPN extranet receiver of VPN BLUE belongs to VPN RED.

    [~PE2] display pim vpn-instance BLUE routing-table extranet receive-vpn-instance RED
     VPN-Instance: BLUE
     Total 1 (*, G) entry; 1 (S, G) entry
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC EXTRANET 
         UpTime: 00:06:16
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.1
             RPF prime neighbor: 10.1.2.1
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: RED
     
     (10.1.1.2, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:03:13
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.1
             RPF prime neighbor: 10.1.2.1
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: RED

    Run the display multicast routing-table command on PE2 to check information about the multicast routing table. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is VPN BLUE.

    [~PE2] display multicast vpn-instance RED routing-table extranet source-vpn-instance BLUE
    Multicast routing table of VPN instance: RED
     Total 0 (*, G) entry; 1 (S, G) entry, 1 matched
     
     00001: (10.1.1.2, 228.0.0.1)
           Uptime: 05:39:09     
           Upstream Interface: MCAST_Extranet(BLUE)
           List of 1 downstream interface
               1: GigabitEthernet3/0/0

    Run the display multicast rpf-info command on PE2 to check the RPF routing information of source 10.1.1.2. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is VPN BLUE.

    [~PE2] display multicast vpn-instance RED rpf-info 10.1.1.2 228.0.0.1
     VPN-Instance: RED
     RPF information about source 10.1.1.2 and group 228.0.0.1
         RPF interface: MCAST_Extranet
         RPF Source VPN-Instance: BLUE
         Referenced route/mask: 10.1.1.0/24
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disable

    After the preceding configurations, Receiver can receive multicast data from Source. Run the display pim routing-table command on CE2 to check information about the PIM routing table. The following command output shows that multicast data has reached CE2 and forwarded to Receiver.

    [~CE2] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:00:09     
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: 10.1.3.1
             RPF prime neighbor: 10.1.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet2/0/0
                 Protocol: static, UpTime: 00:00:09, Expires: - 
    
     (10.1.1.2, 228.0.0.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:04:06     
         Upstream interface: GigabitEthernet3/0/0
             Upstream neighbor: 10.1.3.1
             RPF prime neighbor: 10.1.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 00:00:09, Expires: - 

Configuration Files

  • Configuration file of PE1

    #
    sysname PE1
    #
    multicast routing-enable
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return 
  • Configuration file of P

    #
    sysname P
    #
    multicast routing-enable
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack1
    #
    return
  • Configuration file of PE2

    #
    sysname PE2
    #
    multicast routing-enable
    #
    ip vpn-instance BLUE
     ipv4-family
      route-distinguisher 100:1
      vpn-target 100:1 export-extcommunity
      vpn-target 100:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 239.0.0.0 binding mtunnel 0
    #
    ip vpn-instance RED
     ipv4-family
      route-distinguisher 200:1
      vpn-target 200:1 export-extcommunity
      vpn-target 200:1 import-extcommunity
      vpn-target 100:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 238.1.1.0 binding mtunnel 1
    #
    mpls lsr-id 3.3.3.3
    #
    mpls 
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip binding vpn-instance BLUE
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet3/0/0
     undo portswitch
     undo shutdown
     ip binding vpn-instance RED
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance BLUE
     ip address 3.3.3.3 255.255.255.255
    #
    interface MTunnel1
     ip binding vpn-instance RED
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance BLUE
      import-route direct
      import-route ospf 3
     #
     ipv4-family vpn-instance RED
      import-route direct
      import-route ospf 2
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    ospf 2 vpn-instance RED
     import-route bgp
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
    #
    ospf 3 vpn-instance BLUE
     import-route bgp
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    pim
    #
    pim vpn-instance BLUE
     static-rp 4.4.4.4
    #
    pim vpn-instance RED
     static-rp 4.4.4.4
    #
    return 
  • Configuration file of CE1

    #
    sysname CE1
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    ospf 3
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 4.4.4.4 0.0.0.0
    #
    pim
     static-rp 4.4.4.4
    #
    return 
  • Configuration file of CE2

    #
    sysname CE2
    #
    multicast routing-enable
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.4.1 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 228.0.0.1
    #
    interface GigabitEthernet3/0/0
     undo portswitch
     undo shutdown
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    ospf 2
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    pim
     static-rp 4.4.4.4
    #
    return 
    
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055017

Views: 43953

Downloads: 97

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next