No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Routing 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IS-IS Functions

Example for Configuring Basic IS-IS Functions

This section describes how to configure basic IS-IS functions, including specifying the NET, configuring the IS-IS level, and enabling IS-IS on each device.

Networking Requirements

In Figure 9-13:

  • Device A, Device B, Device C, and Device D run IS-IS for IP interworking.

  • Device A, Device B, and Device C belong to Area 10, and Device D belongs to Area 20.

  • Device A and Device B are Level-1 devices; Device C is a Level-1-2 device; Device D is a Level-2 device.

Figure 9-13 Configuring basic IS-IS functions

Device Name

Interface

IP Address

Device A

GE1/0/0

10.1.1.2/24

Device B

GE1/0/0

10.1.2.2/24

Device C

GE1/0/0

10.1.1.1/24

GE2/0/0

10.1.2.1/24

GE3/0/0

192.168.0.1/24

Device D

GE1/0/0

192.168.0.2/24

GE2/0/0

172.16.1.1/16

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IS-IS, configure the level, and specify the NET on each router.

  2. Configure Device A and Device C to authenticate Hello packets in a specified mode and with the specified password.

  3. View the IS-IS LSDB and the routing table of each router.

Data Preparation

To complete the configuration, you need the following data:

  • Area addresses of Device A, Device B, Device C, and Device D

  • Levels of Device A, Device B, Device C, and Device D

Procedure

  1. Configure an IP address for each interface.

    This example assumes that you know the configuration method and no details are provided here, for detailed configurations, see Figure 9-13 and configuration files in this example.

  2. Configure basic IS-IS functions.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-1
    [*DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [*DeviceA-isis-1] quit
    [*DeviceA] interface gigabitethernet 1/0/0
    [*DeviceA-GigabitEthernet1/0/0] isis enable 1
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] is-level level-1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] quit
    [*DeviceB] interface gigabitethernet 1/0/0
    [*DeviceB-GigabitEthernet1/0/0] isis enable 1
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceB-GigabitEthernet1/0/0] quit

    # Configure Device C.

    [~DeviceC] isis 1
    [*DeviceC-isis-1] is-level level-1-2
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] quit
    [*DeviceC] interface gigabitethernet 1/0/0
    [*DeviceC-GigabitEthernet1/0/0] isis enable 1
    [*DeviceC-GigabitEthernet1/0/0] quit
    [*DeviceC] interface gigabitethernet 2/0/0
    [*DeviceC-GigabitEthernet2/0/0] isis enable 1
    [*DeviceC-GigabitEthernet2/0/0] quit
    [*DeviceC] interface gigabitethernet 3/0/0
    [*DeviceC-GigabitEthernet3/0/0] isis enable 1
    [*DeviceC-GigabitEthernet3/0/0] commit
    [~DeviceC-GigabitEthernet3/0/0] quit

    # Configure Device D.

    [~DeviceD] isis 1
    [*DeviceD-isis-1] is-level level-2
    [*DeviceD-isis-1] network-entity 20.0000.0000.0004.00
    [*DeviceD-isis-1] quit
    [*DeviceD] interface gigabitethernet 2/0/0
    [*DeviceD-GigabitEthernet2/0/0] isis enable 1
    [*DeviceD-GigabitEthernet2/0/0] quit
    [*DeviceD] interface gigabitethernet 1/0/0
    [*DeviceD-GigabitEthernet1/0/0] isis enable 1
    [*DeviceD-GigabitEthernet1/0/0] commit
    [~DeviceD-GigabitEthernet1/0/0] quit

  3. Configure the authentication mode and password used by Device A and Device C to authenticate Hello packets.

    # Configure Device A.

    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] isis authentication-mode md5 huawei
    [*DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    # Configure Device C.

    [~DeviceC] interface gigabitethernet 1/0/0
    [~DeviceC-GigabitEthernet1/0/0] isis authentication-mode md5 huawei
    [*DeviceC-GigabitEthernet1/0/0] commit
    [~DeviceC-GigabitEthernet1/0/0] quit

  4. Verify the configuration.

    # Display the IS-IS LSDB of each router.

    [~DeviceA] display isis lsdb
                            Database information for ISIS(1)
                            --------------------------------
                              Level-1 Link State Database
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00* 0x00000006   0xbf7d        649           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        545           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        582           111     1/0/0
    Total LSP(s): 3 
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload 
    [~DeviceB] display isis lsdb
                            Database information for ISIS(1)
                            --------------------------------
                              Level-1 Link State Database
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        642           68      0/0/0
    0000.0000.0002.00-00* 0x00000003   0xef4d        538           68      0/0/0
    0000.0000.0003.00-00  0x00000008   0x3340        574           111     1/0/0
    Total LSP(s): 3 
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload
    [~DeviceC] display isis lsdb
                            Database information for ISIS(1)
                            --------------------------------
                              Level-1 Link State Database
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000006   0xbf7d        638           68      0/0/0
    0000.0000.0002.00-00  0x00000003   0xef4d        533           68      0/0/0
    0000.0000.0003.00-00* 0x00000008   0x3340        569           111     1/0/0
    Total LSP(s): 3 
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload
                              Level-2 Link State Database
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00* 0x00000008   0x55bb        650           100     0/0/0
    0000.0000.0004.00-00  0x00000005   0x651         629           84      0/0/0
    Total LSP(s): 2 
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload 
    [~DeviceD] display isis lsdb
                            Database information for ISIS(1)
                            --------------------------------
                              Level-2 Link State Database
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00  0x00000008   0x55bb        644           100     0/0/0
    0000.0000.0004.00-00* 0x00000005   0x651         624           84      0/0/0
    Total LSP(s): 2 
    *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload

    # Display the IS-IS routing table of each router. In the routing table of a Level-1 device, there must be a default route with a Level-1-2 device as the next hop. The routing table of a Level-2 device must have all Level-1 and Level-2 routes.

    [~DeviceA] display isis route
                             Route information for ISIS(1)
                             -----------------------------
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    GE1/0/0         Direct          D/-/L/-/-
     10.1.2.0/24        20        NULL    GE1/0/0         10.1.1.1        A/-/-/-/-
     192.168.0.0/24     20        NULL    GE1/0/0         10.1.1.1        A/-/-/-/-
     0.0.0.0/0          10        NULL    GE1/0/0         10.1.1.1        A/-/-/-/-
        Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                     U-Up/Down Bit Set
    [~DeviceC] display isis route
                             Route information for ISIS(1)
                             -----------------------------
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    GE1/0/0         Direct          D/-/L/-/-
     10.1.2.0/24        10        NULL    GE2/0/0         Direct          D/-/L/-/-
     192.168.0.0/24     10        NULL    GE3/0/0         Direct          D/-/L/-/-
        Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                     U-Up/Down Bit Set
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------
     10.1.1.0/24        10        NULL    -               Direct          D/-/L/-/-
     10.1.2.0/24        10        NULL    -               Direct          D/-/L/-/-
     192.168.0.0/24     10        NULL    -               Direct          D/-/L/-/-
     172.16.0.0/16      20        NULL    GE3/0/0         192.168.0.2     A/-/-/-/-
        Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                     U-Up/Down Bit Set
    [~DeviceD] display isis route
                             Route information for ISIS(1)
                             -----------------------------
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     IPV4 Destination   IntCost   ExtCost ExitInterface   NextHop          Flags
    --------------------------------------------------------------------------
     192.168.0.0/24     10        NULL    GE3/0/0         Direct           D/-/L/-/-
     10.1.1.0/24        20        NULL    GE3/0/0         192.168.0.1      A/-/-/-/-
     10.1.2.0/24        20        NULL    GE3/0/0         192.168.0.1      A/-/-/-/-
     172.16.0.0/16      10        NULL    GE2/0/0         Direct           D/-/L/-/-
        Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                     U-Up/Down Bit Set

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     isis authentication-mode md5 cipher N`C55QK<`=/Q=^Q`MAF4<1!!
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    isis 1
     is-level level-1-2
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis authentication-mode md5 cipher N`C55QK<`=/Q=^Q`MAF4<1!!
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     isis enable 1
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.1.1 255.255.0.0
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055018

Views: 47582

Downloads: 200

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next