No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Routing 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPF-BGP Synchronization

Example for Configuring OSPF-BGP Synchronization

This section describes how to configure OSPF-BGP synchronization to minimize the impact of device restart on BGP services on the network.

Networking Requirements

On the network shown in Figure 5-20, all devices run BGP. An EBGP connection is set up between Device D and Device E. IBGP connections are set up between devices in AS 10, and OSPF is used as an IGP protocol.

OSPF-BGP synchronization is required on Device B so that the restart of Device B does not interrupt the traffic from Device A to AS 20.

Figure 5-20 Networking for configuring OSPF-BGP synchronization
NOTE:

Interface 1, interface 2, interface 3 in this example are GE 1/0/0, GE 2/0/0, and GE 3/0/0, respectively.



Precautions

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable OSPF on Device A, Device B, Device C, and Device D (except 10.2.1.1/30) and specify the same area for all OSPF interfaces.

  2. Set up IBGP connections between Device A, Device B, Device C, and Device D (except 10.2.1.1/30).

  3. Configure the OSPF cost on Device C.

  4. Set up EBGP connections between Device D and Device E.

  5. Configure BGP to import direct routes and OSPF processes on Device D.

  6. Configure BGP on Device E.

Data Preparation

To complete the configuration, you need the following data:

  • Data of Device A, including the Router ID (1.1.1.1), number of the AS to which Device A belongs (10), OSPF process number (1), and network segment addresses of Area 0 (10.1.1.0/30 and 10.1.2.0/30)

  • Data of Device B, including the Router ID (2.2.2.2), number of the AS to which Device B belongs (10), OSPF process number (1), and network segment addresses of Area 0 (10.1.1.0/30 and 10.1.3.0/30)

  • Data of Device C, including the Router ID (3.3.3.3), number of the AS to which Device C belongs (10), OSPF process number (1), and network segment addresses of Area 0 (10.1.2.0/30 and 10.1.4.0/30)

  • Data of Device D, including the Router ID (4.4.4.4), number of the AS to which Device D belongs (10), OSPF process number (1), and network segment addresses of Area 0 (10.1.3.0/30 and 10.1.4.0/30)

  • Data of Device E, including the Router ID (5.5.5.5) and number of the AS to which Device E belongs (20)

Procedure

  1. Assign an IP address to each interface. For configuration details, see Configuration Files in this section.
  2. Configure basic OSPF functions. For details, see Example for Configuring Basic OSPF Functions.
  3. Set up IBGP connections.

    # Configure Device A.

    <DeviceA> system-view
    [~DeviceA] interface loopback 0
    [~DeviceA-LoopBack0] ip address 1.1.1.1 32
    [*DeviceA-LoopBack0] quit
    [*DeviceA] bgp 10
    [*DeviceA-bgp] router-id 1.1.1.1
    [*DeviceA-bgp] peer 2.2.2.2 as-number 10
    [*DeviceA-bgp] peer 2.2.2.2 connect-interface LoopBack 0
    [*DeviceA-bgp] peer 3.3.3.3 as-number 10
    [*DeviceA-bgp] peer 3.3.3.3 connect-interface LoopBack 0
    [*DeviceA-bgp] peer 4.4.4.4 as-number 10
    [*DeviceA-bgp] peer 4.4.4.4 connect-interface LoopBack 0
    [*DeviceA-bgp] quit
    [*DeviceA] commit

    # Configure Device B.

    <DeviceB> system-view
    [~DeviceB] interface loopback 0
    [~DeviceB-LoopBack0] ip address 2.2.2.2 32
    [*DeviceB-LoopBack0] quit
    [*DeviceB] bgp 10
    [*DeviceB-bgp] router-id 2.2.2.2
    [*DeviceB-bgp] peer 1.1.1.1 as-number 10
    [*DeviceB-bgp] peer 1.1.1.1 connect-interface LoopBack 0
    [*DeviceB-bgp] peer 3.3.3.3 as-number 10
    [*DeviceB-bgp] peer 3.3.3.3 connect-interface LoopBack 0
    [*DeviceB-bgp] peer 4.4.4.4 as-number 10
    [*DeviceB-bgp] peer 4.4.4.4 connect-interface LoopBack 0
    [*DeviceB-bgp] quit
    [*DeviceB] commit

    # Configure Device C.

    <DeviceC> system-view
    [~DeviceC] interface loopback 0
    [~DeviceC-LoopBack0] ip address 3.3.3.3 32
    [*DeviceC-LoopBack0] quit
    [*DeviceC] bgp 10
    [*DeviceC-bgp] router-id 3.3.3.3
    [*DeviceC-bgp] peer 1.1.1.1 as-number 10
    [*DeviceC-bgp] peer 1.1.1.1 connect-interface LoopBack 0
    [*DeviceC-bgp] peer 2.2.2.2 as-number 10
    [*DeviceC-bgp] peer 2.2.2.2 connect-interface LoopBack 0
    [*DeviceC-bgp] peer 4.4.4.4 as-number 10
    [*DeviceC-bgp] peer 4.4.4.4 connect-interface LoopBack 0
    [*DeviceC-bgp] quit
    [*DeviceC] commit

    # Configure Device D.

    <DeviceD> system-view
    [~DeviceD] interface loopback 0
    [~DeviceD-LoopBack0] ip address 4.4.4.4 32
    [*DeviceD-LoopBack0] quit
    [*DeviceD] bgp 10
    [*DeviceD-bgp] router-id 4.4.4.4
    [*DeviceD-bgp] peer 1.1.1.1 as-number 10
    [*DeviceD-bgp] peer 1.1.1.1 connect-interface LoopBack 0
    [*DeviceD-bgp] peer 2.2.2.2 as-number 10
    [*DeviceD-bgp] peer 2.2.2.2 connect-interface LoopBack 0
    [*DeviceD-bgp] peer 3.3.3.3 as-number 10
    [*DeviceD-bgp] peer 3.3.3.3 connect-interface LoopBack 0
    [*DeviceD-bgp] quit
    [*DeviceD] commit

  4. Set up EBGP connections.

    # Configure Device D.

    [*DeviceD] bgp 10
    [*DeviceD-bgp] peer 10.2.1.2 as-number 20
    [*DeviceD-bgp] import-route direct
    [*DeviceD-bgp] import-route ospf 1
    [*DeviceD-bgp] quit
    [*DeviceD] commit

    # Configure Device E.

    [*DeviceE] bgp 20
    [*DeviceE-bgp] peer 10.2.1.1 as-number 10
    [*DeviceE-bgp] ipv4-family unicast
    [*DeviceE-bgp-af-ipv4] network 10.3.1.0 30
    [*DeviceE-bgp-af-ipv4] quit
    [*DeviceE-bgp] commit

  5. Configure the OSPF cost on Device C.

    [~DeviceC] interface gigabitethernet 1/0/0
    [~DeviceC-GigabitEthernet1/0/0] ospf cost 2
    [*DeviceC-GigabitEthernet1/0/0] quit
    [~DeviceC] interface gigabitethernet 2/0/0
    [~DeviceC-GigabitEthernet2/0/0] ospf cost 2
    [*DeviceC-GigabitEthernet2/0/0] commit
    [~DeviceC-GigabitEthernet2/0/0] quit
    [*DeviceC] commit
    NOTE:

    After the OSPF cost is set to 2 on Device C, Device A selects only Device B as the intermediate router to the network segment 10.2.1.0, and Device C becomes a backup of Device B.

    # Check the routing table on DeviceA. BGP learns the route to 10.1.3.0, and the outbound interface is GE 1/0/0.

    [~DeviceA] display ip routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 20       Routes : 20
    
        Destination/Mask       Proto    Pre  Cost    Flags NextHop         Interface
    
            1.1.1.1/32         Direct   0    0       D     127.0.0.1       InLoopBack0
            1.1.1.255/32       Direct   0    0       D     127.0.0.1       InLoopBack0
            2.2.2.2/32         OSPF     10   3       D     10.1.1.2        GigabitEthernet1/0/0
            4.4.4.0/24         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
            4.4.4.4/32         OSPF     10   3       D     10.1.1.2        GigabitEthernet1/0/0
            5.5.5.0/24         BGP      255  0       RD    10.2.1.2        GigabitEthernet1/0/0
           10.1.1.0/30         Direct   0    0       D     10.1.1.1        GigabitEthernet1/0/0
           10.1.1.3/32         Direct   0    0       D     10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32         Direct   0    0       D     127.0.0.1       InLoopBack0
           10.1.1.255/32       Direct   0    0       D     127.0.0.1       InLoopBack0
           10.1.1.255/32       Direct   0    0       D     10.1.1.2        GigabitEthernet1/0/0
           10.1.1.2/32         Direct   0    0       D     10.1.1.2        GigabitEthernet1/0/0
           10.1.1.255/32       Direct   0    0       D     10.1.1.2        GigabitEthernet1/0/0
           10.1.2.0/30         Direct   0    0       D     10.1.2.1        GigabitEthernet2/0/0
           10.1.2.3/32         Direct   0    0       D     10.1.2.1        GigabitEthernet2/0/0
           10.1.2.1/32         Direct   0    0       D     127.0.0.1       InLoopBack0
           10.1.2.255/32       Direct   0    0       D     127.0.0.1       InLoopBack0
           10.1.2.2/32         Direct   0    0       D     10.1.2.2        GigabitEthernet2/0/0
           10.1.2.255/32       Direct   0    0       D     10.1.2.2        GigabitEthernet2/0/0
          127.0.0.0/8          Direct   0    0       D     127.0.0.1       InLoopBack0
          127.0.0.1/32         Direct   0    0       D     127.0.0.1       InLoopBack0
          127.0.0.255/32       Direct   0    0       D     127.0.0.1       InLoopBack0
        10.1.3.0/30       OSPF    10   2       D     10.1.1.2        GigabitEthernet1/0/0
           10.1.3.1/32         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
           10.1.4.0/30         OSPF     10   3       D     10.1.1.2        GigabitEthernet1/0/0
                               OSPF     10   3       D     10.1.2.2        GigabitEthernet2/0/0
           10.1.4.1/32         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
           10.2.1.0/30         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
           10.2.1.2/32         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
           10.3.1.0/30         BGP      255  0       RD    4.4.4.4         GigabitEthernet1/0/0
           255.255.255.255/32  Direct   0    0       D     127.0.0.1       InLoopBack0

    # Display the routing table on Device B.

    [~DeviceB] display ip routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 19       Routes : 19
    
        Destination/Mask       Proto    Pre  Cost      Flags NextHop         Interface
    
            2.2.2.2/32         Direct   0    0           D   127.0.0.1        InLoopBack0
            2.2.2.255/32       Direct   0    0           D   127.0.0.1        InLoopBack0
            1.1.1.1/32         OSPF     10   2           D   10.1.1.1         GigabitEthernet1/0/0
            4.4.4.0/24         BGP      255  0           RD  10.1.3.2         GigabitEthernet2/0/0
            4.4.4.4/32         OSPF     10   2           D   10.1.3.2         GigabitEthernet2/0/0
            5.5.5.0/24         BGP      255  0           RD  10.2.1.2         GigabitEthernet2/0/0
           10.1.1.0/30         Direct   0    0           D   10.1.1.2         GigabitEthernet1/0/0
           10.1.1.3/32         Direct   0    0           D   10.1.1.2         GigabitEthernet1/0/0
           10.1.1.1/32         Direct   0    0           D   10.1.1.1         GigabitEthernet1/0/0
           10.1.1.255/32       Direct   0    0           D   10.1.1.1         GigabitEthernet1/0/0
           10.1.1.2/32         Direct   0    0           D   127.0.0.1        InLoopBack0
           10.1.1.255/32       Direct   0    0           D   127.0.0.1        InLoopBack0
           10.1.2.0/30         OSPF     10   2           D   10.1.1.1         GigabitEthernet1/0/0
           10.1.3.0/30         Direct   0    0           D   10.1.3.1         GigabitEthernet2/0/0
           10.1.3.3/32         Direct   0    0           D   10.1.3.1         GigabitEthernet2/0/0
           10.1.3.1/32         Direct   0    0           D   127.0.0.1        InLoopBack0
           10.1.3.255/32       Direct   0    0           D   127.0.0.1        InLoopBack0
           10.1.3.2/32         Direct   0    0           D   10.1.3.2         GigabitEthernet2/0/0
           10.1.3.255/32       Direct   0    0           D   10.1.3.2         GigabitEthernet2/0/0
          127.0.0.0/8          Direct   0    0           D   127.0.0.1        InLoopBack0
          127.0.0.1/32         Direct   0    0           D   127.0.0.1        InLoopBack0
          127.0.0.255/32       Direct   0    0           D   127.0.0.1        InLoopBack0
           10.1.4.0/30         OSPF     10   2           D   10.1.3.2         GigabitEthernet2/0/0
           10.1.4.1/32         BGP      255  0           RD  10.1.3.2         GigabitEthernet2/0/0
           10.2.1.0/30         BGP      255  0           RD  10.1.3.2         GigabitEthernet2/0/0
           10.2.1.2/32         BGP      255  0           RD  10.1.3.2         GigabitEthernet2/0/0
         10.3.1.0/30      BGP    255  0           RD  10.1.3.2         GigabitEthernet2/0/0
           255.255.255.255/32  Direct   0    0           D     127.0.0.1       InLoopBack0

    As shown in the routing table, Device B learns the route to 10.3.1.0 through BGP, and the outbound interface is GE 2/0/0. The routes to 10.1.2.0 and 10.1.4.0 can be learned through OSPF. The costs of these routes are both 2.

  6. Enable OSPF-BGP synchronization on Device B.

    [~DeviceB] ospf 1
    [*DeviceB-ospf-1] stub-router on-startup
    [*DeviceB-ospf-1] quit
    [*DeviceB] commit

  7. Verify the configuration.

    # Restart router Device B.

    NOTE:

    Exercise caution when running the reboot command it may lead to a temporary network crash. In addition, save the configuration file of the router before restarting the router.

    <DeviceB> reboot
    System will reboot! Continue?[Y/N] y

    # Display the routing table on Device A. As shown in the routing table, BGP learns the route to 10.3.1.0, and the outbound interface is GE 2/0/0.

    [~DeviceA] display ip routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 20       Routes : 20
    
    Destination/Mask    Proto  Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  Direct 0    0           D   127.0.0.1        InLoopBack0
            2.2.2.2/32  OSPF   10   4           D   10.1.2.2         GigabitEthernet2/0/0
            4.4.4.0/24  BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0
            4.4.4.4/32  OSPF   10   4           D   10.1.2.2         GigabitEthernet2/0/0
            5.5.5.0/24  BGP    255  0           RD  10.2.1.2         GigabitEthernet2/0/0
           10.1.1.0/30  Direct 0    0           D   10.1.1.1         GigabitEthernet1/0/0
           10.1.1.1/32  Direct 0    0           D   127.0.0.1        InLoopBack0
           10.1.1.2/32  Direct 0    0           D   10.1.1.2         GigabitEthernet1/0/0
           10.1.2.0/30  Direct 0    0           D   10.1.2.1         GigabitEthernet2/0/0
           10.1.2.1/32  Direct 0    0           D   127.0.0.1        InLoopBack0
           10.1.2.2/32  Direct 0    0           D   10.1.2.2         GigabitEthernet2/0/0
          127.0.0.0/8   Direct 0    0           D   127.0.0.1        InLoopBack0
          127.0.0.1/32  Direct 0    0           D   127.0.0.1        InLoopBack0
           10.1.3.0/30  OSPF   10   2           D   10.1.1.2         GigabitEthernet1/0/0
           10.1.3.1/32  BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0
           10.1.4.0/30  OSPF   10   3           D   10.1.2.2         GigabitEthernet2/0/0
           10.1.4.1/32  BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0
           10.2.1.0/30  BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0
           10.2.1.2/32  BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0
          10.3.1.0/30   BGP    255  0           RD  4.4.4.4          GigabitEthernet2/0/0

    # Display the routing table on Device B. As shown in the routing table, only OSPF routes exist in the routing table because IGP routes converge faster than BGP routes do. The costs of the OSPF routes are 65535.

    [~DeviceB] display ip routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 15       Routes : 15
    
    Destination/Mask    Proto  Pre  Cost      Flags NextHop        Interface
    
            1.1.1.1/32  OSPF   10   65536       D  10.1.1.1        GigabitEthernet1/0/0
            2.2.2.2/32  Direct 0    0           D  127.0.0.1       InLoopBack0
            4.4.4.4/32  OSPF   10   65536       D  10.1.3.2        GigabitEthernet2/0/0
           10.1.1.0/30  Direct 0    0           D  10.1.1.2        GigabitEthernet1/0/0
           10.1.1.1/32  Direct 0    0           D  10.1.1.1        GigabitEthernet1/0/0
           10.1.1.2/32  Direct 0    0           D  127.0.0.1       InLoopBack0
           10.1.2.0/30  OSPF   10   65536       D  10.1.1.1        GigabitEthernet1/0/0
           10.1.3.0/30  Direct 0    0           D  10.1.3.1        GigabitEthernet2/0/0
           10.1.3.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
           10.1.3.2/32  Direct 0    0           D  10.1.3.2        GigabitEthernet2/0/0
          127.0.0.0/8   Direct 0    0           D   127.0.0.1      InLoopBack0
          127.0.0.1/32  Direct 0    0           D   127.0.0.1      InLoopBack0
           10.1.4.0/30  OSPF   10   65536       D  10.1.3.2        GigabitEthernet2/0/0
          127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0

    # Display the routing table on Device B again.

    [~DeviceB] display ip routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 19       Routes : 19
    
    Destination/Mask    Proto  Pre  Cost       Flags NextHop       Interface
    
            2.2.2.2/32  Direct 0    0           D    127.0.0.1        InLoopBack0
            1.1.1.1/32  OSPF   10   2           D    10.1.1.1         GigabitEthernet1/0/0
            4.4.4.0/24  BGP    255  0           RD   10.1.3.2         GigabitEthernet2/0/0
            4.4.4.4/32  OSPF   10   2           D    10.1.3.2         GigabitEthernet2/0/0
            5.5.5.0/24  BGP    255  0           RD   10.2.1.2         GigabitEthernet2/0/0
           10.1.1.0/30  Direct 0    0           D    10.1.1.2         GigabitEthernet1/0/0
           10.1.1.1/32  Direct 0    0           D    10.1.1.1         GigabitEthernet1/0/0
           10.1.1.2/32  Direct 0    0           D    127.0.0.1        InLoopBack0
           10.1.2.0/30  OSPF   10   2           D    10.1.1.1         GigabitEthernet1/0/0
           10.1.3.0/30  Direct 0    0           D    10.1.3.1         GigabitEthernet2/0/0
           10.1.3.1/32  Direct 0    0           D    127.0.0.1        InLoopBack0
           10.1.3.2/32  Direct 0    0           D    10.1.3.2         GigabitEthernet2/0/0
          127.0.0.0/8   Direct 0    0           D    127.0.0.1        InLoopBack0
          127.0.0.1/32  Direct 0    0           D    127.0.0.1        InLoopBack0
           10.1.4.0/30  OSPF   10   2           D    10.1.3.2         GigabitEthernet2/0/0
           10.1.4.1/32  BGP    255  0           RD   10.1.3.2         GigabitEthernet2/0/0
           10.2.1.0/30  BGP    255  0           RD   10.1.3.2         GigabitEthernet2/0/0
           10.2.1.2/32  BGP    255  0           RD   10.1.3.2         GigabitEthernet2/0/0
           10.3.1.0/30  BGP    255  0           RD   10.1.3.2         GigabitEthernet2/0/0

    As shown in the routing table, BGP routes on Device B have converged, and the routing information is the same as that displayed before the restart.

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    router id 1.1.1.1
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.252
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.2.1 255.255.255.252
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 10
     router-id 1.1.1.1
     peer 2.2.2.2 as-number 10
     peer 2.2.2.2 connect-interface LoopBack 0
     peer 3.3.3.3 as-number 10
     peer 3.3.3.3 connect-interface LoopBack 0
     peer 4.4.4.4 as-number 10
     peer 4.4.4.4 connect-interface LoopBack 0
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.1.2.0 0.0.0.3
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    router id 2.2.2.2
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.252
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.3.1 255.255.255.252
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 10
     router-id 2.2.2.2
     peer 1.1.1.1 as-number 10
     peer 1.1.1.1 connect-interface LoopBack 0
     peer 3.3.3.3 as-number 10
     peer 3.3.3.3 connect-interface LoopBack 0
     peer 4.4.4.4 as-number 10
     peer 4.4.4.4 connect-interface LoopBack 0
    #
    ospf 1
     stub-router on-startup
     area 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.1.3.0 0.0.0.3
      network 2.2.2.2 0.0.0.0
    #
    return
  • Device C configuration file

    #
     sysname DeviceC
    #
    router id 3.3.3.3
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.4.1 255.255.255.252
     ospf cost 2
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.2.2 255.255.255.252
     ospf cost 2
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 10
     router-id 3.3.3.3
     peer 1.1.1.1 as-number 10
     peer 1.1.1.1 connect-interface LoopBack 0
     peer 2.2.2.2 as-number 10
     peer 2.2.2.2 connect-interface LoopBack 0
     peer 4.4.4.4 as-number 10
     peer 4.4.4.4 connect-interface LoopBack 0
    
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.3
      network 10.1.4.0 0.0.0.3
      network 3.3.3.3 0.0.0.0
    #
    return
  • Device D configuration file

    #
     sysname DeviceD
    #
    router id 4.4.4.4
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.4.2 255.255.255.252
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.3.2 255.255.255.252
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.252
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 10
     router-id 4.4.4.4
     peer 10.2.1.2 as-number 20
     peer 1.1.1.1 as-number 10
     peer 1.1.1.1 connect-interface LoopBack 0
     peer 2.2.2.2 as-number 10
     peer 2.2.2.2 connect-interface LoopBack 0
     peer 3.3.3.3 as-number 10
     peer 3.3.3.3 connect-interface LoopBack 0
     #
    ipv4-family unicast
      undo synchronization
      import-route direct
      import-route ospf 1
      peer 10.2.1.2 enable
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.3.0 0.0.0.3
      network 10.1.4.0 0.0.0.3
    #
    return
  • Device E configuration file

    #
     sysname DeviceE
    #
    router id 5.5.5.5
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.252
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.3.1.1 255.255.255.252
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
    #
    bgp 20
     router-id 5.5.5.5
     peer 10.2.1.1 as-number 10
    #
    ipv4-family unicast
      undo synchronization
      network 10.3.1.0 255.255.255.252
      peer 10.2.1.1 enable
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055018

Views: 55457

Downloads: 211

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next