No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - IP Routing 01

This is NE40E V800R010C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Dynamic BFD for IPv4 Static Routes

Example for Configuring Dynamic BFD for IPv4 Static Routes

Dynamic BFD for IPv4 static routes can fast detect link failures.

Networking Requirements

On the network shown in Figure 3-5, Device A is connected to Device B through Switch C. It is required that Device A communicate with other Devices through static default routes and that a BFD session be established between Device A and Device B to detect link failures.

Figure 3-5 Networking for configuring dynamic BFD for static routes
NOTE:

Interfaces 1 and 2 in this example are GE 1/0/0, GE 2/0/0, respectively.



Precautions

When configuring dynamic BFD for static routes, note the following:

  • BFD has been enabled globally.

  • The parameters configured on the two ends of a BFD session must be consistent.

Configuration Roadmap

The configuration roadmap is as follows:

  1. On Device A, configure an IPv4 static route to Device B.

  2. Configure dynamic BFD for static routes.

Data Preparation

To complete the configuration, you need the following data:

  • Peer IP address to be detected by BFD

  • Default values of the local detection multiplier and of the minimum intervals at which BFD Control packets are sent and received

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure static routes.

    # On Device A, configure a static route to 2.2.2.2/32.

    [~DeviceA] ip route-static 2.2.2.2 32 200.1.1.2
    [*DeviceA] commit

    # Check the IP routing table of Device A. The following command output shows that the static route exists in the routing table.

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 10        Routes : 10
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  Direct 0    0             D  127.0.0.1       LoopBack0
            2.2.2.2/32  Static 60   0             RD 200.1.1.2       GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
          200.1.1.0/24  Direct 0    0             D  200.1.1.1       GigabitEthernet1/0/0
          200.1.1.1/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
          200.1.1.2/32  Direct 0    0             D  200.1.1.2       GigabitEthernet1/0/0
        200.1.1.255/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
    

    # On Device B, configure a static route to 1.1.1.1/32.

    [~DeviceB] ip route-static 1.1.1.1 32 200.1.1.1
    [*DeviceB] commit

  3. Configure dynamic BFD for static routes.

    # On Device A, bind the static route to the BFD session.

    [~DeviceA] bfd
    [*DeviceA-bfd] quit
    [*DeviceA] ip route-static bfd 200.1.1.2 local-address 200.1.1.1
    [*DeviceA] ip route-static 2.2.2.2 32 200.1.1.2 bfd enable
    [*DeviceA] commit

    # On Device B, bind the static route to the BFD session.

    [~DeviceB] bfd
    [*DeviceB-bfd] quit
    [*DeviceB] ip route-static bfd 200.1.1.1 local-address 200.1.1.2
    [*DeviceB] ip route-static 1.1.1.1 32 200.1.1.1 bfd enable
    [*DeviceB] commit

  4. Verify the configuration.

    # After the preceding configuration, on Device A and Device B, you can view that the BFD session has been established and is Up and that the static routes have been bound to the BFD session.

    Use the command output Device A as an example.

    [~DeviceA] display bfd session all verbose
    (w): State in WTR 
    (*): State is invalid
    ------------------------------------------------------------------------------
      (Multi Hop) State : Up                    Name : dyn_8193
    ------------------------------------------------------------------------------
      Local Discriminator    : 8193             Remote Discriminator   : 8193
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer IP Address
      Bind Session Type      : Dynamic
      Bind Peer IP Address   : 200.1.1.2
      Bind Interface         : -
      Bind Source IP Address : 200.1.1.1
      FSM Board Id           : 0                TOS-EXP                : 6
      Min Tx Interval (ms)   : 50               Min Rx Interval (ms)   : 50
      Actual Tx Interval (ms): 50               Actual Rx Interval (ms): 50
      Local Detect Multi     : 3                Detect Interval (ms)   : 150
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 4784             TTL                    : 253
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : 0                Local Demand Mode      : Disable
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : STATICRT
      Session TX TmrID       : 0                Session Detect TmrID   : 0
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      Session Description    : -
    ------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 200.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 7.1.1.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ip route-static bfd 200.1.1.2 local-address 200.1.1.1
    ip route-static 2.2.2.2 32 200.1.1.2 bfd enable
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 200.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 8.1.1.1 255.255.255.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ip route-static bfd 200.1.1.1 local-address 200.1.1.2
    ip route-static 1.1.1.1 32 200.1.1.1 bfd enable
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055018

Views: 48657

Downloads: 201

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next