No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - QoS 01

This is NE40E V800R010C10SPC500 Configuration Guide - QoS
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring QPPB (IS-IS)

Example for Configuring QPPB (IS-IS)

This section provides an example for configuring QPPB (IS-IS).

Networking Requirements

On the network shown in Figure 7-8, IS-IS neighbor relationships are established between Device A and Device B, and Device B advertises IS-IS routes with community attributes to Device A. A QPPB policy is applied to traffic passing through Device A. Device B functions as an IS-IS route sender, and Device A functions as an IS-IS route receiver.

NOTE:

Interface1 in this example is GE1/0/0.

Figure 7-8 Configuring QPPB

Precautions

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing policy on Device A to match the community attributes against the community list, and associate traffic behaviors with QoS local IDs for the matched routes.

  2. Configure basic IS-IS functions.

  3. Apply the QPPB policy to the inbound interface of Device A.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of interfaces

  • Routing policy name, matching rules, and routing attributes

  • QPPB policy name

Procedure

  1. Assign an IP address to each interface.

    Assign an IP address to each interface based on Figure 7-8.

  2. Configure a routing policy on Device A and associate traffic behaviors with QoS local IDs for the matched routes.

    # Configure a routing policy on Device A.

    <DeviceA> system-view
    [~DeviceA] route-policy ac permit node 123
    [~DeviceA-route-policy] apply qos-local-id 1
    [~DeviceA-route-policy] commit
    [~DeviceA-route-policy] return

    # Configure a QoS policy.

    <DeviceA> system-view
    [~DeviceA] traffic behavior dd
    [~DeviceA-behavior-dd] remark dscp af11
    [~DeviceA-behavior-dd] commit
    [~DeviceA-behavior-dd] return

    # Configure a QPPB policy on Device A.

    <DeviceA> system-view
    [~DeviceA] qppb local-policy ac
    [~DeviceA-localpolicy-ac] qos-local-id 1 behavior dd
    [~DeviceA-localpolicy-ac] commit
    [~DeviceA-localpolicy-ac] return

  3. Configure basic IS-IS functions.

    # Configure Device A.

    <DeviceA> system-view
    [~DeviceA] isis 1
    [~DeviceA-isis-1] is-level level-1
    [~DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [~DeviceA-isis-1] cost-style wide
    [~DeviceA-isis-1] filter-policy route-policy ac import
    [~DeviceA-isis-1] traffic-eng level-1
    [~DeviceA-isis-1] quit
    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] isis enable 1
    [~DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

    # Configure Device B.

    <DeviceB> system-view
    [~DeviceB] isis 1
    [~DeviceB-isis-1] network-entity 10.0000.0000.0001.00
    [~DeviceB-isis-1] cost-style wide
    [~DeviceB-isis-1] quit
    [~DeviceB] interface gigabitethernet 1/0/0
    [~DeviceB-GigabitEthernet1/0/0] isis enable 1
    [~DeviceB-GigabitEthernet1/0/0] commit
    [~DeviceB-GigabitEthernet1/0/0] quit

  4. Apply the QPPB policy to the inbound interface of Device A.

    <DeviceA> system-view
    [~DeviceA] interface gigabitethernet 1/0/0
    [~DeviceA-GigabitEthernet1/0/0] qppb-policy ac source inbound
    [~DeviceA-GigabitEthernet1/0/0] commit
    [~DeviceA-GigabitEthernet1/0/0] quit

  5. Verify the configuration.

    # Display information about the QPPB policy on Device A.

    [~DeviceA] display qppb local-policy configuration ac
    qppb local-policy: ac
     statistics disable
     is-used yes
     qos-local-id 1 behavior dd 

Configuration Files

  • Device A configuration file.

    #
    sysname DeviceA
    #
    traffic behavior dd
     remark dscp af11
    #
    isis 1
     is-level level-1
     cost-style wide
     network-entity 10.0000.0000.0001.00
     filter-policy route-policy ac import
     traffic-eng level-1
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.1.1 255.255.255.0
     isis enable 1
     qppb-policy ac source inbound
    #
    route-policy ac permit node 123
     apply qos-local-id 1
    #
    qppb local-policy ac                                                           
     qos-local-id 1 behavior dd
    #
    return
  • Device B configuration file.

    #
    sysname DeviceB
    #
    isis 1
     cost-style wide
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.1.2 255.255.255.0
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055024

Views: 22583

Downloads: 115

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next