No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - QoS 01

This is NE40E V800R010C10SPC500 Configuration Guide - QoS
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring HQoS on a Serial Interface

Example for Configuring HQoS on a Serial Interface

This section provides an example for configuring HQoS on a serial interface in the networking.

Networking Requirements

For the purpose of better utilization of the bandwidth of the interface, each user accesses the network through a serial interface. The packets of all users are then converged to the backbone network by the router.

As shown in Figure 8-8, router is an access device to the backbone network. 2G User and 3G User access the network through serial1/0/0/1:1 and serial1/0/0/2:2 of router. 2G User is guaranteed with a bandwidth of 20 Mbit/s; 3G User, 40 Mbit/s. The bandwidth of the EF flow of User1 is 6 Mbit/s; that of the AF1 flow, 2 Mbit/s. The bandwidth of the EF flow of 3G User is 5 Mbit/s. 2G User and 3G User are in the same subscriber group. The bandwidth of the group queue is 100 Mbit/s.

Figure 8-8 Networking diagram for configuring SQ

NOTE:

Interfaces 1, 2, and 3 stand for Serial 0/1/0/1:1, Serial 0/1/0/2:2, and GE 2/0/0.

Configuration Roadmap

In upstream HQoS scheduling on an Ethernet interface, CQ adopts the default scheduling setting and is not configured by users.

It is recommended that users configure downstream CQ on an Ethernet interface so that the backbone network is not congested.

The configuration roadmap is as follows:

  1. Configuring parameters of packet dropping for the FQ WRED object.

  2. Configuring algorithms for flow queue scheduling and related parameters.

  3. Configuring service class mappings from FQs to CQs.

  4. Configuring values of GQ shaping.

  5. Configuring SQs on the upstream interface of the access router.

Data Preparation

To complete the configuration, you need the following data:

  • Parameters of flow-wred packet dropping

  • Algorithms for flow-queue scheduling and related parameters

  • Service class mappings for flow-mapping

  • Values of user-group-queue shaping

  • Values of user-queue CIR, PIR, and network-header-length

Procedure

  1. Configure a WRED object referenced by FQs.

    # Configure parameters of flow-wred packet dropping.

    <HUAWEI> system view
    [~HUAWEI] flow-wred test
    [*HUAWEI-flow-wred-test] color green low-limit 70 high-limit 100 discard-percentage 100
    [*HUAWEI-flow-wred-test] color yellow low-limit 60 high-limit 90 discard-percentage 100
    [*HUAWEI-flow-wred-test] color red low-limit 50 high-limit 80 discard-percentage 100
    [*HUAWEI-flow-wred-test] commit
    [~HUAWEI-flow-wred-test] return

    After the preceding configuration, you can run the display flow-wred configuration verbose command to view the configured parameters of the FQ WRED object.

    <HUAWEI> display flow-wred configuration verbose test
    flow-wred-name : test
    ---------------------------------------------------
     color    low-limit    high-limit    discard-percent
    ---------------------------------------------------
     green    70            100           100
     yellow   60            90            100
     red      50           80           100
    Queue Depth : 32768   
    Reference relationships : test

  2. Configure algorithms for queue scheduling and related parameters of FQs.

    # Configure the scheduling algorithms, WRED parameters, and shaping values for FQs.

    <HUAWEI> system view
    [~HUAWEI] flow-queue test1
    [*HUAWEI-flow-queue-template-test1] queue af1 lpq flow-wred test shaping 2000
    [*HUAWEI-flow-queue-template-test1] queue ef pq flow-wred test shaping 6000
    [*HUAWEI-flow-queue-template-test1] commit
    [~HUAWEI-flow-queue-template-test1] quit
    [~HUAWEI] flow-queue test2
    [*HUAWEI-flow-queue-template-test2] queue ef pq flow-wred test shaping 5000
    [*HUAWEI-flow-queue-template-test2] commit
    [~HUAWEI-flow-queue-template-test2] return

    After the preceding configuration, you can run the display flow-queue configuration verbose command to view the configuration of the FQ template.

    <HUAWEI> display flow-queue configuration verbose test1 
    Codes: Arith(Schedule algorithm)
           U-Weight(Schedule weight configured by users)
           I-Weight(Inverse schedule weight used by TM)
           A-Weight(Actual schedule weight obtained by users)
           Shp(Shaping value, the percentage of subscriber queue's PIR)
           Drop-Arith(The name of the WRED object used by the flow queue)
    
    
    Flow Queue Template : test1
    ------------------------------------------------------------------
    Cos  Arith  U-Weight  I-Weight  A-Weight  Shp      Pct  Drop-Arith
    ------------------------------------------------------------------
    be   wfq    10        3         10.00     -        -    Tail Drop
    af1  lpq    -         -         -         2000     -    test
    af2  wfq    10        3         10.00     -        -    Tail Drop
    af3  wfq    15        2         15.00     -        -    Tail Drop
    af4  wfq    15        2         15.00     -        -    Tail Drop
    ef   pq     -         -         -         6000     -    test
    cs6  pq     -         -         -         -        -    Tail Drop
    cs7  pq     -         -         -         -        -    Tail Drop
    Reference relationships : NULL    
    <HUAWEI> display flow-queue configuration verbose test2
    Codes: Arith(Schedule algorithm)
           U-Weight(Schedule weight configured by users)
           I-Weight(Inverse schedule weight used by TM)
           A-Weight(Actual schedule weight obtained by users)
           Shp(Shaping value, the percentage of subscriber queue's PIR)
           Drop-Arith(The name of the WRED object used by the flow queue)
    
    
    Flow Queue Template : test2
    ------------------------------------------------------------------
    Cos  Arith  U-Weight  I-Weight  A-Weight  Shp      Pct  Drop-Arith
    ------------------------------------------------------------------
    be   wfq    10        3         10.00     -        -    Tail Drop
    af1  wfq    10        3         10.00     -        -    Tail Drop
    af2  wfq    10        3         10.00     -        -    Tail Drop
    af3  wfq    15        2         15.00     -        -    Tail Drop
    af4  wfq    15        2         15.00     -        -    Tail Drop
    ef   pq     -         -         -         5000     -    test
    cs6  pq     -         -         -         -        -    Tail Drop
    cs7  pq     -         -         -         -        -    Tail Drop
    Reference relationships : NULL

  3. Configure service class mappings from FQs to CQs.

    <HUAWEI> system view
    [~HUAWEI] flow-mapping test1
    [*HUAWEI-flow-mapping-test1] map flow-queue af1 to port-queue ef
    [*HUAWEI-flow-mapping-test1] commit
    [~HUAWEI-flow-mapping-test1] return

    After the preceding configuration, you can run the display flow-mapping configuration verbose command to view the configured parameters of the FQ mapping object and the referential relations of the object.

    <HUAWEI> display flow-mapping configuration verbose test1
    flow-mapping-name : test1
     fq-cosvalue to pq-cosvalue
     be          to be
     af1         to ef
     af2         to af2
     af3         to af3
     af4         to af4
     ef          to ef
     cs6         to cs6
     cs7         to cs7
     [reference relationship]
     NULL

  4. Configure the value for the GQ shaping.

    # Configure user-group-queue.

    <HUAWEI> system view
    [~HUAWEI] user-group-queue test
    [*HUAWEI-user-group-queue-test-slot-all] shaping 500000 inbound
    [*HUAWEI-user-group-queue-test-slot-all] commit
    [~HUAWEI-user-group-queue-test-slot-all] return

    After the preceding configuration, you can run the display user-group-queue configuration verbose command to view the configuration of the GQ and the referential relations.

    <HUAWEI> display user-group-queue configuration verbose test 
    user-group-queue-name : test
     slot : 3
     [current configuration]
      inbound
       shaping-value <kbps> : 100000
       pbs-value <byte> : 104858
      outbound
       shaping-value <kbps> : NA
       pbs-value <byte> : NA
       weight-value : NA
       flow-wred-name : NA
     [reference relationship]
     NULL

  5. Configure an SQ on the upstream interface of the access router.

    <HUAWEI> system view
    [~HUAWEI]service-template st1
    [*HUAWEI-service-template-st1-slot-all] network-header-length 10 inbound
    [*HUAWEI-service-template-st1-slot-all] commit
    [~HUAWEI-service-template-st1-slot-all] quit
    [~HUAWEI]controller cpos 1/0/0
    [*HUAWEI-Cpos1/0/0] e1 1 channel-set 1 timeslot-list 1-31
    [*HUAWEI-Cpos1/0/0] e1 2 channel-set 2 timeslot-list 1-31
    [*HUAWEI-Cpos1/0/0] undo shutdown
    [*HUAWEI-Cpos1/0/0] commit
    [~HUAWEI-Cpos1/0/0] quit
    [~HUAWEI] interface serial 1/0/0/1:1
    [*HUAWEI-Serial1/0/0/1:1] link-protocol ppp
    [*HUAWEI-Serial1/0/0/1:1] ip address 10.20.1.1 24
    [*HUAWEI-Serial1/0/0/1:1] user-queue cir 20000 pir 20000 flow-queue test1 flow-mapping test1 user-group-queue test inbound service-template st1
    [*HUAWEI-Serial1/0/0/1:1] commit
    [~HUAWEI-Serial1/0/0/1:1] quit
    [~HUAWEI] interface serial 1/0/0/2:2
    [*HUAWEI-Serial1/0/0/2:2] link-protocol ppp
    [*HUAWEI-Serial1/0/0/2:2] ip address 10.20.2.1 24
    [*HUAWEI-Serial1/0/0/2:2] user-queue cir 40000 pir 40000 flow-queue test2 flow-mapping test1 user-group-queue test inbound service-template st1
    [*HUAWEI-Serial1/0/0/2:2] commit
    [~HUAWEI-Serial1/0/0/2:2] return
    After the preceding configuration, you can run the display user-queue configuration interface command to view the detailed HQoS configuration on the interface.
    <HUAWEI> display user-queue configuration interface serial 1/0/0/1:1 inbound
    user-queue configuration infomation show :                                   
     GigabitEthernet1/0/0/1:1 Inbound:               
        CirValue<kbps>: 20000  
        PirValue<kbps>: 20000  
        FlowQueue: test1
        FlowMapping: test1
        GroupQueue: test
        service-template: NULL    
    <HUAWEI> display user-queue configuration interface serial 1/0/0/2:2 inbound
    user-queue configuration infomation show :                                   
     GigabitEthernet1/0/0/2:2 Inbound:               
        CirValue<kbps>: 40000  
        PirValue<kbps>: 40000  
        FlowQueue: test2
        FlowMapping: test1
        GroupQueue: test
        service-template: NULL    

  6. Verify the configuration.

    When packets are available in the network, you can find that packets of 2G User's AF1 and EF flows and 3G User's EF flow are forwarded at the guaranteed bandwidth.

Configuration Files

Configuration file of router

#
 sysname HUAWEI
#
flow-wred test
 color green low-limit 70 high-limit 100 discard-percentage 100
 color yellow low-limit 60 high-limit 90 discard-percentage 100
 color red low-limit 50 high-limit 80 discard-percentage 100
#
flow-mapping test1
 map flow-queue af1 to port-queue ef
#
flow-queue test1
 queue af1 lpq shaping 2000 flow-wred test
 queue ef pq shaping 6000 flow-wred test
#
flow-queue test2
 queue ef pq shaping 5000 flow-wred test
#
user-group-queue test
 shaping 100000 inbound
#
service-template st1
 network-header-length 10 inbound
#
controller cpos 1/0/0
 undo shutdown
 e1 1 channel-set 1 timeslot-list 1-31
 e1 2 channel-set 2 timeslot-list 1-31
#
interface Serial1/0/0/1:1
 undo shutdown
 link-protocol ppp
 ip address 10.20.1.1 255.255.255.0
 user-queue cir 20000 pir 20000 flow-queue test1 flow-mapping test1 user-group-queue test inbound service-template st1
#
interface Serial1/0/0/2:2
 undo shutdown
 link-protocol ppp
 ip address 10.20.2.1 255.255.255.0
 user-queue cir 40000 pir 40000 flow-queue test2 flow-mapping test1 user-group-queue test inbound service-template st1
#
interface GigabitEthernet2/0/0
 undo shutdown
 ip address 10.20.1.1 255.255.255.0
#
ospf 10
 area 0.0.0.0
 network 10.20.1.0 0.0.0.255
 network 10.20.2.0 0.0.0.255
 network 10.20.1.0 0.0.0.255
#
return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055024

Views: 22395

Downloads: 115

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next