No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - QoS 01

This is NE40E V800R010C10SPC500 Configuration Guide - QoS
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Profile-based HQoS

Example for Configuring Profile-based HQoS

This section provides an example for configuring profile-based HQoS so that service traffic of different types are transmitted through different sub-interfaces.

Networking Requirements

As shown in Figure 8-9, users need to access the router through the DSLAM. The router functions as the access device of the backbone network.

Three types of services of the users are to be mapped to three PVCs of the DSLAM. The traffic flows of the same user access the router through sub-interfaces GE 1/0/0.1, GE 1/0/0.2, and GE 1/0/0.3 respectively, with different types of traffic flowing through different sub-interfaces. When reaching the router, traffic flows carry double tags. The inner tag indicates the user, and the outer tag indicates the service type. Uniform scheduling of user traffic needs to be implemented with 100 Mbit/s assured bandwidth. The bandwidth for EF flows should be 30 Mbit/s, and the bandwidth for AF1 flows should be 10 Mbit/s. The bandwidth for the user group to which the users belong should be 500 Mbit/s. On the downstream interface of the router, the traffic rate of EF flows should not be higher than 120 Mbit/s. The mappings VLAN Tag marked for services is as follow:
  • PC: the outer VLAN Tag is 1; the inner VLAN Tag is 1 to 100.
  • VOIP: the outer VLAN Tag is 2; the inner VLAN Tag is 1 to 100.
  • IPTV: the outer VLAN Tag is 3; the inner VLAN Tag is 1 to 100.
NOTE:

Subinterface1.1, Subinterface2.1, Subinterface3.1, interface2 in this example are GE1/0/0.1, GE1/0/0.2, GE1/0/0.3 and GE2/0/0, respectively.

Figure 8-9 Networking diagram of profile-based HQoS

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure packet drop parameters for flow WRED objects.

  2. Configure scheduling algorithms and parameters for the flow queues.

  3. Configure CoS mappings between flow queues and class queues.

  4. Configure the shaping value for the user group queues.

  5. Configure the length for packet loss compensation of the service profile.

  6. Configure scheduling parameters and the CIR value of the user queues.

  7. Configure packet drop parameters for class WRED objects.

  8. Configure class queues on the downstream interface of the access router.

Data Preparation

To complete the configuration, you need the following data:

  • Packet drop parameters for flow-wred

  • Algorithms of flow-queue scheduling and related parameters

  • Flow-mapping of CoS

  • Shaping value for user group queues

  • Values of CIR, PIR, and network-header-length in the user-queue command in the QoS profile

  • Interface to which the QoS profile is applied

  • Port-wred parameters that are referenced by port-queue

  • Algorithms, related parameters, and shaping values for port-queue scheduling

Procedure

  1. Configure a WRED object referenced by a flow queue.

    # Configure packet dropping parameters of flow-wred.

    <HUAWEI> system view
    [~HUAWEI] flow-wred test
    [*HUAWEI-flow-wred-test] color green low-limit 70 high-limit 100 discard-percentage 100
    [*HUAWEI-flow-wred-test] color yellow low-limit 60 high-limit 90 discard-percentage 100
    [*HUAWEI-flow-wred-test] color red low-limit 50 high-limit 80 discard-percentage 100
    [*HUAWEI-flow-wred-test] commit
    [~HUAWEI-flow-wred-test] return

    After the preceding configuration, you can run the display flow-wred configuration verbose command to view the configured parameters of the flow WRED object.

    <HUAWEI> display flow-wred configuration verbose test
    flow-wred-name : test
    ---------------------------------------------------
     color    low-limit    high-limit    discard-percent
    ---------------------------------------------------
     green    70            100           100
     yellow   60            90            100
     red      50           80           100
    Queue Depth : 1000   
    Reference relationships : NULL

  2. Configure scheduling algorithms and parameters for flow queues.

    # Configure the scheduling algorithms, WRED parameters, and shaping values for flow queues.

    <HUAWEI> system view
    [~HUAWEI] flow-queue test
    [*HUAWEI-flow-queue-template-test] queue af1 lpq flow-wred test shaping 10000
    [*HUAWEI-flow-queue-template-test] queue ef pq flow-wred test shaping 30000

    After the preceding configuration, you can run the display flow-queue configuration verbose command to view the configurations of the flow queue profile.

    <HUAWEI> display flow-queue configuration verbose test 
    Codes: Arith(Schedule algorithm)
           U-Weight(Schedule weight configured by users)
           I-Weight(Inverse schedule weight used by TM)
           A-Weight(Actual schedule weight obtained by users)
           Shp(Shaping value, the percentage of subscriber queue's PIR)
           Drop-Arith(The name of the WRED object used by the flow queue)
    
    
    Flow Queue Template : test
    ------------------------------------------------------------------
    Cos  Arith  U-Weight  I-Weight  A-Weight  Shp      Pct  Drop-Arith
    ------------------------------------------------------------------
    be   wfq    10        3         10.00     -        -    Tail Drop
    af1  lpq    -         -         -         10000    -    test
    af2  wfq    10        3         10.00     -        -    Tail Drop
    af3  wfq    15        2         15.00     -        -    Tail Drop
    af4  wfq    15        2         15.00     -        -    Tail Drop
    ef   pq     -         -         -         30000    -    test
    cs6  pq     -         -         -         -        -    Tail Drop
    cs7  pq     -         -         -         -        -    Tail Drop
    Reference relationships : NULL    

  3. Configure CoS mappings between flow queues and class queues.

    <HUAWEI> system view
    [~HUAWEI] flow-mapping test
    [*HUAWEI-flow-mapping-test] map flow-queue af1 to port-queue ef
    [*HUAWEI-flow-mapping-test] commit
    [~HUAWEI-flow-mapping-test] return

    After the preceding configuration, run the display flow-mapping configuration verbose command to view the configured parameters of the flow queue mapping object and the referential relationships of the object.

    <HUAWEI> display flow-mapping configuration verbose test
    flow-mapping-name : test
     fq-cosvalue to pq-cosvalue
     be          to be
     af1         to ef
     af2         to af2
     af3         to af3
     af4         to af4
     ef          to ef
     cs6         to cs6
     cs7         to cs7
     [reference relationship]
     NULL

  4. Configure the shaping value for user group queues.

    <HUAWEI> system view
    [~HUAWEI] user-group-queue test
    [*HUAWEI-user-group-queue-test-slot-all] shaping 500000 inbound
    [*HUAWEI-user-group-queue-test-slot-all] commit
    [~HUAWEI-user-group-queue-test-slot-all] return

    After the preceding configuration, run the display user-group-queue configuration verbose command to view the configurations and the referential relationships of the user group queue.

    <HUAWEI> display user-group-queue configuration verbose test 
    user-group-queue-name : test
     slot : 3
     [current configuration]
      inbound
       shaping-value <kbps> : 500000
       pbs-value <byte> : 524288
      outbound
       shaping-value <kbps> : NA
       pbs-value <byte> : NA
       weight-value : NA
       flow-wred-name : NA
     [reference relationship]
     NULL

  5. Configure the length for packet loss compensation of the service profile.

    # Configure the service profile and network-header-length.

    <HUAWEI> system view
    [~HUAWEI] service-template test
    [*HUAWEI-service-template-test-slot-all] network-header-length 12 inbound
    [*HUAWEI-service-template-test-slot-all] commit
    [~HUAWEI-service-template-test-slot-all] quit
    After the preceding configuration, you can run the display service-template configuration verbose command to view the configurations of the service profile, the value of network-header-length, and the referential relationships of the service profile.
    <HUAWEI> display service-template configuration verbose
    [service-template detail information] total number : 1 slot all     : 1
    
    service-template-name : test slot : all [current configuration] inbound network-header-length: 12
    
      outbound network-header-length: NA
    
     [reference relationship] NULL
    

  6. Configure scheduling parameters in the QoS profile and apply the parameters to interfaces.

    # Configure scheduling parameters for user-queue and suppression rate of broadcast packets in the QoS profile.

    <HUAWEI> system view
    [~HUAWEI] qos-profile test
    [*HUAWEI-qos-profile-test] user-queue cir 100000 flow-queue test flow-mapping test user-group-queue test service-template test

    # Create QinQ termination sub-interfaces and configure QinQ termination. Then apply the QoS profile to GE 1/0/0.1, GE 1/0/0.2, and GE 1/0/0.3.

    <HUAWEI> system-view
    [~HUAWEI] interface gigabitethernet 1/0/0.1
    [*HUAWEI-GigabitEthernet1/0/0.1] control-vid 1 qinq-termination
    [*HUAWEI-GigabitEthernet1/0/0.1] qinq termination pe-vid 1 ce-vid 1 to 100 
    [*HUAWEI-GigabitEthernet1/0/0.1] ip address 10.10.1.1 24
    [*HUAWEI-GigabitEthernet1/0/0.1] qos-profile test inbound pe-vid 1 ce-vid 1 to 100 group group1
    [*HUAWEI-GigabitEthernet1/0/0.1] commit
    [~HUAWEI-GigabitEthernet1/0/0.1] quit
    [~HUAWEI] interface gigabitethernet 1/0/0.2
    [*HUAWEI-GigabitEthernet1/0/0.2] control-vid 2 qinq-termination
    [*HUAWEI-GigabitEthernet1/0/0.2] qinq termination pe-vid 2 ce-vid 1 to 100 
    [*HUAWEI-GigabitEthernet1/0/0.2] ip address 10.10.2.1 24
    [*HUAWEI-GigabitEthernet1/0/0.2] qos-profile test inbound pe-vid 2 ce-vid 1 to 100 group group1
    [*HUAWEI-GigabitEthernet1/0/0.2] commit
    [~HUAWEI-GigabitEthernet1/0/0.2] quit
    [~HUAWEI] interface gigabitethernet 1/0/0.3
    [*HUAWEI-GigabitEthernet1/0/0.3] control-vid 3 qinq-termination
    [*HUAWEI-GigabitEthernet1/0/0.3] qinq termination pe-vid 3 ce-vid 1 to 100 
    [*HUAWEI-GigabitEthernet1/0/0.3] ip address 10.10.3.1 24
    [*HUAWEI-GigabitEthernet1/0/0.3] qos-profile test inbound pe-vid 3 ce-vid 1 to 100 group group1
    [*HUAWEI-GigabitEthernet1/0/0.3] commit
    [~HUAWEI-GigabitEthernet1/0/0.3] quit

    After the preceding configuration, you can run the display qos-profile configuration qos-profile-name and display qos-profile application profile-name commands to view the configurations of the QoS profile and its applications.

    <HUAWEI> display qos-profile configuration test
    <HUAWEI> display qos-profile configuration test
    qos-profile: test 
    inbound: 
    outbound: 
    both: 
    user-queue cir 100000 pir 100000 flow-queue test flow-mapping test user-group-queue test service-template test 
    <HUAWEI>  display qos-profile application test
    qos-profile test: 
    GigabitEthernet1/0/0.1 
    GigabitEthernet1/0/0.2 
    GigabitEthernet1/0/0.3 
    Reference number by access user:[inbound] 0, [outbound] 0
    Reference number by VNI:[inbound] 0, [outbound] 0

    You can run the display qos-profile statistics interface gigabitethernet1/0/0.1 pe-vid 1 ce-vid 1 inbound command to view statistics about the QoS profile on GE 1/0/0.1.

    <HUAWEI> display qos-profile statistics interface gigabitethernet1/0/0.1 pe-vid 1 ce-vid 1 inbound
    GigabitEthernet1/0/0.1 inbound traffic statistics:
     [be]
      Pass:                   38,226,678 packets,              3,784,441,122 bytes
      Discard:               183,848,703 packets,             18,201,021,597 bytes
      Last 5 minutes pass rate:
                                 112,576 pps,                     89,160,656 bps
      Last 5 minutes discard rate:
                                 223,089 pps,                    176,686,608 bps
     [af1]
      Pass:                    9,940,098 packets,                984,069,702 bytes
      Discard:               721,620,432 packets,             71,440,422,768 bytes
      Last 5 minutes pass rate:
                                  11,962 pps,                      9,474,208 bps
      Last 5 minutes discard rate:
                                 323,664 pps,                    256,341,960 bps
     [af2]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [af3]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [af4]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [ef]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [cs6]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [cs7]
      Pass:                            0 packets,                          0 bytes
      Discard:                         0 packets,                          0 bytes
      Last 5 minutes pass rate:
                                       0 pps,                              0 bps
      Last 5 minutes discard rate:
                                       0 pps,                              0 bps
     [total]
      Pass:                   48,166,776 packets,              4,768,510,824 bytes
      Discard:               905,469,135 packets,             89,641,444,365 bytes
      Last 5 minutes pass rate:
                                 124,538 pps,                     98,634,864 bps
      Last 5 minutes discard rate:
                                 546,753 pps,                    433,028,568 bps   

  7. Configure a WRED object referenced by the class queue.

    # Configure the port-wred packet dropping parameters referenced by the class queue.

    <HUAWEI> system view
    [~HUAWEI] port-wred test
    [*HUAWEI-port-wred-test] color green low-limit 70 high-limit 100 discard-percentage 100
    [*HUAWEI-port-wred-test] color yellow low-limit 60 high-limit 90 discard-percentage 100
    [*HUAWEI-port-wred-test] color red low-limit 50 high-limit 80 discard-percentage 100
    [*HUAWEI-port-wred-test] commit
    [~HUAWEI-port-wred-test] return

    After the preceding configuration, you can run the display port-wred configuration verbose command to view the configurations of the class WRED object.

    <HUAWEI> display port-wred configuration verbose test
    Port wred name : test
    ---------------------------------------------------
    Color    Low-limit    High-limit    Discard-percent
    ---------------------------------------------------
    green    70           100           100
    yellow   60           90            100
    red      50           80            100
    Reference relationships : NULL  

  8. Configure a class queue.

    # Configure the scheduling algorithms, WRED parameters, and shaping values for port-queue.

    <HUAWEI> system view
    [~HUAWEI] interface gigabitethernet 2/0/0
     [~HUAWEI-GigabitEthernet2/0/0] undo shutdown
    [*HUAWEI-GigabitEthernet2/0/0] port-queue ef pq shaping 120 port-wred test outbound
    [*HUAWEI-GigabitEthernet2/0/0] commit
    [~HUAWEI-GigabitEthernet2/0/0] return

    After the preceding configuration, you can run the display port-queue configuration interface command to view the configurations of the class queue.

    <HUAWEI> display port-queue configuration interface gigabitethernet 2/0/0 outbound
    GigabitEthernet2/0/0 outbound current port-queue configuration:   
    be :  arithmetic: wfq                weight: 10         tm weight: 3           
           fact weight: 10.00             shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     af1:  arithmetic: wfq                weight: 10         tm weight: 3           
           fact weight: 10.00             shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     af2:  arithmetic: wfq                weight: 10         tm weight: 3           
           fact weight: 10.00             shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     af3:  arithmetic: wfq                weight: 15         tm weight: 2           
           fact weight: 15.00             shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     af4:  arithmetic: wfq                weight: 15         tm weight: 2           
           fact weight: 15.00             shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     ef :  arithmetic: pq                 weight: NA         tm weight: NA          
           fact weight: NA                shaping(mbps): 120                         
           port-wred: test                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     cs6:  arithmetic: pq                 weight: NA         tm weight: NA          
           fact weight: NA                shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0                      
                                                                                    
     cs7:  arithmetic: pq                 weight: NA         tm weight: NA          
           fact weight: NA                shaping(mbps): NA                         
           port-wred: NA                                                            
             green(low-high limit) (kbytes)                  0 - 0                  
             yellow(low-high limit)(kbytes)                  0 - 0                  
             red  (low-high limit) (kbytes)                  0 - 0                  
           current queue-length    (kbytes)                  0   
    

  9. Verify the configuration.

    # When there are flows on the network, you can observe that packets of User1's AF1 and EF flows and User2's EF flows are forwarded at the assured bandwidth.

    Running the display port-queue statistics command on the downstream interface GE 2/0/0 of the router, you can see that EF packets increase rapidly.

    <HUAWEI> display port-queue statistics interface gigabitethernet 2/0/0 ef outbound
    GigabitEthernet2/0/0 outbound traffic statistics:                            
    [ef]
      Current usage percentage of queue: 10  
      Total pass:
                               5,097,976 packets,                458,817,750 bytes
      Total discard:
                                       0 packets,                          0 bytes
        Drop tail discard:
                                       0 packets,                          0 bytes
        Wred discard:
                                       0 packets,                          0 bytes
      Last 30 seconds pass rate:
                                  12,030 pps,                      8,661,600 bps
      Last 30 seconds discard rate:
                                       0 pps,                              0 bps
        Drop tail discard rate:
                                       0 pps,                              0 bps
        Wred discard rate:
                                       0 pps,                              0 bps    
      buffer size:                    10 kbytes
      used buffer size:                0 kbytes
      Peak rate:                                                                    
                              2013-11-17 13:15:18                          8,661,600 bps 

Configuration Files

  • Configuration file of the router.

    #
     sysname HUAWEI
    #
    flow-wred test
     color green low-limit 70 high-limit 100 discard-percentage 100
     color yellow low-limit 60 high-limit 90 discard-percentage 100
     color red low-limit 50 high-limit 80 discard-percentage 100
    #
    flow-mapping test
     map flow-queue af1 to port-queue ef
    #
    flow-queue test
     queue af1 lpq shaping 10000 flow-wred test
     queue ef pq shaping 30000 flow-wred test
    #
    user-group-queue test
     shaping 500000 inbound
    #
    service-template test
     network-header-length 12 inbound
    #
    qos-profile test
     user-queue cir 100000 pir 100000 flow-queue test flow-mapping test user-group-queue test service-template test  
    #
    port-wred test
     color green low-limit 70 high-limit 100 discard-percentage 100
     color yellow low-limit 60 high-limit 90 discard-percentage 100
     color red low-limit 50 high-limit 80 discard-percentage 100
    #
    interface GigabitEthernet1/0/0.1  
     encapsulation qinq-termination
     qinq termination pe-vid 1 ce-vid 1 to 100 
     ip address 10.10.1.1 255.255.255.0
     qos-profile test inbound pe-vid 1 ce-vid 1 to 100 group group1
    #
    interface GigabitEthernet1/0/0.2 
     encapsulation qinq-termination
     qinq termination pe-vid 2 ce-vid 1 to 100 
     ip address 10.10.2.1 255.255.255.0
     qos-profile test inbound pe-vid 2 ce-vid 1 to 100 group group1
    #
    interface GigabitEthernet1/0/0.3 
     encapsulation qinq-termination
     qinq termination pe-vid 3 ce-vid 1 to 100 
     ip address 10.10.3.1 255.255.255.0
     qos-profile test inbound pe-vid 3 ce-vid 1 to 100 group group1
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
     port-queue ef pq shaping 120 port-wred test outbound
    #
    ospf 10
     area 0.0.0.0
     network 10.20.1.0 0.0.0.255
     network 10.10.1.0 0.0.0.255
     network 10.10.2.0 0.0.0.255
     network 10.10.3.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055024

Views: 25981

Downloads: 117

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next