No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - QoS 01

This is NE40E V800R010C10SPC500 Configuration Guide - QoS

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Priority Mappings Based on Simple Traffic Classification (MPLS)

Example for Configuring Priority Mappings Based on Simple Traffic Classification (MPLS)

This part describes how to configure simple traffic classification in the context of priority mappings for MPLS packets.

Networking Requirements

MPLS neighbor relationships are established between Device A, Device B, and Device C. When IP packets reach Device A, Device A adds MPLS header to these IP packets before transmitting them to Device C. When these MPLS packets reach Device C, Device C removes their MPLS headers and forwards them as IP packets.

In this manner, the DSCP value of the IP traffic can be changed to the EXP value of MPLS traffic on Device A, and the EXP value of MPLS traffic can be changed to the DSCP value of the IP traffic on Device C.

NOTE:

Interfaces 1 through 2 in this example are GE 1/0/0, GE 2/0/0, respectively.

Figure 5-11 Networking diagram

NOTE:
  • In this configuration example, it is assumed that the three routers have been configured so that Device A forwards IP traffic as MPLS traffic to Device C, and Device forwards MPLS traffic as IP traffic.

  • This example lists only the commands related to QoS.

Configuration Notes

During the configuration, pay attention to the following:

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. On the inbound interface GigabitEthernet 1/0/0 of Device A, configure the mapping from the IP DSCP field to the MPLS EXP field and enable simple traffic classification.

  2. On the inbound interface GigabitEthernet 1/0/0 of Device C, configure the mapping from the MPLS EXP field to the IP DSCP field and enable simple traffic classification.

Data Preparation

To complete the configuration, you need the following data:

MPLS EXP values, the internal service classes and colors of the packets on the router, and the DSCP values of IP packets to be mapped

Procedure

  1. Configure basic MPLS functions and routes (detail omitted here).

    For detailed configuration, refer to the Chapter "Basic MPLS Configuration" in the HUAWEI NetEngine40E Universal Service Router Configuration Guide - MPLS.

  2. Configure the mapping between DSCP field and EXP field at GigabitEthernet1/0/0 on Device A.

    <routerA> system-view
    [~routerA] diffserv domain default
    [*routerA-dsdomain-default] ip-dscp-inbound 18 phb af4 green
    [*routerA-dsdomain-default] mpls-exp-outbound af4 green map 5
    [*routerA-dsdomain-default] commit
    [~routerA-dsdomain-default] quit
    [~routerA] interface GigabitEthernet 1/0/0
    [~routerA-GigabitEthernet1/0/0] undo shutdown
    [*routerA-GigabitEthernet1/0/0] trust upstream default
    [*routerA-GigabitEthernet1/0/0] commit
    [~routerA-GigabitEthernet1/0/0] quit
    [~routerA] interface GigabitEthernet 2/0/0
    [~routerA-GigabitEthernet2/0/0] undo shutdown
    [*routerA-GigabitEthernet2/0/0] trust upstream default
    [*routerA-GigabitEthernet2/0/0] commit
    [~routerA-GigabitEthernet2/0/0] quit

    In the preceding configuration, AF2 green packets (DSCP value being 18) are mapped to the internal service level of AF4 of the router on the inbound interface of Device A. On the outbound interface, the internal service level of AF4 of the router is mapped to the EF service level (MPLS priority 5) of the MPLS service. In this manner, the traffic that enters Device A leaves as EF traffic.

  3. Configure the mapping from the MPLS EXP field to the IP DSCP field on GigabitEthernet 1/0/0 of Device C.

    <routerC> system-view
    [~routerC] diffserv domain default
    [*routerC-dsdomain-default] mpls-exp-inbound 5 phb af3 green
    [*routerC-dsdomain-default] ip-dscp-outbound af3 green map 32
    [*routerC-dsdomain-default] commit
    [~routerC-dsdomain-default] quit
    [~routerC] interface GigabitEthernet 1/0/0
    [~routerC-GigabitEthernet1/0/0] undo shutdown
    [*routerC-GigabitEthernet1/0/0] trust upstream default
    [*routerC-GigabitEthernet1/0/0] commit
    [~routerC-GigabitEthernet1/0/0] quit
    [~routerC] interface GigabitEthernet 2/0/0
    [~routerC-GigabitEthernet2/0/0] undo shutdown
    [*routerC-GigabitEthernet2/0/0] trust upstream default
    [*routerC-GigabitEthernet2/0/0] commit
    [~routerC-GigabitEthernet2/0/0] quit

    In the preceding configuration, the MPLS priority 5 is mapped to the internal service level of AF3 (green packets) of the router on the inbound interface of Device C. On the outbound interface, the internal service level of AF3 (green packets) of the router is mapped to the DSCP value of 32. In this manner, the traffic that enters Device C leaves as AF4 traffic.

  4. Verify the configuration.

    After the preceding configurations, if traffic is sent from GigabitEthernet 1/0/0 on Device A at 100 Mbit/s with the DSCP value being 18, Device C forwards the traffic at 100 Mbit/s with the DSCP value being 32.

Configuration Files

  • Configuration file of Device A

    #
     sysname routerA
    #
    diffserv domain default
      ip-dscp-inbound 18 phb af4 green 
      mpls-exp-outbound af4 green map 5
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 2.2.2.1 255.255.255.0
     trust upstream default
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 3.3.3.1 255.255.255.0
     trust upstream default
    #
    return
  • Configuration file of Device C

    #
     sysname routerC
    #
    diffserv domain default
      ip-dscp-outbound af3 green map 32
      mpls-exp-inbound 5 phb af3 green 
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 4.4.4.1 255.255.255.0
     trust upstream default
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 5.5.5.1 255.255.255.0
     trust upstream default
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055024

Views: 30982

Downloads: 146

Average rating:
This Document Applies to these Products

Related Version

Related Documents

Share
Previous Next