No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - User Access 01

This is NE40E V800R010C10SPC500 Configuration Guide - User Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 Dual-Device Hot Backup

Example for Configuring IPv6 Dual-Device Hot Backup

This section provides an example for configuring IPv6 dual-device hot backup. The example provides the networking requirements, configuration roadmap, configuration procedure, and configuration files.

Networking Requirements

Due to IPv4 address depletion, carriers deploy IPv6. To help services with IPv4 hot backup be smoothly evolved to IPv6 and to support IPv4 and IPv6 protection, IPv6 dual-device hot backup must be deployed.

Figure 11-5 IPv6 dual-device hot backup
NOTE:

Interface 1 and interface 2 in this example are GE 2/0/0, GE 2/0/1, respectively.



Device Name Interface Name IP Address
BRAS1 GE2/0/1.1 10.1.1.1/24 (on a VRRP-enabled interface)
GE 2/0/1.333 From which users get online
Loopback1 10.1.2.1/32 (on the RBS interface of BRAS1)
BRAS2 GE 2/0/1.1 10.1.1.2/24 (on a VRRP-enabled interface)
GE 2/0/1.332 From which users get online
Loopback1 10.1.2.2/32 (on the RBS interface of BRAS2)

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure routes to implement IP connectivity between devices and PBR on both BRASs. For details, see HUAWEI NetEngine40E Universal Service Router Configuration Guide - IP Routing.

  2. Configure basic user access functions and ensure that the two devices have the same configuration. For details, see HUAWEI NetEngine40E Universal Service Router Configuration Guide - User Access.

  3. Establish a multi-device backup platform. Configure an RBS on the network side of the master and backup BRASs (BRAS1 and BRAS2). BRAS1 is the master router and BRAS2 is the backup router.

  4. Configure a VRRP backup group on the access side of two routers (BRAS1 and BRAS2) to determine the master and backup status. Create a BFD session, and configure the VRRP backup group to track the BFD session.
  5. Configure an RBP for backing up BRAS user information and multicast services.

  6. Bind an RBP to an interface from which users get online.

NOTE:

The configuration on BRAS2 is similar to the configuration on BRAS1. The configuration procedure on BRAS1 is used in this example. For details about configurations on BRAS2, see the Configuration Files.

Data Preparation

To complete the configuration, you need the following data:

  • VRRP parameters, such as a VRID and a preemption delay

  • BFD parameters, such as the local and remote discriminators and expected minimum interval at which BFD Control packets are sent and received

  • IP address of each interface on BRAS1 and BRAS2

  • Backup ID, which works together with an RBS to identify an RBP to which users belong

  • User access parameters

Procedure

  1. Configure user access functions.

    For configuration procedure, see configuration in HUAWEI NetEngine40E Universal Service Router Configuration Guide - User Access.

  2. Configure a VRRP backup group on the access side of two routers (BRAS1 and BRAS2) to determine the master and backup status. Create a BFD session and configure the VRRP backup group to track the BFD session.

    # Configure a BFD session on the access side to rapidly detect faults in interfaces or links and trigger a master/backup VRRP switchover.

    [~BRAS1] bfd
    [*BRAS1] quit
    [*BRAS1] bfd bfd1 bind peer-ip 10.1.1.2
    [*BRAS1-bfd-session-bfd1] discriminator local 8
    [*BRAS1-bfd-session-bfd1] discriminator remote 6
    [*BRAS1-bfd-session-bfd1] commit
    [~BRAS1-bfd-session-bfd1] quit

    # Create a VRRP backup group on GE 3/1/10.1, and configure the VRRP backup group to track the BFD session and a network-side interface.

    [~BRAS1] interface GigabitEthernet 2/0/1.1               
    [*BRAS1-GigabitEthernet2/0/1.1] vlan-type dot1q 200                           
    [*BRAS1-GigabitEthernet2/0/1.1] ip address 10.1.1.1 255.255.255.0            
    [*BRAS1-GigabitEthernet2/0/1.1] vrrp vrid 1 virtual-ip 10.1.1.100            
    [*BRAS1-GigabitEthernet2/0/1.1] admin-vrrp vrid 1                             
    [*BRAS1-GigabitEthernet2/0/1.1] vrrp vrid 1 priority 180                      
    [*BRAS1-GigabitEthernet2/0/1.1] vrrp vrid 1 preempt-mode timer delay 60                                                        
    [*BRAS1-GigabitEthernet2/0/1.1] vrrp vrid 1 track interface GigabitEthernet 2/0/0 reduced 50                    
    [*BRAS1-GigabitEthernet2/0/1.1] vrrp vrid 1 track bfd-session 8 peer
    [*BRAS1-GigabitEthernet2/0/1.1] commit
    [~BRAS1-GigabitEthernet2/0/1.1] quit

  3. Configure an RBS and an RBP.

    [~BRAS1] interface loopback1
    [*BRAS1-loopback1] ip address 10.1.2.1 32
    [*BRAS1-loopback1] commit
    [~BRAS1-loopback1] quit

    # Configure an RBS.

    [~BRAS1] remote-backup-service rui
    [*BRAS1-rm-backup-srv-rui] peer 10.1.2.2 source 10.1.2.1 port 6001
    [*BRAS1-rm-backup-srv-rui] track interface GigabitEthernet2/0/0
    [*BRAS1-rm-backup-srv-rui] commit
    [~BRAS1-rm-backup-srv-rui] quit

    # Configure an RBP.

    [~BRAS1] remote-backup-profile p1
    [*BRAS1-rm-backup-prf-p1] service-type bras
    [*BRAS1-rm-backup-prf-p1] backup-id 101 remote-backup-service rui
    [*BRAS1-rm-backup-prf-p1] peer-backup hot
    [*BRAS1-rm-backup-prf-p1] vrrp-id 1 interface gigabitethernet 2/0/1.1
    [*BRAS1-rm-backup-prf-p1] commit
    [~BRAS1-rm-backup-prf-p1] quit

    # Bind the RBP to the interface from which users get online.

    [~BRAS1] interface gigabitethernet 2/0/1.333
    [*BRAS1-GigabitEthernet2/0/1.333] remote-backup-profile p1
    [*BRAS1-GigabitEthernet2/0/1.333] commit
    [~BRAS1-GigabitEthernet2/0/1.333] quit

  4. Create a protection channel between the master and backup BRASs.

    [~BRAS1] remote-backup-service rui
    [*BRAS1-rm-backup-srv-rui] protect lsp-tunnel for-all-instance peer-ip 10.1.2.2
    [*BRAS1-rm-backup-srv-rui] commit
    [~BRAS1-rm-backup-srv-rui] quit

  5. Verify the configuration.

    After completing the configurations, run the display remote-backup-profile command on a device to view the master and backup VRRP status. BRAS1 is in the Master state, and BRAS2 is in the Backup state.

    <BRAS1> display remote-backup-profile p1
     -----------------------------------------------
     Profile-Index : 0x1000
     Profile-Name : p1
     Service: bras
     Remote-backup-service : rui
     Backup-ID    : 101
     track protocol : VRRP
     VRRP-ID: 1
     VRRP-Interface : Gigabitethernet 2/0/1.1
     Access-conctrol: --
     State : Master
     Peer State    : Slave
     Interface: 
               GigabitEthernet2/0/1.333
     Backup mode : hot
     Slot-Number  : 3
     Card-Number  : 1
     Port-Number  : 10
     Traffic threshold : 50(MB)
     Traffic interval : 10(minutes)  
    <BRAS2> display remote-backup-profile p2
     -----------------------------------------------
     Profile-Index : 0x1001
     Profile-Name : p2
     Service: bras
     Remote-backup-service : rui
     Backup-ID    : 101
     track protocol : VRRP
     VRRP-ID: 1
     VRRP-Interface : Gigabitethernet 2/0/1.1
     Access-conctrol: --
     State : Slave
     Peer State    : Master
     Interface: 
               GigabitEthernet2/0/1.332
     Backup mode : hot
     Slot-Number  : 1
     Card-Number  : 0
     Port-Number  : 10
     Traffic threshold : 50(MB)
     Traffic interval : 10(minutes)  

Configuration Files

  • BRAS1 configuration file

    #
    sysname BRAS1
    #
    ipv6
    #
    bfd
    #
    mpls
    #
    mpls ldp
    #
    ipv6 prefix prefix1 local
     prefix 2013::/64
    #
    ipv6 pool pool1 bas local
     prefix prefix1
    #
    aaa
     domain huawei   
      authentication-scheme default0                    
      accounting-scheme default0                  
      ipv6-pool pool1
    #
    remote-backup-service rui                      
     peer 10.1.2.2 source 10.1.2.1 port 6001       
     protect lsp-tunnel for-all-instance peer-ip 10.1.2.2   
     track interface GigabitEthernet2/0/0          
     ipv6-pool pool1
    #
    remote-backup-profile p1                       
     service-type bras         
     backup-id 101 remote-backup-service rui                   
     peer-backup hot                    
     vrrp-id 1 interface GigabitEthernet2/0/1.1
    #
    interface GigabitEthernet2/0/1.1              
     vlan-type dot1q 1                             
     ip address 10.1.1.1 255.255.255.0            
     vrrp vrid 1 virtual-ip 10.1.1.100            
     admin-vrrp vrid 1                             
     vrrp vrid 1 priority 180                      
     vrrp vrid 1 preempt-mode timer delay 60       
     vrrp vrid 1 track interface GigabitEthernet2/0/0 reduced 50                    
     vrrp vrid 1 track bfd-session session-name bfd1 peer
    #
    interface GigabitEthernet2/0/1.333            
     ipv6 enable  
     ipv6 address auto link-local                  
     ipv6 nd autoconfig managed-address-flag       
     ipv6 nd autoconfig other-flag                           
     user-vlan 2   
     remote-backup-profile p1                       
     bas          
      access-type layer2-subscriber default-domain authentication huawei   
      authentication-method-ipv6 bind
    #
    interface LoopBack1
     ip address 10.1.2.1 255.255.255.255
    #
    bfd bfd1 bind peer-ip 10.1.1.2
     discriminator local 8
     discriminator remote 6
     commit 
    #
    ospf 1        
     import-route direct                           
     area 0.0.0.0 
     network 10.1.2.1 0.0.0.0
    #
     return 
  • BRAS2 configuration file

    #
    sysname BRAS2
    #
    ipv6
    #
    bfd
    #
    mpls
    #
    mpls ldp
    #
    ipv6 prefix prefix1 local
     prefix 2013::/64
    #
    ipv6 pool pool1 bas local
     prefix prefix1
    #
    aaa
     domain huawei   
      authentication-scheme default0                    
      accounting-scheme default0                  
      ipv6-pool pool1
    #
    remote-backup-service rui
     peer 10.1.2.1 source 10.1.2.2 port 6001
     protect lsp-tunnel for-all-instance peer-ip 10.1.2.1
     track interface GigabitEthernet2/0/0
    #
    remote-backup-profile p2
     service-type bras
     backup-id 101 remote-backup-service rui
     peer-backup hot
     vrrp-id 1 interface GigabitEthernet2/0/1.1
    #
    interface GigabitEthernet2/0/1.1              
     vlan-type dot1q 1                             
     ip address 10.1.1.2 255.255.255.0           
     vrrp vrid 1 virtual-ip 10.1.1.100            
     admin-vrrp vrid 1                             
     vrrp vrid 1 priority 150                      
     vrrp vrid 1 track interface GigabitEthernet2/0/0 reduced 50                    
     vrrp vrid 1 track bfd-session session-name bfd1 peer
    #
    interface GigabitEthernet 2/0/1.332          
     ipv6 enable  
     ipv6 address auto link-local                  
     ipv6 nd autoconfig managed-address-flag       
     ipv6 nd autoconfig other-flag                            
     user-vlan 2   
     remote-backup-profile p2                      
     bas          
      access-type layer2-subscriber default-domain authentication huawei
      authentication-method-ipv6 bind
    #
    interface LoopBack1
     ip address 10.1.2.2 255.255.255.255
    #
    bfd bfd2 bind peer-ip 10.1.2.1                
     discriminator local 6                         
     discriminator remote 8                        
     commit 
    #
    ospf 1
     import-route direct
     area 0.0.0.0
     network 10.1.2.2 0.0.0.0
    #
    return 
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055031

Views: 19447

Downloads: 89

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next