No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C10SPC500 Configuration Guide - User Access 01

This is NE40E V800R010C10SPC500 Configuration Guide - User Access
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Address Assignment Based on the Remote Address Pool

Example for Configuring Address Assignment Based on the Remote Address Pool

This section provides an example for assigning IPv4 addresses from a remote IP address pool, including the networking requirements, configuration roadmap, configuration procedure, and configuration files.

Networking Requirements

As shown in Figure 4-5, it is required that a remote address pool be configured to assign IP addresses to access users and the following requirements be met:

  • The remote address pool is used to assign IP addresses to users in the domain isp2.

  • The router, functioning as a relay agent, is connected to the DHCPv4 server through GE 3/0/0 whose IP address is 10.1.1.2/24.

  • The IP address of the DHCPv4 server bound to the remote address pool is 10.1.1.1, and no standby DHCPv4 server is deployed.

  • Non-authentication and non-accounting are adopted by the user.

Figure 4-5 Networking diagram for address assignment based on the remote address pool
NOTE:

Interfaces 1 through 3 in this example are 1/0/0.1,2/0/0,3/0/0 respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Create a DHCPv4 server group and a remote address pool, and bind the address pool to the DHCPv4 server group.

  2. Configure the domain isp2 to which the user belongs, including the authentication mode and the accounting mode.

  3. Configure the BAS interface, including the user access mode.

Data Preparation

To complete the configuration, you need the following data:

  • Name of the address pool

  • IP address of the gateway

  • Name of the user domain

  • IP address of the interface that connects the router to the DHCPv4 server

  • User access mode

Procedure

  1. Configure the router.

    # Create a DHCPv4 server group.

    <HUAWEI> system-view
    [~HUAWEI] dhcp-server group group1
    [*HUAWEI-dhcp-server-group-group1] dhcp-server 10.1.1.1
    [*HUAWEI-dhcp-server-group-group1] commit
    [~HUAWEI-dhcp-server-group-group1] quit

    # Create a remote address pool, and bind the pool to the DHCPv4 server group.

    [~HUAWEI] ip pool pool2 bas remote
    [*HUAWEI-ip-pool-pool2] gateway 10.10.10.1 24
    [*HUAWEI-ip-pool-pool2] dhcp-server group group1
    [*HUAWEI-ip-pool-pool2] commit
    [~HUAWEI] quit

    # Configure a domain named isp2.

    [~HUAWEI] aaa
    [*HUAWEI-aaa] domain isp2
    [*HUAWEI-aaa-domain-isp2] authentication-scheme default0
    [*HUAWEI-aaa-domain-isp2] accounting-scheme default0
    [*HUAWEI-aaa-domain-isp2] ip-pool pool2
    [*HUAWEI-aaa-domain-isp2] commit
    [~HUAWEI-aaa-domain-isp2] quit
    [~HUAWEI-aaa] quit

    # Configure the router interface for user access.

    [~HUAWEI] interface GigabitEthernet 1/0/0.1
    [*HUAWEI-GigabitEthernet1/0/0.1] user-vlan 1
    [*HUAWEI-GigabitEthernet1/0/0.1-vlan-1-1] bas
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] access-type layer2-subscriber
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] authentication-method bind
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] default-domain authentication isp2
    [*HUAWEI-GigabitEthernet1/0/0.1-bas] commit
    [~HUAWEI-GigabitEthernet1/0/0.1-bas] quit
    [~HUAWEI-GigabitEthernet1/0/0.1] quit

    # Configure the router interface to connect to the DHCPv4 server.

    [~HUAWEI] interface GigabitEthernet 3/0/0
    [*HUAWEI-GigabitEthernet3/0/0] ip address 10.1.1.2 255.255.255.0
    [*HUAWEI-GigabitEthernet3/0/0] commit
    [~HUAWEI-GigabitEthernet3/0/0] quit

  2. Verify the configuration.

    # Check the configurations of the DHCPv4 server group group1.

    [~HUAWEI] display dhcp-server group group1
      Group-Name          : group1
      Release-Agent       : Support
      Primary-Server      : 10.1.1.1
        Vpn instance      : --
      Weight              : 0
      Status              : up
      Secondary-Server    : --
        Vpn instance      : --
      Weight              : 0
      Status              : up
      Algorithm           : master-backup
      Source              : --
      Giaddr              : --

    # Check the configurations of the remote address pool pool2.

    [~HUAWEI] display ip pool name pool2
      Pool-Name      : pool2
      Pool-No        : 0 
      Pool-constant-index :- 
      DHCP-Group     : group1
      Position       : Remote          Status           : Unlocked
      Gateway        : 10.10.10.1      Mask             : 255.255.255.0
      Vpn instance   : --
      Profile-Name   : -               Server-Name      : -
      Codes: CFLCT (conflicted)
    
      ---------------------------------------------------------------------------------------
      ID           start             end total  used  idle CFLCT disable reserved static-bind
      ---------------------------------------------------------------------------------------
       0      10.10.10.0    10.10.10.255   256     0   256     0       0        0           0
      ---------------------------------------------------------------------------------------

    # Check the configurations of the domain isp2.

    [~HUAWEI] display domain isp2
     ------------------------------------------------------------------------------
      Domain-name                     : isp2
      Domain-state                    : Active
      Authentication-scheme-name      : default0
      Accounting-scheme-name          : default0
      Authorization-scheme-name       :
      Primary-DNS-IP-address          : -
      Second-DNS-IP-address           : -
      Primary-NBNS-IP-address         : -
      Second-NBNS-IP-address          : -
      User-group-name                 : -
      Idle-data-attribute (time,flow) : 0, 60
      Install-BOD-Count               : 0
      Report-VSM-User-Count           : 0
      Value-added-service             : COPS
      User-access-limit               : 279552
      Online-number                   : 0
      Web-IP-address                  : -
      Web-URL                         : -
      Portal-server-IP                : -
      Portal-URL                      : -
      Portal-force-times              : 2
      PPPoE-user-URL                  : Disable
      IPUser-ReAuth-Time(second)      : 300
      Ancp auto qos adapt             : Disable
      RADIUS-server-template          : -
      Two-acct-template               : -
      HWTACACS-server-template        : -
      Bill Flow                       : Disable
      Tunnel-acct-2867                : Disabled
    
      Flow Statistic:
      Flow-Statistic-Up               : Yes
      Flow-Statistic-Down             : Yes
      Source-IP-route                 : Disable
      IP-warning-threshold            : -
      Multicast Forwarding            : Yes
      Multicast Virtual               : No
      Max-multilist num               : 4
      Multicast-profile               : -
      IP-address-pool-name            : pool2
      Quota-out                     : Offline
      ------------------------------------------------------------------------------
    

Configuration Files

  • Configuration file of router

    #
     sysname HUAWEI
    
    #
    dhcp-server group group1
     dhcp-server 10.1.1.1
    #
    ip pool pool2 bas remote
     gateway 10.10.10.1 255.255.255.0
     dhcp-server group group1
    #
    aaa
     authentication-scheme default0
     #
     accounting-scheme default0
     #
    domain isp2
     authentication-scheme default0
     accounting-scheme default0
     ip-pool pool2
     #
    interface GigabitEthernet1/0/0.1
     undo shutdown
     user-vlan 1
     bas
     #
      access-type layer2-subscriber default-domain authentication
     isp2
      authentication-method bind
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055031

Views: 17100

Downloads: 69

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next