No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S V800R010C10SPC500 Configuration Guide - MPLS 01

This is NE20E-S V800R010C10SPC500 Configuration Guide - MPLS
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Establishing a Static MPLS TE Tunnel

Example for Establishing a Static MPLS TE Tunnel

This section provides an example for configuring a static MPLS TE tunnel, which involves enabling MPLS TE, configuring the MPLS TE bandwidth, setting up an MPLS TE tunnel, and setting up a static CR-LSP.

Networking Requirements

On the carrier network shown in Figure 3-20, some devices have low routing and processing performance. The carrier hopes to use an MPLS TE tunnel to transmit services. To meet this requirement, two static TE tunnels between LSRA and LSRC can be established to transmit traffic in opposite directions. A static TE tunnel is manually established, without using a dynamic signaling protocol or IGP routes, which consumes a few device resources and has low requirement on device performance.

Figure 3-20 Networking diagram for static CR-LSP configuration
NOTE:

Interfaces 1 through 2 in this example are GE 0/1/0, GE 0/2/0, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface on each LSR, configure a loopback address as an MPLS LSR ID, and configure OSPF to advertise the route to the network segment connecting to each interface and LSR ID.

  2. Configure the LSR ID and globally enable MPLS and MPLS TE on each node and interface.

  3. Configure the maximum reservable bandwidth and BC0 bandwidth for the link on each outgoing interface of each LSR along the tunnel. (The tunnel obtains bandwidth from BC0).
  4. Create a tunnel interface on the ingress and specify the IP address of the tunnel, tunnel protocol, destination address, tunnel ID, and the signaling protocol used to establish the tunnel.

  5. Configure a static CR-LSP associated with the tunnel and specify the following parameters on each type of node:
    • Ingress: outgoing label and next-hop address
    • Transit node: inbound interface name, next-hop address, and outgoing label
    • Egress: incoming label and inbound interface name
NOTE:
  • The outgoing label of each node is the incoming label of the next node.

  • When running the static-cr-lsp ingress { tunnel-interface tunnel interface-number | tunnel-name } destination destination-address { nexthop next-hop-address | outgoing-interface interface-type interface-number } * out-label out-label [ bandwidth [ ct0 ] bandwidth ] command to configure the ingress of a CR-LSP, note that tunnel-name must be the same as the tunnel name created using the interface tunnel interface -number command. tunnel-name is a case-sensitive character string with no spaces. For example, the name of the tunnel created by using the interface Tunnel 20 command is Tunnel20. In this case, the parameter of the static CR-LSP on the ingress is Tunnel20. This restriction does not apply to transit nodes or egresses.

Data Preparation

To complete the configuration, you need the following data:

  • OSPF process ID and area ID of each LSR

  • Tunnel interface names, tunnel interface IP addresses, destination addresses, tunnel IDs, and tunnel signaling protocol (CR-Static) on LSRA and LSRC

  • The maximum reservable bandwidth and BC bandwidth for links
  • Next-hop address and outgoing label of the ingress on the static CR-LSP

  • Inbound interface name, next-hop address, and outgoing label of the transit node on the static CR-LSP

  • Inbound interface name of the egress on the static CR-LSP

Procedure

  1. Assign the IP address to each interface and configure a routing protocol.

    # Assign the IP address to each interface and configure the routing protocol using the information in Figure 3-20 to implement reachability between LSRs.

    For configuration details, see Configuration Files in this section.

  2. Configure the basic MPLS functions and enable MPLS TE.

    # Configure LSRA.

    [~LSRA] mpls lsr-id 1.1.1.1
    [*LSRA] mpls
    [*LSRA-mpls] mpls te
    [*LSRA-mpls] quit
    [*LSRA] interface gigabitethernet 0/1/0
    [*LSRA-GigabitEthernet0/1/0] mpls
    [*LSRA-GigabitEthernet0/1/0] mpls te
    [*LSRA-GigabitEthernet0/1/0] commit
    [~LSRA-GigabitEthernet0/1/0] quit

    Repeat this step for LSRB and LSRC. For configuration details, see Configuration Files in this section.

  3. Configure MPLS-TE bandwidth attributes for links.

    # Configure the maximum reservable link bandwidth and BC0 bandwidth on each outbound interface of each LSR along the tunnel. The BC0 bandwidth for links must be greater than the tunnel bandwidth (10 Mbit/s).

    # Configure LSRA.

    [~LSRA] interface gigabitethernet 0/1/0
    [~LSRA-GigabitEthernet0/1/0] mpls te bandwidth max-reservable-bandwidth 100000
    [*LSRA-GigabitEthernet0/1/0] mpls te bandwidth bc0 100000
    [*LSRA-GigabitEthernet0/1/0] commit
    [~LSRA-GigabitEthernet0/1/0] quit

    # Configure LSRB.

    [~LSRB] interface gigabitethernet 0/1/0
    [~LSRB-GigabitEthernet0/1/0] mpls te bandwidth max-reservable-bandwidth 100000
    [*LSRB-GigabitEthernet0/1/0] mpls te bandwidth bc0 100000
    [*LSRB-GigabitEthernet0/1/0] quit
    [*LSRB] interface gigabitethernet 0/2/0
    [*LSRB-GigabitEthernet0/2/0] mpls te bandwidth max-reservable-bandwidth 100000
    [*LSRB-GigabitEthernet0/2/0] mpls te bandwidth bc0 100000
    [*LSRB-GigabitEthernet0/2/0] commit
    [~LSRB-GigabitEthernet0/2/0] quit

    # Configure LSRC.

    [~LSRC] interface gigabitethernet 0/2/0
    [~LSRC-GigabitEthernet0/2/0] mpls te bandwidth max-reservable-bandwidth 100000
    [*LSRC-GigabitEthernet0/2/0] mpls te bandwidth bc0 100000
    [*LSRC-GigabitEthernet0/2/0] commit
    [~LSRC-GigabitEthernet0/2/0] quit

  4. Configure an MPLS TE tunnel.

    # Create the MPLS TE tunnel from LSRA to LSRC on LSRA.

    [~LSRA] interface Tunnel 10
    [*LSRA-Tunnel10] ip address unnumbered interface loopback 1
    [*LSRA-Tunnel10] tunnel-protocol mpls te
    [*LSRA-Tunnel10] destination 3.3.3.3
    [*LSRA-Tunnel10] mpls te tunnel-id 100
    [*LSRA-Tunnel10] mpls te signal-protocol cr-static
    [*LSRA-Tunnel10] commit
    [~LSRA-Tunnel10] quit

    # Create the MPLS TE tunnel from LSRC to LSRA on LSRC.

    [~LSRC] interface Tunnel 20
    [*LSRC-Tunnel20] ip address unnumbered interface loopback 1
    [*LSRC-Tunnel20] tunnel-protocol mpls te
    [*LSRC-Tunnel20] destination 1.1.1.1
    [*LSRC-Tunnel20] mpls te tunnel-id 200
    [*LSRC-Tunnel20] mpls te signal-protocol cr-static
    [*LSRC-Tunnel20] commit
    [~LSRC-Tunnel20] quit

  5. Create a static CR-LSP from LSRA to LSRC.

    # Configure LSRA as the ingress of the static CR-LSP.

    [~LSRA] static-cr-lsp ingress tunnel-interface Tunnel 10 destination 3.3.3.3 nexthop 2.1.1.2 out-label 20 bandwidth ct0 10000
    [*LSRA] commit

    # Configure LSRB as the transit node of the static CR-LSP.

    [~LSRB] static-cr-lsp transit Tunnel10 incoming-interface gigabitethernet 0/1/0 in-label 20 nexthop 3.2.1.2 out-label 30 bandwidth ct0 10000
    [*LSRB] commit

    # Configure LSRC as the egress of the static CR-LSP.

    [~LSRC] static-cr-lsp egress Tunnel10 incoming-interface gigabitethernet 0/2/0 in-label 30
    [*LSRC] commit

  6. Create a static CR-LSP from LSRC to LSRA.

    # Configure LSRC as the ingress of the static CR-LSP.

    [~LSRC] static-cr-lsp ingress tunnel-interface Tunnel 20 destination 1.1.1.1 nexthop 3.2.1.1 out-label 120 bandwidth ct0 10000
    [*LSRC] commit

    # Configure LSRB as the transit node of the static CR-LSP.

    [~LSRB] static-cr-lsp transit Tunnel20 incoming-interface gigabitethernet 0/2/0 in-label 120 nexthop 2.1.1.1 out-label 130 bandwidth ct0 10000
    [*LSRB] commit

    # Configure LSRA as the egress of the static CR-LSP.

    [~LSRA] static-cr-lsp egress Tunnel20 incoming-interface gigabitethernet 0/1/0 in-label 130
    [*LSRA] commit

  7. Verify the configuration.

    After completing the configuration, run the display interface tunnel command on LSRA. The command output shows that the status of the tunnel interface is Up.

    Run the display mpls te tunnel command on each LSR to view the establishment status of the MPLS TE tunnel.

    [~LSRA] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.1          3.3.3.3          1       --/20          I  Tunnel10
    -                -                -       130/--         E  Tunnel20
    [~LSRB] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    -                -                -       20/30            T  Tunnel10
    -                -                -       120/130          T  Tunnel20
    [~LSRC] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    -                -                -       30/--            E  Tunnel10       
    3.3.3.3          1.1.1.1          1       --/120           I  Tunnel20 

    Run the display mpls lsp or display mpls static-cr-lsp command on each LSR to view the establishment status of the static CR-LSP.

    # Display the configuration on LSRA.

    [~LSRA] display mpls static-cr-lsp
    TOTAL          : 2     STATIC CRLSP(S)
    UP             : 2     STATIC CRLSP(S)
    DOWN           : 0     STATIC CRLSP(S)
    Name            FEC              I/O Label  I/O If                    Status
    Tunnel10    3.3.3.3/32        NULL/20    -/GE0/1/0                 Up
    Tunnel20    -/-               130/NULL   GE0/1/0/-                 Up

    # Display the configuration on LSRB.

    [~LSRB] display mpls static-cr-lsp
    TOTAL          : 2     STATIC CRLSP(S)
    UP             : 2     STATIC CRLSP(S)
    DOWN           : 0     STATIC CRLSP(S)
    Name            FEC              I/O Label  I/O If                     Status
    Tunnel10    -/-               20/30      GE0/1/0/GE0/2/0            Up
    Tunnel20    -/-               120/130    GE0/2/0/GE0/1/0            Up

    # Display the configuration on LSRC.

    [~LSRC] display mpls static-cr-lsp
    TOTAL          : 2     STATIC CRLSP(S)
    UP             : 2     STATIC CRLSP(S)
    DOWN           : 0     STATIC CRLSP(S)
    Name            FEC                I/O Label  I/O If                    Status
    Tunnel20    1.1.1.1/32          NULL/120   -/GE0/2/0                 Up
    Tunnel10    -/-                 30/NULL    GE0/2/0/-                 Up

    When the static CR-LSP is used to establish the MPLS TE tunnel, the packets on the transit node and the egress are forwarded directly based on the specified incoming and outgoing labels. Therefore, no FEC information is displayed on LSRB or LSRC.

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
     mpls te
    #
    static-cr-lsp ingress tunnel-interface Tunnel10 destination 3.3.3.3 nexthop 2.1.1.2 out-label 20 bandwidth ct0 10000
    #
    static-cr-lsp egress Tunnel20 incoming-interface GigabitEthernet0/1/0 in-label 130
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 2.1.1.1 255.255.255.0
     mpls
     mpls te        
     mpls te bandwidth max-reservable-bandwidth 100000
     mpls te bandwidth bc0 100000
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #               
    interface Tunnel10
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.3
     mpls te signal-protocol cr-static
     mpls te tunnel-id 100
    #               
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
     mpls te
    #
    static-cr-lsp transit Tunnel10 incoming-interface GigabitEthernet0/1/0 in-label 20 nexthop 3.2.1.2 out-label 30 bandwidth ct0 10000
    #
    static-cr-lsp transit Tunnel20 incoming-interface GigabitEthernet0/2/0 in-label 120 nexthop 2.1.1.1 out-label 130 bandwidth ct0 10000
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 3.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 100000
     mpls te bandwidth bc0 100000
    #               
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 2.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 100000
     mpls te bandwidth bc0 100000
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #               
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
     mpls te
    #
    static-cr-lsp ingress tunnel-interface Tunnel20 destination 1.1.1.1 nexthop 3.2.1.1 out-label 120 bandwidth ct0 10000
    #
    static-cr-lsp egress Tunnel10 incoming-interface GigabitEthernet0/2/0 in-label 30
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 3.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 100000
     mpls te bandwidth bc0 100000
    #
    interface GigabitEthernet0/1/0
     undo shutdown
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Tunnel20
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te signal-protocol cr-static
     mpls te tunnel-id 200
    #
    return
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055103

Views: 20116

Downloads: 35

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next