No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S V800R010C10SPC500 Configuration Guide - MPLS 01

This is NE20E-S V800R010C10SPC500 Configuration Guide - MPLS
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LDP to Automatically Send DoD Requests

Example for Configuring LDP to Automatically Send DoD Requests

This example describes how to configure LDP to automatically send downstream on demand (DoD) requests for labels. The configuration procedure includes operations of enabling MPLS and MPLS LDP globally and configuring the DoD mode.

Networking Requirements

Pseudo wire emulation edge-to-edge (PWE3) refers to a technology that carries Layer 2 services on a packet switched network (PSN). PWE3 sets up a pseudo wire (PW) over a public network tunnel. To establish the public network tunnel, a remote LDP session must be created between LSRA and LSRD shown in Figure 4-18. LSRA uses the remote LDP session to automatically send DoD requests to LSRD for a Label Mapping message containing a route to the loopback address (LSR ID) of LSRD. This reduces unneeded IP and MPLS entries and efficiently uses network resources.

Figure 4-18 Networking for configuring LDP to automatically send DoD requests

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address and its mask to every interface and configure a loopback interface address as an LSR ID on every node.

  2. Configure basic IS-IS functions on backbone nodes and static routes to edge nodes and their adjacent nodes.

  3. Enable MPLS and MPLS LDP on each node and its interfaces.

  4. Configure the DoD label advertisement mode.

  5. Configure the inter-area LDP extension.

  6. Configure a remote LDP session and enable LDP to automatically send requests for labels advertised in DoD mode.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of every interface on every node shown in Figure 4-18

  • IS-IS level of each node

Procedure

  1. Assign an IP address and its mask to every interface and configure a loopback interface address as an LSR ID on every node.

    Assign an IP address and its mask to every physical interface and configure a loopback interface address as an LSR ID on every node shown in Figure 4-18. For configuration details, see Configuration Files in this section.

  2. Configure basic IS-IS functions on backbone nodes and static routes to edge nodes and their adjacent nodes.

    # Configure basic IS-IS functions on LSRB.

    <~LSRB> system-view
    [~LSRB] isis 1
    [*LSRB-isis-1] network-entity 10.0000.0000.0001.00
    [*LSRB-isis-1] quit
    [*LSRB] interface pos 1/0/1
    [*LSRB-Pos1/0/1] isis enable 1
    [*LSRB-Pos1/0/1] quit
    [*LSRB] interface loopback 0
    [*LSRB-LoopBack0] isis enable 1
    [*LSRB-LoopBack0] commit
    [~LSRB-LoopBack0] quit

    # Configure basic IS-IS functions on LSRC and import static routes.

    <~LSRC> system-view
    [~LSRC] isis 1
    [*LSRC-isis-1] network-entity 10.0000.0000.0002.00
    [*LSRC-isis-1] import-route static
    [*LSRC-isis-1] quit
    [*LSRC] interface pos 1/0/0
    [*LSRC-Pos1/0/0] isis enable 1
    [*LSRC-Pos1/0/0] quit
    [*LSRC] interface loopback 0
    [*LSRC-LoopBack0] isis enable 1
    [*LSRC-LoopBack0] commit
    [~LSRC-LoopBack0] quit

    # Configure a default route with a next-hop address of 10.1.1.2 on LSRA.

    <~LSRA> system-view
    [~LSRA] ip route-static 0.0.0.0 0.0.0.0 10.1.1.2

    # Configure LSRB with a static route to LSRA.

    <~LSRB> system-view
    [~LSRB] ip route-static 1.1.1.1 255.255.255.255 10.1.1.1

    # Configure LSRC with a static route to LSRD.

    <~LSRC> system-view
    [~LSRC] ip route-static 4.4.4.4 255.255.255.255 10.1.3.2

    # Configure a default route with a next-hop address of 10.1.3.1 on LSRD.

    <~LSRD> system-view
    [~LSRD] ip route-static 0.0.0.0 0.0.0.0 10.1.3.1

    # Run the display ip routing-table command on LSRA to view route information. The configured default route exists in the routing table of LSRA.

    [~LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
    
    Destination/Mask    Proto  Pre  Cost       Flags NextHop         Interface
    
            0.0.0.0/0   Static 60   0           RD   10.1.1.2        Pos1/0/0
            1.1.1.1/32  Direct 0    0            D   127.0.0.1       LoopBack0
           10.1.1.0/24  Direct 0    0            D   10.1.1.1        Pos1/0/0
           10.1.1.1/32  Direct 0    0            D   127.0.0.1       Pos1/0/0
           10.1.1.2/32  Direct 0    0            D   10.1.1.2        Pos1/0/0
          127.0.0.0/8   Direct 0    0            D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0            D   127.0.0.1       InLoopBack0
    

    # Run the display ip routing-table command on LSRB to view route information. The configured static route to LSRA exists in the routing table of LSRB.

    [~LSRB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 12       Routes : 12
    
    Destination/Mask    Proto    Pre  Cost       Flags NextHop         Interface
    
            1.1.1.1/32  Static   60   0           RD   10.1.1.1        Pos1/0/0
            2.2.2.2/32  Direct   0    0            D   127.0.0.1       LoopBack0
            3.3.3.3/32  ISIS-L1  15   10           D   10.1.2.2        Pos1/0/1
            4.4.4.4/32  ISIS-L1  15   74           D   10.1.2.2        Pos1/0/1
           10.1.1.0/24  Direct   0    0            D   10.1.1.2        Pos1/0/0
           10.1.1.1/32  Direct   0    0            D   10.1.1.1        Pos1/0/0
           10.1.1.2/32  Direct   0    0            D   127.0.0.1       Pos1/0/0
           10.1.2.0/24  Direct   0    0            D   10.1.2.1        Pos1/0/1
           10.1.2.1/32  Direct   0    0            D   127.0.0.1       Pos1/0/1
           10.1.2.2/32  Direct   0    0            D   10.1.2.2        Pos1/0/1
          127.0.0.0/8   Direct   0    0            D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct   0    0            D   127.0.0.1       InLoopBack0
    

  3. Enable MPLS and MPLS LDP on each node and its interfaces.

    # Configure LSRA.

    [~LSRA] mpls lsr-id 1.1.1.1
    [~LSRA] mpls
    [*LSRA-mpls] quit
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] quit
    [*LSRA] interface pos 1/0/0
    [*LSRA-Pos1/0/0] mpls
    [*LSRA-Pos1/0/0] mpls ldp
    [*LSRA-Pos1/0/0] commit
    [~LSRA-Pos1/0/0] quit

    Repeat this step for LSRB, LSRC, and LSRD. For configuration details, see Configuration Files in this section.

  4. Configure the DoD mode.

    # Configure LSRA.

    [~LSRA] interface pos 1/0/0
    [*LSRA-Pos1/0/0] mpls ldp advertisement dod
    [*LSRA-Pos1/0/0] commit
    [~LSRA-Pos1/0/0] quit

    # Configure LSRB.

    [~LSRB] interface pos 1/0/0
    [*LSRB-Pos1/0/0] mpls ldp advertisement dod
    [*LSRB-Pos1/0/0] commit
    [~LSRB-Pos1/0/0] quit

    # Configure LSRC.

    [~LSRC] interface pos 1/0/1
    [*LSRC-Pos1/0/1] mpls ldp advertisement dod
    [*LSRC-Pos1/0/1] commit
    [~LSRC-Pos1/0/1] quit

    # Configure LSRD.

    [~LSRD] interface pos 1/0/0
    [*LSRD-Pos1/0/0] mpls ldp advertisement dod
    [*LSRD-Pos1/0/0] commit
    [~LSRD-Pos1/0/0] quit

  5. Configure the inter-area LDP extension to enable the longest match rule.

    # Run the longest-match command on LSRA to enable LDP to use the longest match rule to search for routes related to an LSP to be established.

    [~LSRA] mpls ldp
    [*LSRA-mpls-ldp] longest-match
    [*LSRA-mpls-ldp] commit
    [~LSRA-mpls-ldp] quit

    # Run the longest-match command on LSRD to enable LDP to use the longest match rule to search for routes related to an LSP to be established.

    [~LSRD] mpls ldp
    [*LSRD-mpls-ldp] longest-match
    [*LSRD-mpls-ldp] commit
    [~LSRD-mpls-ldp] quit

  6. Configure a remote LDP session and enable LDP to automatically send DoD requests.

    # Configure LSRA.

    [~LSRA] mpls ldp remote-peer lsrd
    [*LSRA-mpls-ldp-remote-lsrd] remote-ip 4.4.4.4
    [*LSRA-mpls-ldp-remote-lsrd] remote-ip auto-dod-request
    [*LSRA-mpls-ldp-remote-lsrd] commit
    [~LSRA-mpls-ldp-remote-lsrd] quit

    # Configure LSRD.

    [~LSRD] mpls ldp remote-peer lsra
    [*LSRD-mpls-ldp-remote-lsra] remote-ip 1.1.1.1
    [*LSRD-mpls-ldp-remote-lsra] remote-ip auto-dod-request
    [*LSRD-mpls-ldp-remote-lsra] commit
    [~LSRD-mpls-ldp-remote-lsra] quit

  7. Verify the configuration.

    # After completing the preceding configurations, run the display ip routing-table 4.4.4.4 command to view the route to LSRD (4.4.4.4) on LSRA.

    [~LSRA] display ip routing-table 4.4.4.4
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 1
    Destination/Mask    Proto  Pre  Cost       Flags NextHop         Interface
    
            0.0.0.0/0   Static 60   0           RD   10.1.1.2        Pos1/0/0
    

    The command output shows that there is only a default route to 4.4.4.4 in the routing table.

    # Run the display mpls ldp lsp command on LSRA to view information about the established LSP.

    [~LSRA] display mpls ldp lsp
     LDP LSP Information
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop         OutInterface
     -------------------------------------------------------------------------------
     4.4.4.4/32         NULL/1026      -               10.1.1.2        Pos1/0/0
     -------------------------------------------------------------------------------
     TOTAL: 1 Normal LSP(s) Found.
     TOTAL: 0 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established
     A '*' before a Label means the USCB or DSCB is stale
     A '*' before a UpstreamPeer means the session is stale
     A '*' before a DS means the session is stale
     A '*' before a NextHop means the LSP is FRR LSP  
    

    The command output shows that an LSP destined for LSRD (4.4.4.4) has been established on LSRA. LSRA has requested for a Label mapping message containing the route to 4.4.4.4 and obtained the route, and the LSP has been successfully established.

    # Run the display tunnel-info all command on LSRA to view information about the established LSP.

    [~LSRA] display tunnel-info all
     * -> Allocated VC Token
    Tunnel ID           Type                 Destination           Token
    ----------------------------------------------------------------------
    0x1000              lsp                   4.4.4.4                0
    

    The command output shows that the LSP originated from LSRA and destined for LSRD has been established.

Configuration Files

  • LSRA configuration file

    #
     sysname LSRA
    #
     mpls lsr-id 1.1.1.1
     mpls
    #
    mpls ldp
     longest-match
    #
    #
     mpls ldp remote-peer lsrd
     remote-ip 4.4.4.4
     undo remote-ip pwe3
     remote-ip auto-dod-request
    #
    interface Pos1/0/0
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
     ip route-static 0.0.0.0 0.0.0.0 10.1.1.2
    #
    return
    
  • LSRB configuration file

    #
     sysname LSRB
    #
     mpls lsr-id 2.2.2.2
     mpls
    #
    mpls ldp
    #
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Pos1/0/0
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface Pos1/0/1
     link-protocol ppp
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
     ip route-static 1.1.1.1 255.255.255.255 10.1.1.1
    #
    return
    
  • LSRC configuration file

    #
     sysname LSRC
    #
     mpls lsr-id 3.3.3.3
     mpls
    #
    mpls ldp
    #
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     import-route static
    #
    interface Pos1/0/0
     link-protocol ppp
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Pos1/0/1
     link-protocol ppp
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
     ip route-static 4.4.4.4 255.255.255.255 10.1.3.2
    #
    return
    
  • LSRD configuration file

    #
     sysname LSRD
    #
     mpls lsr-id 4.4.4.4
     mpls
    #
    mpls ldp
     longest-match
    #
    #
     mpls ldp remote-peer lsra
     remote-ip 1.1.1.1
     undo remote-ip pwe3
     remote-ip auto-dod-request
    #
    interface Pos1/0/0
     link-protocol ppp
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
     ip route-static 0.0.0.0 0.0.0.0 10.1.3.1
    #
    return
    
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055103

Views: 19706

Downloads: 35

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next