No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S V800R010C10SPC500 Configuration Guide - Virtual Access 01

This is NE20E-S V800R010C10SPC500 Configuration Guide - Virtual Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Virtual Cluster Accesss to Carry Ethernet Services (Multiple Base Stations on the Same Network Segment)

Example for Configuring Virtual Cluster Accesss to Carry Ethernet Services (Multiple Base Stations on the Same Network Segment)

This section provides an example for configuring virtual cluster access to carry Ethernet services on an IP radio access network (RAN) when multiple base stations are located on the same network segment.

Networking Requirements

As shown in Figure 2-10, AP1 and AP2 are respectively connected to eNodeB1 and eNodeB2, and the primary and secondary masters are deployed on the access ring. Configure virtual cluster access on AP1, AP2, and the primary and secondary masters, and establish virtual paths (VPs) and virtual circuits (VCs) from AP1 and AP2 to the primary and secondary masters to carry packets from the eNodeBs. To implement end-to-end Ethernet service bearing, configure Layer 3 virtual private network (L3VPN) access over VCs on the masters.
Figure 2-10 Virtual cluster access networking
Table 2-5 Interface IP addresses

Device Name

Interface Name

IP Address

AP1

Loopback0

3.1.2.9/32

GigabitEthernet0/1/1

3.4.0.3/30

GigabitEthernet0/1/3

3.7.1.3/30

GigabitEthernet0/1/7

-

AP2

Loopback0

4.1.2.9/32

GigabitEthernet0/1/1

3.4.0.4/30

GigabitEthernet0/1/3

4.8.0.4/30

GigabitEthernet0/1/7

-

Master1

Loopback0

7.1.2.9/32

GigabitEthernet0/1/0

7.8.0.7/30

GigabitEthernet0/1/1

2.7.0.7/30

GigabitEthernet0/1/2

3.7.1.7/30

Master2

Loopback0

8.1.2.9/32

GigabitEthernet0/1/0

7.8.0.8/30

GigabitEthernet0/1/1

2.8.0.8/30

GigabitEthernet0/1/3

4.8.0.8/30

RSG

Loopback0

2.1.2.9/32

GigabitEthernet0/1/2

2.4.0.2/30

GigabitEthernet0/1/4

2.8.0.2/30

GigabitEthernet0/1/5

1.2.0.2/30

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a loopback interface address as a management IP address on each node.

  2. Configure Multiprotocol Extensions for BGP (MP-BGP), Multiprotocol Label Switching (MPLS), and L3VPN instances on the masters and radio network controller site gateway (RSG).

  3. Enable virtual cluster access globally and on the interfaces of the masters and APs, assign management IP addresses to the masters and APs, and specify the primary and secondary masters for the APs.

  4. Create vBridge interfaces, assign IP addresses to the interfaces, and bind the interfaces to an L3VPN instance.

  5. Create Remote-AP interfaces and add them to a vBridge broadcast domain.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of directly connected interfaces and loopback interface addresses on each node (for details, see Figure 2-10)

  • Primary master for AP1 and AP2: Master1; secondary master for AP1 and AP2: Master2

  • Numbers of the Remote-AP interfaces on Master1: 1 and 2; numbers of the Remote-AP interfaces on Master2: 1 and 2

  • Number of the vBridge interface on Master1: 1; IP address of the vBridge interface on Master1: 10.1.1.1/24; number of the vBridge interface on Master2: 2; IP address of the vBridge interface on Master2: 10.1.1.1/24

Procedure

  1. Assign an IP address to each interface and configure a loopback interface address as a management IP address on each node.

    For configuration details, see Configuration Files in this section.

  2. Configure MP-BGP, MPLS, and L3VPN instances on the masters and RSG.

    For configuration details, see Configuration Files in this section.

  3. Enable virtual cluster access globally and on the interfaces of the masters and APs, assign management IP addresses to the masters and APs, and specify the primary and secondary masters for the APs.

    For configuration details, see Configuration Files in this section.

  4. Create vBridge interfaces, assign IP addresses to the interfaces, and bind the interfaces to an L3VPN instance.

    # Configure Master1.

    <Master1> system-view
    [~Master1] interface VBridge 1
    [*Master1-VBridge1] ip binding vpn-instance a
    [*Master1-VBridge1] ip address 10.1.1.1 255.255.255.0
    [*Master1-VBridge1] connect-slot 9
    [*Master1-VBridge1] commit
    [~Master1-VBridge1] quit

    # Configure Master2.

    <Master2> system-view
    [*Master2] interface VBridge 2
    [*Master2-VBridge2] ip binding vpn-instance a
    [*Master2-VBridge2] ip address 10.1.1.1 255.255.255.0
    [*Master2-VBridge2] connect-slot 9
    [*Master2-VBridge2] commit
    [~Master2-VBridge2] quit

  5. Create Remote-AP interfaces and add them to a vBridge broadcast domain.

    # Configure Master1.

    [~Master1] interface Remote-Ap 1
    [*Master1-Remote-Ap1] bind ap ip 3.1.2.9 interface GigabitEthernet0/1/7
    [*Master1-Remote-Ap1] vbridge 1
    [*Master1-Remote-Ap1] quit
    [*Master1] interface Remote-Ap 2
    [*Master1-Remote-Ap2] bind ap ip 4.1.2.9 interface GigabitEthernet0/1/7
    [*Master1-Remote-Ap2] vbridge 1
    [*Master1-Remote-Ap2] commit
    [~Master1-Remote-Ap2] quit

    # Configure Master2.

    [~Master2] interface Remote-Ap 1
    [*Master2-Remote-Ap1] bind ap ip 3.1.2.9 interface GigabitEthernet0/1/7
    [*Master2-Remote-Ap1] vbridge 2
    [*Master2-Remote-Ap1] quit
    [*Master2] interface Remote-Ap 2
    [*Master2-Remote-Ap2] bind ap ip 4.1.2.9 interface GigabitEthernet0/1/7
    [*Master2-Remote-Ap2] vbridge 2
    [*Master2-Remote-Ap2] commit
    [~Master2-Remote-Ap2] quit

  6. Verify the configuration.

    After completing the configurations, run the display virtual-cluster-access vc command on each node. The command output shows that the VC status is Up. The following example uses the command output on Master1.

    [~Master1] display virtual-cluster-access vc
    --------------------------------------------------------------------------------
    MasterID        ApID            State ApIF
    --------------------------------------------------------------------------------
    7.1.2.9         3.1.2.9         Up    GigabitEthernet0/0/7 
    7.1.2.9         4.1.2.9         Up    GigabitEthernet0/0/7 

Configuration Files

  • AP1 configuration file

    #
    sysname AP1
    #
    bfd
    #
    virtual-cluster-access
     role ap
     admin 3.1.2.9
     master primary 7.1.2.9
     master secondary 8.1.2.9
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 3.4.0.3 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet0/1/3
     undo shutdown
     ip address 3.7.1.3 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface LoopBack0
     ip address 3.1.2.9 255.255.255.255
     isis enable 65534
    #
    return  
  • AP2 configuration file

    #
    sysname AP2
    #
    bfd
    #
    virtual-cluster-access
     role ap
     admin 4.1.2.9
     master primary 7.1.2.9
     master secondary 8.1.2.9
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 3.4.0.4 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet0/1/3
     undo shutdown
     ip address 4.8.0.4 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface LoopBack0
     ip address 4.1.2.9 255.255.255.255
     isis enable 65534
    #
    return 
  • Master1 configuration file

    #
    sysname Master1
    #
    ip vpn-instance a
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 7.1.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    virtual-cluster-access
     role master
     admin 7.1.2.9
     ap name 123 ip 3.1.2.9
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0007.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 7.8.0.7 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 2.7.0.7 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     ip address 3.7.1.7 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface LoopBack0
     ip address 7.1.2.9 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap1
     undo shutdown
     bind ap ip 3.1.2.9 interface GigabitEthernet0/1/7
     vbridge 1
    #
    interface Remote-Ap2
     undo shutdown
     bind ap ip 4.1.2.9 interface GigabitEthernet0/1/7
     vbridge 1
    #
    interface VBridge1
     undo shutdown
     ip binding vpn-instance a
     ip address 10.1.1.1 255.255.255.0
     connect-slot 9
    #
    bgp 100
     peer 2.1.2.9 as-number 100
     peer 2.1.2.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      import-route direct
      peer 2.1.2.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.1.2.9 enable
     #
     ipv4-family vpn-instance a
      import-route direct med 10
    #
    ospf 1 router-id 7.1.2.9
     opaque-capability enable
     area 0.0.0.0
      network 2.7.0.0 0.0.0.255
      network 7.1.2.9 0.0.0.0
    #
    return 
    
  • Master2 configuration file

    #
    sysname Master2
    #
    ip vpn-instance a
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    bfd
    #
    mpls lsr-id 8.1.2.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    virtual-cluster-access
     role master
     admin 8.1.2.9
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0008.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 7.8.0.8 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 2.8.0.8 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/3
     undo shutdown
     ip address 4.8.0.8 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface LoopBack0
     ip address 8.1.2.9 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap1
     undo shutdown
     bind ap ip 3.1.2.9 interface GigabitEthernet0/1/7
     vbridge 2
    #
    interface Remote-Ap2
     undo shutdown
     bind ap ip 4.1.2.9 interface GigabitEthernet0/1/7
     vbridge 2
    #
    interface VBridge2
     undo shutdown
     ip binding vpn-instance a
     ip address 10.1.1.1 255.255.255.0
     connect-slot 9
    #
    bgp 100
     peer 2.1.2.9 as-number 100
     peer 2.1.2.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      import-route direct
      peer 2.1.2.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.1.2.9 enable
     #
     ipv4-family vpn-instance a
      import-route direct med 20
    #
    ospf 1 router-id 8.1.2.9
     opaque-capability enable
     area 0.0.0.0
      network 2.8.0.0 0.0.0.255
      network 8.1.2.9 0.0.0.0
    #
    return 
  • RSG configuration file

    #
    sysname RSG
    #
    ip vpn-instance a
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 2.1.2.9
    #
    mpls
     label advertise non-null
    #
    mpls ldp
     graceful-restart
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     ip address 2.7.0.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/4
     undo shutdown
     ip address 2.8.0.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/5
     undo shutdown
     ip binding vpn-instance a
     ip address 1.2.0.2 255.255.255.252
    #
    interface LoopBack0
     ip address 2.1.2.9 255.255.255.255
    #
    bgp 100
     peer 7.1.2.9 as-number 100
     peer 7.1.2.9 connect-interface LoopBack0
     peer 8.1.2.9 as-number 100
     peer 8.1.2.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      import-route direct
      peer 7.1.2.9 enable
      peer 8.1.2.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 7.1.2.9 enable
      peer 8.1.2.9 enable
     #
     ipv4-family vpn-instance a
      import-route direct
      peer 1.2.0.1 as-number 500
    #
    ospf 1 router-id 2.1.2.9
     opaque-capability enable
     graceful-restart
     area 0.0.0.0
      network 2.1.2.9 0.0.0.0
      network 2.7.0.0 0.0.0.255
      network 2.8.0.0 0.0.0.255
    #
    return 
Translation
Download
Updated: 2019-01-03

Document ID: EDOC1100055113

Views: 1798

Downloads: 18

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next