No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Routed Proxy ARP

Example for Configuring Routed Proxy ARP

This example provides an example for configuring routed proxy ARP.

Networking Requirements

Two hosts on the same network segment but on different physical networks need to communicate with each other.

As shown in Figure 2-7, two routers are connected by serial links. No default gateways are set for Host A and Host B that reside on different physical networks. To enable Host A and Host B to communicate with each other, configure routed proxy ARP on routers.

Figure 2-7 Configuring routed proxy ARP

Device Name

Interface

IP Address

Device A

GE0/1/0

172.16.1.1/24

GE0/2/0

172.17.3.1/24

Device B

GE0/1/0

172.16.2.1/24

GE0/2/0

172.17.3.2/24

Precautions

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for the interface that connects each router to a host, ensuring that the link between each host and each router is working properly.

  2. Configure routed proxy ARP on the interface that connects each router to a host. After receiving an ARP request (for the destination host's MAC address) sent by the host, the router that has routed proxy ARP enabled responds to the request with its own MAC address. The host then forwards data to the router.

  3. Configure a default route between two routers so that data can be transmitted along the route.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of the interface that connects Device A to Host A: 172.16.1.1/24; IP address of the interface that connects Device B to Host B: 172.16.2.1/24

  • Default route on each router

  • IP address of Host A: 172.16.1.2/16; IP address of Host B: 172.16.2.2/16

Procedure

  1. Configure Device A.

    # Configure an IP address for GE 0/1/0.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ip address 172.16.1.1 255.255.255.0

    # Enable routed proxy ARP.

    [*DeviceA-GigabitEthernet0/1/0] arp-proxy enable
    [*DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] quit

    # Configure a static route.

    [*DeviceA] ip route-static 0.0.0.0 0 gigabitethernet 0/2/0 172.17.3.2

    # Configure an IP address for GE 0/2/0.

    [*DeviceA] interface gigabitethernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] ip address 172.17.3.1 255.255.255.0
    [*DeviceA-GigabitEthernet0/2/0] undo shutdown
    [*DeviceA-GigabitEthernet0/2/0] quit
    [*DeviceA] commit

  2. Configure Device B.

    # Configure an IP address for GE 0/1/0.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] ip address 172.16.2.1 255.255.255.0

    # Enable routed proxy ARP.

    [*DeviceB-GigabitEthernet0/1/0] arp-proxy enable
    [*DeviceB-GigabitEthernet0/1/0] undo shutdown
    [*DeviceB-GigabitEthernet0/1/0] quit

    # Configure a static route.

    [*DeviceB] ip route-static 0.0.0.0 0 gigabitethernet 0/2/0 172.17.3.1

    # Configure an IP address for GE 0/2/0.

    [*DeviceB] interface gigabitethernet 0/2/0
    [*DeviceB-GigabitEthernet0/2/0] ip address 172.17.3.2 255.255.255.0
    [*DeviceB-GigabitEthernet0/2/0] undo shutdown
    [*DeviceB-GigabitEthernet0/2/0] quit
    [*DeviceB] commit

  3. Configure hosts.

    # Configure an IP address for Host A.

    # Configure an IP address for Host B.

  4. Verify the configuration.

    # Ping Host B from Host A, and the ping is successful.

    # Check ARP entries on Host A. The command output shows that the MAC address of Host B is the MAC address of GE 0/1/0 on Device A.

    C:\Documents and Settings\Administrator>arp -a
    Interface: 172.16.1.2 --- 0x2
      Internet Address      Physical Address      Type
      172.16.2.2            00e0-fc39-80aa        dynamic

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/2/0 172.17.3.2
    #
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
     arp-proxy enable
    #
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.17.3.1 255.255.255.0
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/2/0 172.17.3.1
    #
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.2.1 255.255.255.0
     arp-proxy enable
    #
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.17.3.2 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055376

Views: 15071

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next