No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Proxy ARP Within a VLAN

Example for Configuring Proxy ARP Within a VLAN

If user isolation is configured for different users in the same virtual local area network (VLAN), the users cannot communicate with each other. To resolve this problem, you can configure proxy Address Resolution Protocol (ARP) for the VLAN.

Networking Requirements

As shown in Figure 2-8, CE is connected to the sub-interface Eth-Trunk1.1 of PE. Eth-Trunk1.1 is associated with VLAN 10.

Host A and Host B are two users connected with CE. On CE, the interfaces connected with Host A and Host B belong to the same VLAN. User isolation in a VLAN is configured on CE.

To implement communication between Host A and Host B, enable proxy ARP within a VLAN on Eth-Trunk1.1 of PE.

Figure 2-8 Configuring proxy ARP in a VLAN
NOTE:

Interfaces 1 through 2 in this example are GE 0/1/1, GE 0/1/2, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Create a VLAN on the CE and configure the users that need to communicate with each other to belong to the same VLAN.

  2. Create an Eth-Trunk interface on the PE and configure an IP address for the Eth-Trunk as the gateway IP address.

  3. Associate the Eth-Trunk1.1 and VLAN.

  4. Enable proxy ARP on Eth-Trunk1.1 so that isolated users in VLAN 10 can communicate with each other.

Data Preparation

To complete the configuration, you need the following data:

  • VLAN to which hosts belong

  • IP address of Eth-Trunk1.1

  • VLAN associated with Eth-Trunk1.1

  • IP addresses for hosts

Procedure

  1. Create a VLAN on the CE and configure the users that need to communicate with each other to belong to the same VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE
    [*HUAWEI] commit
    [~CE] vlan 10
    [*CE-vlan 10] commit
    [~CE-vlan 10] quit
    [~CE] interface gigabitethernet 0/1/1
    [~CE-GigabitEthernet0/1/1] portswitch
    [*CE-GigabitEthernet0/1/1] undo shutdown
    [*CE-GigabitEthernet0/1/1] port default vlan 10
    [*CE-GigabitEthernet0/1/1] commit
    [~CE-GigabitEthernet0/1/1] quit
    [~CE] interface gigabitethernet 0/1/2
    [~CE-GigabitEthernet0/1/2] portswitch
    [*CE-GigabitEthernet0/1/2] undo shutdown
    [*CE-GigabitEthernet0/1/2] port default vlan 10
    [*CE-GigabitEthernet0/1/2] commit
    [~CE-GigabitEthernet0/1/2] quit

  2. Create Eth-Trunk1.1 on the PE and configure an IP address for Eth-Trunk1.1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE
    [*HUAWEI] commit
    [~PE] interface eth-trunk 1.1
    [*PE-Eth-Trunk1.1] ip address 10.10.10.1 255.255.255.0
    [*PE-Eth-Trunk1.1] commit

  3. Configure IP addresses for Host A and Host B.

    # Configure IP addresses for Host A and Host B. The IP addresses must be in the same network segment with the IP address of Eth-Trunk1.1.

    After the configurations, Hosts and PE can ping through each other but Hosts cannot ping through each other.

  4. Associate Eth-Trunk1.1 with VLAN 10.

    [~PE-Eth-Trunk1.1] vlan-type dot1q 10
    [*PE-Eth-Trunk1.1] commit

  5. Enable proxy ARP in VLAN 10 on Eth-Trunk1.1.

    [~PE-Eth-Trunk1.1] arp-proxy inner-sub-vlan-proxy enable
    [*PE-Eth-Trunk1.1] commit

  6. Verify the configuration.

    Host A and Host B can ping through each other.

Configuration Files

  • PE configuration file

    #
    sysname PE
    #
    interface Eth-Trunk1
     undo shutdown
    #
    interface Eth-Trunk1.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.10.10.1 255.255.255.0
     arp-proxy inner-sub-vlan-proxy enable
    #
    return
  • CE configuration file

    #
    sysname CE
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port default vlan 10
    #
    interface GigabitEthernet0/1/2
     portswitch
     undo shutdown
     port default vlan 10
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055376

Views: 15870

Downloads: 33

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next