No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IP Address with a 31-bit Mask

Example for Configuring an IP Address with a 31-bit Mask

This section provides an example for configuring an IP address with a 31-bit mask.

Networking Requirements

As shown in Figure 9-8, Device A and Device B are directly connected through a PPP link. To allow Device A and Device B to communicate, configure IP addresses with a 31-bit mask for the interfaces that connect Device A and Device B.

Figure 9-8 Configuring an IP address with a 31-bit mask
NOTE:

Interfaces 1 in this example are GE 0/1/0.



Precautions

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address with a 31-bit mask for GE 0/1/0 on Device A.

  2. Configure an IP address with a 31-bit mask for GE 0/1/0 on Device B.

Data Preparation

To complete the configuration, you need the following data:

  • IP address and subnet mask of GE 0/1/0 on Device A

  • IP address and subnet mask of GE 0/1/0 on Device B

Procedure

  1. Configure an IP address for each interface.

    # Configure an IP address for GE 0/1/0 on Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface GigabitEthernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ip address 10.1.1.1 31
    [*DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] quit

    # Configure an IP address for GE 0/1/0 on Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface GigabitEthernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] ip address 10.1.1.0 31
    [*DeviceB-GigabitEthernet0/1/0] undo shutdown
    [*DeviceB-GigabitEthernet0/1/0] commit
    [~DeviceB-GigabitEthernet0/1/0] quit

  2. Verify the configuration.

    # After the configuration is complete, check the routing table on Device A. The command output shows that both the network address and the broadcast address of the network segment are used as host addresses.

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/31  Direct 0    0           D  10.1.1.1           GigabitEthernet0/1/0
           10.1.1.0/32  Direct 0    0           D  10.1.1.0           GigabitEthernet0/1/0
           10.1.1.1/32  Direct 0    0           D  127.0.0.1          GigabitEthernet0/1/0
          127.0.0.0/8   Direct 0    0           D  127.0.0.1          InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1          InLoopBack0

    # After the configuration is complete, check the routing table on Device B. In the routing table, you can view that both the network address and the broadcast address of the network segment are used as host addresses.

    [~DeviceB] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 5        Routes : 5
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/31  Direct 0    0           D  10.1.1.0           GigabitEthernet0/1/0
           10.1.1.0/32  Direct 0    0           D  127.0.0.1          GigabitEthernet0/1/0
           10.1.1.1/32  Direct 0    0           D  10.1.1.1           GigabitEthernet0/1/0
          127.0.0.0/8   Direct 0    0           D  127.0.0.1          InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1          InLoopBack0   

Configuration Files

  • Device A

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.254
    #
    return
  • Device B

    #
     sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.0 255.255.255.254
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055376

Views: 15204

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next