No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface-specific UCMP for IP Packet Forwarding

Example for Configuring Interface-specific UCMP for IP Packet Forwarding

This section provides an example for configuring interface-specific UCMP for IP packet forwarding.

Networking Requirements

On the network shown in Figure 10-2, three paths between Device A and Device E travel through Device B, Device C, and Device D, respectively. To allow traffic to be load balanced among these paths, configure UCMP for IP packet forwarding. In this example, configure UCMP on specified interfaces, not on an entire router.

Figure 10-2 Configuring interface-specific UCMP
NOTE:

The configurations in this example are performed on Device A, Device B, Device C, Device D, and Device E. HUAWEI NE20E-S2 can function as Device A, Device B, Device C, Device D, and Device E.



Device Name Interface Name IP Address
Device A GE 0/1/8 10.30.1.1/24
GE 0/3/0 10.40.1.1/24
GE 0/2/0 10.50.1.1/24
Device B GE 0/1/0 10.30.1.2/24
GE 0/2/0 10.60.1.2/24
Device C GE 0/1/0 10.40.1.2/24
GE 0/2/0 10.70.1.2/24
Device D GE 0/1/0 10.50.1.2/24
GE 0/2/0 10.80.1.2/24
Device E GE 0/1/8 10.60.1.1/24
GE 0/3/0 10.70.1.1/24
GE 0/2/0 10.80.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on each router. IS-IS is used in this example.

  2. Enable UCMP on each interface, allowing the three paths between Device A and Device E to perform UCMP during IP packet forwarding.

Data Preparation

To complete the configuration, you need the following data:

  • Type and number of each interface

  • IP address of each interface

  • IS-IS area ID and level for each router

Procedure

  1. Assign an IP address to each interface. For configuration details, see Configuration Files in this section.
  2. Configure basic IS-IS functions.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-1
    [*DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [*DeviceA-isis-1] commit
    [~DeviceA-isis-1] quit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] isis enable 1
    [*DeviceA-GigabitEthernet0/1/0] quit
    [*DeviceA] interface gigabitethernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] isis enable 1
    [*DeviceA-GigabitEthernet0/2/0] quit
    [*DeviceA] interface gigabitethernet 0/1/8
    [*DeviceA-GigabitEthernet0/1/8] isis enable 1
    [*DeviceA-GigabitEthernet0/1/8] quit
    [*DeviceA] interface gigabitethernet 0/3/0
    [*DeviceA-GigabitEthernet0/3/0] isis enable 1
    [*DeviceA-GigabitEthernet0/3/0] quit
    [*DeviceA] commit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] is-level level-1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] commit
    [~DeviceB-isis-1] quit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] isis enable 1
    [*DeviceB-GigabitEthernet0/1/0] quit
    [*DeviceB] interface gigabitethernet 0/2/0
    [*DeviceB-GigabitEthernet0/2/0] isis enable 1
    [*DeviceB-GigabitEthernet0/2/0] quit
    [*DeviceB] commit

    # Configure Device C.

    [~DeviceC] isis 1
    [*DeviceC-isis-1] is-level level-1
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] commit
    [~DeviceC-isis-1] quit
    [~DeviceC] interface gigabitethernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] isis enable 1
    [*DeviceC-GigabitEthernet0/1/0] quit
    [*DeviceC] interface gigabitethernet 0/2/0
    [*DeviceC-GigabitEthernet0/2/0] isis enable 1
    [*DeviceC-GigabitEthernet0/2/0] quit
    [*DeviceC] commit

    # Configure Device D.

    [~DeviceD] isis 1
    [*DeviceD-isis-1] is-level level-1
    [*DeviceD-isis-1] network-entity 10.0000.0000.0004.00
    [*DeviceD-isis-1] commit
    [~DeviceD-isis-1] quit
    [~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] isis enable 1
    [*DeviceD-GigabitEthernet0/1/0] quit
    [*DeviceD] interface gigabitethernet 0/2/0
    [*DeviceD-GigabitEthernet0/2/0] isis enable 1
    [*DeviceD-GigabitEthernet0/2/0] quit
    [*DeviceD] commit

    # Configure Device E.

    [~DeviceE] isis 1
    [*DeviceE-isis-1] is-level level-1
    [*DeviceE-isis-1] network-entity 10.0000.0000.0005.00
    [*DeviceE-isis-1] commit
    [~DeviceE-isis-1] quit
    [~DeviceE] interface gigabitethernet 0/1/0
    [~DeviceE-GigabitEthernet0/1/0] isis enable 1
    [*DeviceE-GigabitEthernet0/1/0] quit
    [*DeviceE] interface gigabitethernet 0/2/0
    [*DeviceE-GigabitEthernet0/2/0] isis enable 1
    [*DeviceE-GigabitEthernet0/2/0] quit
    [*DeviceE] interface gigabitethernet 0/1/8
    [*DeviceE-GigabitEthernet0/1/8] isis enable 1
    [*DeviceE-GigabitEthernet0/1/8] quit
    [*DeviceE] interface gigabitethernet 0/3/0
    [*DeviceE-GigabitEthernet0/3/0] isis enable 1
    [*DeviceE-GigabitEthernet0/3/0] quit
    [*DeviceE] commit

  3. Verify basic IS-IS configurations.

    # Display IS-IS routing information on Device A.

    [~DeviceA] display isis route
                Route information for ISIS(1)
                      -----------------------------
    
                      ISIS(1) Level-1 Forwarding Table
                      --------------------------------
    
     IPV4 Destination     IntCost    ExtCost ExitInterface       NextHop         Flags
    --------------------------------------------------------------------------------
     10.1.1.0/24              10         NULL    GE0/1/0         Direct          D/-/L/-/-
     10.20.1.0/24              30         NULL    GE0/3/0         10.40.1.2        A/-/-/-/C
                                                 GE0/2/0         10.50.1.2
                                                 GE0/1/8        10.30.1.2
     10.30.1.0/24              10         NULL    GE0/1/8        Direct          D/-/L/-/-
     10.40.1.0/24              10         NULL    GE0/3/0         Direct          D/-/L/-/-
     10.50.1.0/24              10         NULL    GE0/2/0         Direct          D/-/L/-/-
     10.60.1.0/24              20         NULL    GE0/1/8        10.30.1.2        R/-/-
     10.70.1.0/24              20         NULL    GE0/3/0         10.40.1.2        A/-/-/-/-
     10.80.1.0/24              20         NULL    GE0/2/0         10.50.1.2        R/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                           U-Up/Down Bit Set, C-In Computing
    

    # Ping Device E at 10.20.1.1 from Device A. The ping operation is successful. The NMS that manages Device A displays that ECMP is implemented among outbound interfaces.

    <routerA> ping 10.20.1.1
      PING 10.20.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.20.1.1: bytes=56 Sequence=1 ttl=254 time=16 ms
        Reply from 10.20.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=5 ttl=254 time=64 ms
    
        --- 10.20.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/16/64 ms 
    

  4. Enable UCMP on every outbound interface of Device A.

    [~routerA] interface gigabitethernet 0/2/0
    [~routerA-GigabitEthernet0/2/0] load-balance unequal-cost enable
    [*routerA-GigabitEthernet0/2/0] quit
    [*routerA] interface gigabitethernet 0/1/8
    [*routerA-GigabitEthern0/1/8] load-balance unequal-cost enable
    [*routerA-GigabitEthern0/1/8] quit
    [*routerA] interface gigabitethernet 0/3/0
    [*routerA-GigabitEthernet0/3/0] load-balance unequal-cost enable
    [*routerA-GigabitEthernet0/3/0] quit
    [*routerA] commit

  5. Verify the configuration.

    # Ping Device E at 10.20.1.1 from Device A. The ping operation is still successful. The NMS displays that UCMP is implemented among outbound interfaces.

    <routerA> ping 10.20.1.1
      PING 10.20.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.20.1.1: bytes=56 Sequence=1 ttl=254 time=16 ms
        Reply from 10.20.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.20.1.1: bytes=56 Sequence=5 ttl=254 time=64 ms
    
      --- 10.20.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/16/64 ms
    

Configuration Files

  • Device A configuration file

    #
     sysname routerA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.50.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.40.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.30.1.1 255.255.255.0
     isis enable 1
    #
    return
    
  • Device B configuration file

    #
     sysname routerB
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.30.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.60.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device C configuration file

    #
     sysname routerC
    #
    isis 1
    is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.40.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.70.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device D configuration file

    #
     sysname routerD
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.50.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.80.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device E configuration file

    #
     sysname routerE
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0005.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.80.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 10.70.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.60.1.1 255.255.255.0
     isis enable 1
    #
    return
    
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055376

Views: 17920

Downloads: 35

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next