No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - IP Services
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IP Unnumbered on an Interface

Example for Configuring IP Unnumbered on an Interface

This section provides an example for configuring IP unnumbered on an interface.

Networking Requirements

As shown in Figure 9-6, an enterprise builds its intranet through an integrated services digital network (ISDN). Device A and Device B connect to a local LAN through GE 0/1/0 and connect to each other over the ISDN through dialing interfaces GE 0/2/0. To save IP address resources, the dialing interfaces are configured to borrow IP addresses from GE 0/1/0.

Figure 9-6 Configuring IP unnumbered on an interface
NOTE:

Interfaces 1 through 2 in this example are GE 0/1/0, GE 0/2/0, respectively.



Precautions

None

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses to be borrowed.

  2. Configure interfaces to borrow IP addresses from other interfaces.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of the numbered interfaces

  • Numbers of the numbered interfaces

Procedure

  1. Configure Device A.

    # Configure an IP address for GE 0/1/0.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ip address 172.16.10.1 255.255.255.0
    [*DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] quit

    # Configure GE 0/2/0 to borrow the IP address from GE 0/1/0.

    [*DeviceA] interface GigabitEthernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] ip address unnumbered interface gigabitethernet 0/1/0
    [*DeviceA-GigabitEthernet0/2/0] undo shutdown
    [*DeviceA-GigabitEthernet0/2/0] quit

    # Configure a route to the Ethernet network segment of Device B.

    [*DeviceA] ip route-static 172.16.20.0 255.255.255.0 GigabitEthernet 0/2/0
    [*DeviceA] commit

  2. Configure Device B.

    # Configure an IP address for GE 0/1/0.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] ip address 172.16.20.1 255.255.255.0
    [*DeviceB-GigabitEthernet0/1/0] undo shutdown
    [*DeviceB-GigabitEthernet0/1/0] quit

    # Configure GE 0/2/0 to borrow the IP address from GE 0/1/0.

    [*DeviceB] interface GigabitEthernet 0/2/0
    [*DeviceB-GigabitEthernet0/2/0] ip address unnumbered interface gigabitethernet 0/1/0
    [*DeviceB-GigabitEthernet0/2/0] undo shutdown
    [*DeviceB-GigabitEthernet0/2/0] quit

    # Configure a route to the Ethernet network segment of Device A.

    [*DeviceB] ip route-static 172.16.10.0 255.255.255.0 GigabitEthernet 0/2/0
    [*DeviceB] commit

  3. Verify the configuration.

    # Ping the IP address of Device B's interface that directly connects to Device A from Device A. The ping operation is successful.

    [~DeviceA] ping 172.16.20.1
      PING 172.16.20.2: 56  data bytes, press CTRL_C to break
        Reply from 172.16.20.2: bytes=56 Sequence=1 ttl=255 time=25 ms
        Reply from 172.16.20.2: bytes=56 Sequence=2 ttl=255 time=25 ms
        Reply from 172.16.20.2: bytes=56 Sequence=3 ttl=255 time=26 ms
        Reply from 172.16.20.2: bytes=56 Sequence=4 ttl=255 time=26 ms
        Reply from 172.16.20.2: bytes=56 Sequence=5 ttl=255 time=26 ms
      --- 172.16.20.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 25/25/26 ms

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.10.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address unnumbered interface GigabitEthernet0/1/0
    #
    ip route-static 172.16.20.0 255.255.255.0 GigabitEthernet0/2/0
    #
    return
  • Device B configuration file

    #
     sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.20.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address unnumbered interface GigabitEthernet0/1/0
    #
    ip route-static 172.16.10.0 255.255.255.0 GigabitEthernet0/2/0
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055376

Views: 17932

Downloads: 35

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next