No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a QinQ Tunnel

Example for Configuring a QinQ Tunnel

After a QinQ tunnel is configured, an enterprise can set up its own VLANs based on the QinQ tunnel. Branch offices of the same enterprise in different locations can communicate with each other through the VLANs. Offices of different enterprises cannot communicate.

Networking Requirements

On the network shown in Figure 9-15, enterprise 1 has two offices and enterprise 2 has three offices. Offices of enterprise 1 and enterprise 2 are connected to PE1 and PE2 on the carrier network respectively. Enterprise 1 and enterprise 2 each have a VLAN.

You can configure QinQ tunnels on PE1 and PE2 so that offices of the same enterprise (enterprise 1 or enterprise 2) can interwork but offices of different enterprises (enterprise 1 and enterprise 2) cannot interwork.

Figure 9-15 Typical networking of the QinQ tunnel
NOTE:

Interfaces 1 through 4 in this example are GE0/1/1, GE0/2/1, GE0/3/1, GE0/1/9, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an outer VLAN tag for QinQ packets.

  2. Configure a QinQ tunnel so that packets exchanged between VLAN users become double-tagged QinQ packets after passing through the QinQ tunnel.

  3. Configure interfaces on which the QinQ tunnel is not enabled. These interfaces allow packets carrying the specified outer VLAN tags to pass through so that users from different VLANs of the same enterprise can communicate.

Data Preparation

To complete the configuration, you need the following data:

  • Number of the interface connecting to enterprise 1 and enterprise 2

  • Outer VLAN tag of the QinQ interface connecting to enterprise 1 and enterprise 2

Procedure

  1. Create an outer VLAN tag for the QinQ tunnel.

    # Configure PE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] vlan batch 10 20

    # Configure PE2.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2] vlan batch 10 20

  2. Configure the QinQ tunnel function.

    # Configure PE1.

    [*PE1] interface gigabitethernet 0/1/1
    [*PE1-GigabitEthernet0/1/1] portswitch
    [*PE1-GigabitEthernet0/1/1] port link-type dot1q-tunnel
    [*PE1-GigabitEthernet0/1/1] port default vlan 10
    [*PE1-GigabitEthernet0/1/1] undo shutdown
    [*PE1-GigabitEthernet0/1/1] quit
    [*PE1] interface gigabitethernet 0/2/1
    [*PE1-GigabitEthernet0/2/1] portswitch
    [*PE1-GigabitEthernet0/2/1] port link-type dot1q-tunnel
    [*PE1-GigabitEthernet0/2/1] port default vlan 20
    [*PE1-GigabitEthernet0/2/1] undo shutdown
    [*PE1-GigabitEthernet0/2/1] quit
    [*PE1] interface gigabitethernet 0/3/1
    [*PE1-GigabitEthernet0/3/1] portswitch
    [*PE1-GigabitEthernet0/3/1] port link-type dot1q-tunnel
    [*PE1-GigabitEthernet0/3/1] port default vlan 10
    [*PE1-GigabitEthernet0/3/1] undo shutdown
    [*PE1-GigabitEthernet0/3/1] quit
    [*PE1] commit

    # Configure PE2.

    [*PE2] interface gigabitethernet 0/1/1
    [*PE2-GigabitEthernet0/1/1] portswitch
    [*PE2-GigabitEthernet0/1/1] port link-type dot1q-tunnel
    [*PE2-GigabitEthernet0/1/1] port default vlan 20
    [*PE2-GigabitEthernet0/1/1] undo shutdown
    [*PE2-GigabitEthernet0/1/1] quit
    [*PE2] interface gigabitethernet 0/2/1
    [*PE2-GigabitEthernet0/2/1] portswitch
    [*PE2-GigabitEthernet0/2/1] port link-type dot1q-tunnel
    [*PE2-GigabitEthernet0/2/1] port default vlan 10
    [*PE2-GigabitEthernet0/2/1] undo shutdown
    [*PE2-GigabitEthernet0/2/1] quit
    [*PE2] commit

  3. Configure other interfaces.

    # Allow the packets from VLAN 10 and VLAN 20 to pass through GE 0/1/9 on PE1.

    [~PE1] interface gigabitethernet 0/1/9
    [*PE1-GigabitEthernet0/1/9] portswitch
    [*PE1-GigabitEthernet0/1/9] port link-type trunk
    [*PE1-GigabitEthernet0/1/9] port trunk allow-pass vlan 10 20
    [*PE1-GigabitEthernet0/1/9] undo shutdown
    [*PE1-GigabitEthernet0/1/9] quit
    [*PE1] commit

    # Allow the packets from VLAN 10 and VLAN 20 to pass through GE 0/3/1 on PE2.

    [~PE2] interface gigabitethernet 0/3/1
    [*PE2-GigabitEthernet0/3/1] portswitch
    [*PE2-GigabitEthernet0/3/1] port link-type trunk
    [*PE2-GigabitEthernet0/3/1] port trunk allow-pass vlan 10 20
    [*PE2-GigabitEthernet0/3/1] undo shutdown
    [*PE2-GigabitEthernet0/3/1] quit
    [*PE2] commit

  4. Verify that the following conditions are true:

    Hosts in different offices on the same VLAN of enterprise 1 can ping each other.

    Hosts in different offices on the same VLAN of enterprise 2 can ping each other.

    Host of enterprise 1 cannot ping hosts of enterprise 2.

Configuration Files

  • Configuration file of PE1

    #
     sysname PE1
    #
     vlan batch 10 20
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     portswitch
     port link-type dot1q-tunnel
     port default vlan 10
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     portswitch
     port link-type dot1q-tunnel
     port default vlan 20
    #
    interface GigabitEthernet0/3/1
     undo shutdown
     portswitch
     port link-type dot1q-tunnel
     port default vlan 10
    #
    interface GigabitEthernet0/1/9
     undo shutdown
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
  • Configuration file of PE2

    #
     sysname PE2
    #
     vlan batch 10 20
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     portswitch
     port link-type dot1q-tunnel
     port default vlan 20
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     portswitch
     port link-type dot1q-tunnel
     port default vlan 10
    #
    interface GigabitEthernet0/3/1
     undo shutdown
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055378

Views: 16437

Downloads: 34

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next