No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Hybrid VLAN-based Layer 2 Protocol Tunneling

Example for Configuring Hybrid VLAN-based Layer 2 Protocol Tunneling

When backbone network edge devices receive both tagged and untagged Layer 2 protocol data units (PDUs) from user networks, configure hybrid VLAN-based Layer 2 protocol tunneling to allow both the tagged and untagged Layer 2 PDUs to be tunneled across the backbone network. Layer 2 PDUs from the user networks then travel through different Layer 2 tunnels to reach the destinations to perform Layer 2 protocol calculation. This example uses the Spanning Tree Protocol (STP) and a user-defined Layer 2 protocol.

Networking Requirements

When each edge device interface on a backbone network connects to more than one user network and some Layer 2 PDUs from the user networks carry VLAN tags while others do not, configure hybrid VLAN-based Layer 2 protocol tunneling to allow both the tagged and untagged Layer 2 PDUs from the user networks to be tunneled across the backbone network. Layer 2 PDUs from the user networks then travel through different Layer 2 tunnels to reach the destinations to perform Layer 2 protocol calculation.

On the network shown in Figure 6-6, CEs are connected through PEs. CE1 and CE2 run STP and send BPDUs that carry VLAN 100 to PE1; CE3 and CE4 run a user-defined Layer 2 protocol (with the multicast destination MAC address 0100-c300-0100) and send Layer 2 PDUs that do not carry VLAN tags to PE2. The PEs on the backbone network then receive both tagged and untagged Layer 2 PDUs. To achieve the following requirements, configure hybrid VLAN-based Layer 2 protocol tunneling on the PEs:

  • CE1 and CE2 in VLAN 100 build a spanning tree.

  • CE3 and CE4 in VLAN 200 perform user-defined Layer 2 protocol calculation.

In addition, the PEs are able to perform the following procedures:

  • Add the default VLAN ID of the interface that has received the untagged Layer 2 PDUs to the PDUs and then tunnel the PDUs.

  • Add an outer VLAN tag (backbone network VLAN ID) to tagged Layer 2 PDUs and then tunnel the PDUs. The backbone network VLAN ID is configured as the default VLAN ID of the interface.

The default multicast destination MAC address 0180-C200-0000 of BPDUs is used in this example.

Figure 6-6 Hybrid VLAN-based Layer 2 protocol tunneling networking
NOTE:

Interface 1, interface 2, and interface 3 stand for GE 0/1/1, GE 0/1/2, and GE 0/1/3, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. (Optional) Switch all interfaces on the CEs, Ls, PEs, and the P to Layer 2 mode.

    NOTE:

    Skip this step if the interfaces are already Layer 2 interfaces.

  2. Enable STP on the CEs and PEs.
  3. Configure Layer 2 forwarding on the CEs to allow CE1 and CE2 to send BPDUs that carry a specific VLAN ID to PE1 and allow CE3 and CE4 to send untagged Layer 2 PDUs to PE2.

  4. Configure Layer 2 forwarding on the aggregation devices L1 and L2 to allow BPDUs that carry a specific VLAN ID and untagged Layer 2 PDUs to pass through.
  5. Configure hybrid VLAN-based Layer 2 protocol tunneling on the PEs:

    1. Configure Layer 2 forwarding on the PEs to allow BPDUs that carry a specific VLAN ID and untagged Layer 2 PDUs to pass through.
    2. Disable STP on PEs' user-side interfaces and enable Layer 2 protocol tunneling on both tagged and untagged interfaces.
    3. Configure the PEs to replace the multicast destination MAC address in the BPDUs from the CEs.
  6. Configure Layer 2 forwarding on the P to allow BPDUs that carry a specific VLAN ID and untagged Layer 2 PDUs to pass through.

Data Preparation

To complete the configuration, you need the following data:

  • Types and numbers of the interfaces that connect the CEs and Ls, that connect the PEs and Ls, and that connect the PEs and the P
  • VLAN IDs of the CEs
  • VLAN IDs of BPDUs that are allowed to pass through the Ls and PEs
  • Specified multicast MAC address to replace the multicast destination MAC address in BPDUs

Procedure

  1. (Optional) Switch all interfaces on the CEs, Ls, PEs, and the P to Layer 2 mode.

    Run the portswitch command to switch all interfaces on the CEs, Ls, PEs, and the P to Layer 2 mode.

  2. Enable STP on the CEs and PEs.

    # Configure CE1.

    [~CE1] stp enable
    [*CE1] commit

    # Configure CE2.

    [~CE2] stp enable
    [*CE2] commit

    # Configure PE1.

    [~PE1] stp enable
    [*PE1] commit

    # Configure PE2.

    [~PE2] stp enable
    [*PE2] commit
    NOTE:

    CE3 and CE4 run a user-defined Layer 2 protocol.

  3. Configure Layer 2 forwarding on the CEs.

    # Configure CE1.

    [~CE1] vlan 100
    [*CE1-vlan100] quit
    [*CE1] interface gigabitethernet 0/1/1
    [*CE1-GigabitEthernet0/1/1] undo shutdown
    [*CE1-GigabitEthernet0/1/1] port link-type trunk
    [*CE1-GigabitEthernet0/1/1] port trunk allow-pass vlan 100
    [*CE1-GigabitEthernet0/1/1] stp bpdu vlan 100
    [*CE1-GigabitEthernet0/1/1] quit
    [*CE1] commit

    # Configure CE2.

    [~CE2] vlan 100
    [*CE2-vlan100] quit
    [*CE2] interface gigabitethernet 0/1/1
    [*CE2-GigabitEthernet0/1/1] undo shutdown
    [*CE2-GigabitEthernet0/1/1] port link-type trunk
    [*CE2-GigabitEthernet0/1/1] port trunk allow-pass vlan 100
    [*CE2-GigabitEthernet0/1/1] stp bpdu vlan 100
    [*CE2-GigabitEthernet0/1/1] quit
    [*CE2] commit
    NOTE:

    CE3 and CE4 run a user-defined Layer 2 protocol and the Layer 2 PDUs do not carry VLAN tags.

  4. Configure Layer 2 forwarding on L1 and L2.

    # Configure L1.

    [~L1] vlan batch 100 200
    [*L1] interface gigabitethernet 0/1/3
    [*L1-GigabitEthernet0/1/3] undo shutdown
    [*L1-GigabitEthernet0/1/3] port link-type hybrid
    [*L1-GigabitEthernet0/1/3] port hybrid untagged 200
    [*L1-GigabitEthernet0/1/3] port hybrid tagged 100
    [*L1-GigabitEthernet0/1/3] quit
    [*L1] interface gigabitethernet 0/1/1
    [*L1-GigabitEthernet0/1/1] undo shutdown
    [*L1-GigabitEthernet0/1/1] port link-type trunk
    [*L1-GigabitEthernet0/1/1] port trunk allow-pass vlan 100
    [*L1-GigabitEthernet0/1/1] quit
    [*L1] interface gigabitethernet 0/1/2
    [*L1-GigabitEthernet0/1/2] undo shutdown
    [*L1-GigabitEthernet0/1/1] port link-type access
    [*L1-GigabitEthernet0/1/2] port default vlan 200
    [*L1-GigabitEthernet0/1/2] quit
    [*L1] commit

    # Configure L2.

    [~L2] vlan batch 100 200
    [*L2] interface gigabitethernet 0/1/3
    [*L2-GigabitEthernet0/1/3] port link-type hybrid
    [*L2-GigabitEthernet0/1/3] port hybrid untagged 200
    [*L2-GigabitEthernet0/1/3] port hybrid tagged 100
    [*L2-GigabitEthernet0/1/3] quit
    [*L2] interface gigabitethernet 0/1/1
    [*L2-GigabitEthernet0/1/1] undo shutdown
    [*L2-GigabitEthernet0/1/1] port link-type trunk
    [*L2-GigabitEthernet0/1/1] port trunk allow-pass vlan 100
    [*L2-GigabitEthernet0/1/1] quit
    [*L2] interface gigabitethernet 0/1/2
    [*L2-GigabitEthernet0/1/2] undo shutdown
    [*L2-GigabitEthernet0/1/1] port link-type access
    [*L2-GigabitEthernet0/1/2] port default vlan 200
    [*L2-GigabitEthernet0/1/2] quit
    [*L2] commit

  5. Configure hybrid VLAN-based Layer 2 protocol tunneling on the PEs:

    1. Configure Layer 2 forwarding on the PEs.

      Configure the PEs to add the default VLAN 200 to untagged Layer 2 PDUs and add the backbone network VLAN 100 to BPDUs that carry VLAN 100 and then tunnel them.

      # Configure PE1.

      [~PE1] vlan batch 100 200
      [*PE1] interface gigabitethernet 0/1/2
      [*PE1-GigabitEthernet0/1/2] undo shutdown
      [*PE1-GigabitEthernet0/1/2] port link-type trunk
      [*PE1-GigabitEthernet0/1/2] port trunk allow-pass vlan 100 200
      [*PE1-GigabitEthernet0/1/2] quit
      [*PE1] interface gigabitethernet 0/1/1
      [*PE1-GigabitEthernet0/1/1] undo shutdown
      [*PE1-GigabitEthernet0/1/1] port link-type dot1q-tunnel
      [*PE1-GigabitEthernet0/1/1] port default vlan 100
      [*PE1-GigabitEthernet0/1/1] commit

      # Configure PE2.

      [~PE2] vlan batch 100 200
      [*PE2] interface gigabitethernet 0/1/2
      [*PE2-GigabitEthernet0/1/2] undo shutdown
      [*PE2-GigabitEthernet0/1/2] port link-type trunk
      [*PE2-GigabitEthernet0/1/2] port trunk allow-pass vlan 100 200
      [*PE2-GigabitEthernet0/1/2] quit
      [*PE2] interface gigabitethernet 0/1/1
      [*PE2-GigabitEthernet0/1/1] undo shutdown
      [*PE2-GigabitEthernet0/1/1] port link-type dot1q-tunnel
      [*PE2-GigabitEthernet0/1/1] port default vlan 100
      [*PE2-GigabitEthernet0/1/1] commit
    2. Disable STP on PEs' user-side interfaces and enable Layer 2 protocol tunneling on both tagged and untagged interfaces.

      # Configure PE1.

      [~PE1-GigabitEthernet0/1/1] stp disable
      [*PE1-GigabitEthernet0/1/1] l2protocol-tunnel stp enable
      [*PE1-GigabitEthernet0/1/1] l2protocol-tunnel stp enable
      [*PE1-GigabitEthernet0/1/1] quit
      [*PE1] commit

      # Configure PE1.

      [~PE2-GigabitEthernet0/1/1] stp disable
      [*PE2-GigabitEthernet0/1/1] l2protocol-tunnel stp enable
      [*PE2-GigabitEthernet0/1/1] quit
      [*PE2] commit
    3. Configure the PEs to replace the multicast destination MAC address in the BPDUs from the CEs.

      # Configure PE1.

      [~PE1] l2protocol-tunnel stp group-mac 0100-5e00-0011
      [*PE1] commit

      # Configure PE2.

      [~PE2] l2protocol-tunnel stp group-mac 0100-5e00-0011
      [*PE2] commit

  6. Configure Layer 2 forwarding on the P.

    [~P] vlan batch 100 200
    [*P] interface gigabitethernet 0/1/2
    [*P-GigabitEthernet0/1/2] undo shutdown
    [*P-GigabitEthernet0/1/2] port link-type trunk
    [*P-GigabitEthernet0/1/2] port trunk allow-pass vlan 100 200
    [*P-GigabitEthernet0/1/2] quit
    [*P] interface gigabitethernet 0/1/1
    [*P-GigabitEthernet0/1/1] undo shutdown
    [*P-GigabitEthernet0/1/1] port link-type trunk
    [*P-GigabitEthernet0/1/1] port trunk allow-pass vlan 100 200
    [*P-GigabitEthernet0/1/1] quit
    [*P] commit

  7. Verify the configuration.

    After completing the configurations, run the display l2protocol-tunnel group-mac command on the PEs to view Layer 2 protocol tunneling information, such as the tunneled Layer 2 protocol names, protocol types, multicast destination MAC addresses, and specified multicast MAC addresses (group MAC addresses).

    The following example uses the command output on PE1.

    [~PE1] display l2protocol-tunnel group-mac stp
    Protocol         Protocol-MAC   Group-MAC       
    -----------------------------------------------------------------------------
    stp              0180-c200-0000 0100-5e00-0011 

    After completing the configurations, run the display stp brief command on the CEs to view the MSTP port role. The following example uses the command output on CE1 and CE2. The command output shows that GE 0/1/1 on CE1 is the root port and GE 0/1/1 on CE2 is the designated port.

    [~CE1] display stp brief
     MSTID  Port                        Role  STP State     Protection   Cost   Edged
         0  GigabitEthernet0/1/1        ROOT  forwarding    none       199999   disable
    [~CE2] display stp brief
     MSTID  Port                        Role  STP State     Protection   Cost   Edged
         0  GigabitEthernet0/1/1        DESI  forwarding    none       199999   disable

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 100
    #
    stp enable
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100
     stp bpdu vlan 100
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 100
    #
    stp enable
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100
     stp bpdu vlan 100
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 100 200
    #
    l2protocol-tunnel stp group-mac 0100-5e00-0011
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type dot1q-tunnel
     port default vlan 100
     stp disable
     l2protocol-tunnel stp enable
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 100 200
    #
    l2protocol-tunnel stp group-mac 0100-5e00-0011
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type dot1q-tunnel
     port default vlan 100
     stp disable
     l2protocol-tunnel stp enable
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • P configuration file

    #
    sysname P
    #
    vlan batch 100 200
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • L1 configuration file

    #
    sysname L1
    #
    vlan batch 100 200
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     port link-type access
     port default vlan 200
    #
    interface GigabitEthernet0/1/3
     undo shutdown
     port link-type hybrid
     port hybrid tagged 100
     port hybrid untagged 200
    #
    return
  • L2 configuration file

    #
    sysname L2
    #
    vlan batch 100 200
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     port link-type access
     port default vlan 200
    #
    interface GigabitEthernet0/1/3
     undo shutdown
     port link-type hybrid
     port hybrid tagged 100
     port hybrid untagged 200
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055378

Views: 16520

Downloads: 34

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next