No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - LAN Access and MAN Access
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring ERPS over VPLS in Scenarios Where a CE Is Dual-Homed to PEs Through VLANIF Interfaces

Example for Configuring ERPS over VPLS in Scenarios Where a CE Is Dual-Homed to PEs Through VLANIF Interfaces

To configure ERPS over VPLS in scenarios where a CE is dual-homed to PEs through VLANIF interfaces, enable ERPS on CE1, CE2, PE1, and PE2 and configure the ERPS sub-ring to access the VPLS network in NVC mode.

Networking Requirements

On the VPLS network shown in Figure 11-10, CE1 is dual-homed to PE1 and PE2 through VLANIF interfaces. However, this networking will cause PE3 to receive two copies of CE1 traffic from both PE1 and PE2. To prevent this problem, enable ERPS on CE1, CE2, PE1, and PE2 and configure CE2's GE 0/2/0 as an RPL owner port to block traffic from CE1. In this way, CE1's traffic reaches PE3 over PE1 without traversing CE2, thereby preventing any duplicate traffic or loops.

Figure 11-10 Configuring ERPS over VPLS in scenarios where CE1 is dual-homed to PE1 and PE2 through VLANIF interfaces
NOTE:

Interface 1, interface 2, and interface 3 stand for GE 0/1/0, GE 0/2/0, and GE 0/3/0, respectively.



NOTE:
  • The configurations of ERPS over VPLS in CE single-homing scenarios are similar to those in CE dual-homing scenarios. This section uses CE dual-homing scenarios as an example.

  • If an ERPS ring has revertive switching enabled and an AC interface recovers, it is not recommended that you use the clear command to trigger revertive switching before the wait to restore (WTR) or wait to block (WTB) timer expires. If you do so and the VSI bound to the AC interface recovers later than the AC interface, traffic will be interrupted for a long time.

Device

Interface

IP Address

PE1

GE 0/1/0

--

GE 0/2/0

10.1.1.1/24

GE 0/3/0

10.3.1.1/24

Loopback1

1.1.1.1/32

PE2

GE 0/1/0

--

GE 0/2/0

10.2.1.1/24

GE 0/3/0

10.3.1.2/24

Loopback1

2.2.2.2/32

PE3

GE 0/1/0

10.1.1.2/24

GE 0/2/0

10.2.1.2/24

Loopback1

3.3.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on the VPLS backbone network to allow the PEs to communicate.

  2. Configure basic MPLS functions and establish LDP LSPs on the VPLS backbone network.

  3. Establish VPLS connections between each two PEs and bind each VLANIF interface to a VSI.

  4. Configure ERPS.

    • Enable ERPS on CE1, CE2, PE1, and PE2.
    • Configure PE2's GE 0/2/0 as an RPL owner port.

Data Preparation

To complete the configuration, you need the following data:

  • Data needed for configuring OSPF: IP address of each interface, OSPF process ID, and OSPF domain ID

  • MPLS LSR IDs (used as peer addresses)

  • VSI names and VSI IDs

  • VLANIF interfaces bound to VSIs

  • ERPS ring ID, control VLAN ID, and RPL owner port number

Procedure

  1. Configure interface IP addresses and an IGP on the VPLS backbone network to allow PEs to communicate. This example uses OSPF as the IGP.

    When configuring OSPF, configure each PE to advertise their 32-bit IP addresses (used as LSR IDs) of loopback interfaces.

    For configuration details, see Configuration Files in this section.

  2. Configure basic MPLS functions and establish dynamic LDP LSPs between each two PEs.

    # Configure PE1.

    [~PE1] mpls lsr-id 1.1.1.1
    [*PE1] mpls
    [*PE1-mpls] quit
    [*PE1] mpls ldp
    [*PE1-mpls-ldp] quit
    [*PE1] interface gigabitethernet 0/2/0
    [*PE1-GigabitEthernet0/2/0] mpls
    [*PE1-GigabitEthernet0/2/0] mpls ldp
    [*PE1-GigabitEthernet0/2/0] quit
    [*PE1] interface gigabitethernet 0/3/0
    [*PE1-GigabitEthernet0/3/0] mpls
    [*PE1-GigabitEthernet0/3/0] mpls ldp
    [*PE1-GigabitEthernet0/3/0] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] mpls lsr-id 2.2.2.2
    [*PE2] mpls
    [*PE2-mpls] quit
    [*PE2] mpls ldp
    [*PE2-mpls-ldp] quit
    [*PE2] interface gigabitethernet 0/2/0
    [*PE2-GigabitEthernet0/2/0] mpls
    [*PE2-GigabitEthernet0/2/0] mpls ldp
    [*PE2-GigabitEthernet0/2/0] quit
    [*PE2] interface gigabitethernet 0/3/0
    [*PE2-GigabitEthernet0/3/0] mpls
    [*PE2-GigabitEthernet0/3/0] mpls ldp
    [*PE2-GigabitEthernet0/3/0] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] mpls lsr-id 3.3.3.3
    [*PE3] mpls
    [*PE3-mpls] quit
    [*PE3] mpls ldp
    [*PE3-mpls-ldp] quit
    [*PE3] interface gigabitethernet 0/1/0
    [*PE3-gigabitethernet0/1/0] mpls
    [*PE3-gigabitethernet0/1/0] mpls ldp
    [*PE3-gigabitethernet0/1/0] quit
    [*PE3] interface gigabitethernet 0/2/0
    [*PE3-GigabitEthernet0/2/0] mpls
    [*PE3-GigabitEthernet0/2/0] mpls ldp
    [*PE3-GigabitEthernet0/2/0] quit
    [*PE3] commit

  3. Enable MPLS L2VPN on each PE.

    # Configure PE1.

    [~PE1] mpls l2vpn
    [*PE1-l2vpn] commit
    [~PE1-l2vpn] quit

    # Configure PE2.

    [~PE2] mpls l2vpn
    [*PE2-l2vpn] commit
    [~PE2-l2vpn] quit

    # Configure PE3.

    [~PE3] mpls l2vpn
    [*PE3-l2vpn] commit
    [~PE3-l2vpn] quit

  4. Configure VPLS.

    # Configure PE1.

    [~PE1] vsi s1 static
    [*PE1-vsi-s1] pwsignal ldp
    [*PE1-vsi-s1-ldp] vsi-id 10
    [*PE1-vsi-s1-ldp] peer 2.2.2.2
    [*PE1-vsi-s1-ldp] peer 3.3.3.3
    [*PE1-vsi-s1-ldp] quit
    [*PE1-vsi-s1] quit
    [*PE1] commit
    [~PE1] vlan 10
    [*PE1-vlan10] quit
    [*PE1] interface vlanif10
    [*PE1-Vlanif10] l2 binding vsi s1
    [*PE1-Vlanif10] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] vsi s1 static
    [*PE2-vsi-s1] pwsignal ldp
    [*PE2-vsi-s1-ldp] vsi-id 10
    [*PE2-vsi-s1-ldp] peer 1.1.1.1
    [*PE2-vsi-s1-ldp] peer 3.3.3.3
    [*PE2-vsi-s1-ldp] quit
    [*PE2-vsi-s1] quit
    [*PE2] commit
    [~PE2] vlan 10
    [*PE2-vlan10] quit
    [*PE2] interface vlanif10
    [*PE2-Vlanif10] l2 binding vsi s1
    [*PE2-Vlanif10] quit
    [*PE2] commit

    # Configure PE3.

    [~PE3] vsi s1 static
    [*PE3-vsi-s1] pwsignal ldp
    [*PE3-vsi-s1-ldp] vsi-id 10
    [*PE3-vsi-s1-ldp] peer 1.1.1.1
    [*PE3-vsi-s1-ldp] peer 2.2.2.2
    [*PE3-vsi-s1-ldp] quit
    [*PE3-vsi-s1] quit
    [*PE3] commit

  5. Configure ERPS on PE1, PE2, CE1, and CE2.

    # Configure PE1.

    [~PE1] erps ring 1
    [*PE1-erps-ring1] control-vlan 100
    [*PE1-erps-ring1] protected-instance 0 to 4094
    [*PE1-erps-ring1] version v2
    [*PE1-erps-ring1] sub-ring
    [*PE1-erps-ring1] quit
    [*PE1] commit
    [~PE1] interface gigabitethernet 0/1/0
    [*PE1-gigabitethernet0/1/0] undo shutdown
    [*PE1-gigabitethernet0/1/0] portswitch
    [*PE1-gigabitethernet0/1/0] port link-type trunk
    [*PE1-gigabitethernet0/1/0] port trunk allow-pass vlan 10 100
    [*PE1-gigabitethernet0/1/0] stp disable
    [*PE1-gigabitethernet0/1/0] erps ring 1
    [*PE1-gigabitethernet0/1/0] commit
    [~PE1-gigabitethernet0/1/0] quit

    # Configure PE2.

    [~PE2] erps ring 1
    [*PE2-erps-ring1] control-vlan 100
    [*PE2-erps-ring1] protected-instance 0 to 4094
    [*PE2-erps-ring1] version v2
    [*PE2-erps-ring1] sub-ring
    [*PE2-erps-ring1] quit
    [*PE2] commit
    [~PE2] interface gigabitethernet 0/1/0
    [*PE2-gigabitethernet0/1/0] undo shutdown
    [*PE2-gigabitethernet0/1/0] portswitch
    [*PE2-gigabitethernet0/1/0] port link-type trunk
    [*PE2-gigabitethernet0/1/0] port trunk allow-pass vlan 10 100
    [*PE2-gigabitethernet0/1/0] stp disable
    [*PE2-gigabitethernet0/1/0] erps ring 1
    [*PE2-gigabitethernet0/1/0] commit
    [~PE2-gigabitethernet0/1/0] quit

    # Configure CE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE1
    [*HUAWEI] commit
    [~CE1] erps ring 1
    [*CE1-erps-ring1] control-vlan 100
    [*CE1-erps-ring1] protected-instance 0 to 4094
    [*CE1-erps-ring1] version v2
    [*CE1-erps-ring1] sub-ring
    [*CE1-erps-ring1] quit
    [*CE1] commit
    [~CE1] interface gigabitethernet 0/1/0
    [*CE1-gigabitethernet0/1/0] undo shutdown
    [*CE1-gigabitethernet0/1/0] portswitch
    [*CE1-gigabitethernet0/1/0] port link-type trunk
    [*CE1-gigabitethernet0/1/0] port trunk allow-pass vlan 10 100
    [*CE1-gigabitethernet0/1/0] stp disable
    [*CE1-gigabitethernet0/1/0] erps ring 1
    [*CE1-gigabitethernet0/1/0] commit
    [~CE1-gigabitethernet0/1/0] quit
    [~CE1] interface gigabitethernet 0/2/0
    [*CE1-gigabitethernet0/2/0] undo shutdown
    [*CE1-gigabitethernet0/2/0] portswitch
    [*CE1-gigabitethernet0/2/0] port link-type trunk
    [*CE1-gigabitethernet0/2/0] port trunk allow-pass vlan 10 100
    [*CE1-gigabitethernet0/2/0] stp disable
    [*CE1-gigabitethernet0/2/0] erps ring 1
    [*CE1-gigabitethernet0/2/0] commit
    [~CE1-gigabitethernet0/2/0] quit

    # Configure CE2.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE2
    [*HUAWEI] commit
    [~CE2] erps ring 1
    [*CE2-erps-ring1] control-vlan 100
    [*CE2-erps-ring1] protected-instance 0 to 4094
    [*CE2-erps-ring1] version v2
    [*CE2-erps-ring1] sub-ring
    [*CE2-erps-ring1] quit
    [*CE2] commit
    [~CE2] interface gigabitethernet 0/1/0
    [*CE2-gigabitethernet0/1/0] undo shutdown
    [*CE2-gigabitethernet0/1/0] portswitch
    [*CE2-gigabitethernet0/1/0] port link-type trunk
    [*CE2-gigabitethernet0/1/0] port trunk allow-pass vlan 10 100
    [*CE2-gigabitethernet0/1/0] stp disable
    [*CE2-gigabitethernet0/1/0] erps ring 1
    [*CE2-gigabitethernet0/1/0] commit
    [~CE2-gigabitethernet0/1/0] quit
    [~CE2] interface gigabitethernet 0/2/0
    [*CE2-gigabitethernet0/2/0] undo shutdown
    [*CE2-gigabitethernet0/2/0] portswitch
    [*CE2-gigabitethernet0/2/0] port link-type trunk
    [*CE2-gigabitethernet0/2/0] port trunk allow-pass vlan 10 100
    [*CE2-gigabitethernet0/2/0] stp disable
    [*CE2-gigabitethernet0/2/0] erps ring 1 rpl owner
    [*CE2-gigabitethernet0/2/0] commit
    [~CE2-gigabitethernet0/2/0] quit

  6. Verify the configuration.

    After the configurations are complete, run the display vsi name s1 verbose command on PE3. The command output shows that PE3 has established two PWs: one with PE1 (1.1.1.1), one with PE2 (2.2.2.2.).

    [~PE3] display vsi name s1 verbose
     ***VSI Name               : s1
        Administrator VSI      : no
        Isolate Spoken         : disable
        VSI Index              : 2
        PW Signaling           : ldp
        Member Discovery Style : static
        Bridge-domain Mode     : disable
        PW MAC Learn Style     : unqualify
        Encapsulation Type     : vlan
        MTU                    : 1500
        Diffserv Mode          : uniform
        Service Class          : --
        Color                  : --
        DomainId               : 255
        Domain Name            :
        Ignore AcState         : disable
        P2P VSI                : disable
        Multicast Fast Swicth  : disable
        Create Time            : 0 days, 1 hours, 19 minutes, 38 seconds
        VSI State              : up
        Resource Status        : Valid
    
        VSI ID                 : 10
       *Peer Router ID         : 1.1.1.1
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 32891
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0x0000000001004c4b41 
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : -- 
        CKey                   : 2
        NKey                   : 1862271177
        Stp Enable             : 0
        PwIndex                : 1
        Control Word           : disable
       *Peer Router ID         : 2.2.2.2
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 32892
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0x0000000001004c4b42 
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : -- 
        CKey                   : 2
        NKey                   : 1862271178
        Stp Enable             : 0
        PwIndex                : 2
        Control Word           : disable
     
      **PW Information:
    
       *Peer Ip Address        : 1.1.1.1
        PW State               : up
        Local VC Label         : 32891
        Remote VC Label        : 32890
        Remote Control Word    : disable
        PW Type                : label
        Tunnel ID              : 0x0000000001004c4b41 
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : --
        Ckey                   : 2
        Nkey                   : 1862271177
        Main PW Token          : 0x0
        Slave PW Token         : 0x0
        Tnl Type               : ldp
        OutInterface           : LDP LSP
        Backup OutInterface    : --
        Stp Enable             : 0
        Mac Flapping           : 0
        PW Last Up Time        : 2013/12/26 17:35:12
        PW Total Up Time       : 0 days, 1 hours, 19 minutes, 38 seconds  
       *Peer Ip Address        : 2.2.2.2
        PW State               : up
        Local VC Label         : 32892
        Remote VC Label        : 32893
        Remote Control Word    : disable
        PW Type                : label
        Tunnel ID              : 0x0000000001004c4b42 
        Broadcast Tunnel ID    : --
        Broad BackupTunnel ID  : --
        Ckey                   : 2
        Nkey                   : 1862271178
        Main PW Token          : 0x0
        Slave PW Token         : 0x0
        Tnl Type               : ldp
        OutInterface           : LDP LSP
        Backup OutInterface    : --
        Stp Enable             : 0
        Mac Flapping           : 0
        PW Last Up Time        : 2013/12/28 10:35:45
        PW Total Up Time       : 0 days, 1 hours, 19 minutes, 45 seconds

    Run the display erps command on CE2. The command output shows that the link between CE1 and CE2 is blocked.

    [~CE2] display erps
    D  : Discarding
    F  : Forwarding
    R  : RPL Owner
    N  : RPL Neighbour
    FS : Forced Switch
    MS : Manual Switch
    Total number of rings configured = 1
    Ring  Control  WTR Timer  Guard Timer  Port 1              Port 2
    ID    VLAN     (min)      (csec)
    --------------------------------------------------------------------------------
       1       100         5          200  (F)GE0/1/0          (D,R)GE0/2/0
    --------------------------------------------------------------------------------
    

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 10 100
    #
    erps ring 1
     control-vlan 100
     protected-instance 0 to 4094
     version v2
     sub-ring
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls l2vpn
    #
    vsi s1 static
     pwsignal ldp
      vsi-id 10
      peer 2.2.2.2
      peer 3.3.3.3
    #
    mpls ldp
    #
    interface Vlanif10
     l2 binding vsi s1
     suppression enable percent
     broadcast-suppression percent 1
     multicast-suppression percent 1
     unknown-unicast-suppression percent 1
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 10.3.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 10 100
    #
    erps ring 1
     control-vlan 100
     protected-instance 0 to 4094
     version v2
     sub-ring
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls l2vpn
    #
    vsi s1 static
     pwsignal ldp
      vsi-id 10
      peer 1.1.1.1
      peer 3.3.3.3
    #
    mpls ldp
    #
    interface Vlanif10
     l2 binding vsi s1
     suppression enable percent
     broadcast-suppression percent 1
     multicast-suppression percent 1
     unknown-unicast-suppression percent 1
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
    
  • PE3 configuration file

    #
    sysname PE3
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls l2vpn
    #
    vsi s1 static
     pwsignal ldp
      vsi-id 10
      peer 1.1.1.1
      peer 2.2.2.2
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/0
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
    
  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 10 100
    #
    erps ring 1
     control-vlan 100
     protected-instance 0 to 4094
     version v2
     sub-ring
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1
    #
    interface GigabitEthernet0/2/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1
    #
    return
    
  • CE2 configuration file

    #
    sysname CE1
    #
    vlan batch 10 100
    #
    erps ring 1
     control-vlan 100
     protected-instance 0 to 4094
     version v2
     sub-ring
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1
    #
    interface GigabitEthernet0/2/0
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10 100
     stp disable
     erps ring 1 rpl owner
    #
    return
    
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055378

Views: 18753

Downloads: 35

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next