No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - Security 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - Security
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Device to Obtain Forwarded Packet Headers

Example for Configuring a Device to Obtain Forwarded Packet Headers

This section provides an example for configuring a device to obtain forwarded packet headers.

Networking Requirements

As shown in Figure 10-4, PC1 accesses the Internet over Device A and Device B. Video quality on PC1 deteriorates, which may be caused by a fault that occurred on Device B. To find out the reason why video quality deteriorates, configure Device A to obtain packet headers forwarded by Device B to the inbound interface GE 0/1/0 of Device A.

Figure 10-4 Configuring Device A to obtain forwarded packet headers
NOTE:

Interfaces 1, 2 and 3 in this example are GE 0/1/0, GE 0/1/1 and GE 0/1/2, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an access control list (ACL) rule.

  2. Configure Device A to obtain forwarded packet headers.

Data Preparation

To complete the configuration, you need the following data:
  • Interface IP addresses
  • ACL number
  • Packet header obtaining timeout time, number of obtained packet headers, and packet header obtaining file name

Procedure

  1. Configure interface IP addresses and routing protocol. The configuration details are not provided.
  2. Configure an ACL rule.

    <DeviceA> system-view
    [DeviceA] acl number 2001
    [DeviceA-acl4-basic-2001] rule permit source 10.1.1.1 0.0.0.0
    [DeviceA-acl4-basic-2001] commit
    [DeviceA-acl4-basic-2001] quit
    [DeviceA] quit

  3. Configure Device A to obtain forwarded packet headers.

    <DeviceA> capture-packet forwarding interface gigabitethernet 0/1/0 inbound acl 2001 time-out 3600 packet-len 62 packet-num 900

  4. View the configuration and the packet header obtaining file.

    # View the configuration.

    <DeviceA> display capture-packet config-state
    Capture-Packet Index 1
    Type        : forwarding
    Interface   : GigabitEthernet
    Direction   : inbound
    ACL         : 2001
    File Name   : cfcard:/capture_fwd_GigabitEthernet3.0.0_2012-05-03-14-25-42.cap
    Time-out    : 3600 seconds
    Packet-num  : 900
    Packet-len  : 62
    BufferOnly  : disabled 

    # View the packet header obtaining file.

    <DeviceA> display capture-packet file cfcard:/capture_fwd_GigabitEthernet3.0.0_2012-05-03-14-25-42.cap
    a1 b2 c3 d4 00 02 00 04 00 00 00 00 00 00 00 00
    00 00 ff ff 00 00 00 09 4d 10 36 db 00 0a d5 81
    00 00 00 0c 00 00 00 0c ff 03 c0 21 09 9d 00 08
    8a 8c bc c3 4d 10 36 db 00 0a d6 ae

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    acl number 2001
     rule 5 permit source 10.1.1.1 0
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/1/2
     undo shutdown
     ip address 10.1.5.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055397

Views: 21851

Downloads: 39

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next