No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Combination of 1588v2, Synchronous Ethernet, and WAN to Implement Frequency Synchronization

Example for Configuring the Combination of 1588v2, Synchronous Ethernet, and WAN to Implement Frequency Synchronization

This section provides an example for configuring the combination of 1588v2, synchronous Ethernet, and wide area network (WAN) to implement frequency synchronization. Only GE interfaces can run 1588v2. When 10GE WAN links and 1588v2-incapable Ethernet links are used, the combination of 1588v2, synchronous Ethernet, and WAN clock techniques can be configured to implement network-wide clock synchronization.

Networking Requirements

A carrier runs the mobile bearer network shown in Figure 9-13, which consists of both 10 GE WAN links and Ethernet links. Each bearer network device and NodeB are connected to a BITS server to implement frequency synchronization. This deployment imposes high installation and maintenance costs.

The carrier purchases 1588v2 devices to upgrade the clock synchronization network. Only a single BITS server can meet frequency requirements of wireless bearer services.

Device B imports BITS clock signals and forwards the signals to NodeBs along specific links:
  • Device B forwards the signals to Device C along a WAN link. Device C forwards the clock signals to Device D along a 1588v2 link. Upon receipt, Device D sends the clock signals to NodeB-2 over an E1 link.
  • Device B uses synchronous Ethernet to forward the signals to Device A. Upon receipt, Device A use 1588v2 to send the signals to NodeB-1. 1588v2 packets are encapsulated using UDP.
Figure 9-13 Frequency synchronization using the combination of 1588v2, synchronous Ethernet, and WAN techniques
NOTE:

The configurations in this example are performed on Device A, Device B, Device C, and Device D. HUAWEI NE20E-S2 can function as Device A, Device B, Device C, and Device D.

Interfaces 1 and 2 in this example are GE 0/1/0, GE 0/2/0, respectively.



Device Name

Interface Name

Interface IP Address

Interface MAC Address

Device A

GE 0/2/0

10.0.0.2/24

-

Device A

GE 0/1/0

172.16.0.1/24

-

Device B

GE 0/1/0

10.0.0.1/24

-

Device B

GE 0/2/0

192.168.0.1/24

-

Device C

GE 0/2/0

192.168.0.2/24

-

Device C

GE 0/1/0

10.10.0.1/24

0000-1111-cccc

Device D

GE 0/1/0

10.10.0.2/24

0000-1111-dddd

NodeB-1

- -

0000-1111-b1b1

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure OSPF routes.

  2. Import BITS time signals to Device B.

  3. Configure Device A to use synchronous Ethernet to synchronize clock signals with Device B.

  4. Configure Device C to use WAN clock techniques to synchronize clock signals with Device B.

  5. Configure Device A as a BC to use UDP to encapsulate 1588v2 packets and advertise clock signals to NodeB-1.

  6. Configure Device C as a BC to use UDP to encapsulate 1588v2 packets and advertise clock signals to Device D.

  7. Configure Device D as an OC to synchronize clock signals with Device C.

  8. Configure Device D to use WAN clock techniques to advertise clock signals to NodeB-2.

Data Preparation

To complete the configuration, you need the following data:

  • Delay measurement mechanism (Delay)

Procedure

  1. Configure a data link layer protocol and assign an IP address to each interface. The configuration details are not provided here.
  2. Configure OSPF to ensure that devices are reachable to each other. The configuration details are not provided here.
  3. Import BITS0 signals to Device B.

    [*DeviceB] clock bits-type bits0 2mhz
    [*DeviceB] clock source bits0 synchronization enable
    [*DeviceB] clock source bits0 priority 1
    [*DeviceB] commit

  4. Configure Device A to use synchronous Ethernet to synchronize clock signals with Device B.
    1. Enable synchronous Ethernet on Device B.

      [~DeviceB] interface gigabitethernet 0/1/0
      [~DeviceB-GigabitEthernet0/1/0] clock synchronization enable
      [*DeviceB-GigabitEthernet0/1/0] commit

    2. Enable synchronous Ethernet on Device A.

      [~DeviceA] interface gigabitethernet 0/2/0
      [~DeviceA-GigabitEthernet0/2/0] clock synchronization enable
      [*DeviceA-GigabitEthernet0/2/0] clock priority 1
      [*DeviceA-GigabitEthernet0/2/0] commit
      [~DeviceA-GigabitEthernet0/2/0] quit
      [*DeviceA] clock manual source interface gigabitethernet 0/2/0
      [*DeviceA] commit

  5. Configure Device C to use WAN clock techniques to synchronize clock signals with Device B.
    1. Configure the 10GE WAN interface named GE 0/2/0 on Device B.

      [~DeviceB] interface gigabitethernet 0/2/0
      [~DeviceB-GigabitEthernet0/2/0] clock synchronization enable
      [*DeviceB-GigabitEthernet0/2/0] commit

    2. Configure the 10GE WAN interface named GE 0/2/0 on Device C.

      [~DeviceC] interface gigabitethernet 0/2/0
      [~DeviceC-GigabitEthernet0/2/0] clock synchronization enable
      [*DeviceC-GigabitEthernet0/2/0] commit

  6. Configure Device A as a BC to use UDP to encapsulate 1588v2 packets and advertise clock signals to NodeB-1.

    [*DeviceA] ptp enable
    [*DeviceA] ptp device-type bc
    [*DeviceA] ptp domain 1
    [*DeviceA] ptp clock-source local priority1 0
    [*DeviceA] commit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ptp delay-mechanism delay
    [*DeviceA-GigabitEthernet0/1/0] ptp enable
    [*DeviceA-GigabitEthernet0/1/0] ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
    [*DeviceA-GigabitEthernet0/1/0] ptp udp-egress destination-mac 0000–1111–b1b1
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] quit

  7. Configure NodeB-1 to receive 1588v2 packets that are sent by Device A. The configuration details are not provided here.
  8. Configure Device C as a BC to use UDP to encapsulate 1588v2 packets and advertise clock signals to Device D.

    [*DeviceC] ptp enable
    [*DeviceC] ptp device-type bc
    [*DeviceC] ptp domain 2
    [*DeviceC] ptp clock-source local priority1 0
    [*DeviceC] commit
    [~DeviceC] interface gigabitethernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] ptp delay-mechanism delay
    [*DeviceC-GigabitEthernet0/1/0] ptp enable
    [*DeviceC-GigabitEthernet0/1/0] ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
    [*DeviceC-GigabitEthernet0/1/0] ptp udp-egress destination-mac 0000–1111–dddd
    [*DeviceC-GigabitEthernet0/1/0] commit
    [~DeviceC-GigabitEthernet0/1/0] quit

  9. Configure Device D as an OC to receive 1588v2 packets sent by Device C and synchronize clock signals with Device C.

    [*DeviceD] ptp enable
    [*DeviceD] ptp device-type oc
    [*DeviceD] ptp domain 2
    [*DeviceD] ptp clock-source local priority1 128
    [*DeviceD] clock manual source ptp
    [*DeviceD] commit
    [
    ~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] ptp delay-mechanism delay
    [*DeviceD-GigabitEthernet0/1/0] ptp enable
    [*DeviceD-GigabitEthernet0/1/0] ptp udp-egress source-ip 10.10.0.2 destination-ip 10.10.0.1
    [*DeviceD-GigabitEthernet0/1/0] ptp udp-egress destination-mac 0000–1111–cccc
    [*DeviceD-GigabitEthernet0/1/0] commit
    [~DeviceD-GigabitEthernet0/1/0] quit

  10. Configure Device D to use WAN clock techniques to advertise clock signals to NodeB-2.
    1. Configure an E1 interface on Device D as the master clock.

      [*DeviceD] controller e1 0/2/0
      [*DeviceD-E1 0/2/0] clock master
      [*DeviceD-E1 0/2/0] commit

    2. Configure the interface connecting Device D to NodeB-2 as the slave clock. The configuration details are not provided here.

Configuration Files

  • Configuration file of Device A

    #
     sysname DeviceA
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
     ptp clock-source local priority1 0
    interface gigabitethernet 0/1/0
     undo shutdown
     ip address 172.16.0.2 255.255.255.0
     clock synchronization enable
     ptp delay-mechanism delay
     ptp enable
     ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
     ptp udp-egress destination-mac 0000–1111–b1b1
    interface gigabitethernet 0/2/0
     undo shutdown
     ip address 10.0.0.2 255.255.255.0
     clock synchronization enable
     clock priority 1
    #
     clock manual source interface gigabitethernet 0/2/0
    #
    ospf 1
     area 0.0.0.0
      network 10.0.0.0 0.0.0.255
      network 172.16.0.0 0.0.0.255
    #
    
  • Configuration file of Device B

    #
     sysname DeviceB
    #
     clock bits-type bits0 2mhz
     clock source bits0 synchronization enable
     clock source bits0 priority 1
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 10.0.0.1 255.255.255.0
     clock synchronization enable
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     clock synchronization enable
    #
    ospf 1
     area 0.0.0.0
      network 10.0.0.0 0.0.0.255
      network 192.168.0.0 0.0.0.255
    #
    
  • Configuration file of Device C

    #
     sysname DeviceC
    #
     ptp enable
     ptp device-type bc
     ptp domain 2
     ptp clock-source local priority1 0
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 10.10.0.1 255.255.255.0
     ptp delay-mechanism delay
     ptp enable
     ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
     ptp udp-egress destination-mac 0000–1111–dddd
    #
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     clock synchronization enable
    #
    ospf 1
     area 0.0.0.0
      network 10.10.0.0 0.0.0.255
      network 192.168.0.0 0.0.0.255
    #
    
  • Configuration file of Device D

    #
     sysname DeviceD
    #
     ptp enable
     ptp device-type oc
     ptp domain 2
     ptp clock-source local priority1 128
     clock manual source ptp
    interface gigabitethernet 0/1/0
     undo shutdown
     ip address 10.10.0.2 255.255.255.0
     ptp delay-mechanism delay
     ptp enable
     ptp udp-egress source-ip 10.10.0.2 destination-ip 10.10.0.1
     ptp udp-egress destination-mac 0000–1111–cccc
    controller e1 0/2/0
     clock master
    #
    ospf 1
     area 0.0.0.0
      network 10.10.0.0 0.0.0.255
    #
    
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055400

Views: 14425

Downloads: 26

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next