No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring SNMP Proxy Using Default Parameter Settings

Example for Configuring SNMP Proxy Using Default Parameter Settings

This section provides an example of how to configure Simple Network Management Protocol (SNMP) proxy using default parameter settings.

Networking Requirements

SNMP communicates management information between an NMS and a device, such as a router, so that the NMS can manage the device. If the NMS and device use different versions of SNMP, the NMS cannot manage the device.

To solve this problem, configure SNMP proxy on a middle-point device between the NMS and managed device, as shown in Figure 16-16. The NMS manages the middle-point device and managed device as an independent network element, reducing the number of managed network elements and management costs.
Figure 16-16 Networking diagram for configuring SNMP proxy using default parameter settings
NOTE:

Interface 1 and Interfaces 2 in this example are GE 0/1/0 and GE 0/1/1 respectively.

Configuring SNMP proxy using default parameter settings requires only one configuration command and is easy to implement. After you configure SNMP proxy, the middle-point device communicates with the managed device based on the default parameter settings used in the configuration command.

Precautions

In this type of SNMP proxy configuration, you do not need to configure SNMP on the managed device.

Before you configure SNMP proxy using default parameter settings, be sure to use the display default-parameter ccu command to check the default parameter settings to be used in the configuration command.
<HUAWEI> display default-parameter ccu
Remote CCU NO. 1
-------------------------------------------------------
    VPN instance               : ccu_private_vpn
    Local IP address           : 192.168.1.1
    CCU IP address             : 192.168.1.100
    SNMP version               : V2c
    SNMP proxy security        : ******
    CCU agent engineId         : 800007DB01192168001100
    CCU targetHost             : proxy_host@ccu1
    EMS targetHost             : proxy_host@ems
    SNMP proxy read rule       : proxy_rule_read@ccu1
    SNMP proxy write rule      : proxy_rule_write@ccu1
    SNMP proxy trap rule       : proxy_rule_trap@ccu1
-------------------------------------------------------

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure interface IP addresses for the NMS, middle-point device, and managed device to communicate.
  2. Configure virtual private network (VPN) information on the managed device for the middle-point device and managed device to communicate over a VPN.
  3. Configure SNMP proxy on the middle-point device using default parameter settings, so that you can use the middle-point device to manage the managed device.

Data Preparation

To complete the configuration, you need the following data:
  • Types and numbers of the interfaces that connect the middle-point device and managed device
  • Type, number, and IP address of the interface that connects the middle-point device to the NMS

Procedure

  1. Configure an IP address for the interface that connects the middle-point device to the NMS.

    [~PE] interface gigabitethernet 0/1/0
    [~PE-GigabitEthernet0/1/0] ip address 3.1.1.1 24
    [*PE-GigabitEthernet0/1/0] commit
    [~PE-GigabitEthernet0/1/0] quit
    NOTE:

    The IP address of the interface that connects the middle-point device to the managed device does not need to be configured. After SNMP proxy is configured using default parameter settings, the middle-point device automatically assigns an IP address to this interface.

    Configuring an IP address for the interface that connects the managed device to the middle-point device is similar to this step.

  2. Configure VPN information on the managed device.

    For detailed configurations, see Configuring Basic BGP/MPLS IP VPN in NE20E Configuration Guide - VPN.

    NOTE:

    The VPN instance name configured on the managed device must be the same as that on the middle-point device.

  3. Configure SNMP proxy using default parameter settings on the middle-point device.

    [~PE] set ccu target-host 192.168.1.100 vpn-instance ccu_private_vpn GigabitEthernet 0/1/1
    [*PE] commit

  4. Verify the configuration.

    NOTE:

    The following operations can be performed only on the middle-point device.

    # Run the display snmp-agent proxy community command. SNMP proxy community information is displayed.

    [~PE] display snmp-agent proxy community
       Proxy Community name : %#%#qTp*MccD#Z[sHw4"pbzVHzAfO]gWN;h#30K=)%}X1jIHNF<QdMskYG$9xj:9k\EZN6Mi!Hrt@\Oa8tqP%#%#
           Remote engine ID : 800007DB01192168001100 active
           Storage-type     : nonVolatile 

    # Run the display snmp-agent proxy rule command. Proxy rules for SNMP packets are displayed.

    [~PE] display snmp-agent proxy rule
       Proxy Rule name : proxy_rule_read@ccu1
           Type             : read
           Remote engine ID : 800007DB01192168001100
           Host name        : proxy_host@ccu1
           Security name    : %#%#[7SCH}$<HX.vZ8%7YS3L:IsCPA^LbRRK-`/6"i"$%#%#
           Version          : v2c
           Level            : No authentication and privacy
    
       Proxy Rule name : proxy_rule_trap@ccu1
           Type             : trap
           Remote engine ID : 800007DB01192168001100
           Host name        : proxy_host@ems
           Security name    : %#%#yowoL2.\8~LKL5*|k[h'3`Nv:DX;Y-$tU=SWNu[*%#%#
           Version          : v2c
           Level            : No authentication and privacy
    
       Proxy Rule name : proxy_rule_write@ccu1
           Type             : write
           Remote engine ID : 800007DB01192168001100
           Host name        : proxy_host@ccu1
           Security name    : %#%#p,[';vISF&eOO7AF2%oAA[p`U\b6wIipjB,:x^EJ%#%#
           Version          : v2c
           Level            : No authentication and privacy

    # Run the display snmp-agent proxy target-host command. Target host information is displayed.

    [~PE] display snmp-agent proxy target-host
    Proxy target-host NO. 1
    -----------------------------------------------------------
      Host-name        : proxy_host@ccu1
      IP-address       : 192.168.1.100
      Port             : 161
      Timeout          : 15
      Source interface : -
      VPN instance     : -
      Security name    :  %#%#yowoL2.\8~LKL5*|k[h'3`Nv:DX;Y-$tU=SWNu[*%#%# 
      Version          : v2c
      Level            : No authentication and privacy
    -----------------------------------------------------------
    
    Proxy target-host NO. 2
    -----------------------------------------------------------
      Host-name        : proxy_host@ems
      IP-address       : 2.1.1.1
      Port             : 162
      Timeout          : 15
      Source interface : -
      VPN instance     : ccu_private_vpn
      Security name    : %#%#D1$/6-y>U4Y\pXU}y8H3(,3s*gIyD)-Fq'O1/+uA%#%# 
      Version          : v2c
      Level            : No authentication and privacy
    -----------------------------------------------------------

Configuration Files

The following lists only the configuration file for the middle-point device.
#
sysname PE
#
ip vpn-instance ccu_private_vpn
 ipv4-family
#
interface GigabitEthernet0/1/0
 undo shutdown
 ip address 3.1.1.1 255.255.255.0
#
interface GigabitEthernet0/1/1
 undo shutdown
 ip binding vpn-instance ccu_private_vpn
 ip address 192.168.1.1 255.255.255.0
#
snmp-agent
snmp-agent local-engineid 800007DB0338EBD9110010
#
snmp-agent sys-info version all
#
snmp-agent usm-user v3 ccu_user1
#
snmp-agent proxy community cipher %#%#qTp*MccD#Z[sHw4"pbzVHzAfO]gWN;h#30K=)%}X1jIHNF<QdMskYG$9xj:9k\EZN6Mi!Hrt@\Oa8tqP%#%# remote-engineid 800007DB01192168001100
#
snmp-agent proxy target-host proxy_host@ccu1 address udp-domain 192.168.1.100 udp-port 161 public-net params securityname cipher %#%#yowoL2.\8~LKL5*|k[h'3`Nv:DX;Y-$tU=SWNu[*%#%# v2c
snmp-agent proxy target-host proxy_host@ems address udp-domain 2.1.1.1 udp-port 162 vpn-instance ccu_private_vpn params securityname cipher %#%#p,[';vISF&eOO7AF2%oAA[p`U\b6wIipjB,:x^EJ%#%# v2c
#
snmp-agent proxy rule proxy_rule_read@ccu1 read remote-engineid 800007DB01192168001100 target-host proxy_host@ccu1 params-in securityname cipher %#%#D1$/6-y>U4Y\pXU}y8H3(,3s*gIyD)-Fq'O1/+uA%#%# v2c
snmp-agent proxy rule proxy_rule_trap@ccu1 trap remote-engineid 800007DB01192168001100 target-host proxy_host@ems params-in securityname cipher %#%#C:lz(^O8~ES/&".w":rQ}]z^)egwE-{"Ce)M/T1)%#%# v2c
snmp-agent proxy rule proxy_rule_write@ccu1 write remote-engineid 800007DB01192168001100 target-host proxy_host@ccu1 params-in securityname cipher %#%#%j89h;)p777^{b1BQtds=_<$O.<~qR.DDbwYS3_G6%#%# v2c
#
return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055400

Views: 14525

Downloads: 26

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next