No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Multicast MAC Encapsulation Mode for 1588v2 Packets to Implement Network-wide Clock Synchronization

Example for Configuring the Multicast MAC Encapsulation Mode for 1588v2 Packets to Implement Network-wide Clock Synchronization

This section provides an example for configuring the multicast MAC encapsulation mode for 1588v2 packets to implement network-wide clock synchronization. The 1588v2 clock synchronization protocol transmits BITS frequencies and time signals. 1588v2 helps both wireless bearer and access networks achieve network-wide clock synchronization. NE20Es by default use the multicast MAC encapsulation mode. All NE20Es are configured as BCs on the 1588v2 network to implement network-wide clock synchronization.

Networking Requirements

The bearer network shown in Figure 9-15 transmits wireless services to NodeBs. All nodes on the bearer network run 1588v2. PEs obtain time information from BITS servers. NodeB-2 does not run 1588v2 and uses synchronous Ethernet to implement frequency synchronization. NodeB-1 and NodeB-3 run 1588v2. PE1 and PE2 dynamically select the grandmaster. The selected grandmaster then advertises 1588v2 time signals, which allows all NodeBs and PEs to achieve frequency synchronization. 1588v2-enabled NodeBs and PEs can also achieve time synchronization in addition to frequency synchronization.

All nodes on the bearer network can be configured as BCs to transmit clock information. 1588v2-disabled NodeB-2 uses an E1 line to transmit clock signals.

Figure 9-15 Multicast MAC encapsulation mode for 1588v2 packets to implement network-wide clock synchronization

Device Name

Interface Name

Interface IP Address

PE1

GE 0/2/0

10.0.0.1/24

PE1

GE 0/1/0

172.16.0.1/24

PE2

GE 0/2/0

10.0.0.2/24

PE2

GE 0/1/0

192.168.0.1/24

CE1

GE 0/2/0

172.16.0.2/24

CE1

GE 0/1/0

10.10.0.1/24

CE2

GE 0/1/0

192.168.0.2/24

CE2

GE 0/1/1

172.20.0.1/24

NodeB-1

-

10.10.0.2/24

NodeB-3

-

172.20.0.2/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Connect PE1 and PE2 to BITS servers.

  2. Configure PE1, PE2, CE1, and CE2 as BCs.

NOTE:
The default multicast MAC encapsulation mode is used to transmit 1588v2 packets.

Data Preparation

To complete the configuration, you need the following data:

  • Configure a routing protocol. In this example, OSPF is used.

  • Delay measurement mechanism (Pdelay)

  • 1588v2 clock domain numbers

  • Interval at which Announce packets are sent and maximum number of Announce packet timeouts

  • Interval at which Sync packets are sent

  • Interval at which Delay packets are sent

Procedure

  1. Assign an IP address to each interface and configure OSPF. The configuration details are not provided here.
  2. Configure each PE to use clock interfaces to import BITS signals.

    # Import BITS1 signals from BITS-1 to PE1 and configure PE1 to participate in dynamic 1588v2 clock source selection.

    [*PE1] ptp enable
    [*PE1] clock bits-type bits1 1pps input 
    [*PE1] ptp clock-source bits1 on 
    [*PE1] ptp clock-source bits1 priority1 2 
    [*PE1] commit

    # Import BITS1 signals from BITS-2 to PE2 and configure PE2 to participate in dynamic 1588v2 clock source selection.

    [*PE2] ptp enable
    [*PE2] clock bits-type bits1 1pps input
    [*PE2] ptp clock-source bits1 on 
    [*PE2] ptp clock-source bits1 priority1 1 
    [*PE2] commit

  3. Configure PE1, PE2, CE1, and CE2 as BCs.

    # Enable 1588v2 and configure 1588v2 parameters on PE1.

    [*PE1] ptp enable
    [*PE1] ptp device-type bc
    [*PE1] ptp domain 1
    [*PE1] commit
    [~PE1] interface gigabitethernet 0/1/0
    [~PE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*PE1-GigabitEthernet0/1/0] ptp enable
    [*PE1-GigabitEthernet0/1/0] commit
    [~PE1-GigabitEthernet0/1/0] quit
    [~PE1] interface gigabitethernet 0/2/0
    [~PE1-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*PE1-GigabitEthernet0/2/0] ptp enable
    [*PE1-GigabitEthernet0/2/0] commit
    [~PE1-GigabitEthernet0/2/0] quit

    # Enable 1588v2 and configure 1588v2 parameters on PE2.

    [*PE2] ptp enable
    [*PE2] ptp device-type bc
    [*PE2] ptp domain 1
    [*PE2] commit
    [~PE2] interface gigabitethernet 0/1/0
    [~PE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*PE2-GigabitEthernet0/1/0] ptp enable
    [*PE2-GigabitEthernet0/1/0] commit
    [~PE2-GigabitEthernet0/1/0] quit
    [~PE2] interface gigabitethernet 0/2/0
    [~PE2-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*PE2-GigabitEthernet0/2/0] ptp enable
    [*PE2-GigabitEthernet0/2/0] commit
    [~PE2-GigabitEthernet0/2/0] quit

    # Enable 1588v2 and configure 1588v2 parameters on CE1.

    [*CE1] ptp enable
    [*CE1] ptp device-type bc
    [*CE1] ptp domain 1
    [*CE1] commit
    [~CE1] interface gigabitethernet 0/2/0
    [~CE1-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*CE1-GigabitEthernet0/2/0] ptp enable
    [*CE1-GigabitEthernet0/2/0] commit
    [~CE1-GigabitEthernet0/2/0] quit
    [~CE1] interface gigabitethernet 0/1/0
    [~CE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*CE1-GigabitEthernet0/1/0] ptp enable
    [*CE1-GigabitEthernet0/1/0] commit
    [~CE1-GigabitEthernet0/1/0] quit

    # Configure NodeB-1 to receive 1588v2 packets sent by CE1. The configuration details are not provided here.

    # Enable 1588v2 on CE2, configure 1588v2 parameters, and specify 1588v2 time signals as the local primary reference source.

    [*CE2] ptp enable
    [*CE2] ptp device-type bc
    [*CE2] ptp domain 1
    [*CE2] commit
    [~CE2] interface gigabitethernet 0/1/1
    [~CE2-GigabitEthernet0/1/1] ptp delay-mechanism pdelay
    [*CE2-GigabitEthernet0/1/1] ptp enable
    [*CE2-GigabitEthernet0/1/1] commit
    [~CE2-GigabitEthernet0/1/1] quit
    [~CE2] interface gigabitethernet 0/1/0
    [~CE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*CE2-GigabitEthernet0/1/0] ptp enable
    [*CE2-GigabitEthernet0/1/0] commit
    [~CE2-GigabitEthernet0/1/0] quit

  4. Verify the configuration.

    After completing the configurations, run the display ptp all state command to view the 1588v2 operating status. The command output on CE1 is used as an example. The command output shows that GE 0/2/0 of CE1 is working in the Slave state, the grandmaster clock ID is 000a0bfffe0c0dd4, and the parent clock ID is also 000a0bfffe0c0dd4. CE1 has synchronized with the master clock source.

    <CE1> display ptp all
      Device config info
      ------------------------------------------------------------------
      PTP state         :enabled    Domain  value      :1
      Slave only        :no         Device type        :BC
      Set port state    :no         Local clock ID     :000a0bfffe0c0d42
      Acl               :no         Virtual clock ID   :no
      Acr               :no
    
      BMC run info
      ------------------------------------------------------------------
      Grand clock ID    :000a0bfffe0c0dd4
      Receive number    :GigabitEthernet0/2/0
      Parent clock ID   :000a0bfffe0c0dd4
      Parent portnumber :6417
      Priority1         :128        Priority2          :128
      Step removed      :1          Clock accuracy     :49
      Clock class       :187        Time Source        :160
      UTC Offset        :0          UTC Offset Valid   :False
      Time Scale        :ARB        Time Traceable     :False
      Leap              :None       Frequence Traceable:False
    
      Port info
      Name                  State        Delay-mech Ann-timeout Type Domain
      ------------------------------------------------------------------------
      GigabitEthernet0/2/0  slave        pdelay      10          BC   1
      Time Performance Statistics(ns): Slot 1  Card 0  Port 0
      ------------------------------------------------------------------------
      Realtime(T2-T1)   :534               Pathdelay     :0
      Max(T2-T1)        :887704804
      Min(T2-T1)        :512
    
      Clock source info
      Clock Pri1 Pri2 Accuracy Class TimeSrc Signal Switch Direction In-Status
      ------------------------------------------------------------------------
      local 200  128  0x31     187   0xa0     -      -      -         -
      bits1 128  128  0x20       6   0x20     none   off   -/-        abnormal

Configuration Files

  • Configuration file of CE1

    #
     sysname CE1
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.16.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.10.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-drop enable
    #
     ospf 1
     area 0.0.0.0
     network 172.16.0.0 0.0.0.255
     network 10.10.0.0 0.0.0.255
    #
      
  • Configuration file of CE2

    #
     sysname CE2
    #
     ptp enable
     ptp device-type bc
     ptp domain 1#
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     ptp enable ptp delay-mechanism pdelay
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 172.20.0.1 255.255.255.0
     ptp enable ptp delay-mechanism pdelay
    #
     ospf 1
     area 0.0.0.0
     network 192.168.0.0 0.0.0.255
     network 172.20.0.0 0.0.0.255
    #
      
  • Configuration file of PE1

    #
     sysname PE1
    #
     ptp enable
     clock bits-type bits1 1pps input 
     ptp clock-source bits1 on 
     ptp clock-source bits1 priority1 2 
      ptp device-type bc
     ptp domain 1
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.0.0.1 255.255.255.0
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 172.16.0.0 0.0.0.255
    #
    
  • Configuration file of PE2

    #
     sysname PE2
    #
     ptp enable
     clock bits-type bits1 1pps input 
     ptp clock-source bits1 on 
     ptp clock-source bits1 priority1 1 
     ptp device-type bc
     ptp domain 1
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
    interface gigabitethernet 0/2/0
     undo shutdown
     ip address 10.0.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 192.168.0.0 0.0.0.255
    #
    
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055400

Views: 14547

Downloads: 26

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next