No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE20E-S2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Manycast Mode

Example for Configuring the Manycast Mode

Networking Requirements

As shown in Figure 5-7,

  • DeviceC and DeviceD are in the same network segment; DeviceA is in another network segment; DeviceF connects with the two network segments.

  • DeviceC functions as an NTP manycast server and its local clock is a master clock with the stratum 2. Manycast packets are sent out from GE0/1/0.

  • DeviceD and DeviceA are manycast clients and send packets on their respective GE0/1/0.

Figure 5-7 Configuring the NTP manycast mode

NOTE:

Interfaces 1 and Interface 2 in this example are GE 0/1/0 and GE 0/2/0 respectively.

Precautions

Ensure manycast client is reachable to the manycast server before synchronization. This can be checked using ping command on the console interface.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure DeviceC as an NTP manycast server.

  2. Configure DeviceA and DeviceD as NTP manycast clients.

  3. Enable multicast for Device F.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of DeviceA, DeviceC, DeviceD, and DeviceF and unicast routing protocol

  • Stratum of the NTP master clock

Procedure

  1. Configure an IP address for each router.

    Configure IP addresses based on Figure 5-7. The detailed procedures are not mentioned here.

  2. Configure an NTP manycast server.

    # Set the local clock on DeviceC as an NTP master clock with stratum 2.

    <DeviceC> system-view
    [~DeviceC] ntp-service refclock-master 2

    # Configure DeviceC to be an NTP manycast server. NTP manycast server sends NTP manycast packets after receiving manycast client packets.

    [*DeviceC] interface gigabitethernet 0/1/0
    [*DeviceC-GigabitEthernet0/1/0] ntp-service manycast-server
    [*DeviceC-GigabitEthernet0/1/0] commit

  3. Configure DeviceD.

    # Configure DeviceD to be an NTP manycast client. DeviceD sends NTP manycast packets to manycast server on GE0/1/0.

    <DeviceD> system-view
    [~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] ntp-service manycast-client
    [*DeviceD-GigabitEthernet0/1/0] commit

  4. Configure DeviceA.

    # Configure DeviceA to be an NTP manycast client. DeviceA sends NTP manycast packets to manycast server on GE0/1/0.

    <DeviceA> system-view
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ntp-service manycast-client
    [*DeviceA-GigabitEthernet0/1/0] commit

  5. Enable multicast for Device F.

    <DeviceF> system-view
    [~DeviceF] multicast routing-enable
    [*DeviceF] commit
    [~DeviceF] interface gigabitethernet 0/2/0
    [~DeviceF-GigabitEthernet0/2/0] pim sim
    [~DeviceF-GigabitEthernet0/2/0] igmp enable
    [~DeviceF-GigabitEthernet0/2/0] igmp static-group 224.0.1.1
    [*DeviceF-GigabitEthernet0/2/0] commit
    [~DeviceF-GigabitEthernet0/2/0] quit
    [~DeviceF] interface gigabitethernet 0/1/0
    [~DeviceF-GigabitEthernet0/1/0] pim sim
    [~DeviceF-GigabitEthernet0/1/0] quit

  6. Verify the configuration.

    After the configurations are complete, the clock on Device A and DeviceD can be synchronized to the clock on DeviceC.

    Check the NTP status on DeviceD and you can find that the clock status is "synchronized". That is, clock synchronization completes. The stratum of the clock on DeviceD is 3, one stratum lower than that on DeviceC.

    [~DeviceD] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 3.0.1.32
     nominal frequency: 60.0002 Hz
     actual frequency: 60.0002 Hz
     clock precision: 2^18
     clock offset: 0.66 ms
     root delay: 24.47 ms
     root dispersion: 208.39 ms
     peer dispersion: 9.63 ms
     reference time: 17:03:32.022 UTC Apr 25 2005(C61734FD.800303C0)
     autokey crypto flags: 0x80021

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 1.0.1.11 255.255.255.0
     ntp-service manycast-client
    #
    return
  • Device C configuration file

    #
     sysname DeviceC
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 3.0.1.31 255.255.255.0
     ntp-service manycast-server
    #
    return
  • Device D configuration file

    #
     sysname DeviceD
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 3.0.1.32 255.255.255.0
     ntp-service manycast-client
    #
    return
  • Device F configuration file

    #
     sysname DeviceF
    #
    multicast routing-enable
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 3.0.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 1.0.1.2 255.255.255.0
     pim sm
     igmp static-group 224.0.1.1
    #
    Return
Translation
Download
Updated: 2019-01-02

Document ID: EDOC1100055400

Views: 20162

Downloads: 30

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next