No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring DCN

Example for Configuring DCN

This section provides an example for configuring the data communication network (DCN) feature.

Networking Requirements

A gateway network element (GNE) shown in Figure 23-1 is connected to a network management system (NMS) and to two network elements (NEs). A static route is configured for communication between the NMS and GNE.

Figure 23-1 Networking diagram for configuring DCN

Precautions

Before configuring DCN, note the following:

  • An NMS's IP address is a public IP address, and a GNE's NEIP address is a Layer 3 virtual private network (VPN) address. To implement address conversion, you must specify a GNE's interface that is connected to an NMS, bind the GNE's interface to a DCN VPN instance, and set an IP address for the GNE's interface.

  • The binding operation must be performed before you set an IP address for the interface. Otherwise, this IP address will be deleted when you bind the interface to the DCN VPN instance.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the DCN feature globally.

  2. Bind the interface (connecting the GNE to the NMS) to a DCN VPN instance. Then set an IP address for the interface.

  3. Configure a static route for communication between the NMS and GNE.

  4. Configure the automatic NE report function on the GNE.

Data Preparation

To complete the configuration, you need the following data:

  • Name of the DCN VPN instance
    NOTE:

    A DCN VPN instance named __dcn_vpn__ is automatically generated when the DCN feature is enabled globally on the GNE.

    You can run the display ip vpn-instance command on the GNE to view the DCN VPN instance name.

  • IP address of the interface connecting the GNE to the NMS

Procedure

  1. Enable the DCN feature globally.

    # Enable the DCN feature globally. In this example, a GNE is used.

    <HUAWEI> system-view
    [~HUAWEI] sysname gne
    [*HUAWEI] commit
    [~gne] dcn
    [*gne-dcn] ne-ip 10.1.1.2 24
    [*gne-dcn] quit

  2. Bind the interface (connecting the GNE to the NMS) to DCN VPN instance __dcn_vpn__. Then, set an IP address for the interface.

    [*gne] interface GigabitEthernet 0/1/0
    [*gne-GigabitEthernet0/1/0] ip binding vpn-instance __dcn_vpn__
    [*gne-GigabitEthernet0/1/0] ip address 1.1.1.2 16
    [*gne-GigabitEthernet0/1/0] commit
    [~gne-GigabitEthernet0/1/0] quit

  3. Configure a static route for communication between the NMS and GNE. For configuration details, see "Configuration Files" in this section.
  4. Configure the automatic NE report function on the GNE.

    # Enable the automatic NE report function on the GNE.

    [~gne] dcn
    [*gne-dcn] auto-report
    [*gne-GigabitEthernet0/1/0] commit

  5. Verify the configuration.

    # View the configurations of the GNE.

    <gne> display dcn brief
    ------------------------------------------------
     NE-ID:               0x280FC
     NE-IP:               10.1.1.2
     Mask:                255.255.255.0
     DCN-Interface:       LoopBack1023
     Auto-Report:         Enable
    ------------------------------------------------

Configuration Files

  • Configuration file of the GNE

    #                                                                               
    ip dcn vpn-instance __dcn_vpn__                                                 
    #                                                                               
    interface GigabitEthernet0/1/0                                                  
     undo shutdown                                                                  
     dcn                                                                            
     ip binding vpn-instance __dcn_vpn__                                            
     ip address 1.1.1.2 16 255.255.0.0                                             
    #                                                                               
    interface LoopBack1023                                                    
     description DCN loopback interface                                             
     ip binding vpn-instance __dcn_vpn__                                            
     ip address 10.1.1.2 255.255.255.0                                               
    #                                                                               
    ospf 65534 vpn-instance __dcn_vpn__                                             
     description DCN ospf create by default                                         
     opaque-capability enable                                                       
     vpn-instance-capability simple                                                 
     area 0.0.0.0                                                                   
      network 0.0.0.0 255.255.255.255                                               
    #                                                                               
    !The DCN function implements the capability of plug-and-play for this device.
    !A NE IP address based on the unique NE ID is automatically generated in VPN
    !of DCN. It is recommended that the NE IP address be changed to the planned 
    !one by running the ne-ip X.X.X.X <MASK>command after the device being online.
    dcn                                                                             
     auto-report                                                                    
     ne-ip 10.1.1.2 255.255.255.0
    #                                                                               
    return 
  • Configuration files of NE1 and NE2

    #                                                                               
    interface GigabitEthernet0/1/1                                                  
     undo shutdown                                                                  
     dcn                                                                            
    #                                                                               
    interface LoopBack1023                                                    
     description DCN loopback interface                                             
     ip binding vpn-instance __dcn_vpn__                                            
     ip address 128.1.0.1 255.255.0.0                                               
    #                                                                               
    ospf 65534 vpn-instance __dcn_vpn__                                             
     description DCN ospf create by default                                         
     opaque-capability enable 
     hostname                                                       
     vpn-instance-capability simple                                                 
     area 0.0.0.0                                                                   
      network 0.0.0.0 255.255.255.255                                               
    #                                                                               
    !The DCN function implements the capability of plug-and-play for this device.
    !A NE IP address based on the unique NE ID is automatically generated in VPN
    !of DCN. It is recommended that the NE IP address be changed to the planned 
    !one by running the ne-ip X.X.X.X <MASK>command after the device being online.
    dcn                                                                             
    #                                                                               
    return
Download
Updated: 2019-01-02

Document ID: EDOC1100058392

Views: 15142

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next