No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples for CES ACR

Configuration Examples for CES ACR

Networking Requirements

As shown in Figure 8-2, Node B and PE1 are connected through E1 links, and BSC and PE2 are connected through E1 links. The encapsulation protocol is configured as TDM on the channelized serial interfaces of the E1 links. A PW is formed between PE1 and PE2 to transparently transmit TDM cells.

After the ACR function is configured on PE1, PE1 can transparently transmit clock signals through the PW. Therefore, the clocks on PE1 and PE2 can be synchronized.

Figure 8-2 Networking diagram for configuring the ACR function
NOTE:

The configurations in this example are performed on PE1 and PE2. HUAWEI NE40E-M2 Series can function as PE1 and PE2.

Interfaces 1 through 3 in this example are E1 1/0/1, GE 0/2/0, GE 0/2/1, respectively.



Device Interface IP address
PE1

GE 0/2/0

Loopback 0

10.1.1.1/24

2.2.2.2/32

P

GE 2/0/0

GE 2/0/1

Loopback 0

10.1.1.2/24

10.2.1.1/24

4.4.4.4/32

PE2

GE 0/2/1

Loopback 0

10.2.1.2/24

3.3.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Run an IGP on the PEs and P to interwork them.

  2. Configure basic MPLS functions on the backbone network, configure MPLS L2VPN on PE1 and PE2, and establish the remote MPLS LDP peer relationship between PE1 and PE2.

  3. Configure the ACR function on PE1 and PE2.

  4. Configure the encapsulation protocol of the serial interface to TDM on PE1 and PE2.

  5. Configure a PW on PE1 and PE2.

Data Preparation

To complete the configuration, you need the following data:

  • L2VC IDs on both ends of the PW

  • MPLS LSR IDs of PE1, P, and PE2

  • IP addresses of the loopback interfaces used to configure remote peers on the PEs

  • Number of the clock recovery domain on PE1

Procedure

  1. Run an IGP on the backbone network so that devices can communicate with each other. The configuration details are not mentioned here. For detailed configurations, see the configuration file of this example.
  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN on the PEs. Then, establish the remote MPLS LDP peer relationship between the PEs at both ends of the PW. The configuration details are not mentioned here. For detailed configurations, see the configuration file of this example.

    The remote MPLS LDP peer relationship needs to be established only when a dynamic PW is established.

  3. Configure ACR on PE1 and PE2.

    1. Configure PE1.

      [*PE1] controller e1 0/1/0 
      [*PE1-E1 0/1/0] clock recovery-domain 1 
      [*PE1-E1 0/1/0] commit
      [~PE1-E1 0/1/0] quit
      

      # Obtain a clock source recovered by CES-ACR from clock recovery domain 1 on subcard 1 of slot 1.

      [*PE1] clock source cesacr slot 1 card 1 recovery-domain 1 synchronization enable

  4. Configure the encapsulation protocol of the serial interface as TDM.

    1. Configure PE1.

      [*PE1] controller e1 0/1/0 
      [*PE1-E1 0/1/0] using ce1 
      [*PE1-E1 0/1/0] channel-set 1 timeslot-list 1-31 
      [*PE1-E1 0/1/0] commit
      [~PE1-E1 0/1/0] quit
      [*PE1] interface serial0/1/0:1 
      [*PE1-Serial0/1/0:1] link-protocol tdm 
      [*PE1-Serial0/1/0:1] commit
      [~PE1-Serial0/1/0:1] quit
      
    2. Configure PE2.

      [*PE2] controller e1 0/1/0
      [*PE2-E1 0/1/0] using ce1
      [*PE2-E1 0/1/0] channel-set 1 timeslot-list 1-31
      [*PE2-E1 0/1/0] commit
      [~PE2-E1 0/1/0] quit
      [*PE2] interface serial0/1/0:1
      [*PE2-Serial0/1/0:1] link-protocol tdm
      [*PE2-Serial0/1/0:1] commit
      [~PE2-Serial0/1/0:1] quit
      

  5. Configure a PW.

    NOTE:

    PW protection is supported. If one of multiple CES PWs fails, clock recovery is automatically switched to another CES PW.

    1. Configure PE1.

      [*PE1] interface serial0/1/0:1
      [*PE1-Serial0/1/0:1] mpls l2vc 3.3.3.3 100 control-word tdm-encapsulation-number 8
      [*PE1-Serial0/1/0:1] commit
      [~PE1-Serial0/1/0:1] quit
    2. Configure PE2.

      [*PE2] interface serial0/1/0:1
      [*PE2-Serial0/1/0:1] mpls l2vc 2.2.2.2 100 control-word tdm-encapsulation-number 8
      [*PE2-Serial0/1/0:1] commit
      [~PE2-Serial0/1/0:1] quit

  6. Verify the configuration.

    Run the display mpls l2vc interface serial0/1/0:1 command on PE1. You can view that the status of the PW is Active.

    *client interface       : Serial0/1/0:1 is up
      session state          : up
      AC state               : up
      VC state               : up
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 3.3.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 146433       remote VC label      : 146432
      TDM encapsulation number: 8
      jitter-buffer           : 20
      idle-code               : ff
      rtp-header              : disable
      local AC OAM State     : up
      local PSN State        : up
      local forwarding state : forwarding
      local status code      : 0x0
      remote AC OAM state    : up
      remote PSN state       : up
      remote forwarding state: forwarding
      remote statuscode      : 0x0
      BFD for PW             : unavailable
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 1500         remote VC MTU        : 0
      local VCCV             : alert lsp-ping bfd
      remote VCCV            : alert lsp-ping bfd
      local control word     : disable      remote control word  : disable
      tunnel policy name     : --
      traffic behavior name  : --
      PW template name       : --
      primary or secondary   : primary
      VC tunnel/token info   : 1 tunnels/tokens
        NO.0  TNL type : lsp   , TNL ID : 0x40800b
      create time            : 0 days, 0 hours, 20 minutes, 27 seconds
      up time                : 0 days, 0 hours, 6 minutes, 33 seconds
      last change time       : 0 days, 0 hours, 6 minutes, 33 seconds
      VC last up time        : 2010/02/21 17:42:25
      VC total up time       : 0 days, 0 hours, 14 minutes, 38 seconds
      CKey                   : 8
      NKey                   : 7                
      

    Run the display acr-dcr slot 1 card 1 recovery-domain 1 command on PE1. If Master PW State is displayed as Lock, it indicates that PE1 has traced the clock sent by PE2.

    [~PE1] display acr-dcr slot 1 card 1 recovery-domain 1
    Domain info
      ----------------------------------------------------------
      E1 count:  1
      Master PW SerialPort:Serial0/1/0:1,    Channel ID:404
      Master PW state: lock
    
      E1 info
      ----------------------------------------------------------
      E1 number:20,   Port:E1 0/1/0,   Direction:2,   PW count:1
          PW SerialPortName:Serial0/1/0:1,   Channel ID:404      

Configuration Files

  • Configuration file of PE1

    #
     sysname PE1
    #
     mpls lsr-id 2.2.2.2
     mpls
    #
     mpls l2vpn
    #
    mpls ldp
    #
     mpls ldp remote-peer 3.3.3.3
     remote-ip 3.3.3.3 
    #
    clock source cesacr slot 1 card 1 recovery-domain 1 synchronization enable
    #
    controller e1 0/1/0
    using ce1
    channel-set 1 timeslot-list 1-31
    clock recovery-domain 1
    undo shutdown
    #
    interface serial0/1/0:1
     link-protocol tdm
     mpls l2vc 3.3.3.3 100 control-word tdm-encapsulation-number 8
     undo shutdown
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • Configuration file of PE2

    #
     sysname PE2
    #
     mpls lsr-id 3.3.3.3
     mpls
    #
     mpls l2vpn
    #
    mpls ldp
    #
     mpls ldp remote-peer 2.2.2.2
     remote-ip 2.2.2.2
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    controller Cpos0/1/0                                                            
     e1 1 channel-set 1 timeslot-list 1-31 
    #
    interface Serial0/1/0:1                                                       
     link-protocol tdm                                                              
     mpls l2vc 2.2.2.2 100 control-word tdm-encapsulation-number 8                                                        
     undo shutdown 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • Configuration file of P

    #
     sysname P
    #
     mpls lsr-id 4.4.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    
Download
Updated: 2019-01-02

Document ID: EDOC1100058392

Views: 18445

Downloads: 31

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next