No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Unicast MAC Encapsulation Mode for 1588v2 Packets to Implement Network-wide Clock Synchronization

Example for Configuring the Unicast MAC Encapsulation Mode for 1588v2 Packets to Implement Network-wide Clock Synchronization

This section provides an example for configuring the unicast MAC encapsulation mode for 1588v2 packets to implement network-wide clock synchronization. The 1588v2 clock synchronization protocol transmits BITS frequencies and time signals. 1588v2 helps both wireless bearer and access networks achieve network-wide clock synchronization. NE40Es use UDP to encapsulate 1588v2 packets and transmit the packets to NodeBs that support only UDP packets.

Networking Requirements

The bearer network shown in Figure 9-14 transmits wireless services to NodeBs. All nodes on the bearer network run 1588v2. PEs obtain time information from BITS servers. NodeB-2 does not run 1588v2 and uses synchronous Ethernet to implement frequency synchronization. NodeB-1 and NodeB-3 run 1588v2. PE1 and PE2 dynamically select the grandmaster. The selected grandmaster advertises 1588v2 time signals over the network, which allows all NodeBs and PEs to achieve frequency synchronization. 1588v2-enabled NodeBs and PEs can also achieve time synchronization in addition to frequency synchronization.

All nodes on the bearer network can be configured as BCs to transmit clock information. 1588v2-disabled NodeB-2 uses an E1 line to transmit clock signals.

Figure 9-14 Unicast MAC encapsulation mode for 1588v2 packets to implement network-wide clock synchronization
NOTE:

The configurations in this example are performed on PE1, PE2, CE1, and CE2. HUAWEI NE40E-M2 Series can function as PE1, PE2, CE1, and CE2.



Device Name

Interface Name

Interface IP Address

Interface MAC Address

PE1

GE 0/2/0

10.0.0.1/24

0000-2222-1111

PE1

GE 0/1/0

172.16.0.1/24

0000-1111-1111

PE2

GE 0/2/0

10.0.0.2/24

0000-2222-2222

PE2

GE 0/1/0

192.168.0.1/24

0000-1111-2222

CE1

GE 0/2/0

172.16.0.2/24

1111-2222-1111

CE1

GE 0/1/0

10.10.0.1/24

1111-2222-3333

CE2

GE 0/1/0

192.168.0.2/24

1111-2222-4444

CE2

GE 0/1/1

172.20.0.1/24

1111-2222-5555

NodeB-1

-

10.10.0.2/24

2222-3333-1111

NodeB-3

-

172.20.0.2/24

2222-3333-2222

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol and ensure the communion between devices. In this example, OSPF is used.

  2. Connect PE1 and PE2 to BITS servers.

  3. Configure PE1, PE2, CE1, and CE2 as BCs.

  4. Configure the unicast UDP encapsulation mode for 1588v2 packets.

Data Preparation

To complete the configuration, you need the following data:

  • Delay measurement mechanism (Pdelay)

  • 1588v2 clock domain numbers

  • Interval at which Announce packets are sent and maximum number of Announce packet timeouts

  • Interval at which Sync packets are sent

  • Interval at which Pdelay packets are sent

Procedure

  1. Assign an IP address to each interface and configure OSPF. The configuration details are not provided here.
  2. Configure each PE to use clock interfaces to import BITS signals.

    # Configure PE1 to import BITS1 signals from BITS-1, participate in dynamic 1588v2 clock source selection, and import 1588v2 time signals.

    [*PE1] ptp enable
    [*PE1] clock bits-type bits1 1pps input
    [*PE1] ptp clock-source bits1 on
    [*PE1] ptp clock-source bits1 priority1 2
    [*PE1] clock source ptp synchronization enable
    [*PE1] clock source ptp priority 1
    [*PE1] commit

    # Configure PE2 to import BITS1 signals from BITS-2, participate in dynamic 1588v2 clock source selection, and import 1588v2 time signals.

    [*PE2] ptp enable
    [*PE2] clock bits-type bits1 1pps input
    [*PE2] ptp clock-source bits1 on 
    [*PE2] ptp clock-source bits1 priority1 1 
    [*PE2] clock source ptp synchronization enable
    [*PE2] clock source ptp priority 1
    [*PE2] commit

  3. Configure PE1, PE2, CE1, and CE2 as BCs.

    # Enable 1588v2 and configure 1588v2 parameters on PE1.

    [*PE1] ptp enable
    [*PE1] ptp device-type bc
    [*PE1] ptp domain 1
    [*PE1] commit
    [~PE1] interface gigabitethernet 0/1/0
    [~PE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*PE1-GigabitEthernet0/1/0] ptp enable
    [*PE1-GigabitEthernet0/1/0] ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
    [*PE1-GigabitEthernet0/1/0] ptp udp-egress destination-mac 1111-2222-1111
    [*PE1-GigabitEthernet0/1/0] commit
    [*PE1-GigabitEthernet0/1/0] quit
    [~PE1] interface gigabitethernet 0/2/0
    [~PE1-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*PE1-GigabitEthernet0/2/0] ptp enable
    [*PE1-GigabitEthernet0/2/0] ptp udp-egress source-ip 10.0.0.1 destination-ip 10.0.0.2
    [*PE1-GigabitEthernet0/2/0] ptp udp-egress destination-mac 0000-2222-2222
    [*PE1-GigabitEthernet0/2/0] commit
    [*PE1-GigabitEthernet0/2/0] quit

    # Enable 1588v2 and configure 1588v2 parameters on PE2.

    [*PE2] ptp enable
    [*PE2] ptp device-type bc
    [*PE2] ptp domain 1
    [*PE2] commit
    [~PE2] interface gigabitethernet 0/1/0
    [~PE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*PE2-GigabitEthernet0/1/0] ptp enable
    [*PE2-GigabitEthernet0/1/0] ptp udp-egress source-ip 192.168.0.1 destination-ip 192.168.0.2
    [*PE2-GigabitEthernet0/1/0] ptp udp-egress destination-mac 1111-2222-4444
    [*PE2-GigabitEthernet0/1/0] commit
    [*PE2-GigabitEthernet0/1/0] quit
    [~PE2] interface gigabitethernet 0/2/0
    [~PE2-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*PE2-GigabitEthernet0/2/0] ptp enable
    [*PE2-GigabitEthernet0/2/0] ptp udp-egress source-ip 10.0.0.2 destination-ip 10.0.0.1
    [*PE2-GigabitEthernet0/2/0] ptp udp-egress destination-mac 0000-2222-1111
    [*PE2-GigabitEthernet0/2/0] commit
    [~PE2-GigabitEthernet0/2/0] quit

    # Enable 1588v2 and configure 1588v2 parameters on CE1.

    [*CE1] ptp enable
    [*CE1] ptp device-type bc
    [*CE1] ptp domain 1
    [*CE1] commit
    [~CE1] interface gigabitethernet 0/2/0
    [~CE1-GigabitEthernet0/2/0] ptp delay-mechanism pdelay
    [*CE1-GigabitEthernet0/2/0] ptp enable
    [*CE1-GigabitEthernet0/2/0] ptp udp-egress source-ip 172.16.0.2 destination-ip 172.16.0.1
    [*CE1-GigabitEthernet0/2/0] ptp udp-egress destination-mac 0000-1111-1111
    [*CE1-GigabitEthernet0/2/0] commit
    [*CE1-GigabitEthernet0/2/0] quit
    [~CE1] interface gigabitethernet 0/1/0
    [~CE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*CE1-GigabitEthernet0/1/0] ptp enable
    [*CE1-GigabitEthernet0/1/0] ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
    [*CE1-GigabitEthernet0/1/0] ptp udp-egress destination-mac 2222-3333-1111
    [*CE1-GigabitEthernet0/1/0] commit
    [~CE1-GigabitEthernet0/1/0] quit

    # Configure NodeB-1 to receive 1588v2 packets sent by CE1. The configuration details are not provided here.

    # Enable 1588v2 on CE2, configure 1588v2 parameters, and specify 1588v2 time signals as the local primary reference source.

    [*CE2] ptp enable
    [*CE2] ptp device-type bc
    [*CE2] ptp domain 1
    [*CE2] clock manual source ptp
    [*CE2] commit
    [~CE2] interface gigabitethernet 0/1/0
    [~CE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
    [*CE2-GigabitEthernet0/1/0] ptp enable
    [*CE2-GigabitEthernet0/1/0] ptp udp-egress source-ip 192.168.0.2 destination-ip 192.168.0.1
    [*CE2-GigabitEthernet0/1/0] ptp udp-egress destination-mac 0000-1111-2222
    [*CE2-GigabitEthernet0/1/0] commit
    [~CE2-GigabitEthernet0/1/0] quit
    [~CE2] interface gigabitethernet 0/1/1
    [~CE2-GigabitEthernet0/1/1] ptp delay-mechanism pdelay
    [*CE2-GigabitEthernet0/1/1] ptp enable
    [*CE2-GigabitEthernet0/1/1] ptp udp-egress source-ip 172.20.0.1 destination-ip 172.20.0.2
    [*CE2-GigabitEthernet0/1/1] ptp udp-egress destination-mac 2222-3333-2222
    [*CE2-GigabitEthernet0/1/1] commit
    [~CE2-GigabitEthernet0/1/1] quit

    # Configure NodeB-3 to receive 1588v2 packets sent by CE2. The configuration details are not provided here.

  4. Configure CE2 to use WAN clock techniques to advertise clock signals to NodeB-2.

    # Configure an E1 interface on CE2 as the master clock.

    [*CE2] controller e1 0/2/0
    [*CE2-E1 0/2/0] clock master
    [*CE2-E1 0/2/0] commit

    # Configure the interface that connects NodeB-2 to CE2 as the slave clock. The configuration details are not provided here.

  5. Configure 1588v2 packet attributes on each CE and PE.

    # Configure CE1.

    [~CE1] interface gigabitethernet 0/2/0
    [~CE1-GigabitEthernet0/2/0] ptp announce receipt-timeout 10
    [*CE1-GigabitEthernet0/2/0] ptp min-pdelayreq-interval 10
    [*CE1-GigabitEthernet0/2/0] commit
    [~CE1-GigabitEthernet0/2/0] quit
    [~CE1] interface gigabitethernet 0/1/0
    [~CE1-GigabitEthernet0/1/0] ptp announce-drop enable
    [*CE1-GigabitEthernet0/1/0] commit

    # Configure CE2.

    [~CE2] interface gigabitethernet 0/1/0
    [~CE2-GigabitEthernet0/1/0] ptp announce receipt-timeout 10
    [*CE2-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
    [*CE2-GigabitEthernet0/1/0] commit
    [~CE2-GigabitEthernet0/1/0] quit
    [~CE2] interface gigabitethernet 0/1/1
    [~CE2-GigabitEthernet0/1/1] ptp announce-drop enable
    [*CE2-GigabitEthernet0/1/1] commit

    # Configure PE1.

    [~PE1] interface gigabitethernet 0/2/0
    [~PE1-GigabitEthernet0/2/0] ptp announce receipt-timeout 10
    [*PE1-GigabitEthernet0/2/0] commit
    [*PE1-GigabitEthernet0/2/0] quit
    [~PE1] interface gigabitethernet 0/1/0
    [~PE1-GigabitEthernet0/1/0] ptp announce-interval 8
    [*PE1-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
    [*PE1-GigabitEthernet0/1/0] commit
    [~PE1-GigabitEthernet0/1/0] quit

    # Configure PE2.

    [~PE2] interface gigabitethernet 0/2/0
    [~PE2-GigabitEthernet0/2/0] ptp announce receipt-timeout 10
    [*PE2-GigabitEthernet0/2/0] commit
    [~PE2-GigabitEthernet0/2/0] quit
    [~PE2] interface gigabitethernet 0/1/0
    [~PE2-GigabitEthernet0/1/0] ptp announce-interval 8
    [*PE2-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
    [*PE2-GigabitEthernet0/1/0] commit
    [~PE2-GigabitEthernet0/1/0] quit

  6. Verify the configuration.

    After completing the configurations, run the display ptp all state command to view the 1588v2 operating status. The command output on CE1 is used as an example. The command output shows that GE 0/2/0 of CE1 is working in the Slave state, the grandmaster clock ID is 000a0bfffe0c0dd4, and the parent clock ID is also 000a0bfffe0c0dd4. CE1 has synchronized with the primary clock source.

    <CE1> display ptp all
      Device config info
      ------------------------------------------------------------------
      PTP state         :enabled    Domain  value      :1
      Slave only        :no         Device type        :BC
      Set port state    :no         Local clock ID     :000a0bfffe0c0d42
      Acl               :no         Virtual clock ID   :no
      Acr               :no
    
      BMC run info
      ------------------------------------------------------------------
      Grand clock ID    :000a0bfffe0c0dd4
      Receive number    :GigabitEthernet0/2/0
      Parent clock ID   :000a0bfffe0c0dd4
      Parent portnumber :6417
      Priority1         :128        Priority2          :128
      Step removed      :1          Clock accuracy     :49
      Clock class       :187        Time Source        :160
      UTC Offset        :0          UTC Offset Valid   :False
      Time Scale        :ARB        Time Traceable     :False
      Leap              :None       Frequence Traceable:False
    
      Port info
      Name                  State        Delay-mech Ann-timeout Type Domain
      ------------------------------------------------------------------------
      GigabitEthernet0/2/0  slave        pdelay      10          BC   1
      Time Performance Statistics(ns): Slot 1  Card 0  Port 0
      ------------------------------------------------------------------------
      Realtime(T2-T1)   :534               Pathdelay     :0
      Max(T2-T1)        :887704804
      Min(T2-T1)        :512
    
      Clock source info
      Clock Pri1 Pri2 Accuracy Class TimeSrc Signal Switch Direction In-Status
      ------------------------------------------------------------------------
      local   200  128  0x31     187   0xa0     -      -      -         -
      bits1   128  128  0x20       6   0x20     none   off   -/-        abnormal

Configuration Files

  • Configuration file of CE1

    #
     sysname CE1
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 172.16.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce receipt-timeout 10
     ptp min-pdelayreq-interval 10
     ptp udp-egress source-ip 172.16.0.2 destination-ip 172.16.0.1
     ptp udp-egress destination-mac 0000-1111-1111
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.10.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp min-pdelayreq-interval 10
     ptp announce-drop enable
     ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
     ptp udp-egress destination-mac 2222-3333-1111
    #
     ospf 1
     area 0.0.0.0
     network 172.16.0.0 0.0.0.255
     network 10.10.0.0 0.0.0.255
    #
      
  • Configuration file of CE2

    #
     sysname CE2
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
     clock manual source ptp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce receipt-timeout 10
     ptp min-pdelayreq-interval 10
     ptp udp-egress source-ip 192.168.0.2 destination-ip 192.168.0.1
     ptp udp-egress destination-mac 0000-1111-2222
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 172.20.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-drop enable
     ptp udp-egress source-ip 172.20.0.1 destination-ip 172.20.0.2
     ptp udp-egress destination-mac 2222-3333-2222
    #
     ospf 1
     area 0.0.0.0
     network 192.168.0.0 0.0.0.255
     network 172.20.0.0 0.0.0.255
    #
      
  • Configuration file of PE1

    #
     sysname PE1
    #
     ptp enable
     clock bits-type bits1 1pps input
     ptp clock-source bits1 on 
     ptp clock-source bits1 priority1 2 
     clock source ptp synchronization enable
     clock source ptp priority 1
     ptp device-type bc
     ptp domain 1
     interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-interval 8
     ptp min-delayreq-interval 10
     ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
     ptp udp-egress destination-mac 1111-2222-1111
     interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.0.0.1 255.255.255.0
     ptp announce receipt-timeout 10
     ptp udp-egress source-ip 10.0.0.1 destination-ip 10.0.0.2
     ptp udp-egress destination-mac 0000-2222-2222
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 172.16.0.0 0.0.0.255
    #
    
  • Configuration file of PE2

    #
     sysname PE2
    #
     ptp enable
     clock bits-type bits1 1pps input
     ptp clock-source bits1 on 
     ptp clock-source bits1 priority1 1 
     clock source ptp synchronization enable
     clock source ptp priority 1
     ptp device-type bc
     ptp domain 1
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-interval 8
     ptp min-delayreq-interval 10
     ptp udp-egress source-ip 192.168.0.1 destination-ip 192.168.0.2
     ptp udp-egress destination-mac 1111-2222-4444
    interface gigabitethernet 0/2/0
     undo shutdown
     ip address 10.0.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp udp-egress source-ip 10.0.0.2 destination-ip 10.0.0.1
     ptp udp-egress destination-mac 0000-2222-1111
     ptp announce receipt-timeout 10
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 192.168.0.0 0.0.0.255
    #
    
Download
Updated: 2019-01-02

Document ID: EDOC1100058392

Views: 20529

Downloads: 33

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next