No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management 01

This is NE40E-M2 V800R010C10SPC500 Configuration Guide - System Management
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast Mode

Example for Configuring Multicast Mode

In a multicast domain, the device with high clock precision functions as the NTP server, and other devices are synchronized to the clock of the NTP server.

Networking Requirements

As shown in Figure 5-6,

  • Device C and Device D are in the same network segment; Device A is in another network segment; Device F connects with the two network segments.

  • Device C functions as an NTP multicast server and its clock is an NTP master clock with the stratum being 2. Multicast packets are sent out from GE 0/1/0.

  • Device D and Device A sense the multicast packets respectively on GE 0/1/0 of them.

Figure 5-6 Configuring the NTP multicast mode

NOTE:

Interfaces 1 and Interface 2 in this example are GE 0/1/0 and GE 0/2/0 respectively.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Device C as an NTP multicast server.

  2. Configure Device A and Device D as NTP multicast clients.

  3. Enable multicast for Device F.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of Device A, Device C, Device D, and Device F and unicast routing protocol

  • Stratum of the NTP master clock

Procedure

  1. Configure an IP address for each Device.

    Configure IP addresses based on Figure 5-6. The detailed procedures are not mentioned here.

  2. Configure an NTP multicast server.

    # Set the local clock on Device C as a primary NTP master clock with stratum being 2.

    <DeviceC> system-view
    [~DeviceC] ntp-service refclock-master 2

    # Configure Device C to be an NTP multicast server. NTP multicast packets are sent from GE 0/1/0.

    [*DeviceC] interface gigabitethernet 0/1/0
    [*DeviceC-GigabitEthernet0/1/0] ntp-service multicast-server
    [*DeviceC-GigabitEthernet0/1/0] commit

  3. Configure the NTP multicast client Device D on the same network segment as that of the NTP server.

    # Configure Device D to be an NTP multicast client. Device D listens to the NTP multicast packets on GE 0/1/0.

    <DeviceD> system-view
    [~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] ntp-service multicast-client
    [*DeviceD-GigabitEthernet0/1/0] commit

  4. Configure the NTP multicast client Device A in a network segment different from that of the NTP server.

    # Configure Device A to be an NTP multicast client. Device A listens to the NTP multicast packets on GE 0/1/0.

    <DeviceA> system-view
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] ntp-service multicast-client
    [*DeviceA-GigabitEthernet0/1/0] commit

  5. Enable multicast for Device F.

    <DeviceF> system-view
    [~DeviceF] multicast routing-enable
    [*DeviceF] commit
    [~DeviceF] interface gigabitethernet 0/1/0
    [~DeviceF-GigabitEthernet0/1/0] pim sim
    [~DeviceF-GigabitEthernet0/1/0] igmp enable
    [~DeviceF-GigabitEthernet0/1/0] igmp static-group 224.0.1.1
    [*DeviceF-GigabitEthernet0/1/0] commit
    [~DeviceF-GigabitEthernet0/1/0] quit
    [~DeviceF] interface gigabitethernet 0/2/0
    [~DeviceF-GigabitEthernet0/2/0] pim sim
    [~DeviceF-GigabitEthernet0/2/0] quit

  6. Verify the configuration.

    After the configurations are complete, the clock on Device D can be synchronized to the clock on Device C. The clock on Device A, however, fails to be synchronized because Device A and Device C are in different network segments and Device A cannot sense the multicast packets sent from Device C.

    Check the NTP status on Device D and you can find that the clock status is "synchronized". That is, clock synchronization completes. The stratum of the clock on Device D is 3, one stratum lower than that on Device C.

    [~DeviceD] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 3.0.1.31
     nominal frequency: 60.0002 Hz
     actual frequency: 60.0002 Hz
     clock precision: 2^18
     clock offset: 0.66 ms
     root delay: 24.47 ms
     root dispersion: 208.39 ms
     peer dispersion: 9.63 ms
     reference time: 17:03:32.022 UTC Apr 25 2005(C61734FD.800303C0)
     synchronization state: clock synchronized

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 1.0.1.11 255.255.255.0
     ntp-service multicast-client
    #
    return
  • Device C configuration file

    #
     sysname DeviceC
    #
    ntp-service refclock-master 2
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 3.0.1.31 255.255.255.0
     ntp-service multicast-server
    #
    return
  • Device D configuration file

    #
     sysname DeviceD
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 3.0.1.32 255.255.255.0
     ntp-service multicast-client
    #
    return
  • Device F configuration file

    #
     sysname DeviceF
    #
    multicast routing-enable
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 1.0.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 3.0.1.2 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 224.0.1.1
    #
    Return
Download
Updated: 2019-01-02

Document ID: EDOC1100058392

Views: 14635

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next