No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Routing 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BGP-LS

Example for Configuring BGP-LS

BGP-link state (LS) enables BGP to report topology information collected by IGPs to the controller.

Networking Requirements

BGP-LS is a new method of collecting topology information. With powerful routing capabilities of BGP, BGP-LS has the following advantages:
  • Reduces computing capability requirements and spares the necessity of IGPs on the controller.
  • Facilitates route selection and calculation on the controller by using BGP to summarize process or AS topology information and report the complete information to the controller.
  • Requires only one routing protocol (BGP) to report topology information to the controller.

In Figure 10-53, Device A is connected to the controller and reports topology information to the controller. Device A, Device B, Device C, and Device D use IS-IS to communicate with each other at the network layer. Device A, Device B, and Device C reside in area 10, whereas Device D resides in area 20. Device A and Device B are Level-1 devices, Device C is a Level-1-2 device, and Device D is a Level-2 device.

Figure 10-53 Configuring BGP-LS
NOTE:

In this example, the configurations are performed on Device A, Device B, Device C, Device D, and the controller. The NE device can act as Device A, Device B, Device C, or Device D.

In this example, interface 1, interface 2, interface 3, and interface 4 stand for GE 0/3/0, GE 0/1/1, GE 0/1/2, and GE 0/1/3, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface on each NE.

  2. Configure basic IS-IS functions.

  3. Deploy BGP-LS on Device A and the controller.

Data Preparation

To complete the configuration, you need the following data:

  • Area addresses of Device A, Device B, Device C, and Device D

  • Levels of Device A, Device B, Device C, and Device D

  • BGP-LS identifier of Device A

  • BGP AS numbers, BGP-LS domain AS numbers, and BGP-LS domain IDs of Devices and the controller

Procedure

  1. Assign an IP address to each interface on each NE. For configuration details, see Configuration Files in this section.
  2. Configure basic IS-IS functions.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-1
    [*DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [*DeviceA-isis-1] quit
    [*DeviceA] interface gigabitethernet 0/2/0
    [*DeviceA-GigabitEthernet0/2/0] isis enable 1
    [*DeviceA-GigabitEthernet0/2/0] commit
    [~DeviceA-GigabitEthernet0/2/0] quit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] is-level level-1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] quit
    [*DeviceB] interface gigabitethernet 0/4/0
    [*DeviceB-GigabitEthernet0/4/0] isis enable 1
    [*DeviceA-GigabitEthernet0/4/0] commit
    [~DeviceB-GigabitEthernet0/4/0] quit

    # Configure Device C.

    [~DeviceC] isis 1
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] quit
    [*DeviceC] interface gigabitethernet 0/2/0
    [*DeviceC-GigabitEthernet0/2/0] isis enable 1
    [*DeviceC-GigabitEthernet0/2/0] quit
    [*DeviceC] interface gigabitethernet 0/3/0
    [*DeviceC-GigabitEthernet0/3/0] isis enable 1
    [*DeviceC-GigabitEthernet0/3/0] quit
    [*DeviceC] interface gigabitethernet 0/4/0
    [*DeviceC-GigabitEthernet0/4/0] isis enable 1
    [*DeviceC-GigabitEthernet0/4/0] commit
    [~DeviceC-GigabitEthernet0/4/0] quit

    # Configure Device D.

    [~DeviceD] isis 1
    [*DeviceD-isis-1] is-level level-2
    [*DeviceD-isis-1] network-entity 20.0000.0000.0004.00
    [*DeviceD-isis-1] quit
    [*DeviceD] interface gigabitethernet 0/3/0
    [*DeviceD-GigabitEthernet0/3/0] isis enable 1
    [*DeviceD-GigabitEthernet0/3/0] quit
    [*DeviceD] interface LoopBack0
    [*DeviceD-LoopBack0] isis enable 1
    [*DeviceD-LoopBack0] commit
    [~DeviceD-LoopBack0] quit

    # Display IS-IS routes on each NE.

    [~DeviceA] display isis route
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
    
    IPV4 Destination   IntCost    ExtCost ExitInterface     NextHop         Flags
    -------------------------------------------------------------------------------
    0.0.0.0/0          10         NULL    GE0/2/0           11.1.1.1        A/-/-/-
    11.1.1.0/24        10         NULL    GE0/2/0           Direct          D/-/L/-
    11.1.2.0/24        20         NULL    GE0/2/0           11.1.1.1        A/-/-/-
    192.158.0.0/24     20         NULL    GE0/2/0           11.1.1.1        A/-/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set
    [~DeviceB] display isis route
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
    
    IPV4 Destination   IntCost    ExtCost ExitInterface     NextHop         Flags
    -------------------------------------------------------------------------------
    0.0.0.0/0          10         NULL    GE0/4/0           11.1.2.1        A/-/-/-
    11.1.1.0/24        20         NULL    GE0/4/0           11.1.2.1        A/-/-/-
    11.1.2.0/24        10         NULL    GE0/4/0           Direct          D/-/L/-
    192.158.0.0/24     20         NULL    GE0/4/0           11.1.2.1        A/-/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set
    [~DeviceC] display isis route
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
    
    IPV4 Destination   IntCost    ExtCost ExitInterface     NextHop         Flags
    -------------------------------------------------------------------------------
    11.1.1.0/24        10         NULL    GE0/2/0           Direct          D/-/L/-
    11.1.2.0/24        10         NULL    GE0/4/0           Direct          D/-/L/-
    192.158.0.0/24     10         NULL    GE0/3/0           Direct          D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set
    
    
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
    
    IPV4 Destination   IntCost    ExtCost ExitInterface     NextHop         Flags
    -------------------------------------------------------------------------------
    11.1.1.0/24        10         NULL    GE0/2/0           Direct          D/-/L/-
    11.1.2.0/24        10         NULL    GE0/4/0           Direct          D/-/L/-
    172.15.1.1/32      10         NULL    GE0/3/0           192.158.0.2     A/-/-/-
    192.158.0.0/24     10         NULL    GE0/3/0           Direct          D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set
    [~DeviceD] display isis route
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
    
    IPV4 Destination   IntCost    ExtCost ExitInterface     NextHop         Flags
    -------------------------------------------------------------------------------
    11.1.1.0/24        20         NULL    GE0/3/0           192.158.0.1     A/-/-/-
    11.1.2.0/24        20         NULL    GE0/3/0           192.158.0.1     A/-/-/-
    172.15.1.1/32      0          NULL    Loop0             Direct          D/-/L/-
    192.158.0.0/24     10         NULL    GE0/3/0           Direct          D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set

  3. Deploy BGP-LS on Device A and the controller.

    # Enable IS-IS topology advertisement to BGP on Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] bgp-ls enable
    [*DeviceA-isis-1] bgp-ls identifier 20
    [*DeviceA-isis-1] commit
    [~DeviceA-isis-1] quit

    # Enable BGP-LS on Device A and configure the controller as a BGP-LS peer of Device A.

    [~DeviceA] bgp 100
    [*DeviceA-bgp] peer 1.1.1.2 as-number 100
    [*DeviceA-bgp] link-state-family unicast
    [*DeviceA-bgp-af-ls] peer 1.1.1.2 enable
    [*DeviceA-bgp-af-ls] commit
    [~DeviceA-bgp-af-ls] quit
    [~DeviceA-bgp] quit

    # Enable BGP-LS on the controller and configure Device A as a BGP-LS peer of the controller.

    [~Controller] bgp 100
    [*Controller-bgp] peer 1.1.1.1 as-number 100
    [*Controller-bgp] link-state-family unicast
    [*Controller-bgp-af-ls] peer 1.1.1.1 enable
    [*Controller-bgp-af-ls] commit
    [~Controller-bgp-af-ls] quit
    [~Controller-bgp] quit

  4. Verify the configuration.

    # Display BGP-LS peers and their status on Device A.

    [~DeviceA] display bgp link-state unicast peer
     BGP local router ID : 11.1.1.2
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      1.1.1.2         4         100       27       48     0 00:29:11 Established       17

    # Display BGP-LS routes on Device A.

    [~DeviceA] display bgp link-state unicast routing-table
     BGP Local router ID is 11.1.1.2
     Status codes: * - valid, > - best, d - damped, x - best external, a - add path,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     Total Number of Node Routes: 5
     *>     Network  : [NODE][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.00]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [NODE][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.01]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [NODE][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.00]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [NODE][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.01]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [NODE][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
    
     Total Number of Link Routes: 8
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.00]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.01]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.01]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.00]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.01]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.00]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.01]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.01]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.00]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.01]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.01]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [LINK][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][REMOTE[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.01]][LINK[if-address0.0.0.0][peer-address0.0.0.0][if-address::][peer-address::][mt-id0]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
    
     Total Number of IPv4 Prefix Routes: 5
     *>     Network  : [IPV4-PREFIX][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0001.00]][PREFIX[mt-id0][ospf-route-type0][prefix11.1.1.0/24]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [IPV4-PREFIX][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0002.00]][PREFIX[mt-id0][ospf-route-type0][prefix11.1.2.0/24]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [IPV4-PREFIX][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][PREFIX[mt-id0][ospf-route-type0][prefix11.1.1.0/24]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [IPV4-PREFIX][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][PREFIX[mt-id0][ospf-route-type0][prefix11.1.2.0/24]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?
     *>     Network  : [IPV4-PREFIX][ISIS-LEVEL-1][IDENTIFIER0][LOCAL[as100][bgp-ls-identifier11.1.1.2][ospf-area-id0.0.0.0][igp-router-id0000.0000.0003.00]][PREFIX[mt-id0][ospf-route-type0][prefix192.158.0.0/24]]
            NextHop  : 0.0.0.0                                  LocPrf    :
            MED      : 0                                        PrefVal   : 0
            Path/Ogn :  ?

    The preceding command output shows that Device A obtains the topology information on the whole IS-IS network. Device A can use BGP-LS routes to report the topology information to its BGP-LS peer (the controller).

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
     bgp-ls enable level-1-2
     bgp-ls identifier 20
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 11.1.1.2 255.255.255.0
     isis enable 1
    #
    bgp 100
     peer 1.1.1.2 as-number 100
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.2 enable
      link-state-family unicast
      peer 1.1.1.2 enable
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet0/4/0
     undo shutdown
     ip address 11.1.2.2 255.255.255.0
     isis enable 1
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 11.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 192.158.0.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/4/0
     undo shutdown
     ip address 11.1.2.1 255.255.255.0
     isis enable 1
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 192.158.0.2 255.255.255.0
     isis enable 1
    #
    interface LoopBack0
     ip address 172.15.1.1 255.255.255.255
     isis enable 1
    #
    return
  • Controller configuration file

    #
    sysname Controller
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 1.1.1.2 255.255.255.0
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      link-state-family unicast
      peer 1.1.1.1 enable
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058916

Views: 34977

Downloads: 51

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next