No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Routing 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - IP Routing
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BGP Route Dampening

Example for Configuring BGP Route Dampening

Configuring BGP route dampening can improve network stability.

Networking Requirements

In Figure 10-44, all NEs are configured with BGP; Device A resides in AS 100; Device B resides in AS 200; Device C resides in AS 300; Device D resides in AS 400. EBGP runs between Device C and Device A, between Device C and Device B, and between Device C and Device D. For routes from different EBGP neighbors, Device C applies different route dampening policies. It is required that BGP route dampening be configured to suppress unstable routes and improve network stability.

Figure 10-44 Configuring BGP route dampening
NOTE:

Interfaces 1 through 3 in this example are GE 0/1/0, GE 0/2/0, GE 0/3/0, respectively.



Precautions

When configuring BGP route dampening, note the following rules:

  • BGP route dampening takes effect only on EBGP routes.

  • Set a small MaxSuppressTime for routes with the small masks.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Establish EBGP connections between Device A and Device C, between Device B and Device C, and between Device D and Device C.

  2. Configure route dampening policies on Device C and then check routes.

Data Preparation

To complete the configuration, you need the following data:

  • Router IDs and AS numbers of Device A, Device B, Device C, and Device D

  • Name of the route flap dampening policy to be applied to Device C

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure BGP connections.

    # Configure Device A.

    [~DeviceA] bgp 100
    [*DeviceA-bgp] router-id 1.1.1.1
    [*DeviceA-bgp] peer 200.1.1.2 as-number 300
    [*DeviceA-bgp] ipv4-family unicast
    [*DeviceA-bgp-af-ipv4] network 8.0.0.0 255.0.0.0
    [*DeviceA-bgp-af-ipv4] commit
    [~DeviceA-bgp-af-ipv4] quit
    [~DeviceA-bgp] quit

    # Configure Device B.

    [~DeviceB] bgp 200
    [*DeviceB-bgp] router-id 2.2.2.2
    [*DeviceB-bgp] peer 200.1.2.2 as-number 300
    [*DeviceB-bgp] ipv4-family unicast
    [*DeviceB-bgp-af-ipv4] network 9.1.1.0 255.255.255.0
    [*DeviceB-bgp-af-ipv4] commit
    [~DeviceB-bgp-af-ipv4] quit
    [~DeviceB-bgp] quit

    # Configure Device C.

    [~DeviceC] bgp 300
    [*DeviceC-bgp] router-id 3.3.3.3
    [*DeviceC-bgp] peer 200.1.1.1 as-number 100
    [*DeviceC-bgp] peer 200.1.2.1 as-number 200
    [*DeviceC-bgp] peer 200.1.3.1 as-number 400
    [*DeviceC-bgp] commit
    [~DeviceC-bgp] quit

    # Configure Device D.

    [~DeviceD] bgp 400
    [*DeviceD-bgp] router-id 4.4.4.4
    [*DeviceD-bgp] peer 200.1.3.2 as-number 300
    [*DeviceD-bgp] commit
    [~DeviceD-bgp] quit

    # Check the BGP peers of Device C.

    [~DeviceC] display bgp peer
    
     BGP local router ID : 3.3.3.3
     Local AS number : 300
     Total number of peers : 3         Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
      200.1.1.1       4         100        3        3     0 00:00:01 Established    0
      200.1.2.1       4         200        3        3     0 00:00:00 Established    0
      200.1.3.1       4         400        3        3     0 00:00:01 Established    0

    The command output shows that the BGP connection status of with each peer is Established.

  3. Configure BGP route dampening policies.

    # Configure an IP prefix list named prefix-a on Device C to accept only the routes with prefix 8.0.0.0/8.

    [~DeviceC] ip ip-prefix prefix-a index 10 permit 8.0.0.0 8
    [*DeviceC] commit

    # Configure an IP prefix list named prefix-b on Device C to accept only the routes with prefix 9.1.1.0/24.

    [~DeviceC] ip ip-prefix prefix-b index 20 permit 9.1.1.0 24
    [*DeviceC] commit

    # Configure a route-policy named dampen-policy on Device C and then apply different route dampening policies to the routes with different prefix lengths.

    [~DeviceC] route-policy dampen-policy permit node 10
    [*DeviceC-route-policy] if-match ip-prefix prefix-a
    [*DeviceC-route-policy] apply dampening 10 1000 2000 5000
    [*DeviceC-route-policy] commit
    [~DeviceC-route-policy] quit
    [~DeviceC] route-policy dampen-policy permit node 20
    [*DeviceC-route-policy] if-match ip-prefix prefix-b
    [*DeviceC-route-policy] apply dampening 10 800 3000 10000
    [*DeviceC-route-policy] commit
    [~DeviceC-route-policy] quit

    # Apply route dampening policies to the routes that flap.

    [~DeviceC] bgp 300
    [*DeviceC-bgp] ipv4-family unicast
    [*DeviceC-bgp-af-ipv4] dampening route-policy dampen-policy
    [*DeviceC-bgp-af-ipv4] commit
    [~DeviceC-bgp] quit

    # Check the configured route dampening parameters on Device C.

    [~DeviceC] display bgp routing-table dampening parameter
    
     Maximum Suppress Time(in second) : 3973
     Ceiling Value                    : 16000
     Reuse Value                      : 750
     HalfLife Time(in  second)        : 900
     Suppress-Limit                   : 2000
     Route-policy                     : dampen-policy

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 200.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 8.1.1.1 255.0.0.0
    #
    bgp 100
     router-id 1.1.1.1
     peer 200.1.1.2 as-number 300
     #
     ipv4-family unicast
      undo synchronization
      network 8.0.0.0 255.0.0.0
      peer 200.1.1.2 enable
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 200.1.2.1 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 9.1.1.1 255.255.255.0
    #
    bgp 200
     router-id 2.2.2.2
     peer 200.1.2.2 as-number 300
     #
     ipv4-family unicast
      undo synchronization
      network 9.1.1.0 255.255.255.0
      peer 200.1.2.2 enable
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 200.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 200.1.2.2 255.255.255.0
    #
    interface GigabitEthernet0/3/0
     undo shutdown
     ip address 200.1.3.2 255.255.255.0
    #
    bgp 300
     router-id 3.3.3.3
     peer 200.1.1.1 as-number 100
     peer 200.1.2.1 as-number 200
     peer 200.1.3.1 as-number 400
     #
     ipv4-family unicast
      undo synchronization
      dampening route-policy dampen-policy
      peer 200.1.1.1 enable
      peer 200.1.2.1 enable
      peer 200.1.3.1 enable
    #
    route-policy dampen-policy permit node 10
     if-match ip-prefix prefix-a
     apply dampening 10 1000 2000 5000
    #
    route-policy dampen-policy permit node 20
     if-match ip-prefix prefix-b
     apply dampening 10 800 3000 10000
    #
    ip ip-prefix prefix-a index 10 permit 8.0.0.0 8
    #
    ip ip-prefix prefix-b index 20 permit 9.1.1.0 24
    #
    return
  • Device D configuration file

    #
    sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 200.1.3.1 255.255.255.0
    #
    bgp 400
     router-id 4.4.4.4
     peer 200.1.3.2 as-number 300
     #
     ipv4-family unicast
      undo synchronization
      peer 200.1.3.2 enable
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058916

Views: 34172

Downloads: 49

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next