No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - System Monitor 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - System Monitor
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Layer 2 Ethernet Service Activation Test

Example for Configuring a Layer 2 Ethernet Service Activation Test

This section describes how to configure a Layer 2 Ethernet service activation test to check whether network performance complies with the SLA.

Networking Requirements

Figure 4-16 shows how to check the Ethernet frame transmission performance between Device B and Device C complies with the SLA.

Figure 4-16 Configuring a Layer 2 Ethernet service activation test
NOTE:
  • Interface 1 and interface 2 stand for GE0/1/1 and GE0/1/2, respectively.


Configuration Roadmap

  1. Configure a reflector (Device C) and flow-based traffic filtering with the reflection port being set to GE0/1/1.
  2. Configure an initiator (Device B) as well as configuration and performance tests.

Data Preparation

To complete the configuration, you need the following data:

  • Configurations of the reflector (Device C): The MAC address of GE0/1/1 on Device D connected to UNI B is 2-2-2, and the reflector is configured to implement reflection based on flows.
  • Configurations of the initiator (Device B)

    • Service flow configurations and characteristics:

      • Destination MAC address: 2-2-2, that is, the MAC address of GE0/1/1 on Device D connected to UNI B
      • Source MAC address: 1-1-1, that is, the MAC address of GE0/1/1 on Device A connected to UNI A
      • VLAN ID 10 in single-tagged Ethernet packets
      • UDP destination port number 1234
      • UDP source port number 5678
    • Bandwidth template with both the CIR and EIR being set to 10000 kbit/s

    • Service acceptance criteria FLR with the FLR being set to 1000/100000 and both the FTD and FDV being set to 1000 microseconds

    • Enabling of the simple CIR test, traffic policing test, and color mode

    • Ethernet service activation test instance

Procedure

  1. Configure a reachable link between the initiator and reflector and add Layer 2 interfaces to VLAN 10.
  2. Configure the reflector.

    [*DeviceC] nqa test-flow 1
    [*DeviceC-nqa-testflow-1] vlan 10
    [*DeviceC-nqa-testflow-1] udp destination-port 1234
    [*DeviceC-nqa-testflow-1] udp source-port 5678
    [*DeviceC-nqa-testflow-1] traffic-type mac destination 2-2-2
    [*DeviceC-nqa-testflow-1] traffic-type mac source 1-1-1
    [*DeviceC-nqa-testflow-1] quit
    [*DeviceC] nqa reflector 1 interface GigabitEthernet 0/1/1 test-flow 1 exchange-port agetime 0
    [*DeviceC] commit

  3. Configure the initiator to perform configuration and performance tests and view test results.

    [*DeviceB] nqa test-flow 1
    [*DeviceB-nqa-testflow-1] vlan 10
    [*DeviceB-nqa-testflow-1] udp destination-port 1234
    [*DeviceB-nqa-testflow-1] udp source-port 5678
    [*DeviceB-nqa-testflow-1] cir simple-test enable
    [*DeviceB-nqa-testflow-1] bandwidth cir 10000 eir 10000
    [*DeviceB-nqa-testflow-1] sac flr 1000 ftd 1000 fdv 1000
    [*DeviceB-nqa-testflow-1] traffic-type mac destination 2-2-2
    [*DeviceB-nqa-testflow-1] traffic-type mac source 1-1-1
    [*DeviceB-nqa-testflow-1] traffic-policing test enable
    [*DeviceB-nqa-testflow-1] color-mode 8021p green 0 7 yellow 0 7
    [*DeviceB-nqa-testflow-1] quit
    [*DeviceB] nqa test-instance admin ethernet
    [*DeviceB-nqa-admin-ethernet] test-type ethernet-service
    [*DeviceB-nqa-admin-ethernet] forwarding-simulation inbound-interface GigabitEthernet 0/1/1
    [*DeviceB-nqa-admin-ethernet] test-flow 1
    [*DeviceB-nqa-admin-ethernet] start now
    [*DeviceB-nqa-admin-ethernet] commit
    [~DeviceB-nqa-admin-ethernet] display nqa results test-instance admin ethernet
    NQA entry(admin, ethernet) :testflag is inactive ,testtype is ethernet-service
      1 . Test 1 result   The test is finished                                      
       Status           : Pass                                                      
       Test-flow number : 1                                                         
       Mode             : Round-trip                                                
       Last step        : Performance-test                                          
       Estimated total time  :6
       Real test time        :6
       1 . Configuration-test                                                       
        Test-flow 1, CIR simple test                                                
         Begin                    : 2014-06-25 16:22:45.8                           
         End                      : 2014-06-25 16:22:48.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9961/10075/10012                                
         Min/Max/Mean FTD(us)     : 99/111/104                                      
         Min/Max/Mean FDV(us)     : 0/7/3                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
        Test-flow 1, CIR/EIR test, Green                                            
         Begin                    : 2014-06-25 16:23:15.8                           
         End                      : 2014-06-25 16:23:18.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9979/10054/10012                                
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 0/10/3                                          
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
        Test-flow 1, CIR/EIR test, Yellow                                           
         Begin                    : 2014-06-25 16:23:15.8                           
         End                      : 2014-06-25 16:23:18.8                           
         Status                   : --                                              
         Min/Max/Mean IR(kbit/s)    : 9979/10057/10013                                
         Min/Max/Mean FTD(us)     : 98/111/104                                      
         Min/Max/Mean FDV(us)     : 1/11/5                                          
         FL Count/FLR             : 0/0.000%                                        
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%
        Test-flow 1, Traffic policing test, Green                                   
         Begin                    : 2014-06-25 16:23:45.8                           
         End                      : 2014-06-25 16:23:48.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 10039/10054/10045                               
         Min/Max/Mean FTD(us)     : 96/110/104                                      
         Min/Max/Mean FDV(us)     : 1/9/4                                           
         FL Count/FLR             : 0/0.000% 
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                       
        Test-flow 1, Traffic policing test, Yellow                                  
         Begin                    : 2014-06-25 16:23:45.8                           
         End                      : 2014-06-25 16:23:48.8                           
         Status                   : --                                              
         Min/Max/Mean IR(kbit/s)    : 12544/12566/12554                               
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 1/8/3                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
       2 . Performance-test                                                         
        Test-flow 1, Performance-test                                               
         Begin                    : 2014-06-25 16:24:15.8                           
         End                      : 2014-06-25 16:39:15.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9888/10132/10004                                
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 0/8/2                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    # 
    vlan batch 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    # 
    vlan batch 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    nqa test-flow 1
     vlan 10
     udp destination-port 1234
     udp source-port 5678
     cir simple-test enable
     bandwidth cir 10000 eir 10000
     sac flr 1000 ftd 1000 fdv 1000
     traffic-type mac destination 0002-0002-0002
     traffic-type mac source 0001-0001-0001
     traffic-policing test enable
     color-mode 8021p green 0 7 yellow 0 7
    #
    nqa test-instance admin ethernet
     test-type ethernet-service
     forwarding-simulation inbound-interface GigabitEthernet 0/1/1
     test-flow 1
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    vlan batch 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    nqa test-flow 1
     vlan 10
     udp destination-port 1234
     udp source-port 5678
     traffic-type mac destination 0002-0002-0002
     traffic-type mac source 0001-0001-0001
    #
    nqa reflector 1 interface GigabitEthernet 0/1/1 test-flow 1 exchange-port agetime 0
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    # 
    vlan batch 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058924

Views: 6990

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next