No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - System Monitor 01

NE05E and NE08E V300R003C10SPC500

This is NE05E and NE08E V300R003C10SPC500 Configuration Guide - System Monitor
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Collecting Statistics About IPv4 Flows Aggregated Based on the AS Number

Example for Collecting Statistics About IPv4 Flows Aggregated Based on the AS Number

This section provides an example for configuring NetStream to collect statistics about IPv4 flows aggregated based on the AS number. NetStream allows flows to be aggregated based on the AS number, which makes accounting or management easier.

Networking Requirements

On the network shown in Figure 3-9, Device D connects network A and network B to the wide area network (WAN). Device D samples and aggregates flows before sending them to the NetStream Collector (NSC).

Figure 3-9 Networking diagram for collecting statistics about IPv4 flows aggregated based on the AS number
NOTE:
  • Interfaces 1 through 4 in this example are GE0/1/0 , GE0/2/0, GE0/3/0, and GE0/4/0, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reachable routes between the egress NE of the LAN and the WAN.

  2. Configure reachable routes between the ingress NE of the LAN and the NSC.

  3. Configure the ingress NE of the LAN to sent traffic statistics to the specified NSC.

  4. Configure the ingress NE of the LAN to sent traffic statistics to the inbound interface on the NSC.

  5. Aggregate sampled flows to reduce the data sent to the NSC.

  6. Enable NetStream on the inbound interface of the ingress NE.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of each interface

  • IP address of the NSC

  • Output format of NetStream flows

  • NetStream sampling ratio

Procedure

  1. Assign an IP address to each interface on each NE. For configuration details, see Configuration Files in this section.
  2. Configure reachable routes between the WAN, NE A, and NE B.

    # Configure reachable routes between NE A and NE D.

    [*DeviceA] ip route-static 1.1.1.1 24 GigabitEthernet 0/1/0

    # Configure reachable routes between NE B and NE D.

    [*DeviceB] ip route-static 1.1.1.1 24 GigabitEthernet 0/1/0
    [*DeviceB] commit

  3. Configure reachable routes between NE D and the NSC.

    # Configure reachable routes between NE D and NE C.

    [*DeviceD] ip route-static 2.2.2.1 24 3.3.3.2

  4. Enable NetStream on NE D.

    # Enable the NetStream statistics function.

    [*DeviceD] interface gigabitethernet 0/3/0
    [*DeviceD-GigabitEthernet0/3/0] ip netstream inbound

    # Output aggregated flows in V9 format.

    [*DeviceD] ip netstream aggregation as 
    [*DeviceD-aggregation-as] enable
    [*DeviceD-aggregation-as] ip
    netstream export host 2.2.2.1 3000
    [*DeviceD-aggregation-as] ip
    netstream export source 3.3.3.1
    [*DeviceD-aggregation-as] export version 9

    # Enable the NetStream packet sampling function.

    [*DeviceD-GigabitEthernet0/3/0] ip netstream sampler fix-packets 1000 inbound
    [*DeviceD-GigabitEthernet0/3/0] quit
    [*DeviceD] commit

  5. Verify the configuration.

    # Run the display ip netstream cache command to view information about flows in the NetStream flow buffer on NE D.

    <HUAWEI> display ip netstream cache as slot 11
     DstIf   
     SrcIf  
     DstAs      Streams    Packets    Direction     SrcAs   
     --------------------------------------------------------------------------
     GI0/2/0        
     Unknown         
     0          985988     985988     out           0

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet0/1/0
     ip address 172.16.0.1 255.255.255.0
    #
    ip route-static 1.1.1.1 255.255.255.0 GigabitEthernet0/1/0
    #
    return
  • Device B configuration file

    #
     sysname DeviceB
    #
    interface GigabitEthernet0/1/0
     ip address 172.17.1.1 255.255.255.0
    #
    ip route-static 1.1.1.1 255.255.255.0 GigabitEthernet0/1/0
    #
    return
  • Device C configuration file
    #
     sysname DeviceC
    #
    interface GigabitEthernet0/1/0
     ip address 3.3.3.2 255.255.255.0
    #
    return
  • Device D configuration file

    #
     sysname DeviceD
    #
    interface GigabitEthernet0/1/0
     ip address 172.16.0.2 255.255.255.0 
    #
    interface GigabitEthernet0/2/0
     ip address 172.17.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/3/0
     ip address 1.1.1.1 255.255.255.0
     ip netstream inbound
     ip netstream sampler fix-packets 1000 inbound
    #
    interface GigabitEthernet0/4/0
     ip address 3.3.3.1 255.255.255.0
    #
    ip netstream aggregation as
     enable
     export version 9
     ip
    netstream export source 3.3.3.1
     ip
    netstream export host 2.2.2.1 3000
    #
    return
Translation
Download
Updated: 2019-01-14

Document ID: EDOC1100058924

Views: 7064

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next